Comment 3 for bug 666493

Hanno (hzulla) wrote :

I was unable to solve this with the default Ubuntu kernel (the imon.ko module does not switch to the MCE protocol) and the aforementioned 2.6.36 kernel was unstable, producing kernel oopses and undesired video artifacts with my AMD graphics card.

Wanting to stick with the default kernel, my solution so far was:

- remove the default kernel's /lib/modules/2.6.35-22-generic/kernel/drivers/staging/lirc/lirc_imon.ko (which does not work, as well)

- install lirc-modules-source package (this will add an old, but working lirc_imon.ko to the module directory)

- Add this blacklist to /etc/modprobe.d/blacklist-imon.conf:

   blacklist ir_core
   blacklist ir_lirc_codec
   blacklist ir_sony_decoder
   blacklist ir_jvc_decoder
   blacklist ir_rc6_decoder
   blacklist ir_rc5_decoder
   blacklist ir_nec_decoder
   blacklist rc_imon_pad
   blacklist imon

- Add this entry to /etc/modules:

   lirc_imon

- Add this parameter to /etc/modprobe.d/lirc_imon.conf:

   options lirc_imon ir_protocol=1

With this, my old lirc setup continues to work. Hopefully, this helps others looking for a solution.

Instead of reverting to the old lirc setup, a better solution would be to get Ubuntu's imon.ko to work, though.