Ubuntu

linux kernel 2.6.35 slows down the whole system because of kslowdxxx processes

Reported by Vincenzo Ampolo on 2010-10-18
240
This bug affects 46 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

I'm running maverick with kernel:

Linux earth 2.6.35-22-generic #34-Ubuntu SMP Sun Oct 10 09:26:05 UTC 2010 x86_64 GNU/Linux

I've just the browser opened, top says that my cpu is used a 1-3% and my system load is almost 9.60. There is a kslowd001 or kslowd002 or kslowd003 which appears in the top screen and it seems the issue which makes the system load so high.

The problem is already known and has been reported in many other bug reports such as: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/595764

The solution is to switch to a 2.6.36 release where this issue has been resolved. Please provide a 2.6.36 with the ubuntu patches to fix the problem.

Thanks

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-22-generic 2.6.35-22.34
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC262 Analog [ALC262 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: goshawk 1978 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd5200000 irq 49'
   Mixer name : 'Realtek ALC262'
   Components : 'HDA:10ec0262,104d2d00,00100302 HDA:14f12c06,104d1700,00100000'
   Controls : 12
   Simple ctrls : 8
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xd0030000 irq 50'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,104d2d00,00100000'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Mon Oct 18 22:52:37 2010
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=d40958ac-8cf8-4eb9-b97e-b77c74d2d032
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: Sony Corporation VGN-SR21M_S
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.35-22-generic root=/dev/sda6 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.38
SourcePackage: linux
dmi.bios.date: 08/14/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R1110Y1
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR1110Y1:bd08/14/2008:svnSonyCorporation:pnVGN-SR21M_S:pvrC600TTSE:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VGN-SR21M_S
dmi.product.version: C600TTSE
dmi.sys.vendor: Sony Corporation

description: updated
baracus2k (baracus2k) wrote :

I have the same issue with a Dell Inspiron 1150 (Intel 852/855 gfx) running ubuntu 10.10 on 35-22 kernel. I can't get the commit fbf81762e385d patch to apply, I always get hunk failed errors.

I tried the option "sudo -i && echo N >/sys/module/drm_kms_helper/parameters/poll" but there is no parameters folder and creating the local.conf with the options caused ubuntu to give an error at boot saying option 'poll' not found.

Can anyone tell me what exactly I'm doing wrong? Using kernel rc5 fixes it for me but my wifi doesn't work so I need to get this patch working somehow under kernel 35-22.

I've fixed using there 2.6.36 images from natty, the next ubuntu release:

http://archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-image-2.6.36-0-generic_2.6.36-0.4_amd64.deb

http://archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-image-2.6.36-0-generic_2.6.36-0.4_i386.deb

Everything else works fine for me.

In the images the kslowd00X are replaced by kworker/0:[0-3] which do their job much way better. Now my system ha a load near 1.0 during normal operations and i can finally see flash video and play video (it was impossible before)

baracus2k (baracus2k) wrote :

Any chance you could provide us with a patch to fix up 2.6.35-22?

baracus2k (baracus2k) wrote :

Just tried your 2.6.36 kernel and while the slowdown was fixed, my wireless doesn't work just like in 35-rc5.

@baracus2k sorry i don't have time right now to look for a patch and i think is much easier to make your wifi working with 2.6.36 than patching 2.6.35 to behave like 2.6.36 in the kslowd issue.

Maor (maor-gm) on 2010-10-20
Changed in linux (Ubuntu):
status: New → Confirmed
Maor (maor-gm) wrote :

I can confirm that using 2.6.36 kernel from natty (I'm using the pae variant) the situation it's much better, there are still some short spike in kworker thread from time to time which causing short freezes . disabling the poll parameter in kms_drm_helper mitigate the problem completely (as in the 36 rc series).

@Maor: which parameter did you use ? Is it possible to use it on 2.6.35?

2.6.36 didn't detect the correct resolution of my hdmi-capable monitor. I'm falling back to the lucid kernel (2.6.32). Everything works fine: no kslowdXXX, kworkers and monitor issues.

baracus2k (baracus2k) wrote :

@Vicenzo: Could it be that the problem is caused by something else? I don't have any parameters for the kms_drm_helper under 2.6.35. Do you have a parameters folder under /sys/module/drm_kms_helper/ ?

Kyle (kyllerss) wrote :

I performed a fresh install to *fix* the problem after noticing the issue after upgrading from 10.04... unfortunately, the problem is related to the latest kernel so now I am stuck with 2.6.35 and can't fall back to the lucid kernel. Any suggestions for those of us who need to have a working system but are stuck with this broken installation?

Maor (maor-gm) wrote :

@Kyle: you could either install the natty or lucid kernel manually or reinstall the 10.04 release.

The ubuntu kernels can be found in:
http://archive.ubuntu.com/ubuntu/pool/main/l/linux/

Maor.

Kyle (kyllerss) wrote :

Got it. I installed http://archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-image-2.6.36-1-generic_2.6.36-1.7_amd64.deb and now all is good. Anybody have any idea what is causing the problem in the 2.6.35 kernel?

rayn0r (rayn0r) wrote :

I upgraded from "ubuntu server 10.04 64bit" to "ubuntu server 10.10 64bit". since then i have had this problem.
As suggested, i booted the "latest" 10.04 kernel and the problem is "solved"
thx :-)

gds (gds-chartertn) wrote :

Same problem here with HP Pavilion Notebook 1.6GHz. Mouse, keyboard delay and bad audio/video stutter every 10 seconds and correlated to kslowd001 activation as seen in top. (No history with Ubuntu versions other than 10.10 on this machine.)

On my system (x301) I encounter a similar problem. Normaly the system runs fine. But when I use the Display-Port klsowd processes appear and the system is stucked. I use the 2.6.35-22 (32bit) kernel.

Changed in linux (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Mihai (udev) wrote :

I have just installed 10.10 on a T400/Intel graphics and I have this problem as well.

therealv (therealv) wrote :

samsung x120 laptop with intel HD4500 graphics has the same "kslowd" problem with maverick ubuntu all updates

Nuno Salgado (nuno-salgado) wrote :

I installed 2.6.36-020636rc7-generic #201010070908 SMP Thu Oct 7 10:21:05 UTC 2010 i686 GNU/Linux and the problem was gone.

baracus2k (baracus2k) wrote :

Guys, I fixed it. The issue was that the Intel video driver is disabled by default on Ubuntu 10.10. I have an Inspiron 1150 which has the Intel 855 GME graphics. So here's what I did:

1. Followed steps on this website (except for the xorg.conf) and also got the i855 patch
http://www.downloadatoz.com/driver/articles/how-to-enable-intel-graphics-driver-for-ubuntu-10-10.html

2. Don't use the xorg.conf from that website, instead use the location and code from this website
https://wiki.ubuntu.com/X/Bugs/Mavericki8xxStatus

3. Restarted PC

So what are the results?
Before:
idle CPU usage: ~10%
RAM usage after startup: 105 MB
kslowd CPU usage: 45% every 10 seconds
youtube with 3d acceleration: extremely stuttery in full screen
VLC player with movie: freezes/garbled image every 10 seconds
appearance effects: anything other than no effects gives an error

After:
idle CPU usage: 2-5%
RAM usage after startup: 95 MB
kslowd CPU usage: <1% every 10 seconds
youtube with 3d acceleration: smooth up to 480p in full screen
VLC player with movie: 720p is smooth
appearance effects: can enable basic effects but screen gets garbled in some spots, no effects works fine

So looks like this is the main issue. The freezing isn't fully gone as while watching a movie you can just notice it but it's so minor/short that you really need to pay attention to notice it. The only other thing is stability, apparently these drivers cause stability issues. I'm using the patch and I haven't any issues yet, if I find anything I'll let you guys know.

kiu (kiu) wrote :

Using http://archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-image-2.6.36-1-generic_2.6.36-1.7_amd64.deb didnt fix it for me. Still the same problem, but now its kworker instead of kslowd. It happens a lot (95% CPU usage) for several minutes after resuming from suspend.

phlegm (daveshome) wrote :

Same problem happening here. System becomes basically useless at times. Happened during a presentation today.

Ulrik Mikaelsson (rawler) wrote :

Tried upgrading to 2.6.36-020636-generic, and adding to my xorg.conf:
  Section "Device"
    Identifier "Intel"
    Driver "intel"
  EndSection

No luck.

HOWEVER: When also disabling polling by echo N | sudo tee /sys/module/drm_kms_helper/parameters/poll, it seems the problems went away.

So, for those of you still haven't got it right, try upgrading to a fairly recent 2.6.36, disable the polling, and explicitly ask for the Intel-driver. Good luck!

Andy Whitcroft (apw) wrote :

It is believed that this bug is fixed but the commit below:

  commit 930a9e283516a3a3595c0c515113f1b78d07f695
  Author: Chris Wilson <email address hidden>
  Date: Tue Sep 14 11:07:23 2010 +0100

    drm: Use a nondestructive mode for output detect when polling (v2)

This commit is included in the latest Natty kernels which should boot just fine on a Maverick userspace. If someone who is affected

Changed in linux (Ubuntu Maverick):
status: New → Confirmed
importance: Undecided → Medium
Changed in linux (Ubuntu):
status: Confirmed → New
Andy Whitcroft (apw) wrote :

... could test a Natty kernel and report back here that would help. Do remember to back out any work-arounds at the same time. Thanks.

Changed in linux (Ubuntu):
status: New → Incomplete
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → Medium
IgorS (igstef) wrote :

The problem seems to be gone after the latest automatic kernel update on my laptop.
Kubuntu 10.10 2.6.35-23

it's solved for me after latest kernel update in maverick 2.6.35-23

Changed in linux (Ubuntu Maverick):
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Xavier Claessens (zdra) wrote :

I have to admit I have less freezes recently, but this bug is surely not resolved. Especially after a suspend/resume, I still have my mouse freezing repeatdly when that kslowd process takes my CPU.

Can you please reopen it, I don't seems to have privileges for that...

Andy Whitcroft (apw) on 2010-11-29
Changed in linux (Ubuntu):
status: Fix Released → Incomplete
Changed in linux (Ubuntu Maverick):
status: Fix Released → Incomplete

No, definitely not solved for me. Still 4 kslowd tasks after system startup.

thedoctar (thedoctar) wrote :

the new kernal 2.6.35.23 fixed it for me

kiu (kiu) wrote :

2.6.35-23 almost fixed it for me.
After resume it still hangs for about 5 seconds once, but thats fine for me. With the older kernels the system was unusable for several minutes.

Huygens (huygens-25) wrote :

The system does freeze less with latest kernel, but the kslowd*** are still using unnecessary CPU time. It's consuming an average of 1.6% of the CPU (over a ~20h period).

I have an old Sempron 2800+ (64bit) with and old ATI Radeon 9600XT (no not HD, just plain ol' radeon on AGP port!!).

Xavier Claessens (zdra) wrote :

This also affects natty, tested today from fresh install. However the process is not kslowd anymore but kworker/1:0

Xavier Claessens (zdra) wrote :

I added pcie_ports=compat to boot options and the problem is gone on natty with 2.6.37 kernel. I've seen that trick on fedora forum...

Tim Moore (moreginger) wrote :

Was getting this really badly up to 2.6.35-24 kernel, audio was basically crippled (stuttering every 5s or fewer).
Updated to linux-headers-2.6.37-020637rc2 and it's much improved, but far from fixed. It seems to happen about once every 30s or so, now.

This is all on a Samsung X120 laptop.

clint (clint-xenir) on 2010-12-25
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Xavier Claessens (zdra) wrote :

I've been booting with pcie_ports=compat param, it seems to help, but does not fix completely the bug. However I've tried with

echo N > /sys/module/drm_kms_helper/parameters/poll

and that works perfectly! kworker was taking 80% of my CPU and as soon as I ran that command my system became usable again.

Scott Talbert (swt-techie) wrote :

Andy, I tried the latest Natty kernel (2.6.37-12). By default, the problem does seem a little better than in the current Maverick kernel (2.6.35-24). If I disable the polling with 2.6.37-12 (echo N > /sys/module/drm_kms_helper/parameters/poll), the problem goes away completely. I have a Radeon video card.

Henning Moll (drscott) wrote :

Same problem here with 2.6.35-24.

Btw: Why is this bug set to incomplete for maverick?

Changed in linux:
status: Unknown → Fix Released
Changed in linux:
importance: Unknown → Medium
Changed in linux (Ubuntu Maverick):
status: Incomplete → New

I experienced this issue with all kernels for 10.10 and now with 2.6.38-8-generic on Natty.

Is there anything I could do to help fix this problem?

BTW, I don't believe that bug https://bugzilla.kernel.org/show_bug.cgi?id=16265 should be closed.

kiu (kiu) wrote :

While in Maverick the issue had been resolved for me, upgrading to Natty shows the old behavior. After resume the machine freezes for several minutes.

Linux felix 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Vincenzo Ampolo, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/662946/comments/27 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
assignee: Andy Whitcroft (apw) → nobody
status: Confirmed → Invalid

Maverick EOL as per https://wiki.ubuntu.com/Releases .

Changed in linux (Ubuntu Maverick):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.