Font/image corruption after resume from hibernate

Bug #659434 reported by Chris Emerson on 2010-10-12
186
This bug affects 36 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Since updating to Maverick I've noticed that the display becomes somewhat corrupted after resuming from hibernate on my laptop. It looks like the X server's cached images have become corrupt (guess!). It starts out small, but after a few cycles text becomes totally unreadable.

* It's mostly text which is corrupt, and each instance of the same character looks similarly garbled
* All applications are affected - eg terminal, Firefox, chromium, apport-gtk, the GNOME menus
* Changing the font (eg by changing to "Monochrome" from "Best shapes" in the Appearance Settings->Font makes many things look better, but revert to being unreadable after switching back
* Changing the font size in the application (terminal, Firefox) also temporarily fixes the issue
* Some images in Firefox also become garbled, but recover after a forced reload.

I can confirm that the issue still happens with the mainline kernel (linux-image-3.4.0-999-generic_3.4.0-999.201204170501_amd64.deb).

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
Architecture: amd64
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800
 edid-base64: AP///////wBMozM2AAAAAAAPAQOAIRV4Cof1lFdPjCcnUFQAAAABAQEBAQEBAQEBAQEBAQEB7hoAgFAgEDAQMBMAS88QAAAZAAAADwAAAAAAAAAAACOHAmQCAAAA/gBTQU1TVU5HCiAgICAgAAAA/gBMVE4xNTRYMy1MMDYKAHA=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Tue Oct 12 19:52:02 2010
MachineType: LENOVO 0769BMG
ProcCmdLine: root=UUID=1fdf1f18-3ca9-447c-a9b5-9b40d4c276bd ro resume=/dev/sda4 resume2=/dev/sda4 quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
dmi.bios.date: 04/16/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 68ET35WW
dmi.board.name: IEL10
dmi.board.vendor: LENOVO
dmi.board.version: REFERENCE
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnLENOVO:bvr68ET35WW:bd04/16/2008:svnLENOVO:pn0769BMG:pvr3000N200:rvnLENOVO:rnIEL10:rvrREFERENCE:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.name: 0769BMG
dmi.product.version: 3000 N200
dmi.sys.vendor: LENOVO
system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-22-generic

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c) (prog-if 00 [VGA controller])
     Subsystem: Lenovo Device [17aa:383e]

Chris Emerson (chris-ulp) wrote :
Roland Neary (abcccc) wrote :

Same problem here, also using an intel video card, in this case a gma4500. Unlike you I use openbox with xcompmgr. It does seem to be video driver or Xorg related.

João Gomes (jvpgomes) wrote :

I have the exact same problem since I installed Maverick (clean install). I also have an Intel video card.

Another thing in which this problem is visible is the buttons of the Gmail page.

Please let me know need more information.

Bryce Harrington (bryce) on 2010-11-04
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Chris Emerson (chris-ulp) wrote :

Also, is there a way to get the X server to flush its image/font cache to recover from this?

bugbot (bugbot) on 2010-11-23
tags: added: resume
Sergei Ianovich (ynvich-gmail) wrote :

> * All applications are affected - eg terminal, Firefox, chromium, apport-gtk, the GNOME menus

There seems to be a workaround. Restarting the application with corrupted bitmaps helps me. Works with gnome-terminal and firefox.

m (anonymouser) wrote :

Same symptoms here with Intel graphics card on Acer Aspire 4720z. Updated to 10.10 from 10.04 and it appeared after that.

Dominic Sacré (dooooomi) wrote :

I noticed the same problem. I'm running Lucid, but the corrupted text rendering appeared after I manually upgraded xserver-xorg-video-intel. Lucid has version 2.9, and reverting to that release fixes the issue for me, but all versions between 2.11 and 2.13 exhibit the symptoms described in this bug report.

m (anonymouser) wrote :

As a followup to my confirmation above, I have found a solution and I don't experience this problem any more. Unfortunately, I'm not sure what I did. I didn't change any drivers that I'm aware of. I tried changing some settings and such, following recommendations I found on the net, but nothing seemed to work, so I avoided hibernating. Recently I sent the computer into hibernation mode by accident and upon resume, the issue was gone. I've since hibernated and resumed many times, including reboots, and I never have this problem again. I'm sorry I can't tell you what I did though...

Jeremy Nickurak (nickurak) wrote :

Workaround not working here, but I'm on a radeon x1600

Krack (krack3rz) wrote :

heres an image of my fails...only solution so far is restart.

maybe a temporary work around is to reset fonts somehow?
like you would restart nautilus, kill nautilus :D

Miguel de Dios (tres-14159) wrote :
Download full text (18.7 KiB)

I have the same problem with:

----
root@miguel-portatil:/home/miguel# lshw
miguel-portatil
    description: Notebook
    product: HP Compaq 6730s
    vendor: Hewlett-Packard
    version: F.0C
    serial: CNU9142H3T
    width: 32 bits
    capabilities: smbios-2.4 dmi-2.4
    configuration: boot=normal chassis=notebook uuid=EB58EDD4-DE17-DE11-BDA2-50A4BF0C1008
  *-core
       description: Motherboard
       product: 30E8
       vendor: Hewlett-Packard
       physical id: 0
       version: KBC Version 94.1C
     *-firmware
          description: BIOS
          vendor: Hewlett-Packard
          physical id: a
          version: 68PZU Ver. F.0C (03/12/2009)
          size: 64KiB
          capacity: 1984KiB
          capabilities: pci pcmcia upgrade shadowing cdboot bootselect edd int5printscreen int9keyboard int14serial int17printer acpi usb smartbattery biosbootspecification netboot
     *-cpu
          description: CPU
          product: Intel(R) Core(TM)2 Duo CPU T5870 @ 2.00GHz
          vendor: Intel Corp.
          physical id: 0
          bus info: cpu@0
          version: 6.15.13
          serial: 0000-06FD-0000-0000-0000-0000
          slot: Intel(R) Genuine processor
          size: 2001MHz
          capacity: 2001MHz
          width: 64 bits
          clock: 200MHz
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx x86-64 constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm ida cpufreq
          configuration: id=0
        *-cache:0
             description: L2 cache
             physical id: 1
             slot: Internal Cache
             size: 2MiB
             capacity: 2MiB
             capabilities: asynchronous internal write-back unified
        *-cache:1
             description: L1 cache
             physical id: 3
             slot: Internal Cache
             size: 32KiB
             capacity: 32KiB
             capabilities: asynchronous internal write-back data
        *-logicalcpu:0
             description: Logical CPU
             physical id: 0.1
             width: 64 bits
             capabilities: logical
        *-logicalcpu:1
             description: Logical CPU
             physical id: 0.2
             width: 64 bits
             capabilities: logical
     *-cache
          description: L1 cache
          physical id: 2
          slot: Internal Cache
          size: 32KiB
          capacity: 32KiB
          capabilities: asynchronous internal write-back instruction
     *-memory
          description: System Memory
          physical id: 4
          slot: System board or motherboard
          size: 3GiB
        *-bank:0
             description: SODIMM DDR2 Synchronous 800 MHz (1.2 ns)
             product: M4 70T5663QZ3-CF7
             vendor: Samsung
             physical id: 0
             serial: 7868324C
             slot: Top
             size: 2GiB
             width: 64 bits
             clock: 800MHz (1.2ns)
        *-bank:1
             description: SODIMM DDR2 Synchronous 800 MHz (1.2 ns)
             product: EBE11UE6A...

bugbot (bugbot) wrote :

Kernel bug perhaps. Do you still see this problem in natty? If so,
please run apport-collect <bug-number> to update with natty log files.

affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
bugbot (bugbot) on 2011-04-27
description: updated

Not fixed in Natty

tags: added: apport-collected natty

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: cristian 1392 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'ICH6'/'Intel ICH6 with ALC250 at irq 17'
   Mixer name : 'Realtek ALC250 rev 2'
   Components : 'AC97a:414c4752'
   Controls : 33
   Simple ctrls : 21
DistroRelease: Ubuntu 11.04
HibernationDevice: RESUME=UUID=e6635909-87c2-4f4f-a590-fb00a6a969ad
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: TOSHIBA Satellite Pro M70
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=8707b320-b04f-432a-8ec6-5c63f9714ef5 ro quiet splash i915.powersave=0 vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.52
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: natty
Uname: Linux 2.6.38-8-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 12/12/2008
dmi.bios.vendor: TOSHIBA
dmi.bios.version: V5.30
dmi.board.name: HTW00
dmi.board.vendor: TOSHIBA
dmi.board.version: Null
dmi.chassis.asset.tag: *
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvrV5.30:bd12/12/2008:svnTOSHIBA:pnSatelliteProM70:pvrPSM75E-00C007IT:rvnTOSHIBA:rnHTW00:rvrNull:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: Satellite Pro M70
dmi.product.version: PSM75E-00C007IT
dmi.sys.vendor: TOSHIBA

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

As you can see the only "bad" font here is "t" but it can involve any font after some hour

Marius Gedminas (mgedmin) wrote :

I've seen this on Maverick and on Natty. I've got Intel GM965 video. I usually see corrupt images, like the launcher under cursor in my screenshot.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Ramsey (ramsey-hazbun) wrote :

I also have this problem.

inoxi (rus-3i) wrote :

Ok guys... I have found a solution..but this is not a bug fix.. I think this problem comes with incompatibility of the font Ubuntu. I have changed the fonts and its working fine now.

Goto Appearance and Preference
Change these fonts to Verdana (I changed to verdana.. don't know about other fonts)
Application font | Desktop font | Window title font

Cheers,

Inoka

Naftoli Gugenheim (naftoligug) wrote :

I have this problem on Kubuntu 11.04

Mike (mike-fdb) wrote :

This bug can be triggered without suspend/resume. See bug #667737

Changed in linux (Ubuntu):
status: Expired → Confirmed
OrelEagle (oreleagle) wrote :

Hello,

I had this bug in Maverick. I didn't try on Natty, but I have just tested hibernation on Oneiric and the bug is gone.

Maybe I can mention that I made the test on the exact same laptop, using the default upgrade system.

Mike Szablicki (mikeszablicki) wrote :

Ok, I too encounter garbled text (corrupted looking fonts) issue on a Asus EEEPC 1000HD. I do NOT need to hibernate in order to replicate this, as it happens intermittently on my system. I've started to encounter this issue ever since upgrading to 11.04 as well as to 11.10. The workaround provided in comment #39 has worked for me. In Ubuntu 11.10 you will need to run "advanced-settings" to change your default fonts which is available if you've installed "gnome-tweak-tool"

tags: removed: apport-collected natty

Chris Emerson, thank you for reporting this and helping make Ubuntu better. Maverick reached EOL on April 10, 2012.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue in a supported release? If so, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in a supported release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.

Please let us know your results. Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Marius Gedminas (mgedmin) wrote :

This bug is still present in Oneiric, and it's not fixed upstream yet: https://bugs.freedesktop.org/show_bug.cgi?id=45092

Chris Emerson (chris-ulp) wrote :

This still affects me with the Precise beta.

The kernel fix mentioned in http://thread.gmane.org/gmane.linux.kernel/1274203 sounds promising...

Chris

Chris Emerson (chris-ulp) wrote :

This is still an issue after updating to Precise (beta).

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Chris Emerson, thank you for testing this in Precise (beta). In addition to the providing mainline testing results as requested in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/659434/comments/44 could you please provide the information following https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-upstream-testing precise
Chris Emerson (chris-ulp) wrote :

Yep - I've installed the mainline kernel and will report back after the next few hibernates.

Which information from the DebuggingKernelSuspendHibernateResume is actually useful? That seems mainly geared at problems where the system doesn't manage to resume.

In answer to the questions in the "Information Gathering" section:

* Did the machine break while going to sleep or waking up?
  - I don't know; some images are corrupted *somewhere* in the process.
* Is it reproducible?
  - Yes, after most resume-from-hibernate there is some visible corruption of the background and/or some characters.
* Did it work before?
  - Yes, but it's now so long ago I don't know when it started going wrong, sorry.

The rest of the questions look like there's really about a failure to resume - resume's working fine apart from the corruption.

Chris Emerson (chris-ulp) wrote :

I can confirm that the issue still happens with the mainline kernel (linux-image-3.4.0-999-generic_3.4.0-999.201204170501_amd64.deb).

description: updated
Oliver R. (oliverr) wrote :

The problem is also present in 3.2.0-24-generic-pae after a clean install of 12.04. So far I have seen it in firefox (changed the font there) and emacs (no solution yet). It's an Intel board (kernel module i915).

Is any more information helpful?

Oliver R., please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

Oliver R. (oliverr) wrote :

I followed inoxi's hint and changed all fonts from Ubuntu to Verdana, which seems to work.

But what's so special about the Ubuntu font? Are there other fonts that show the same problem?

Oliver R., please stop making comments on this bug report. If you are having a problem in Ubuntu please follow the directions noted in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/659434/comments/52 .

varacanero (varacanero) wrote :

Affects me too, Thinkpad X200 with i915 Intel Graphics and dual display.

varacanero, please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

varacanero (varacanero) wrote :

ok, here it is:

David Pérez (sanete) wrote :

Also affects me: Kubuntu 12.04 and Linux 13 KDE.
VGA compatible controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)
I think it affects only GTK apps like Firefox, Chrome, but not Qt based ones.

If I try to change the display resolution, then the display becomes fully garbaged.

David Pérez (sanete) wrote :

More clues:

Strangely, I haven't observed this bug in Oneiric with the same hardware.
I have a laptop with Nvidia card and same linux distribution and doesn't exhibit this bug either.

Ruman Gerst (ruman-gerst) wrote :

Happens for me on Utopic with an Acer Extensa 5230E (Intel 4500M) using Kubuntu Plasma 5.1.1.
Usually everything works fine until I start a new lightdm/sddm (tried both, doesn't matter) session on VT8 and switching back to the old session (VT7). VT8 is also corrupted if I switch there.

I did not experience this bug until I switch from 14.04 x86 (KDE 4.14.1) to Kubuntu 14.10 x64 by complete reinstall.
Also I upgraded RAM to 3GB and tested it well with MemoryTest (no errors), but could it be some sort of corruption in graphics memory, because this laptop allocates graphics memory when needed (At least it seems to do this).

Ruman Gerst, thank you for your comment. So your problem and hardware may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
https://wiki.ubuntu.com/Kernel/Policies/DuplicateBugs
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.