monitor mode wireless interfaces incorrect channel -1

Bug #643788 reported by rais
174
This bug affects 35 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Incomplete
Low
Unassigned
Nominated for Lucid by needlez6
Nominated for Maverick by needlez6

Bug Description

Binary package hint: aircrack-ng

when i enable monitor mode on wlan0 with 'sudo airmon-ng start wlan0'
followed by this command 'sudo aireplay-ng --option mon0'
i get this error
20:58:09 Waiting for beacon frame (BSSID: ************) on channel -1
20:58:09 mon0 is on channel -1, but the AP uses channel 11

wlan0 is connected to channel 11 but mon0 is not in the same channel.

WORKAROUND: install linux-image-2.6.32 besides 2.6.35.
You need to download the kernel from here :
http://packages.ubuntu.com/lucid-updates/linux-image-2.6.32-25-generic
sudo dpkg --install linux-image-2.6.32-25-generic_*.deb
sudo update-grub

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: aircrack-ng 1:1.1-1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
Architecture: amd64
CheckboxSubmission: 0d1ee44305f4597f855d82fe39cb13fe
CheckboxSystem: 331fbefb4b1f6727f4a8261fee7507c9
Date: Mon Sep 20 21:00:25 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: aircrack-ng

Revision history for this message
rais (ramzi-rais) wrote :
Revision history for this message
needlez6 (needlez6) wrote :

I also get this same issue. I believe its an issue with compat-wireless, or with the kernel 2.6.35 itself. Not sure, but I believe there is a patch to fix this, it is the maxim -1 patch. I will link the patch in my post. However I can not confirm if this fixes the issue because I have no idea how to compile a kernel with this patch. Also if this patch does fix the issue,

Revision history for this message
needlez6 (needlez6) wrote :

Not sure but this is the only solution ive found for it. I don't know if it works because I have no idea how to compile a kernel with it or what to do with it. If you can figure this out, please turn this into a simple solution for us users that don't compile kernels.

Changed in aircrack-ng (Ubuntu):
status: New → Confirmed
description: updated
tags: added: patch
Revision history for this message
rais (ramzi-rais) wrote :

thank you needlez
the idea of compilling my kernel is scaring me! i am not sure i am enough brave to do this.However i confirm that the bug comes from the kernel and not from compat-wireless,because i installed linux-image.2.6.34(lucid) and the problem was solved.

Revision history for this message
needlez6 (needlez6) wrote :

ok, also confirmed this because i compiled compat-wireless from source and still get the same issue. However i am not able to downgrade my linux-image because at the current moment 2.6.35(maverick) is the only one that supports the laptop im running. Strange because i thought 10.04 would fix the issue with the i7 laptops and nvidia cards. So as of now im stuck until this issue is resolved.

Revision history for this message
Blue Dream (shanxian1987) wrote :

Same problem
who have simple solution?

Revision history for this message
Delyan Kalchev (delyank) wrote :

Compare with Bug #602609

Revision history for this message
rais (ramzi-rais) wrote :

blue dream, my (simple) solution is to install linux-image-2.6.32 besides 2.6.35.
You need to download the kernel from here :
http://packages.ubuntu.com/lucid-updates/linux-image-2.6.32-25-generic
sudo dpkg --install linux-image-2.6.32-25-generic_*.deb
sudo update-grub

From this point, In the grub you 'll have the possibility to boot on linux-image-2.6.32 and then aircrack will work ,except if your'r in the same case than needlez6 !

Revision history for this message
needlez6 (needlez6) wrote :

ok, so im sorry to post this fix so late but i finally found a way to fix this.

wget http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-2010-10-16.tar.bz2
tar -jxf compat-wireless-2010-10-16.tar.bz2
cd compat-wireless-2010-10-16
wget http://patches.aircrack-ng.org/mac80211.compat08082009.wl_frag+ack_v1.patch
patch -p1 < mac80211.compat08082009.wl_frag+ack_v1.patch
wget http://patches.aircrack-ng.org/channel-negative-one-maxim.patch
patch ./net/wireless/chan.c channel-negative-one-maxim.patch
gedit scripts/update-initramfs
#*** FIND LINE 13: KLIB=/lib/modules/2.6.31-wl/build
#*** REPLACE WITH: KLIB=/lib/modules/$(uname -r)/build
make
sudo make install
sudo make unload
sudo reboot

This will fix the issue with the negative channel and aircrack-ng. I confirmed this today, it was compat-wireless not just the kernel. Also not sure but I think WPA handshakes are messed up too. But I know this will work to break WEP. And this does work to fix. Thanks to squirrelscript and ubuntuforums and iwir3d.

Changed in aircrack-ng (Ubuntu):
status: Confirmed → Fix Released
assignee: nobody → needlez6 (needlez6)
needlez6 (needlez6)
Changed in aircrack-ng (Ubuntu):
status: Fix Released → Fix Committed
Revision history for this message
comrobo (j-alfarop) wrote :

hello.

I have a card with a broadcom chip and working with b43 driver.

so this patch work with b43?
this change b43 for compat-wireless?

so... thanks for your help.

greetings jo.

Revision history for this message
rais (ramzi-rais) wrote :

intel3945abg wifi card works fine

Revision history for this message
needlez6 (needlez6) wrote :

if you have the channel -1 error this will fix it regardless of what wifi card you use.

Revision history for this message
comrobo (j-alfarop) wrote :

OK, it works, in this difficult card:

Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315]

(some people will know about I'm talking)

Thank you very much!

Revision history for this message
Guy (waterville123) wrote :

New patch works with Atheros ATH9k and with Alfa RTL8187L when using bash. But ... when using WepCrackGui you can't see replies, no IVS capture. Strange.

Revision history for this message
sargas (sargas) wrote :

needlez6, where is this fix committed? A Ubuntu package, compat-wireless upstream, a natty package, etc?

Revision history for this message
needlez6 (needlez6) wrote :

sorry its not commited yet, I was going to compile this fix as a package, didn't realize, changing status now, just to fixed, or patched... sorry, also if you update your kernel to 2.6.35-23 this issue will come back and you will have to redo the entire process. Wish there was a better way to fix this.

Changed in aircrack-ng (Ubuntu):
status: Fix Committed → In Progress
Revision history for this message
needlez6 (needlez6) wrote :

And @Guy: Not sure about WepCrackGui, but I have no issues with Wep crack-ng from the terminal. Are you using -w option and saving it?? Other then that not sure. Try doing it from terminal.

sudo airmon-ng start (dev) (ch)
sudo airodump-ng -c (ch) -w (psk) <mon0>
sudo aireplay-ng --fakeauth 0 -e "ESSID" -b BSSID -h STATION <mon0>
sudo aireplay-ng --arpreplay -b BSSID -h STATION <mon0>

try using that and see if you can get your IVs. And to anyone can they confirm if WPA is messed up or not?? I'm testing but my router is two channels N+G so not sure if I can even do WPA with a G card. Laterz

Revision history for this message
Lucone (johnmyung83) wrote :

Does not work with iwlagn

Revision history for this message
Guy (waterville123) wrote :

The first time I tried using WepCrackGui was after the update from Lucid to Maverick. Then it didn't worked as expected. After reinstalling Maverick from scratch and applying your patch, all work. Even WPA. I'm on 2.6.35-22. Tried with the Alfa RTL8187L. It is just a pitty that after each kernelupdate we will have to fix it again.

Revision history for this message
Guy (waterville123) wrote :

Forgot to say: first I was using Aircrack-ng that was released with Maverick. Now I installed svn r1788.

Revision history for this message
Daniel Hackney (haxney) wrote :

The problem still exists on Maverick 2.6.35-23-generic, but applying needlez6's fix worked. I'm running an Atheros AR5212, x86, Ubuntu 10.10 desktop on a Lenovo Thinkpad T60 laptop. Aircrack works successfully now.

Any idea of when this will be packaged? It would be nice not to have to apply a custom fix ;)

Revision history for this message
Lucas Serven (lserven) wrote :

I just installed the patch following the directions outlined above and it solved the problem perfectly however a side effect has appeared. That is, whenever I'm connected to a network for about two minutes, Maverick freezes completely. I installed the patch last night and the freezing has continued to happen every time i reboot since then. I'm running 10.10 on an eee pc 1005ha.

Thanks for the great work so far!

Revision history for this message
Lucas Serven (lserven) wrote :

I believe that the issue I am having is the same one described in http://ubuntuforums.org/showthread.php?p=10159157, except that I am running 10.10.

Revision history for this message
Guy (waterville123) wrote :

I think that this has nothing to do with the compat-wireless.
After installing Maverick I had those crashes too.
How I solved it:
- go to http://kernel.ubuntu.com/~kernel-ppa/mainline/ and install 2.6.37-rc5-natty.
- get http://www.orbit-lab.org/kernel/compat-wireless-2.6-stable/v2.6.37/compat-wireless-2.6.37-rc5-2.tar.bz2
- then follow the instructions of Needlez6.
- In startup-manager (grub) change to 640 x 480, no splash.
- reboot

May be you can try just the grub-trick on 2.6.35. I didn't try it.

Guy

Revision history for this message
Lucas Serven (lserven) wrote :

I'll give this a try! However, I've been running Maverick since October and had the first crash five minutes after following Needlez6's instructions, so I'm almost certain that this is a result of the patching process. I'll post back early this week! Thanks for the suggestion, Guy.

Lucas

Revision history for this message
cyd (cyd) wrote :

same problem,i'm locked on channel -1 (ath9k driver, ubuntu 10.10, dist-upgrade is done, no fix yet )

Revision history for this message
IMBECIL (duckman-666) wrote :

I'm having the same issue as Lucas Serven and I also think that is a side effect of the fix. Once I removed the patched version, the problem disappeared.

Revision history for this message
IMBECIL (duckman-666) wrote :

I downloaded the most recent tarball of compat-wireless (01/30/2011) and followed Squirrelscript instructions. Solved the freezing problem.
http://wireless.kernel.org/download/compat-wireless-2.6/compat-wireless-2011-01-30.tar.bz2

Revision history for this message
Lucas Serven (lserven) wrote :

I tried the fix that Guy suggested in December but I continued to have the same problems with the erratic panics as a side effect of the patch. However, the compat-wireless package that IMBECIL suggested fixed the channel lock problem and the freezing problem, so now my machine works great. Thanks, IMBECIL.

Revision history for this message
David (davidecumbo) wrote :

I have the same problem that has LUCAS SERVEN. How do I use the compat-wireless package that has posted Imbecil?

Revision history for this message
Justin (compuhowto) wrote :

Hello I thank you all for the help with this channel problem. I have followed the patching directions and everything seemed to go fine until I try and load my b43 drivers I get an error "Error inserting b43 Invalid argument" I am currently downloading an older kernel version to see if that fixes is and I will let you know if that fixes it but I would like to find a way to fix this with the current kernel version. If anyone knows a way please let me know.

Revision history for this message
Justin (compuhowto) wrote :

UPDATE: Kernel 2.6.32-25-generic does indeed not have the -1 channel problem. I am able to use aireplay and inject packets correctly.

I would still like to find a solution for the current kernel version though so if someone knows how to fix the b43 channel -1 problem please post.

lspci shows:
Network controller: Broadcom Corporation BCM4312 802.11a/b/g (rev 02)

Revision history for this message
comrobo (j-alfarop) wrote :

Here is the best solution:

http://ubuntuforums.org/showthread.php?t=1598930&page=13

"Hi, I have a better solution for everyone trying to use this patch that isn't able to get it working. You should go and download the svn package from aircrack-ng. first download the package for svn by running this in terminal.
svn co http://trac.aircrack-ng.org/svn/trunk/ aircrack-ng
then browse to that folder with cd and sudo make && make install"

Revision history for this message
Przemek K. (azrael) wrote :

Natty's kernel 2.6.38-8-generic is affected by this bug too.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Revision history for this message
Przemek K. (azrael) wrote :

The kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.39.1-oneiric/ shows the same behaviour.
This used to work in Ubuntu 10.04 (Lucid) so it's definitely a regression in the Linux kernel in Ubuntu.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: regression-release wifi
Revision history for this message
Lucas Serven (lserven) wrote :

I can confirm that this bug has begun to affect me again in Natty. The patch provided for the bug in Maverick now only results in freezing my system.

Revision history for this message
Rémi Menegon (firewave-free) wrote :

I'm working on a PPA to fixe that, by patching cw-backport. Stay tuned !

Revision history for this message
Przemek K. (azrael) wrote :

Any update?
So far the only workaround that works is using Lucid's 2.6.32 kernel.

Revision history for this message
Przemek K. (azrael) wrote :

Installing any of the linux-backports-modules-compat-wireless-* packages didn't help.

Changed in aircrack-ng (Ubuntu):
status: In Progress → Invalid
Revision history for this message
Przemek K. (azrael) wrote :

This is not a bug in aircrack, only in the Linux kernel.

Revision history for this message
Bruno Clermont (b.clermont-deactivatedaccount) wrote :

I fixed that easily (i'm in Oneiric)

Get package source of linux-backports-modules-cw-3.1-3.0.0-14-*, from:

http://archive.ubuntu.com/ubuntu/pool/main/l/linux-backports-modules-3.0.0/linux-backports-modules-3.0.0_3.0.0-14.6.tar.gz

Extract it, and patch updates/cw-3.1/net/wireless/chan.c

with:

http://patches.aircrack-ng.org/channel-negative-one-maxim.patch

well, I did not used patch in my case, I update the code manually... it might work with patch

then build new packages with dpkg-buildpackage

the result is (in my case):

../linux-backports-modules-cw-3.1-3.0.0-14-generic_3.0.0-14.6_amd64.deb
../linux-backports-modules-cw-3.1-3.0.0-14-server_3.0.0-14.6_amd64.deb
../linux-backports-modules-net-3.0.0-14-generic_3.0.0-14.6_amd64.deb
../linux-backports-modules-net-3.0.0-14-server_3.0.0-14.6_amd64.deb
../linux-headers-lbm-3.0.0-14-generic_3.0.0-14.6_amd64.deb
../linux-headers-lbm-3.0.0-14-server_3.0.0-14.6_amd64.deb
../updates-modules-3.0.0-14-generic-di_3.0.0-14.6_amd64.udeb

I installed the package that match my kernel, rebooted and voila!

Revision history for this message
onny (onny) wrote :

I wonder if this bug might be fixed in 3.2 or maybe in kernel 3.3?

Revision history for this message
Przemek K. (azrael) wrote :

Does anyone know if this bug was ever tracked or fixed in the upstream kernel?

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Revision history for this message
Przemek K. (azrael) wrote :

This bug is tracked in Aircrack-NG project:
http://trac.aircrack-ng.org/ticket/742
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

no longer affects: indra
Przemek K. (azrael)
Changed in aircrack-ng (Ubuntu):
assignee: needlez6 (needlez6) → Przemysław Kulczycki (azrael)
assignee: Przemysław Kulczycki (azrael) → nobody
Revision history for this message
Przemek K. (azrael) wrote :
Revision history for this message
Bruno Clermont (b.clermont-deactivatedaccount) wrote :
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

rais, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

description: updated
no longer affects: aircrack-ng (Ubuntu)
tags: added: kernel-wifi
removed: wifi
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
description: updated
tags: removed: patch
Revision history for this message
Patryk (pmalek) wrote :

@Christopher

This is still an issue for me on Ubuntu 12.04. I have tried running `apport-collect -p linux 643788` but I have received an information that

You are not the reporter or subscriber of this problem report, or the report is a duplicate or already closed.

Please create a new report using "apport-bug".

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Patryk, regarding your comments https://bugs.launchpad.net/ubuntu/+source/linux/+bug/643788/comments/49 :
"This is still an issue for me on Ubuntu 12.04. I have tried running `apport-collect -p linux 643788` but I have received an information that

You are not the reporter or subscriber of this problem report, or the report is a duplicate or already closed.

Please create a new report using "apport-bug"."

This is as designed.

However, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette

When opening up the new report, please feel free to subscribe me to it. Thank you for your understanding.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

Revision history for this message
akrit (aakreetv) wrote :

I also get this same issue, iam using ubuntu 13.04 kernel version 3.8.0-26-generic
how to fix this
can anyone suggest me any patch or anythingelse

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

akrit, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

Thank you for your understanding.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.