Can't boot amd64 live cd on Mac (EFI)

Bug #633983 reported by Kalman Reti on 2010-09-09
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Ubuntu CD Images
casper (Ubuntu)
linux (Ubuntu)
syslinux (Ubuntu)

Bug Description

Previous release livecd's were bootable by holding down option while the cd was in the drive and selecting the "Windows" cd.

Trying this with the Meerkat beta desktop livecd image (md5sum verified) I just get two numbers (1. and 2.) which look like
they should be labeling some text but there is no text visible and the message to select CD-ROM boot type. Typing either a 1 or a 2 doesn't do anything.

Googling revealed that some Windows beta iso images had the same problem booting on Macs; apparently in this case it was an issue that the Windows version had EFI support (and so didn't use the BIOS fallback) but was assuming a newer version of EFI.
There were some other posts which claimed that it was that the iso image was generated incorrectly (something having to do with ISO9660 versions).

Unfortunately, even though I develop software for a living, there is nothing I can do to help debug this (except try newer versions) since once I get to that message, everything seems unresponsive.

The upshot is that a useful thing which I did frequently in older versions (i.e. boot the 64bit desktop livecd on this macbook) no longer works.

chiefcooker (chiefcooker) wrote :

the problem is, that apple efi is not compatible with windows uefi, so will get this error on some mac models with 64bit vistaa sp1, 64bit win7 and now with ubuntu too. the only way to fix this with windows is to create a new install dvd without efi, hopefully the ubuntu devs do not remove efi but try to support apple efi, if this can be done. otherwise please make the livecd not to boot efi on unsupported machines.

best wishes, chief

Jeremy Foshee (jeremyfoshee) wrote :

Hi Kalman,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 633983

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Przemek K. (azrael) on 2010-09-25
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Przemek K. (azrael) wrote :

I can confirm this bug on Macbook 2,1 - I tried to boot latest Maverick daily live CD (64-bit amd64 iso) and it failed - rEFIt recognised it as 3 entries (Linux, Legacy OS, and some EFI64 entry). The first 2 result in a black screen with:


Select CD-ROM Boot Type :
The keyboard becomes unresponsive here and I can't go any further.
The third option says that it can't find a proper EFI image and offers to go back to rEFIt.

Similar bugs in Fedora/Red Hat:

Also here you have some useful information on the same problem with booting 64-bit Windows Vista/7:

I don't think it is a bug with Linux - it's probably IsoLinux.

Przemek K. (azrael) on 2010-09-25
summary: - can't boot Meerkat beta amd64 livecd on core 2 duo macbook
+ Can't boot Maverick beta amd64 live cd on macbook (EFI)
Changed in casper (Ubuntu):
status: New → Invalid
Przemek K. (azrael) on 2010-09-25
tags: added: regression-potential

Booting from 64-bit Live CD works in Lucid. This might be related to the fact that Maverick uses syslinux 4.x while Lucid and earlier releases use syslinux 3.x.

# lucid (utils): Bootloader for Linux/i386 using MS-DOS floppies
2:3.63+dfsg-2ubuntu3: amd64 i386
# maverick (utils): collection of boot loaders
2:4.01+dfsg-3ubuntu1: amd64 i386

Changed in linux (Ubuntu Maverick):
importance: Undecided → High
milestone: none → ubuntu-10.10
Przemek K. (azrael) wrote :

i386 live CD works.
I tried burning the amd64 ISO to 2 different discs - both of them failed to boot in the same way.
I tried today's daily iso amd64 - same outcome.
The amd64 iso was bootable on my other laptop (HP).

Przemek K. (azrael) wrote :

The error message when you try to use the 3rd option in refit is:
Starting bootx64.efi
Error: Unsupported while loading bootx64.efi
* Hit any key to continue *
(pressing any key goes back to refit)

satmandu (satadru-umich) wrote :

Confirming that this also fails with the Select CD-ROM message on a MacBook Pro 3,1 (Late 2007) and the 9/25 nightly cd image build.

satmandu (satadru-umich) wrote :

On the MacBook Pro 3,1 and the 9/25 amd64 nightly build image, I try this:

Hold down option key at boot.
Select "EFI BOOT" CD
I now get grub, with live and install options.

Selecting either gives me this error shortly thereafter:

Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)
Pid: 1, comm: swapper Not tainted 2.6.35-22-generic #33-Ubuntu
Call Trace:
[<ffffffff815863e0>] panic+0x90/0x111
[<ffffffff81aee343>] mount_block_root+0x273/0x29e
[<ffffffff81aee3c4>] mount_root+0x56/0x5a
[<ffffffff81aee538>] prepare_namespace+0x170/0x1a9
[<ffffffff81aed8c9>] kernel_init+0x1ad/0x1bd
[<ffffffff8100aee4>] kernel_thread_helper+0x4/0x10
[<ffffffff81aed71c>] ? kernel_init+0x0/0x1bd
[<ffffffff8100aee0>] ? kernel_thread_helper+0x0/0x10

satmandu (satadru-umich) wrote :

disabling grub options to hide the kernel log gives me this:

md: ... autorun DONE.
RAMDISK: couldn't find valid RAM disk image starting at 0.
List of all partitions:
0b00 1048575 sr0 driver: sr
No filesystem could mount root, tried: ext3 ext2 ext4 fuseblk
Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)
Pid: 1, comm: swapper Not tainted 2.6.35-22-generic #33-Ubuntu
Call Trace:
[<ffffffff815863e0>] panic+0x90/0x111
[<ffffffff81aee343>] mount_block_root+0x273/0x29e
[<ffffffff81aee3c4>] mount_root+0x56/0x5a
[<ffffffff81aee538>] prepare_namespace+0x170/0x1a9
[<ffffffff81aed8c9>] kernel_init+0x1ad/0x1bd
[<ffffffff8100aee4>] kernel_thread_helper+0x4/0x10
[<ffffffff81aed71c>] ? kernel_init+0x0/0x1bd
[<ffffffff8100aee0>] ? kernel_thread_helper+0x0/0x10

Holding "Option" key at boot allowed me to choose only "Windows" CD,
which resulted in the same "Select cd-rom boot type" message.

It is not clear that this is a kernel issue. It is likely this is a incompatibility between the Mac EFI and i386 uEFI implementations. This is suggested by the fact the i386 images boot correctly (which do not have EFI support) but the amd64 images do not (which do have EFI support). To confirm that this is the cause of the issue I have remastered the amd64 image without the EFI support. If those who have these machines could test the image below and let us know it works for you:

Please report any testing results here. Thanks!

Changed in linux (Ubuntu Maverick):
status: Confirmed → Incomplete
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) wrote :

Note that the above image is intended for testing only. We are not in a position to drop EFI support as many newer platforms will only have EFI.

Kalman Reti (kalman-reti) wrote :

I'm downloading the image and will try it out at home tonight (the macbook
is my wife's).

Do you have an md5sum of the image?

On Fri, Oct 01, 2010 at 12:23:33PM -0000, Kalman Reti wrote:

> Do you have an md5sum of the image?

The master copy I have here is as below:

    $ md5sum maverick-desktop-amd64-noEFI.iso
    6d33624636e3d697426aa55467f4421a maverick-desktop-amd64-noEFI.iso


For me it works on a imac9,1 but it doesn't on a macbook2,1. I guess it may be related to 64 vs 32 bits efi, respectively.

Andrea Micheloni (a4a.m7i) wrote :

I can confirm the 10.10rc amd64 is non-bootable in any way on my MacBook 3,1.

Andrea Micheloni (a4a.m7i) wrote :

And the non-EFI iso works like a charm, instead.

Przemek K. (azrael) wrote :

I was able to boot from the amd64 no-EFI iso on my Macbook 2,1.

jf pambrun (jf-pambrun) wrote :

On a MacbookPro 7,1 and the RC release (ubuntu-10.10-rc-desktop-amd64.iso).

Holding option and selecting Windows CD works fine and I was able to proceed with installation.

Selecting EFI Boot shows GRUB, but selecting try or install shows a black screen.
However, adding acpi=force, noefi and video=efifb shows similar error to comments 8 ant 9

Przemek K. (azrael) wrote :

No change for me using today's daily livecd (20101003 - after RC) - i386 works, amd64 doesn't. Using "Option" key doesn't help. (Macbook 2,1)

Colin Watson (cjwatson) wrote :

We'll have to release-note this, although I'm currently working on building unsupported "amd64+mac" CD images which will live under the ports directories on The release-noted workaround will be to use either these images or the i386 image.

Przemek K. (azrael) wrote :

Works for me.

Mario Vukelic (mario-vukelic) wrote :

Thanks. Works on my MacBook 5.5. (Though it boots into a gdm screen which asks for a login and password - I dunno if that's expected in Maverick).

Vladimir Travalja (dovla091) wrote :

well I have similar problem, not only that I can't install ubuntu maverick, I can't install previous versions of ubuntu x86 or x64 it doesn't matter, after I put cd/dvd and press c key or alt and then select the "windows" my macbook pro 3.1 santarosa just freeze it self. I saw this article and saw that you are talking about EFI..., probably the guys that wrote above were right, but the funny thing on my macbook pro v 3.1 I can't boot windows either (XP, VISTA, "vistas service pack called win 7... ;) ), nor anything else. the EFI only recognize OSX install DVD and nothing else... any comment on that?

jay3sh (jay3sh) wrote :

Colin, could you also provide an alternate ISO for amd64+mac? I would like to try it, but I have LVM based setup and can't use desktop ISO for that.

Thanks in advance.

Changed in linux (Ubuntu Maverick):
milestone: ubuntu-10.10 → none
Changed in ubuntu-release-notes:
status: New → Fix Released

Hi, probably a tiny bit too late, but did you try out a (very) recent grub version? I for myself was persecuted by the boot problem starting with amd64 releases of ubuntu 9.xy on my MacBook3,1. Until today I ran a custom grub 1.96 setup on my EFI partition (I expect 1.98 to behave the same). I decided to give its bzr live development branch a try [1] and it fixes the broken ramdisk loading for me (I am now able to boot an official ubuntu kernel instead of the vanilla non-initrd workarounds I was used to). Only problem seems to be the working of video=efifb. Screen got blank somwhere in between booting (I'd guess when encountering conflict between efifb and intel(drm)fb [2]) and stayed blank, but luckily the gdm-startup sound/input sound was hearable. So I did a blank login (no change) and then did close/open the lid and trigger a sleep/wakeup cycle, which amazingly brought up the running X session, I'm writing from. Maybe I should just use video=inteldrmfb instead of video=efifb as boot parameter, though my vanilla kernel with video=efifb (and without inteldrmfb support) didn't show the blank screen issue.

[heiko:hal][~] >> grub-mkimage -V
grub-mkimage (GRUB) 1.99~beta0

[ 3.324964] fb: conflicting fb hw usage inteldrmfb vs EFI VGA - removing generic driver
[ 3.326817] Console: switching to colour dummy device 80x25
[ 3.600250] Console: switching to colour frame buffer device 160x50
[ 3.602903] fb0: inteldrmfb frame buffer device

I can confirm that the modified ISO boots fine.

Pierce Wetter (obastard) wrote :

The release note is incorrect. This also happens on a MacPro. (MacPro 1,1 in my System Profiler)

Also there is only the desktop version in cdimage/ports. Does the server image need to be updated as well?

SeedOfOnan (seedofonan) wrote :

I have a March 2009 version of the Mac Mini. I've been a happy customer of 10.04 64 desktop. Today I tried booting ubuntu-10.10-desktop-amd64 live CD, holding down the <option> key while powering up. The choose-OS screen shows two options for the CD, one labeled 'Windows' and the other EFI. If I select the EFI choice and further choose to launch the live CD instead of install or check disk, then I get exactly what satmandu wrote on 2010-09-27 above. But the alternate 'Windows' choice seems to work fine.

So what was the 'fix' that Robbie Williamson mentioned on 2010-10-09? I'm guessing the inclusion of the second choice that appears labeled 'Windows' (which was the only choice available with the 10.04 live CD). And where might I go online to follow the progress of mac EFI support?

Mario Vukelic (mario-vukelic) wrote :

@Seed: Note that this bugs affects several projects, one of those being the release notes*. The fix mentioned by Robbie was for the release notes only, and was about mentioning the issue (see comment #21 by Colin). For other affected projects, the bug is still considered to have an open status.


aschmitz (aschmitz-) wrote :

Would it be reasonable to add a link to (or a specific ISO from there) to the release notes under the section for this bug?

Crazor (crazor) wrote :

Though not directly concerning this bug, I'd like to ask if anyone experienced PRAM corruption or other strange problems while trying the desktop amd64 installer.

I was able to render my MacBook 5,1 unbootable two times yesterday when I tried the standard (non-"+mac") iso. Neither Snow Leopard would boot nor any Apple installation media I had at hand, nor Ubuntu 10.04. OS X told me it could not enumerate a USB device in some port (none were connected) and then hung up with "still waiting for root device".

After zapping the PRAM, all installations worked again, and I could also boot the Snow Leopard installer DVD. After fiddling around some more with the amd64 installer, the same state occured, after which I had to zap the PRAM again.

Has anybody seen something similar? If not then maybe I need to get my logic board checked or replaced, if this continues.

I'll try the "amd64+mac" installer now.

Crazor: I didn't have anything of the sort. Perhaps the hard shutdowns from booting up the Live CDs were the cause.

tags: added: regression-release
removed: regression-potential
tags: added: maverick
Jools Wills (jools) wrote :

This was the closest bug I could find to an issue I have been having with maverick built kernels and efi. some background first:

I have been building kernels on a linuxmint 9 (lucid) based system, for a joggler device target (efi based device - see

The bug:

Everything was working fine, until I upgraded my system to the linuxmint 10 RC (maverick based). I understand these are not specifically ubuntu, but the build and base system is the same.

After I had upgraded my kernel building machine to linuxmint 10 RC (Maverick based), my kernels have failed to boot on my efi based device with a failure mentioned earlier here "RAMDISK: couldn't find valid RAM disk image starting at 0." the initrd is loaded, but then this failure has occurred. I spent some 7+ hours thinking I had made some error somewhere, and modifying my kernel options, yet even using the config from a previous kernel which worked fine, it would always fail to use the initrd.

Having worked thought every possible "human error" cause I could think of, I could only fall back on the differences between the old and new system. For example GCC/binutils etc. I had already tried a few versions of GCC and it didn't seem to help.

I have however solved the issue now, and it points to an issue with the maverick binutils. After my many failures I downgraded binutils to the lucid release, and rebuild the kernel as usual. It worked!. to make sure it wasn't some fluke, i then upgraded binutils again to the maverick release and rebuilt. again the same failure.

I have no idea what would be causing this specifically with for example LD or some other part of binutils, but I am completely unable to build a kernel that will work with an initrd with the maverick binutils. downgrading them to the lucid version solves the problem completely. This points to what I think may be some significant problem with the maverick binutils, however due to my test case, it is hard to debug further.

John Doe (b2109455) wrote :

I'm experiencing the same issue on non-Apple hardware; and Intel D975XBX board to be exact.

Interestingly the 10.10-desktop-amd64.iso will eventually boot, however neither the 10.10-server-amd64.iso or the 10.10-alternate-amd64.iso work.

Jamie Lokier (jamie-shareable) wrote :

I can confirm there is a *Binutils* issue with building kernels on Maverick, which results in boot failures on (at least my) *32-bit* x86 laptop (not a Mac). The symptoms are different to those described here, but consistent. It suggests a miscompilation/mislinking.

When building on Maverick, I get a kernel which doesn't boot.

When building on the same system, with the same kernel source and config, with just GCC downgraded to Lucid's version, boot fails in the same way. When Binutils is also downgraded, the kernel boots - and the symbol map is at last identical to the kernel I built before upgrading Lucid to Maverick.

I mention this here because an earlier comment refers to Binutils.
Perhaps this entire bug is due to the Binutils issue?

Jamie Lokier (jamie-shareable) wrote :

See #673236 for the binutils issue.

Joseph Mark Jarvis (joejarvis) wrote :

I have this problem on non-Apple hardware as well (see comment #37). I have an Intel DG965WH motherboard.

michael (reeves-87) wrote :

I have discovered some additional information that may help Apple currently implements EFI/uEFI 1.1 on their machines. Windows 7 64 bit requires uEFI 2.0 the same may be true of ubuntu/grub2. Open refits console and type ver to see the EFI version.

Justin Dugger (jldugger) wrote :

I can confirm that this bug also appears in the Natty Alpha 1 liveCD.

Changed in linux (Ubuntu):
assignee: Andy Whitcroft (apw) → nobody
Changed in linux (Ubuntu Maverick):
assignee: Andy Whitcroft (apw) → nobody
Maciej Nabozny (di-dijo) wrote :

I also confirm, that this bug is in Natty Alpha 2

Confirmed as per last comment and my own attempt with the latest daily build of natty.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Mark Jarvis (joejarvis) wrote :

I tried natty beta 2 today hoping for progress. Still experiencing this bug on Intel hardware (see my earlier comment #40).

Yuval (yuvilio) wrote :

Confirm that Natty Beta 2 didn't work for me either. On the other hand (suggested by Juan C Nuno in comment #35) DID work for me as well on my two Core 2 duo iMacs. Install worked and test drive seems ok. Guess i'll use that and dist-upgrade it when Natty comes out.

Can someone try a daily build? There are ISO images that seem to be specifically tailored to mac: "natty-desktop-amd64+mac.iso"

mgriepentrog (mgriepentrog) wrote :

Yuval: Was that with EFI?

I remember trying the +mac distro and not finding any evidence of EFI support on the image. I will have to try again later today to see if it works.

Yuval (yuvilio) wrote :

@mgriepentrog , whops you're right. My iMacs were SMC (the About this Mack->More information->hardware had "SMC version: 1.8f2" and not an EFI version. So Juan C Nuno's link worked for that. I failed to spot that the distinction before posting. So i confirm that ubuntu maverick image only for SMC firmware iMacs and not EFI ones.

This is still an issue in Ubuntu 11.04 (Natty Narwhal) final release.
To use an Ubuntu 64-bit live cd on a Mac or Macbook with EFI, you need to download the amd64+mac iso.

summary: - Can't boot Maverick beta amd64 live cd on macbook (EFI)
+ Can't boot amd64 live cd on macbook (EFI)
tags: added: natty
paniq (paniq) wrote :

None of the isos, including the amd64+mac iso, boot on my new Macbook (8,1). I can't install Ubuntu or try the live CD.

When booting the CD, I get the "ISOLINUX" version line, and then it freezes forever. Please make this go away, I don't want to use OSX ;)

paniq (paniq) wrote :

I should add that my system info says "SMC Version (system): 1.68f96" and the Boot ROM is "MBP81.0047.B04", but this morning I got a hardware update for EFI 2.1 - so, not sure if SMC and EFI are related at all.

paniq (paniq) wrote :

Chauncellor: I tried the daily build available today from the link you posted, and indeed, success - it no longer freezes at boot, but boots right into X - unfortunately that's where it ends right now, because things are crashing and installation is impossible (it's a daily ocelot, after all), but the mentioned problem is fixed.

Since this could be due the EFI 2.1 update from this morning, I'll go back and try the ubuntu-11.04-desktop-amd64+mac.iso image once more.

paniq (paniq) wrote :

Booted into the 11.04 amd64+mac succesfully. I suspect this may be due to the EFI 2.1 update from this morning.

I can't boot with the current daily (initramfs error message), either with 32 or 64 bit image. I can't boot off a USB image (Refit sees it, but it doesn't go any further).
There might be some command line options to type, but there aren't any hint about it (which is a bug)

Changed in syslinux (Ubuntu Maverick):
status: New → Confirmed
Changed in syslinux (Ubuntu):
status: New → Confirmed
Paul P. (leospaul) on 2011-08-20
summary: - Can't boot amd64 live cd on macbook (EFI)
+ Can't boot amd64 live cd on Mac (EFI)

This should be fixed as per bug #702283. Please, confirm with Oniric beta.

piwacet (davrosmeglos) wrote :

Problem still persists.

Tested in Macbook 2,1

ISO image:


Exact same symptoms as original reporter.

You need to use the image that is adjusted to work properly on Mac systems:

On Sep 25, 2011, at 6:30 PM, piwacet <email address hidden> wrote:

> Problem still persists.
> Tested in Macbook 2,1
> ISO image:
> ubuntu-11.10-beta2-desktop-amd64.iso
> Exact same symptoms as original reporter.
> --
> You received this bug notification because you are subscribed to the bug
> report.
> Title:
> Can't boot amd64 live cd on Mac (EFI)
> To manage notifications about this bug go to:

piwacet (davrosmeglos) wrote :

Apologies for the noise.

Tested this image:


on my Macbook 2,1.

It boots swimmingly.


I seem to be unable to boot the "ubuntu-11.10-desktop-amd64+mac" image on a macbook pro. It hangs after the Peter Anvin copyright and "Loading Bootlogo" is displayed...

I'm terribly sorry for the noise. It was a bad burn job.

Samuel Iglesias (samuelig) wrote :

When booting the operating system will not recognize the presence of the LiveCD, and you will end up with a console of initram.

I followed one tip found on Internet.

* Create an USB with the image of Ubuntu 11.10 x86_64 following the instructions on
* Then burn a CD with the same image.
* Plug the USB and insert the CD.
* With rEFIt boot from the CD.
* When booting, the CD will be "lost" but it will continue with the USB image.

Now, I have Ubuntu 11.10 on my macbook pro 8,1.

Przemek K. (azrael) wrote :

The amd64+mac iso images of Ubuntu 11.10 and 12.04 alpha are both working for me.
But it looks like a workaround, not a real fix to the standard amd64 iso image.

JC Hulce (soaringsky) wrote :

This bug affects Ubuntu 10.10, Maverick Meerkat. Maverick has reached end-of-life and is no longer supported, so I am closing the bugtask for Maverick. Please upgrade to a newer version of Ubuntu.
More information here:

Changed in linux (Ubuntu Maverick):
status: Incomplete → Invalid
Changed in syslinux (Ubuntu Maverick):
status: Confirmed → Invalid

It appears that there are no longer any +mac images for 12.04 that I can see (been rooting around Has anyone found any images? I attempted to create the image myself via the red hat link but it was fruitless.

Andrea Micheloni (a4a.m7i) wrote :

@brettcornwall: there are +mac images, just not on that server. Yes, it's kind of dumb to have them spread out, not in the same place...

LaurensV (laurens-daemon) wrote :

I have the exact same problem as OP with 12.04 and 12.04+mac isos on a white macbook 2,1.

Kalman Reti, could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from .

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

> could you please confirm this issue exists with the latest development release
> of Ubuntu? ISO images are available from

I just tested an Ivy Bridge Macbook with the latest trusty daily amd64 image (written to USB stick with dd):

1. boot from apple manager works
2. boot from refind (efi) works
3. boot from refind (bios) works

So it appears this bug is fixed, the amd64+mac images are no longer necessary, at least on this particular hardware.

affects: linux → ubuntu-cdimage

I opened a new bug #1298894 suggesting that the amd64+mac images are now obsolete for trusty. Please comment there if you can't boot the trusty amd64 iso on your Mac.

> Please comment there if you can't boot the trusty amd64 iso on your Mac.

Please also comment in bug #1298894 if you *can* boot the regular 14.04 / trusty amd64 iso on your Mac. There is no point in continuing to produce a Mac specific amd64 image if the regular one now works fine, but it will not be possible to tell if this is the case until people try it and report back.

axion (bugzilla-axion) wrote :

Still getting black screen with trusty on mac book pro 3.1

axion, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report via:

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad:
Ubuntu Kernel Team:
Ubuntu Community:

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:

Walter Lapchynski (wxl) wrote :

regarding chris' bug about removing the images, there are several very relevant comments there, including some discussion about firmware updates which is not mentioned here.

PAD (paolo-arnaldo) wrote :

ubuntu and xubuntu 14.04 black screen same problem with dvd-rom and Macboox 2,1

See bug #1298894 for a solution!

Walter Lapchynski (wxl) wrote :

amd64+mac images are gone as of 14.10:

file a new bug if you have the latest firmware updates and the amd64 images don't work.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in syslinux (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-cdimage:
status: Unknown → Fix Released
affects: ubuntu-cdimage → baltix
affects: baltix → ubuntu-cdimage
PetrolPC (marioluigi95) wrote :

I'm experiencing this bug when attempting to install Linux Mint 17.3 64 bit, Ubuntu 14.04 LTS 64 bit and Debian 8.7.1 64 bit. The issue does not arise when installing the 32 bit versions.
My Macbook specs can be found here:

Dimitri John Ledkov (xnox) wrote :

On 30 January 2017 at 01:06, PetrolPC <email address hidden> wrote:
> I'm experiencing this bug when attempting to install Linux Mint 17.3 64 bit, Ubuntu 14.04 LTS 64 bit and Debian 8.7.1 64 bit. The issue does not arise when installing the 32 bit versions.
> My Macbook specs can be found here:

I believe for that old Mac you do need amd64+mac ISO image of Ubuntu.
Note that these are no longer produced. Alternatively, to install
without UEFI you do need to invoke legacy boot (bootcamp/windows)
procedure to install amd64 image using PC-BIOS emulation.



Changed in ubuntu-cdimage:
importance: Unknown → Medium
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.