Ubuntu

[REGRESSION] e1000e doesnt work on 2.6.35.

Reported by Chuck Short on 2010-08-18
128
This bug affects 26 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading from lucid to maverick my network card will not get an IP address anymore from dhcp. This is a known regression as descibed:

http://kerneltrap.org/mailarchive/linux-netdev/2010/7/29/6282004/thread

This is supposedly fixed by reverting the following commit:

 e98cac447cc1cc418dff1d610a5c79c4f2bdec7f
(e1000e: Fix/cleanup PHY reset code for ICHx/PCHx)

If you need anything else let me know.

chuck

Jeremy Foshee (jeremyfoshee) wrote :

Hi Chuck,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily/current/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 619841

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Albert Bicchi (bicchi) wrote :

I am also getting hit by this bug after upgrading to Maverick's RC:

lspci:
00:19.0 Ethernet controller [0200]: Intel Corporation 82566DC Gigabit Network Connection (rev 02)

Currently DHCP fails to get an IP and this NIC worked under lucid. I have a feeling this is a show stopper as this NIC/module is very popular.

In my case this kernel commit seems to provide the fix but I haven't tested it.
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=5f3eed6fe0e36e4b56c8dd9160241a868ee0de2a

Albert Bicchi (bicchi) wrote :

I have compiled and installed 2.6.36-rc6 which contains the fix i mentioned above.

I confirm that this commit fixes the problem for me:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=5f3eed6fe0e36e4b56c8dd9160241a868ee0de2a

By the way, these might be duplicates of this bug:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/616984
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/591707

Any thoughts on getting this fix into the 2.6.35.X ubuntu kernel before maverick is released? I can see a lot of unhappy users with broken networks.

Hi,

I still have this problem with todays updates.

Non-working ethernet after an upgrade, is that not a showstopper?

Shouldn't there at least be a warning in the release notes??

https://wiki.ubuntu.com/MaverickMeerkat/TechnicalOverview

Best
Anders

Mark Zimmerman (markz) wrote :

This problem occurred for me in ubuntu-10.10-rc-desktop-amd64.iso but is no longer a problem in ubuntu-10.10-desktop-amd64.iso

I hope that means it was actually fixed, rather than randomly disappearing.

Oleg O Andreev (olegoandreev) wrote :

Just a comment: this problem very rarely if using kernel from ppa:tuxonice/ppa (linux-image-generic-tuxonice).

This problem still ocurrs on 2.6.35-23-generic (x86_64).

Also, I tried to launch:
apport-collect -p linux 619841

when the bug happened, but since the computer has no network the command failed. Are we supposed to run that command when the issue is NOT happening?

thanks,

Fabián Rodríguez (magicfab) wrote :

mon, there's a way to collect apport information on that system, then take it to an online system and submit it.

Let me try it first and I'll come back here, it seems the current documentation regarding this is lacking.

Fabián Rodríguez (magicfab) wrote :

Hi mon,

I have now fixed the documentation here:
https://help.ubuntu.com/community/ReportingBugs#Filing%20bugs%20when%20off-line

I tested the instructions there and they should let you submit an offline report.

Thanks Fabian, Here's the output of apport-cli -f -p linux --save bug.apport

Changed to confirmed now that the new information needed is attached. Also, the lastest kernel was tested by Albert Bicchi, as requested.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Rabie van der Merwe (rabie) wrote :

Hi,

I have a box that is affected by this problem, is there anyway I can help (testing/provide support info)?

R

panther_d (dk-mailbox) wrote :

Affects my box as well, Intel DG965OT mainboard.
Between about 20 reboot cycles (warm and cold), I managed to get a connection exactly once. I played with network settings, fixed IP addresses, but wasn't able to get the nic to transfer any data at all.

Had to revert to Karmic because this is my main machine. Fixing this would be essential for me to be able to move onto Lucid.

Rabie van der Merwe (rabie) wrote :

I have tested using linux-image-2.6.36-020636-generic and can confirm that the network cards works, reverting back to 2.6.35 and the network may work for one reboot but not a cold boot (as the registers have been set by the 2.6.36 kernel)
This could be used as a work around however I have another application that fails to compile a kernel module against 2.6.36 so I am stuck.

tags: removed: needs-upstream-testing
Rabie van der Merwe (rabie) wrote :

I have managed to extract Fedora 14's patch for e1000e kernel module and apply it on my system and so far so good, it seems to work ok.

Rabie van der Merwe (rabie) wrote :

Sorry no, looks like I spoke too soon, it did not help, I must have missed something.

tags: removed: needs-kernel-logs
tags: added: regression-release
Joseph Mark Jarvis (joejarvis) wrote :

I experienced this bug as well and reported it about the same time (see #616984, now marked duplicate). I tried Natty Alpha 1 with a 2.6.37 kernel and my network works again.

Erik Andrén (erik-andren) wrote :

It's a joke that this bug still hasn't been fixed. The cause is known. Just revert it and push a new update.

panther_d (dk-mailbox) wrote :

Agree; if nics weren't 5 bucks a piece I'd have moved away from Ubuntu thanks to this bug and the fact it's still open.

It still exists for me too. Upgrading to 11.04 alpha fixed it (and made life more exiting).

Brad Figg (brad-figg) on 2011-04-05
tags: added: maverick
Brad Figg (brad-figg) wrote :

Does this issue still exist? I'm reading back and comment #3 indicates a patch in 2.6.36 that should be in Natty. Can someone test a fix for Lucid? Maverick? Natty?

Brad Figg (brad-figg) wrote :

After reviewing the code for the current Lucid and Maverick kernels, this looks like it should still be an issue for both. Anyone want to step up to being a tester for patched kernels?

Chuck Short (zulcss) wrote :

I dont have the hardware anymore so Im not able to test.

Brad Figg (brad-figg) wrote :

Marking this incomplete until someone steps up to testing.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jim Cline (jcline-physics) wrote :

I am suffering from this bug as well. It should be marked as important

Brad Figg (brad-figg) wrote :

Jim,

Which series are you running? Maverick or Lucid? Are you willing to try test kernels?

Jim Cline (jcline-physics) wrote :

Brad, I am running Maverick, but I realized it's not the same bug. I get an IP address, but my problem is that the connection keeps disappearing at random but frequent intervals. I would be willing to test a new kernel. Can I just add an appropriate apt-source to install an alpha kernel with synaptic? If not some hints about installing kernels would be helpful.

Brad Figg (brad-figg) wrote :

@Jim,

First, you should open a new bug. That way we'll be able to track your specific issue and get information about your specific setup.

Brad

Spuerhund (spuerhund) wrote :

So where is this newly opened bug? I am also suffering from this issue and would help to fix it. My laptop is a Dell Latitude E6510, currently running Ubuntu 10.04 64 bit version. Unfortunately there is no progress in the kernel bugtracker for this issue (https://bugzilla.kernel.org/show_bug.cgi?id=11998).

Vladimir Korenev (vkorenev) wrote :

I installed the last kernel for Lucid (Linux 2.6.35-28-generic #50-Ubuntu SMP Fri Mar 18 18:42:20 UTC 2011 x86_64). The bug is still there.

Vladimir Korenev (vkorenev) wrote :

I've just upgraded to Natty. The bug is still there. Here is output from gmesg:

$ dmesg | grep e1000e
[ 2.171983] e1000e: Intel(R) PRO/1000 Network Driver - 1.2.20-k2
[ 2.171986] e1000e: Copyright(c) 1999 - 2011 Intel Corporation.
[ 2.172022] e1000e 0000:00:19.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
[ 2.172034] e1000e 0000:00:19.0: setting latency timer to 64
[ 2.172137] e1000e 0000:00:19.0: irq 45 for MSI/MSI-X
[ 3.232997] e1000e 0000:00:19.0: PCI INT A disabled
[ 3.233003] e1000e: probe of 0000:00:19.0 failed with error -3

My kernel is
Linux 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Chuck Short, as you no longer have the hardware this report is being closed. For all others, if you are having a problem in Ubuntu, please file a new report by executing the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.