WARNING: at /build/buildd/linux-maverick-2.6.35/arch/x86/include/asm/processor.h:1005 read_measured_perf_ctrs+0x6c/0x80()

Bug #615153 reported by Guy Taylor
368
This bug affects 41 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Undecided
Unassigned
linux (Ubuntu)
Medium
Colin Ian King
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

More info in file included

Kernel from "ppa:kernel-ppa/ppa", I do not know how to link this bug to that ppa.

cat /proc/version
Linux version 2.6.35-14-generic-pae (buildd@hassium) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #20~lucid2-Ubuntu SMP Sun Aug 8 01:11:23 UTC 2010

Revision history for this message
Guy Taylor (thebiggerguy) wrote :
description: updated
tags: added: kernel-bug
Revision history for this message
Philip Muškovac (yofel) wrote :

Affecting the kernel.

affects: ubuntu → linux (Ubuntu)
Changed in linux:
importance: Undecided → Unknown
status: New → Unknown
tags: added: kj-triage
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Declining the Maverick specific nomination for now and leaving this open against the actively developed Ubuntu kernel (which happens to be Maverick at this time). Will re-open the nomination should a fix be narrowed down which we can confirm specifically resolves this issue in Maverick.

Revision history for this message
Samir (samir-i) wrote :

Using ppa kernel 2.6.35-21-generic x86_64 against 10.04.1, this bug still occurs, possibly killing wake from standby (wake fails back to startup-login screen instead of restoring previous gnome session).

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: regression-potential
Revision history for this message
Ritz (jonas-ritz) wrote :
tags: added: patch
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Looks like the patches noted in the upstream bug report should resolve this issue. They appear to be making their way into the upstream 2.6.35.y stable kernel. They'll automatically get pulled into the Maverick kernel as a SRU (stable release update) when we sync up with the upstream stable version which contains the patches.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
tags: added: 2.6.35.y
Revision history for this message
Guy Taylor (thebiggerguy) wrote :

bugzilla.kernel.org:
Fixed by commit d900329e20f4476db6461752accebcf7935a8055 .

Changed in linux (Ubuntu):
assignee: nobody → Colin King (colin-king)
status: Triaged → In Progress
Revision history for this message
Iustinian T. (iustinian) wrote :

2.6.36 from mainline kernels doesn't exhibit this bug, the stock maverick kernel does.

Revision history for this message
Guy Taylor (thebiggerguy) wrote :

Is there an ETA on this fix?

Revision history for this message
Chris Van Hoof (vanhoof) wrote :

This fix was included in the current -proposed kernel:

https://launchpad.net/ubuntu/maverick/+source/linux/2.6.35-24.42

--chris

Revision history for this message
Chris Van Hoof (vanhoof) wrote :

This Bug was fixed in the recent Maverick SRU release of: 2.6.35-24.42

--chris

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Chris Van Hoof (vanhoof) wrote :

This has been corrected upstream, as well as in the Maverick, and Natty series

Changed in linux:
importance: Unknown → Undecided
status: Unknown → New
status: New → Fix Released
Chris Van Hoof (vanhoof)
tags: added: hwe-blocker
Chris Van Hoof (vanhoof)
Changed in linux (Ubuntu Natty):
status: New → Fix Released
Changed in linux (Ubuntu Maverick):
status: New → Fix Released
To post a comment you must log in.