lshw causes laptop to freeze up

Bug #614008 reported by Jim Adams on 2010-08-05
248
This bug affects 42 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
lshw
Invalid
Undecided
Unassigned
linux (Ubuntu)
Undecided
Andy Whitcroft

Bug Description

Binary package hint: lshw

Description: Ubuntu maverick (development branch)
Release: 10.10

lshw:
  Installed: 02.14-1build1
  Candidate: 02.14-1build1
  Version table:
 *** 02.14-1build1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

When I run sudo lshw -C disk, the entire system freezes up and no further activity takes place...I tried it twice and both times after 10 minutes I had to hard reboot the laptop.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: lshw 02.14-1build1
ProcVersionSignature: Ubuntu 2.6.35-14.19-generic 2.6.35
Uname: Linux 2.6.35-14-generic i686
Architecture: i386
Date: Thu Aug 5 13:09:29 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lshw

Jim Adams (oldmanwithers1) wrote :
Jim Adams (oldmanwithers1) wrote :

I am able however to run the command without crashing the laptop so long as I don't 'su - root' or 'sudo'.

I case this is a hardware thing, I'm running Ubuntu on a Leveno X61.

lemonade (lemonade) wrote :

I can confirm this with two different machines; i3 530 with Intel H55 and HP dv5139eu laptop. Both seem to crash when running 2.6.35 kernel and lshw. After downgrading to 2.6.32 kernel (latest on Lucid), lshw seems to work normally.

Changed in lshw (Ubuntu):
status: New → Confirmed
Bowmore (bowmore) wrote :

After some research I found out that the command lshw was broken by kernel 2.6.35-13. Older kernels work just fine.

tags: added: iso-testing
Changed in lshw:
status: Unknown → New
Matt Daubney (daubers) wrote :

This seems to occur for me at the point where lshw is looking at framebuffer devices. No idea if that helps people debugging things.

Dave Gilbert (ubuntu-treblig) wrote :
Download full text (4.2 KiB)

The oops's in bug 625295 and bug 615789 correspond to the oops I'm seeing:

Sep 10 12:26:58 major kernel: [ 1724.099559] PGD 1ed737067 PUD 1ed454067 PMD 0
Sep 10 12:26:58 major kernel: [ 1724.099573] CPU 7
Sep 10 12:26:58 major kernel: [ 1724.099575] Modules linked in: ip6table_filter ip6_tables binfmt_misc dm_crypt ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ipt_REJECT xt_tcpudp iptable_filter ip_tables x_tables bridge stp kvm_intel kvm snd_hda_codec_atihdmi snd_hda_codec_via snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device ppdev parport_pc snd soundcore snd_page_alloc lp parport radeon ttm usbhid r8169 firewire_ohci usb_storage hid firewire_core mii drm_kms_helper pata_via crc_itu_t drm i2c_algo_bit configfs
Sep 10 12:26:58 major kernel: [ 1724.099633]
Sep 10 12:26:58 major kernel: [ 1724.099638] Pid: 3168, comm: lshw Not tainted 2.6.35-20-generic #29-Ubuntu P55M Pro/To Be Filled By O.E.M.
Sep 10 12:26:58 major kernel: [ 1724.099643] RIP: 0010:[<ffffffff812f32ae>] [<ffffffff812f32ae>] fb_open+0x6e/0x1f0
Sep 10 12:26:58 major kernel: [ 1724.099650] RSP: 0018:ffff8801ed671bf8 EFLAGS: 00010246
Sep 10 12:26:58 major kernel: [ 1724.099654] RAX: 0000000000000505 RBX: 0000000000000001 RCX: ffffffffffffffff
Sep 10 12:26:58 major kernel: [ 1724.099658] RDX: ffff8801ed4c9900 RSI: ffff8801ed4c9900 RDI: ffffffff81cf33e8
Sep 10 12:26:58 major kernel: [ 1724.099661] RBP: ffff8801ed671c48 R08: ffff8801ed4c9240 R09: ffff8801ff285900
Sep 10 12:26:58 major kernel: [ 1724.099665] R10: ffff880237c043e0 R11: 0000000000000000 R12: ffff88020ff7f2d0
Sep 10 12:26:58 major kernel: [ 1724.099669] R13: ffff8801ed4c9900 R14: 0000000000000000 R15: 0000000000000001
Sep 10 12:26:58 major kernel: [ 1724.099673] FS: 00007f4a6512d720(0000) GS:ffff880001fc0000(0000) knlGS:0000000000000000
Sep 10 12:26:58 major kernel: [ 1724.099678] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Sep 10 12:26:58 major kernel: [ 1724.099681] CR2: 0000000000000008 CR3: 00000001fd861000 CR4: 00000000000006e0
Sep 10 12:26:58 major kernel: [ 1724.099685] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Sep 10 12:26:58 major kernel: [ 1724.099689] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Sep 10 12:26:58 major kernel: [ 1724.099693] Process lshw (pid: 3168, threadinfo ffff8801ed670000, task ffff8801ed570000)
Sep 10 12:26:58 major kernel: [ 1724.099698] 000000000000001d ffff8801ed671c74 ffff88022ed9b280 ffff88022ec40000
Sep 10 12:26:58 major kernel: [ 1724.099704] <0> 0000000000000000 0000000000000000 ffff88022ed9b280 0000000000000000
Sep 10 12:26:58 major kernel: [ 1724.099710] <0> ffffffff81ce6340 ffff88020ff7f2d0 ffff8801ed671ca8 ffffffff8115685a
Sep 10 12:26:58 major kernel: [ 1724.099725] [<ffffffff8115685a>] chrdev_open+0x10a/0x200
Sep 10 12:26:58 major kernel: [ 1724.099731] [<ffffffff81156750>] ? chrdev_open+0x0/0x200
Sep 10 12:26:58 major kernel: [ 1724.099737] [<ffffffff81150cb5>] __dentry_open+0xe5/0x330
Sep 10 12:26:58 major kernel: [ 1724.099745] [<ffffffff8126066f>] ? security_inode_permission+0x1f/0x30
Sep 10 12:26:5...

Read more...

Dave Gilbert (ubuntu-treblig) wrote :

Hi
  What graphics cards do people here have? I've got a Radeon, I see at least one of the other oops owners is Radeon.
Are there people with non-radeons that are triggering this?
(I think I can see one Nvidia owner - but more info would probably be useful)

Dave

Matt Daubney (daubers) wrote :

@Dave Gilbert I've got a Nvidia Geofrce G210m in this machine I'm seeing the issue on.

koso (koso) wrote :

I have Intel GM965 Mobile ...

Dave Gilbert (ubuntu-treblig) wrote :

OK, so it's not graphics card/frame buffer specific then.

Dave Gilbert (ubuntu-treblig) wrote :

Hi,
  Here's a fix - it's a missing NULL check in get_framebuffer_info

(I think this is an Ubuntu specific issue - I can't see the code in the mainline.
I think it was triggered by the code in
http://old.nabble.com/-PATCH-0-2---Maverick--boot-frambuffer-crash-fixes-td29297713.html )

lshw goes and creates it's own fb devices in tmp to prod them, and creates minor 1 and tries to open it and BANG.

Dave

Dave Gilbert (ubuntu-treblig) wrote :

This is a kernel bug, not lshw's (for the framebuffer case)

affects: lshw (Ubuntu) → linux (Ubuntu)
Andy Whitcroft (apw) on 2010-09-10
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Confirmed → In Progress
tags: added: patch
Andy Whitcroft (apw) wrote :

@Dave -- thanks for pointing out the bug here, i've pushed the equivalent fix to our mailing list for review for Maverick. Good spot.

This should be resolved as of 2.6.35-21.30. Marking Fix Released.

linux (2.6.35-21.30) maverick; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: fbcon -- fix OOPs triggered by race prevention fixes
    - LP: #614008

  [ Daniel Lezcano ]

  * SAUCE: fix compilation warning when CONFIG_SECURITY is not set

  [ Henrik Rydberg ]

  * SAUCE: Input: wacom - add fuzz parameters to features
  * SAUCE: Input: wacom - collect device quirks into single function
  * SAUCE: Input: wacom - add support for the Bamboo Touch trackpad
  * SAUCE: Input: wacom - add a quirk for low resolution Bamboo devices
  * SAUCE: hid: ntrig: Remove unused device ids
  * SAUCE: hid: ntrig: remove sysfs nodes
  * SAUCE: hid: ntrig: Correct logic for quirks
  * SAUCE: hid: ntrig: zero-initialize ntrig struct
  * SAUCE: hid: ntrig: Setup input filtering manually
  * SAUCE: hid: ntrig: New ghost-filtering event logic

  [ Leann Ogasawara ]

  * SAUCE: ndiswrapper: Initialize buffer index and check its value
    - LP: #613796

  [ Manoj Iyer ]

  * SAUCE: Add support for Intellimouse Mode in ALPS touchpad on Dell E2
    series Laptops
    - LP: #632884

  [ Ping Cheng ]

  * SAUCE: Input: wacom - parse the Bamboo device family

  [ Rafi Rubin ]

  * SAUCE: hid: ntrig: identify firmware version (wiggled)

  [ Tim Gardner ]

  * [Config] CONFIG_NL80211_TESTMODE=n

  [ Upstream Kernel Changes ]

  * Revert "input: mt: Add support for the Bamboo Touch trackpad"
  * e1000e: initial support for 82579 LOMs
  * e1000e: correct MAC-PHY interconnect register offset for 82579
  * (pre-stable) ALSA: hda - Add a new hp-laptop model for Conexant 5066,
    tested on HP G60
    - LP: #587388
  * DSS2: Don't power off a panel twice
    - LP: #588243
  * mmc: build fix: mmc_pm_notify is only available with CONFIG_PM=y
  * Input: i8042 - reset keyboard controller wehen resuming from S2R
    - LP: #86820
  * ALSA: hda - Fix beep frequency on IDT 92HD73xx and 92HD71Bxx codecs
    - LP: #414795
  * agp/intel: Support the extended physical addressing bits on
    Sandybridge.
    - LP: #632488
  * drm/i915,intel_agp: Add support for Sandybridge D0
    - LP: #632488
  * (pre-stable) intel_agp,i915: Add more sandybridge graphics device ids
    - LP: #632488
  * mmc: omap: fix for bus width which improves SD card's peformance.
 -- Leann Ogasawara <email address hidden> Tue, 07 Sep 2010 09:58:52 -0700

Confirmed fixed in Maverick.

lsb_release -rd
Description: Ubuntu maverick (development branch)
Release: 10.10

uname -r
2.6.35-21-generic

apt-cache policy lshw
lshw:
  Installed: 02.14-1build1
  Candidate: 02.14-1build1
  Version table:
 *** 02.14-1build1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

Changed in linux (Ubuntu):
status: In Progress → Fix Released
OneTinSoldier (linuxrh) wrote :

Hello,

I entered in bug 619582 which has been marked as a duplicate of this bug, 614008. I want to confirm that the fix works here on my system. After updating to the lastest packages for Maverick this evening, including a minor update to the kernel, I can now successfully run lshw-gtk with root priviledges by launching it via gksu.

Job well done.

Thank you!

Martin Wildam (mwildam) wrote :

Yes, confirm fix working here too. Thanks.

Dave Gilbert (ubuntu-treblig) wrote :

This is an ubuntu only bug

Changed in linux:
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
Changed in lshw:
importance: Unknown → Undecided
status: New → Invalid
Dave Gilbert (ubuntu-treblig) wrote :

It's an ubuntu kernel bug, not an lshw bug

cariboo (cariboo) wrote :

Why bother adding all the extra comments when the bug has been fixed?

vmc (vmclark) wrote :

cariboo907, good point! I think the reason is these comment keep coming through our email account and people think they have to reply. Just like I did :)

 I have been reading these emails, but deleted them and never responded until now, since lshw has been fixed for a while.

Martin Wildam (mwildam) wrote :

Discussion can go here - I also have questions: http://ubuntuforums.org/showthread.php?t=1582842

Changed in linux:
status: Invalid → Confirmed
Changed in lshw:
status: Invalid → Confirmed
Changed in linux (Ubuntu):
status: Fix Released → Incomplete

Balaji, thank you for contributing to this bug and helping make Ubuntu better. If you find another problem, please file a new report. When toggling the status of future bugs, please leave a comment to prevent future misunderstandings. This bug is confirmed Fix Released, marking as such.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in linux:
status: Confirmed → Invalid
Changed in lshw:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.