Ubuntu

resume fails for Lenovo Ideapad S10-3t

Reported by nnutter on 2010-06-25
92
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

This is an issue that was previously working in Lucid's kernel (2.6.32) but now occurs in 2.6.34 and 2.6.35 whether using the kernel ppa in Lucid or using Maverick. The hard drive light blinks for a sec and then goes out and the power light remains on but the screen never comes on and the machine's network interface doesn't come up (no ping/SSH).

I followed the DebuggingKernelSuspend wiki page and will be attaching the dmesg output.

[ 0.700716] Magic number: 14:722:197
[ 0.700793] acpi PNP0100:00: hash matches

I will test the mainline kernel soon and update this ticket.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-5-generic 2.6.35-5.6
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-5.6-generic 2.6.35-rc3
Uname: Linux 2.6.35-5-generic i686
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: nathan 1323 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0400000 irq 44'
   Mixer name : 'Conexant CX20582 (Pebble)'
   Components : 'HDA:14f15066,17aa4003,00100302'
   Controls : 12
   Simple ctrls : 10
Date: Fri Jun 25 16:31:51 2010
HibernationDevice: RESUME=UUID=dd8123e5-46df-4207-b0c6-9a06461174a9
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100602.2)
MachineType: LENOVO 20040M18
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-5-generic root=UUID=b49c4dbf-a609-4d3d-b275-9123f51fe464 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.37
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
dmi.bios.date: 03/12/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 24CN22WW
dmi.board.name: Caucasus2
dmi.board.vendor: LENOVO
dmi.board.version: Rev 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Lenovo
dmi.chassis.version: Rev 1.0
dmi.modalias: dmi:bvnLENOVO:bvr24CN22WW:bd03/12/2010:svnLENOVO:pn20040M18:pvrLenovoIdeapadS10-3t:rvnLENOVO:rnCaucasus2:rvrRev1.0:cvnLenovo:ct10:cvrRev1.0:
dmi.product.name: 20040M18
dmi.product.version: Lenovo Ideapad S10-3t
dmi.sys.vendor: LENOVO

nnutter (nnutter) wrote :
nnutter (nnutter) wrote :

This also occurs in the mainline kernel but the dmesg output is a bit different.

nathan@mini-10:~$ grep -C 5 Magic dmesg-mainline.txt
[ 1.303062] lo: Disabled Privacy Extensions
[ 1.303533] NET: Registered protocol family 17
[ 1.304597] Using IPI No-Shortcut mode
[ 1.304782] PM: Resume from disk failed.
[ 1.304805] registered taskstats version 1
[ 1.305290] Magic number: 14:996:955
[ 1.305430] rtc_cmos 00:05: setting system clock to 2010-06-25 21:54:50 UTC (1277502890)
[ 1.305438] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 1.305442] EDD information not available.
[ 1.305616] Freeing unused kernel memory: 740k freed
[ 1.306192] Write protecting the kernel text: 4948k
nathan@mini-10:~$ aptitude search linux | grep ^i | grep 2.6.35
i linux-headers-2.6.35-020635rc3 - Header files related to Linux kernel versi
i linux-headers-2.6.35-020635rc3- - Linux kernel headers for version 2.6.35 on
i A linux-headers-2.6.35-5 - Header files related to Linux kernel versi
i A linux-headers-2.6.35-5-generic - Linux kernel headers for version 2.6.35 on
i linux-image-2.6.35-020635rc3-ge - Linux kernel image for version 2.6.35 on x
i linux-image-2.6.35-5-generic - Linux kernel image for version 2.6.35 on x

Please let me know if I can provide any other info!

SomeoneE1se (greg-grayhatter) wrote :

What happens if you press the power button after trying to resume from suspend/sleep?

nnutter (nnutter) wrote :

@SomeoneE1lse: On this machine the lid switch does not work. You have to press the power button to wake. Resume is failing, it is not a matter of user error.

nnutter (nnutter) wrote :

Please also note that this issue affects all Lenovo S10-3t's from the limited sample based on the thread linked below:

UbuntuForums.org: Lenovo Ideapad S10-3t
http://ubuntuforums.org/showthread.php?p=9527775

I have commented there asking people to mark this bug as affecting them. Please review this issue and request any further information you may need.

SomeoneE1se (greg-grayhatter) wrote :

@nnutter, Not what I ment, sorry.

Ubuntu 10.04 if I press a key the system wakes, but the screen stays off, once I press the power button the screen turns back on. If the same thing is happening to you, I'd mark this bug as also affecting me

nnutter (nnutter) wrote :

@SomeoneE1lse Ah, this is different. The machine completely fails to resume, the screen does not wake and the machine is not accessible via network. This is a regression that only occurs in 2.6.34 and 2.6.35 kernels not 2.6.32 (the version 10.04 uses). I do experience the same issue you are describing but this issue I am reporting is a bit more severe and would prevent me from upgrading to 10.10 (or would make me install 2.6.32 on 10.10).

nnutter (nnutter) wrote :

This issue persists after the most recent updates (alpha 2 I suppose). I am attaching a new dmesg output from most recent kernel.

nathan@mini-10:~$ uname -a
Linux mini-10 2.6.35-6-generic #9-Ubuntu SMP Wed Jun 30 23:09:46 UTC 2010 i686 GNU/Linux
nathan@mini-10:~$ aptitude search linux | grep ^i | grep 2.6.35
i linux-headers-2.6.35-020635rc3 - Header files related to Linux kernel versi
i linux-headers-2.6.35-020635rc3- - Linux kernel headers for version 2.6.35 on
i A linux-headers-2.6.35-5 - Header files related to Linux kernel versi
i A linux-headers-2.6.35-5-generic - Linux kernel headers for version 2.6.35 on
i A linux-headers-2.6.35-6 - Header files related to Linux kernel versi
i linux-headers-2.6.35-6-generic - Linux kernel headers for version 2.6.35 on
i linux-image-2.6.35-020635rc3-ge - Linux kernel image for version 2.6.35 on x
i linux-image-2.6.35-5-generic - Linux kernel image for version 2.6.35 on x
i linux-image-2.6.35-6-generic - Linux kernel image for version 2.6.35 on x
nathan@mini-10:~$

nnutter (nnutter) wrote :

Attaching a kernel config from a kernel package from AUR that uses 2.6.34+ but does not exhibit the sleep/resume issue. Also fixes issue where opening the lid does not wake the computer (2.6.32 affected as well).

Subsanek (subsanek) on 2010-08-01
Changed in linux:
status: New → Confirmed
Changed in linux (Ubuntu):
status: New → Confirmed
Andy Whitcroft (apw) wrote :

@nnutter -- the testing you have reported seems to be with (what is now) pretty early Maverick kernels. I wonder if you would be able to test with the very latest version (based on the released v2.6.35 + stable updates) and confirm if that is affected; we have reports of known suspend/resume issues being resolved for other Lenovo models with the most recent upstream updates. You also mention that you had no issues running Lucid on this machine, It might be helpful to have the dmesg output from the machine following a boot/suspend/resume on a Lucid kernel (please label this dmesg very clearly when attaching), you should be able to install a Lucid kernel into your Maverick userspace and boot it for that. For the v2.6.34/35 testing you report above, which kernel builds were these, was the v2.6.35 the official release version. Also where did you get the builds were they the ones from the Mainline Builds archive? Could we also get a dmesg from the working kernel you have, again label this dmesg very clearly.

    https://wiki.ubuntu.com/Kernel/MainlineBuilds

I have spent some time looking at your working configuration but it is so divorced from the Ubuntu config as to be almost impossible to use as a comparison source, nothing obvious jumps out from a visual inspection. The diffstat between your working one and our current kernel configuration shows it to be something like 90% different:

     i386-config.flavour.generic | 5606 +++++++++++++++++++++++++++++++++-----------
     1 file changed, 4283 insertions(+), 1323 deletions(-)

Looking at the output of your debugging run, the Hash is pointing to the PNP Timer, it might be worth testing the broken kernels with each of 'nohpet' and 'nolapic' (individually) to see if they have any effect.

If you could perform any of the testing above and report back here that would be helpful. Thanks.

nnutter (nnutter) wrote :

Andy,

Thank you for replying. I have attached the dmesg output for the following cases:
* working Ubuntu kernel from Lucid
* broken Ubuntu kernel from Maverick
* broken Ubuntu kernel from Maverick with nohpet

I tried using nolapic but then received an error at boot that looked like it couldn't find the root disk and dumped me to a BusyBox/Initramfs shell.

I hope I named and described the files adequately but please let me know if not. I am happy to assist in any way I am able. I really appreciate your time on this and I know many other S10-3t users do to.

Andy Whitcroft (apw) wrote :

@nnutter -- thanks for those. One thing which jumps out in the dmesg is that maverick has a touch screen driver for your machine whereas lucid does not. Could you try rmmod hid-cando (or blacklist that module, reboot), then re-test suspend/resume on the Maverick kernel for us.

nnutter (nnutter) wrote :

I tried suspend/resume with cando blacklisted (verified with lsmod | grep cando) and still was not able to resume successfully. I am attaching the dmesg output. Thanks for the suggestion!

Jerone Young (jerone) on 2010-08-19
summary: - resume fails in development kernels
+ resume fails in development kernels for Lenovo Ideapad S10-3t

I just did a fresh install of maverick on another partition and have this resume failure on maverick. So, it's still a problem.

nnutter (nnutter) wrote :

Resume is working on the latest kernel!

Linux mach 2.6.35-19-generic #26-Ubuntu SMP Thu Aug 26 19:13:05 UTC 2010 i686 GNU/Linux

Great work! Thank you, thank you, thank you!

jyio (inportb) wrote :

Seems to be working for me. Thanks very much for the fix!

Thanks for the feedback. Since @nnutter is the original bug reporter and has noted in comment #18 this appears to be resolved with the latest Maverick kernel, I'm marking this Fix Released for now. Should this re-appear feel free to re-open this bug by setting the status back to New. Thanks. I'll also going to close the upstream Linux task for this bug. Thanks.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in linux:
status: Confirmed → Invalid
Uwe Kaminski (jukey) wrote :

There seems to be a regression. When I was using Ubuntu 10.10 there was no problem with resume from suspend.
Now I'm using the Natty Beta release and it appears again. I'll attach the pm-suspend logs.

For reference also take a look at this report (for MeeGo): https://bugs.meego.com/show_bug.cgi?id=10351 and the solution they provided there: https://bugs.meego.com/show_bug.cgi?id=10351#c16

Uwe Kaminski (jukey) wrote :

How I can reopen this report? Or should I create a new one for Natty?

jyio (inportb) wrote :

I can confirm that resume fails. I cannot edit the status of this bug to "new" (and I assume it's up to nnutter to do this).

nnutter (nnutter) on 2011-06-15
Changed in linux (Ubuntu):
status: Fix Released → New
Brad Figg (brad-figg) on 2011-06-15
Changed in linux (Ubuntu):
status: New → Confirmed
nnutter (nnutter) wrote :

Adding 'nohpet' to Grub allows resume to work correctly.

I edited /etc/default/grub to add 'nohpet' to GRUB_CMDLINE_LINUX_DEFAULT and then ran 'sudo update-grub' and rebooted. So my GRUB_CMDLINE_LINUX_DEFAULT line now reads:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nohpet"

nnutter (nnutter) on 2011-06-15
summary: - resume fails in development kernels for Lenovo Ideapad S10-3t
+ resume fails for Lenovo Ideapad S10-3t
anmg (a-gangan) wrote :

Ubuntu 11.10 on lenovo S10-3 (without tuch) - still can not wake up

Marco_E (marco-ertel) wrote :

Here also on 11.10 on a lenovo S10 I can't wake up. Even with the nohpet in the GRUB_CMDLINE_LINUX_DEFAULT

Aran (aran-organicdesign) wrote :

The nohpet option worked for me for a while, but then the problem came back again. I had found in another post that intel_idle.max_cstate=0 also worked. For me the second option worked intermittently, but both options together are working consistently. I have a page with more detail at http://www.organicdesign.co.nz/Lenovo_Ideapad_S10-3

mce (mc2-seznam) wrote :

also cannot wake
ubuntu oneiric 11.10
lenovo S10-3
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=0 nohpet"

nnutter, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bios-outdated-24cn62ww regression-release
removed: regression-potential
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.