8086:27a2 X crashs on Intel 945 video (GPU hung: render error detected/task i915: blocked for more than 120 seconds)

Bug #594129 reported by Jean-Peer Lorenz on 2010-06-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
New
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

X was hanging/crashing. SysRq did work. I'm running a DELL Inspiron 6400 with Intel graphics and had never problems with hanging/crashing X since using Ubuntu. Standby/Resume works. It's getting slowly annoying - things that worked just stop working in newer releases (sorry for the rant but...)

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-22-generic 2.6.32-22.36
Regression: Yes
Reproducible: No
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: peer 2218 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xefebc000 irq 21'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:83847690,102801bd,00102201 HDA:14f12bfa,14f100c3,00090000'
   Controls : 12
   Simple ctrls : 7
CheckboxSubmission: 27774017cc2538f163c801a2a9afdb5a
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Mon Jun 14 15:19:01 2010
Frequency: This has only happened once.
HibernationDevice: RESUME=UUID=018bdd59-a71d-4c23-98c3-21871c5d7d6d
MachineType: Dell Inc. MM061
ProcCmdLine: root=UUID=50ce24c3-8349-4b27-8c69-27211736429a ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
RfKill:
 0: dell-wifi: Wireless LAN
  Soft blocked: no
  Hard blocked: yes
SourcePackage: linux
WpaSupplicantLog:

dmi.bios.date: 06/13/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A17
dmi.board.name: 0KD882
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA17:bd06/13/2007:svnDellInc.:pnMM061:pvr:rvnDellInc.:rn0KD882:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MM061
dmi.sys.vendor: Dell Inc.

Also see attached syslog.

Jean-Peer Lorenz (peer.loz) wrote :
Jeremy Foshee (jeremyfoshee) wrote :

Hi Jean-Peer,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Jean-Peer Lorenz (peer.loz) wrote :

It happened again. Reboot was necessary. Here are the last lines of kern.log:

Jul 14 20:34:57 ayida kernel: [263498.608047] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
Jul 14 20:34:57 ayida kernel: [263498.608066] render error detected, EIR: 0x00000000
Jul 14 20:34:57 ayida kernel: [263498.608103] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5 (awaiting 32599223 at 32599220)
Jul 14 20:35:22 ayida kernel: [263523.308317] composite sync not supported
Jul 14 20:35:22 ayida kernel: [263523.552001] composite sync not supported
Jul 14 20:35:23 ayida kernel: [263524.086137] composite sync not supported
Jul 14 20:35:23 ayida kernel: [263524.306338] composite sync not supported
Jul 14 20:35:23 ayida kernel: [263524.720908] composite sync not supported
Jul 14 20:35:24 ayida kernel: [263524.943925] composite sync not supported
Jul 14 20:35:24 ayida kernel: [263525.320355] composite sync not supported
Jul 14 20:35:24 ayida kernel: [263525.543967] composite sync not supported
Jul 14 20:35:25 ayida kernel: [263525.924743] composite sync not supported
Jul 14 20:35:25 ayida kernel: [263526.138851] composite sync not supported
Jul 14 20:35:25 ayida kernel: [263526.557551] composite sync not supported
Jul 14 20:35:25 ayida kernel: [263526.778671] composite sync not supported
Jul 14 20:37:11 ayida kernel: [263632.513754] composite sync not supported
Jul 14 20:37:17 ayida kernel: [263638.837927] apm: BIOS not found.
Jul 14 20:37:20 ayida kernel: imklog 4.2.0, log source = /proc/kmsg started.
Jul 14 20:37:20 ayida kernel: [263641.429094] udev: starting version 151
Jul 14 20:37:29 ayida kernel: imklog 4.2.0, log source = /proc/kmsg started.
Jul 14 20:37:29 ayida kernel: [263650.069251] udev: starting version 151
Jul 14 20:39:02 ayida kernel: imklog 4.2.0, log source = /proc/kmsg started.

Jean-Peer Lorenz (peer.loz) wrote :

An additional hint: every time this happened (every 3-4 weeks now) I was working in Eclipse.

summary: - X crashs on Intel 945 card with task i915:679 blocked for more than 120
- seconds
+ X crashs on Intel 945 card (task i915:679 blocked for more than 120
+ seconds/GPU hung)
Jean-Peer Lorenz (peer.loz) wrote :

It happened again. I tried to shutdown from terminal, it apparently worked but in fact it does not. Had to reboot :-(

kern.log:

Sep 18 00:27:42 ayida kernel: [264012.588056] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
Sep 18 00:27:42 ayida kernel: [264012.588073] render error detected, EIR: 0x00000000
Sep 18 00:27:42 ayida kernel: [264012.588109] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5 (awaiting 21692688 at 21692687)

summary: - X crashs on Intel 945 card (task i915:679 blocked for more than 120
- seconds/GPU hung)
+ X crashs on Intel 945 video (GPU hung: render error detected/task i915:
+ blocked for more than 120 seconds)
Changed in linux (Ubuntu):
status: Incomplete → New
description: updated
Brad Figg (brad-figg) on 2010-12-03
tags: added: acpi-method-return
Brad Figg (brad-figg) on 2011-04-06
Changed in linux (Ubuntu):
status: New → Confirmed

Jean-Peer Lorenz, thank you for reporting this bug and helping make Ubuntu better. This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
summary: - X crashs on Intel 945 video (GPU hung: render error detected/task i915:
- blocked for more than 120 seconds)
+ 8086:27a2 X crashs on Intel 945 video (GPU hung: render error
+ detected/task i915: blocked for more than 120 seconds)
tags: added: latest-bios-a17
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.