[Lucid] Huawei USB Modem E160 does not work for unknown reason

Bug #592564 reported by Rafal-maj-it on 2010-06-11
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

It started as part of bug #546728 but since user svaens says that the solution (install usb-modeswitch and usb-modeswitch-data - see bug #546728) does not work for him, this is another bug.

Copy:

svaens wrote on 2010-05-28: #18

I am using Huawei E160E HSDPA

It was no good in Karmic, and it is worse in Lucid.
The fix:
sudo aptitude install usb-modeswitch usb-modeswitch-data

doesn't help at all.

I have resorted to buying a 3G Router ..... cost me $180 (still better than the alternatives)

Blackestmajor (blackmajor) wrote :

Hello,

Have you try to install modemmanager package ? In ubuntu-fr.org, somebody has made his E160 modem work with this package. He says the package sends dbus informations of the modem to network-manager.

steba (ste-ba) wrote :

Same here. Huawei E160E recognized as

Bus 001 Device 004: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem

Is not auto-detected as modem:

[ 247.868434] usb 1-3: new high speed USB device using ehci_hcd and address 3
[ 248.011668] usb 1-3: configuration #1 chosen from 1 choice
[ 248.037512] scsi3 : SCSI emulation for USB Mass Storage devices
[ 248.037854] usb 1-3: USB disconnect, address 3
[ 248.037866] usb-storage: device found at 3
[ 248.037868] usb-storage: waiting for device to settle before scanning
[ 254.668163] usb 1-3: new high speed USB device using ehci_hcd and address 4
[ 254.811616] usb 1-3: configuration #1 chosen from 1 choice
[ 254.843974] scsi6 : SCSI emulation for USB Mass Storage devices
[ 254.848950] usb-storage: device found at 4
[ 254.848955] usb-storage: waiting for device to settle before scanning
[ 254.856604] scsi7 : SCSI emulation for USB Mass Storage devices
[ 254.860363] usb-storage: device found at 4
[ 254.860367] usb-storage: waiting for device to settle before scanning
[ 259.849533] usb-storage: device scan complete
[ 259.851652] scsi 6:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
[ 259.872463] usb-storage: device scan complete
[ 259.875492] scsi 7:0:0:0: Direct-Access HUAWEI MMC Storage 2.31 PQ: 0 ANSI: 2
[ 259.885421] sr0: scsi-1 drive
[ 259.885427] Uniform CD-ROM driver Revision: 3.20
[ 259.885647] sr 6:0:0:0: Attached scsi CD-ROM sr0
[ 259.885773] sr 6:0:0:0: Attached scsi generic sg2 type 5
[ 259.892419] sd 7:0:0:0: Attached scsi generic sg3 type 0
[ 259.919212] sd 7:0:0:0: [sdc] Attached SCSI removable disk
[ 273.307280] UDF-fs: No VRS found
[ 273.307286] UDF-fs: No partition found (1)
[ 273.330287] ISO 9660 Extensions: Microsoft Joliet Level 1
[ 273.333290] ISOFS: changing to secondary root

Loading option module manually makes the modem usable.

> sudo modprobe option

[ 511.508120] usbcore: registered new interface driver usbserial
[ 511.510021] USB Serial support registered for generic
[ 511.511933] usbcore: registered new interface driver usbserial_generic
[ 511.511942] usbserial: USB Serial Driver core
[ 511.542627] USB Serial support registered for GSM modem (1-port)
[ 511.545694] option 1-3:1.0: GSM modem (1-port) converter detected
[ 511.551198] usb 1-3: GSM modem (1-port) converter now attached to ttyUSB0
[ 511.551250] option 1-3:1.1: GSM modem (1-port) converter detected
[ 511.556703] usb 1-3: GSM modem (1-port) converter now attached to ttyUSB1
[ 511.556803] usbcore: registered new interface driver option
[ 511.556810] option: v0.7.2:USB Driver for GSM modems

steba (ste-ba) wrote :

Maybe this is related to bug #414458.

This appears to me to work perfectly with the most recent usb-modeswitch. Has this been tried with a recent version? BTW, the usb-modeswitch requires about 15 seconds to quiesce for me - udev triggers an extra action on the basis of the vendor+product, and that takes extra time to complete.

Cheers,

Michael

svaens (svaens) wrote :

I will try again with the latest as soon as I have access to the computer which is showing the problem. It unfortunately won't be for another week.

smooth (smooth-gecko) wrote :

i am using Huawei E160E and faced the same problem...so i tried installing usb-modeswitch and usb-modeswitch-data (see bug #546728)...it didn't work...then i installed wvdial & restarted my pc...it works after that...no problems...maybe you could try it?

Cheers!

Since this is a hardware malfunction, I'll classify this bug as a kernel bug.

affects: ubuntu → linux (Ubuntu)

This is more likely a bug in network-manager since E169 (actually E620) works instantly using wvdial. The only problem with using wvdial to establish a connection is that many desktop applications check network-manager's D-Bus values (such as http://projects.gnome.org/NetworkManager/developers/spec-08.html#org.freedesktop.NetworkManager.Connection.Active, NM_ACTIVE_CONNECTION_STATE_ACTIVATED = 2). If the connection hasn't been established by network-manager, applications such as Firefox and Dropbox will stay in offline mode. With Firefox this can circumvented by altering about:config values but still... Too many applications depend on network-manager's values and there's no easy way to tell to the system that connection has been established without using network-manager.

Okay then, classifying this bug as a network-manager bug. But can someone provide Apport debug information? (usually via "apport-collect 592564")

After some research, it appears this bug is a duplicate of bug 41445. Please add any additionnal information to it.

Miguel Tadeu (mtadeunet) wrote :

Same thing is happening to me...what info can I supply to help out?

@Mohamed, are you sure about the duplicate?

Miguel Tadeu (mtadeunet) wrote :

sorry...only the link in #10 is wrong

Rafal-maj-it, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Tae-Wong SEO (seotaewong40) wrote :

Alessandro Bucci's comment in #13 has nothing at all to do with this bug.

Please hide the spam comment (#13).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers