Ubuntu

Unexpected power-off during boot or when resuming from suspend

Reported by Anoop P B on 2010-06-01
140
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Medium
Ubuntu-Certification
Undecided
Unassigned
linux (Ubuntu)
Medium
Andy Whitcroft
Declined for Lucid by Andy Whitcroft
Maverick
Medium
Unassigned

Bug Description

Using Ubuntu 10.04 32 bit Desktop, the system suddenly and unexpectedly powers off either when booting or when resuming from suspend or hibernate. If waking from suspend, this happens after the login box appears but even before I have begun typing my password. Unfortunately, this happens only once in about 7 or 8 suspends and not everytime. This is on a Dell Vostro V13 laptop.

After powering on the system again immediately after the problem has occurred, I have checked kernel.log and /var/log/messages and found nothing out of the ordinary there.

Re-installing 10.04 did not help. To confirm that this is not a problem with the hardware itself, I have now downgraded to Ubuntu 9.10 since a week and found that the problem went away.

Since I am now on 9.10, I did not use "ubuntu-bug" to report this as I am unsure how useful the information would be on this version of Ubuntu. However, if needed, I can do an apport-collect on 9.10 if it helps.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 2742 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe700000 irq 22'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,1028042b,00100004'
   Controls : 12
   Simple ctrls : 7
DistroRelease: Ubuntu 10.04
Frequency: Once every few days.
LiveMediaBuild: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: Dell Inc. Vostro V13
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Regression: Yes
RelatedPackageVersions: linux-firmware 1.34
Reproducible: No
Tags: lucid suspend resume regression-release needs-upstream-testing
Uname: Linux 2.6.32-21-generic i686
UserGroups:

dmi.bios.date: 01/11/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A02
dmi.board.asset.tag: 12345
dmi.board.name: 031VJ5
dmi.board.vendor: Dell Inc.
dmi.board.version: A02
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A02
dmi.modalias: dmi:bvnDellInc.:bvrA02:bd01/11/2010:svnDellInc.:pnVostroV13:pvrA02:rvnDellInc.:rn031VJ5:rvrA02:cvnDellInc.:ct8:cvrA02:
dmi.product.name: Vostro V13
dmi.product.version: A02
dmi.sys.vendor: Dell Inc.

Jeremy Foshee (jeremyfoshee) wrote :

Hi Anoop,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . However, note you can only test Suspend, not Hibernate, when using a LiveCD. If the issue remains, run the following command from a Terminal (Applications->Accessories->Terminal) it will automatically gather and attach updated debug information to this report.

apport-collect -p linux 588194

Also, please be sure to take a look at https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume . If you can provide any additional information outlined there it would be much appreciated.

Additionally, if you could try to reproduce this with the upstream mainline kernel that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-suspend
tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Anoop P B (anoop-pb) wrote :

On Karmic, upgrading from kernel 2.6.31-21 to the recently available 2.6.31-22 causes the bug to appear in Karmic as well.

I also confirm that this happens in the latest Fedora 13 (Live CD), so it appears to be an upstream bug.

Quentin Berten (qberten) wrote :

The problem seems related to the way ubuntu hibernation work.
The problem disappeared after installing "tux on ice" version of kernel suspend to disk implementation (using version at ppa:tuxonice/ppa):

$> uname -r -v
2.6.32-22-generic-tuxonice #36~ppa2-Ubuntu SMP Sat Jun 5 02:21:24 UTC 2010

Changed in linux (Ubuntu):
status: Incomplete → Triaged
tags: added: kernel-power regression-update
removed: needs-kernel-logs needs-upstream-testing
Anoop P B (anoop-pb) wrote :

It appears to be an acpi issue since passing acpi=off has made the problem go away (at least so far). I've also tried passing acpi=noirq , acpi=oldboot , noapic , nolapic , noirq (of course one at a time) - but none of those helped. Turning off the entire acpi stack seems extreme and I'd rather not do it. Besides, turning off acpi causes my touchpad to stop working.

Anoop P B (anoop-pb) wrote :

Tried the latest mainline kernel 2.6.34-lucid with no luck.
The 'tux on ice' kernel also has the same problem.

Kenneth (khenderick) wrote :

Hi, I have to confirm this bug on a Dell Vostro V13. I'm running Arch Linux however (kernel 2.6.35.5-1 / 2.6.35-ARCH). Just to inform that it's not a strictly ubuntu-bug :). I'll keep searching and looking to this thread.

gpothier (gpothier) wrote :

Same problem on a freshly installed & updated Maverick beta (AMD64 version).

gpothier (gpothier) wrote :

I forgot to mention two things:
- it is on the same hardware than the original reporter (Dell Vostro V13)
- in my case it is much more frequent than once every 7 or 8 suspends, actually I've never been able to successfully suspend more than twice.

znotdead (zhirafchik) wrote :

Confirm problem. But this problem not only hibernate and suspend but on usual loading after shutdown.
dell vostro v13, ubuntu 10.04

gpothier (gpothier) wrote :

Using the debugging procedure outline here: https://wiki.ubuntu.com/DebuggingKernelSuspend
I got the following lines in dmesg:
[ 0.713876] Magic number: 0:898:740
[ 0.713880] hash matches /build/buildd/linux-2.6.35/drivers/base/power/main.c:586

Anybody knows what it means?

gpothier (gpothier) wrote :

I did some more testing and although it seems several devices cause suspend/resume problems, the biggest issue is with bluetooth and usb.
I went to the bios settings and disabled all the integrated devices. In that configuration I did 10 suspend/resume cycles without problem.
Then I started enabling a few devices. With WLAN enabled I had one lock-up out of 10 suspend/resume cycles, but it was a lockup during suspend, not during resume, so it is probably another issue.
However enabling bluetooth makes it impossible to suspend/resume more than once or twice (after the second resume, the machine powers off during resume).
But the strangest thing is this: disabling bluetooth but enabling outside USB ports systematically triggers the unexpected power off during boot, the system becomes unbootable.

Kenneth (khenderick) wrote :

Seems like this issue has fixed itselfs. Since my latest system update, the computer boots up perfect again. It's not like I'm rebooting my laptop every day, but the few times I started it from halt steed up again, it went perfect.

The updates that fixed it:
upgraded cairo (1.8.10-1 -> 1.10.0-2)
upgraded libgl (7.8.2-1 -> 7.8.2-3)
upgraded intel-dri (7.8.2-1 -> 7.8.2-3)
upgraded kernel26 (2.6.35.6-1 -> 2.6.35.7-1)
upgraded kernel26-headers (2.6.35.6-1 -> 2.6.35.7-1)
installed glproto (1.4.12-1)
upgraded mesa (7.8.2-1 -> 7.8.2-3)
upgraded qt (4.6.3-1 -> 4.7.0-2)
upgraded xf86-input-evdev (2.4.0-2 -> 2.5.0-1)
upgraded xf86-input-synaptics (1.2.2-2 -> 1.3.0-1)
upgraded xf86-video-intel (2.12.0-1 -> 2.12.0-3)
upgraded xf86-video-vesa (2.3.0-2 -> 2.3.0-3)
upgraded xkeyboard-config (1.8-1 -> 1.9-1)
installed xorg-server-common (1.9.0-1)
upgraded xorg-server (1.8.1.902-1 -> 1.9.0-1)
upgraded xterm (261-1 -> 262-1)

gpothier (gpothier) wrote :

Kenneth: your comment that the issue is fixed is for Arch Linux, right?
On Ubuntu I've tried mainline kernels, and the good news is that the currently available 2.6.36-rc6 kernel (http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.36-rc6-maverick/) almost fixes the issue: I still observe these unexpected poweroffs during resume, but much less often; and the bluetooth-applet disappears after resume, although bluetooth is working fine.
I also tried the 2.6.35.7 mainline kernel, which does not fix the problem.

Kenneth (khenderick) wrote :

Yep, so I'm guessing it has something to do with the kernel or the intel videodrivers (as the problem did not occur when I put i915.modeset=0 in grubs kernelline). As you didn't get a fix with your 2.6.35.7 it might be the intel videodriver that is causing our trouble. Maybe you can try the very latest intel driver available for Ubuntu?

Kenneth (khenderick) wrote :

It didn't fix it completely, it's just less frequent now :(.

gpothier (gpothier) wrote :

Same here, with the 2.6.36 mainline kernel, in real-world usage I still observe the unexpected poweroff quite often, around once in two or three suspend/resume cycles. It seems that if the machine remains suspended for a while it is much more likely to occur.

gpothier (gpothier) wrote :

I've been testing the 2.6.31-22-generic kernel (from Karmic) on my Maverick install, up to now I've *not* observed a single poweroff. I'll update this bug in a few days to confirm it really works with that kernel.
(the only issue is that the internal microphone doesn't seem to work with that kernel).

Anoop P B (anoop-pb) wrote :

I can confirm that the problem occurs on 2.6.31-22-generic kernel on my Karmic (as I have mentioned earlier in comment #18). I have at times experienced a dozen good resumes before the problem appears again. It does not occur at the same frequency. So even after several successive good resumes, I have experienced the bug in quick succession afterwards.

Currently, the only good config that works for me is 2.6.31-14-generic on Karmic. Installing linux-backports-modules-alsa-2.6.31-14-generic makes the internal microphone work on that kernel.

gpothier (gpothier) wrote :

Thanks for the tip, indeed the alsa backport fixes the mic. I'll keep testing the kernels.

gpothier (gpothier) wrote :

Also note that this machine is Ubuntu Certified:
http://webapps.ubuntu.com/certification/hardware/201004-5578/

The page says that it is certified for 10.04 LTS, but the 2.6.31 Karmic kernel is the last known to work. I think the certificacion should be removed while this bug is not fixed.

gpothier (gpothier) wrote :

I just tested with the recently uploaded 2.6.35.22 maverick kernel: I've not experienced the poweroff issue, but that's because the machine fails to suspend... Either it hangs in a semi-suspended state (but the LCD backlight is still on) and has to be hard-reset, or it just attempts to suspend and immediately wakes up.

Anoop P B (anoop-pb) wrote :

gpothier: Are the unexpected poweroffs during boot gone with 2.6.35.22 maverick kernel?

gpothier (gpothier) wrote :

Yes, they still occur during boot with 2.6.35.22.
I've still not had a single problem with Karmic's 2.6.31-22, though.

Emile (emiletaillebois) wrote :

I have the problem on my Dell Vostro v13 with Ubuntu 10.04 and 10.10.
In the 10.10 release the bug is less frequent.

gpothier (gpothier) wrote :

I just tested the 2.6.37-rc1 mainline kernel, the problem still occurs.
I created an upstream bug report: https://bugzilla.kernel.org/show_bug.cgi?id=22462

Len Brown (len-brown) wrote :

has anybody seen this issue before upstream kernel 2.6.33.1?
(ie the stable upstream release, not the ubuntu release)
if yes, can you tell us about it at the upstream bug report?

https://bugzilla.kernel.org/show_bug.cgi?id=22462

Alejandro Arcos (arcosaf) wrote :

hi, the same problem with 3 V13 with ubuntu 10.10!!! How can help you!!!

gpothier (gpothier) wrote :

I put the results of a kernel bisect in the upstream bug report.

Andrea Cimitan (cimi) wrote :

same issue on my dell vostro v13, I just submitted this kernel bug, cause I've seen this later:
https://bugzilla.kernel.org/show_bug.cgi?id=24192

tags: added: pcert
Alejandro Arcos (arcosaf) wrote :

My team find a solution, but it is not the solution to the error, it may hibernate:

sudo apt-get install hibernate uswsusp

then edit

vim /etc/uswsusp.conf

resume device = /dev/sda5 "swap space"
splash = n
compress = y
early writeout = y
RSA key file = /etc/uswsusp.key
shutdown method = shutdown

then

sudo s2disk

not is nice but working!!!!

Hilmar Demuth (hilmar-demuth) wrote :

I also have the same problem.

actual kernel 2.6.32.25 + 2.6.32.26 (tried both)

It took me some month to realize the problem, because for me the "power off" at boot came very sporadically. Until today the 2nd try was always successful, but a few moments ago I had to boot 10 times to see the login-screen only at the last attempt.

From my observations the problem seems to get worse with any kernel update.

Hilmar Demuth (hilmar-demuth) wrote :

sorry, forgot to add:

I have of course also a Dell Vostro V13.

In order to solve the problem I upgraded the bios version from A01 to A05, no effect.

Andrea Cimitan (cimi) wrote :

in natty, with latest kernels (i guess the last two maybe), the computer NEVER resumes from suspend, and I can't get the login screen much more times.
This is a huge problem, the Ubuntu Certification should be removed until this is fixed, or people (like me) continue to buy laptops and they become unsatisfied from Ubuntu once they understand that they bought incompatible hardware.

Burin_Khazad (burin-khazad) wrote :

Same bug with my Dell Vostro V13 and Ubuntu 10.10 64 bits.

I'm very disappointed because of the certification wich is visible on your website. I hope that you are resolving this important bug.

Burin_Khazad (burin-khazad) wrote :

With a more recent Linux Kernel (2.6.37), the bug doesn't appear as frequently as with the standard kernel. Since I install this new RC Kernel, I don't have the bug when I start my computer, only one time when resuming from suspend.

I install this Kernel from this website : http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.37-rc2-maverick/

Chris Van Hoof (vanhoof) on 2011-01-05
Changed in linux (Ubuntu):
assignee: nobody → Manoj Iyer (manjo)
tags: added: hwe-blocker

I have the same problem. My kernel version is 2.6.35.24-generic on Ubuntu 10.10. I recently upgraded from 2.6.35-22-generic. I have not really found a pattern when it suspend forces a power down and when not.

I experience the same bug on my Dell Vostro V13 laptop. I installed Ubuntu 10.10 on an external USB hard drive.
On boot, I have to try on average three times to have a succesful boot. The two other times, the computer shut downs unexpectedly before displaying the Ubuntu splashscreen.
I tried several kernel version, to no avail (currently running 2.6.37 rc2).

This bug was solved for me when applying a patch proposed for a different bug : https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/380126 (problem with the synaptic touchpad on the same computer model.
Apparenlty it is due to bad interrupts by the touchpad.
Hope this helps.

Burin_Khazad (burin-khazad) wrote :

Thanks a lot for the link Nicolas.

If someone is interrested, you can find the kernel 2.6.35-25.43 compiled with this patch in my website : https://www.isorez.fr/ftp

Kernel packages are for amd64 (compiled in my vostro v13 with Intel T7300). There is also a synaptics package in order to enable the multi touch of the touchpad.

Hope this helps. ;)

Hilmar Demuth (hilmar-demuth) wrote :

After the upgrade to Kernel 2.6.32-27 the bug didn't occure for some time, but today the powerdown happened once more.

Sorry, the bug also effect:

Ubuntu Kernel 2.6.32-27-generic

Hope the bug is fixed soon...
If I can help by testing a new patch for Kernel 2.6.32, please contact me.

Rodolfo (rodolfo-3) wrote :

I have a V13 notebook and the same problem happen using Debian 6.0 (kernel 2.6.32 AMD64) in power on and back to suspend and hibernate.
During the boot messages, I see an ACPI error:
ACPI: I/O resource 0000:00:1f.3 [0x1c00-0x1c1f] conflicts with ACPI region SMBI [0x1c00-0x1c0f]

A "lspci" show:
00:1f.3 SMBus: Intel Corporation 82801I (IHC9 Family) SMBus Copntroller (rev 03)

Other references to 0000:00:1f.3 on dmesg:
[ 0.203876] pci 0000:00:1f.3: reg 10 64bit mmio: [0x000000-0x0000ff]
[ 0.203899] pci 0000:00:1f.3: reg 20 io port: [0x1c00-0x1c1f]
[ 3.688520] i801_smbus 0000:00:1f.3: PCI INT C -> GSI 19 (level, low) -> IRQ 19
[ 3.688529] ACPI: I/O resource 0000:00:1f.3 [0x1c00-0x1c1f] conflicts with ACPI region SMBI [0x1c00-0x1c0f]

Since I added "acpi=off" in kernel line (on grub conf), this problems (power off during boot and ACPI error message) was solved. But I can't suspend/hibernate anymore... =/

I'm downloadind natty-alpha1 to test.

Rodolfo (rodolfo-3) wrote :

Forgot to mention: the touchpad does not work in Xorg with "acpi = off" - probably something related to comment 54

bob (rjderksen) wrote :

I've installed the kernel from #55 (thanks!) and it seems to have cured the boot problem as well as providing synaptic support.
Suspend/hibernate are both working. (V13, SU3500)

Andy Whitcroft (apw) wrote :

It seems that this bug is triggered by the following commit, which has been tested to fix the issue on Maverick. This fix is already in Natty, and has been proposed for SRU to Maverick:

  commit f8313ef1f448006207f12c107123522c8bc00f15
  Author: Jiri Kosina <email address hidden>
  Date: Sat Jan 8 01:37:26 2011 -0800

    Input: i8042 - introduce 'notimeout' blacklist for Dell Vostro V13

    i8042 controller present in Dell Vostro V13 errorneously signals spurious
    timeouts.

    Introduce i8042.notimeout parameter for ignoring i8042-signalled timeouts
    and apply this quirk automatically for Dell Vostro V13, based on DMI match.

    In addition to that, this machine also needs to be added to nomux blacklist.

    Signed-off-by: Jiri Kosina <email address hidden>
    Signed-off-by: Dmitry Torokhov <email address hidden>

Changed in linux (Ubuntu Maverick):
assignee: nobody → Manoj Iyer (manjo)
Changed in linux (Ubuntu):
assignee: Manoj Iyer (manjo) → Andy Whitcroft (apw)
status: Triaged → In Progress
Changed in linux (Ubuntu Maverick):
status: New → In Progress
importance: Undecided → Medium
Changed in linux (Ubuntu):
importance: Undecided → Medium
Andy Whitcroft (apw) wrote :

This fix is being rolled out under Bug #380126.

Changed in linux (Ubuntu):
status: In Progress → Fix Released
gpothier (gpothier) wrote :

The poweroff bug still occurs on Natty as of today, so the touchpad fix doesn't seem to also fix the poweroff bug.

Alejandro Arcos (arcosaf) wrote :

Same error appear after fix touchpad bug.

Rodolfo (rodolfo-3) wrote :

Here, no more problems using kernel 2.6.35-25-dellv13 (thanks Nicolas Becker and Burin_Khazad - comments 54 and 55) and the multitouch trackpad works fine. Using the official natty kernel, it poweroff again and the multitouch doesn't work.

Torge (tdellert) wrote :

I have the same problem using Kubuntu 10.10 64bit with kernel 2.6.35-25 on my Dell Vostro v13.
About each second boot fails with a power-off.
When I find the time, I'll test Burin_Khazeds kernel, too.

Changed in linux:
importance: Unknown → Medium
Jay S (topdownjimmy) wrote :

The kernel from maverick-proposed seems to have solved this issue for me, but has also introduced an occurrence of the symptoms described at bug #34501

Changed in linux:
status: Unknown → Invalid
Ayan George (ayan) on 2011-08-31
tags: added: blocks-hwcert-enablement
Changed in linux (Ubuntu Maverick):
assignee: Manoj Iyer (manjo) → nobody
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.