Ubuntu

[arrandale] Resume doesn't work on a Latitude E6410

Reported by Carlos Parra Camargo on 2010-05-11
334
This bug affects 67 people
Affects Status Importance Assigned to Milestone
Arch Linux
Invalid
Undecided
Unassigned
linux (Ubuntu)
Critical
Manoj Iyer
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Laptop:
- Latitude E6410 Core i5 with an intel video card.
- Clean Lucid Lynx install.

Problem: it doesn't resume at all, it seems that "suspend" in a correct way but when i open the laptop trying to resume, i just get a black screen.

I've been searching around launchpad and others related sites with no luck. I've already tested:
- Turn off DRI at xorg.conf. No results.
- Update xserver-xorg-video-intel to 2.11 (from ubuntu-x-swat ppa repository). Same problem.
- I've tried 2.6.31-10-rt from official ubuntu repositories with the same result.
- Also, I've tried 2.6.33, 2.6.34-rc6 and 2.6.34-rc7 from kernel ppa but it seems that my laptop "freeze" on start with all of these kernels.

In general, my video card is a little anoying, Lucid doesn't works well with this intel video card (no resume, no scroll on the touchpad by default, a lot of problems with external monitors, ...). Anyway, let's start for the resume issue!
---
Architecture: i386
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] No existe el fichero ó directorio
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: Dell Inc. Latitude E6410
Package: xorg 1:7.5+5ubuntu1
PackageArchitecture: i386
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=e104645b-febc-4038-ad66-d7119d74d43b ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=es_ES.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: lucid lucid
Uname: Linux 2.6.32-22-generic i686
UserGroups:

dmi.bios.date: 03/05/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A01
dmi.board.name: 04373Y
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA01:bd03/05/2010:svnDellInc.:pnLatitudeE6410:pvr0001:rvnDellInc.:rn04373Y:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6410
dmi.product.version: 0001
dmi.sys.vendor: Dell Inc.
glxinfo: Error: [Errno 2] No existe el fichero ó directorio
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-22-generic

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Bryce Harrington (bryce) on 2010-05-11
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)

Thank you Bryce.

Anyway, it could be also problem of "linux-image-2.6.32-22-generic" but i'm not sure.

Could i make any test to discover the if the origin is at the intel driver or at the linux image?

Bryce Harrington (bryce) on 2010-05-11
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
IndyCore (jan-kjerbye) wrote :

Dell E6410 ATG with Intel HD graphics. Exact same behaviour on mine.

Random lockups when compositing is enabled and a some gfx glitches in Plymouth COULD suggest an xserver-xorg-video-intel related error.

Kamal Mostafa (kamalmostafa) wrote :

@Carlos and other testers-

Please see bug LP: #553498 (comment #17) for a test kernel for Ubuntu 10.04 LTS which provides a suspend/resume fix that may fix the "always hangs on resume" problem on Intel Core i5 (and possibly i3 and i7 systems). Feedback will be much appreciated.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Critical

@Kamal, sorry but i've a 386 arch so i can't test the test kernel (it just for "amd64"). If you can rebuild for a 386 arch i would be really thank you!

Geir Ove Myhr (gomyhr) on 2010-05-16
summary: - Resume doesn't work on a Latitude E6410
+ [arrandale] Resume doesn't work on a Latitude E6410
tags: added: arrandale lucid resume suspend
Kamal Mostafa (kamalmostafa) wrote :

I have posted a PPA build of the test kernel that I mentioned in comment #25. The PPA provides both the amd64 and i386 versions of the kernel. This kernel includes the fix for bug LP: #553498 (comment #17) -- it is a test kernel for Ubuntu 10.04 LTS which provides a suspend/resume fix that may fix the "always hangs on resume" problem on Intel Core i5 (and possibly i3 and i7 systems):

https://launchpad.net/~kamalmostafa/+archive/linux-kamal-scien

Feedback will be much appreciated.

First of all, thanks! I've just tested this Kamal kernel but I'm still having exactly the same problem.

carlospc@camelot:~$ uname -a
Linux camelot 2.6.32-22-generic #34~kamal~scien-Ubuntu SMP Tue May 18 01:14:38 UTC 2010 i686 GNU/Linux

Kamal, do you need any file log? Should i "apport-collect" again the logs?

Thanks!

Kamal Mostafa (kamalmostafa) wrote :

@Carlos - Looks like the problem must be due to some other than the SCI_EN issue - sorry that didn't do the trick. No need to apport-collect again, that test kernel won't supply any more useful data than submitted previously.

Thanks anyway! Well, i will continue researching around the ACPI Error, extracted from the syslog:

May 18 17:57:50 camelot kernel: [ 16.718853] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.ECDV.ECR1] (Node f702e6a8), AE_TIME
May 18 17:57:50 camelot kernel: [ 16.718897] ACPI Error (psparse-0537): Method parse/execution failed [\ECRB] (Node f702e780), AE_TIME
May 18 17:57:50 camelot kernel: [ 16.718923] ACPI Error (psparse-0537): Method parse/execution failed [\ECG5] (Node f702e828), AE_TIME
May 18 17:57:50 camelot kernel: [ 16.718949] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.AC__._PSR] (Node f702ec18), AE_TIME
May 18 17:57:50 camelot kernel: [ 16.719133] ACPI Exception: AE_TIME, Error reading AC Adapter state (20090903/ac-140)

Stenten (stenten) wrote :

Reassigning to linux because suspend/resume is handled by the kernel, and Kamal (who is working on this) is in the Kernel Team. Apologies if this isn't the correct action.

affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
tags: added: i386 kernel-power

Thanks Stenten.

* I've tested the new kernel (linux-image-2.6.32-22-generic 2.6.32-22.36) but i still having the same resume problem.
* I've also tested the new BIOS version (P02 and A03, both cases) but it fails as well.

I will continue testing, if any developer need my help, just ping me!

ashayh (ashay-humane) wrote :

Hello

Same problem with a Latitude E6410 and:

01:00.0 VGA compatible controller: nVidia Corporation NVS 3100M (rev a2)

Please let me know if you want any any files/logs from me.

Stenten (stenten) wrote :

On Sat, Jun 5, 2010 at 7:00 PM, ashayh <email address hidden> wrote:

> Hello
>
> Same problem with a Latitude E6410 and:
>
> 01:00.0 VGA compatible controller: nVidia Corporation NVS 3100M (rev a2)
>
> Please let me know if you want any any files/logs from me.

This bug report is for Intel Arrandale chipsets only. Please file a new bug
report by typing "ubuntu-bug xorg" into a terminal.

Dominik (dominik-dbruhn) wrote :

I got the same problem, also a Dell E6410. If I can help by providing information please reply here or send me a message.

Dominik (dominik-dbruhn) wrote :

I gathered the following information:
1. Upgrading the Bios to A01 or A03 (the most recent Version) does not help!
2. Upgrading to the "2.6.34-020634-generic" Kernel from
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-lucid/linux-image-2.6.34-020634-generic_2.6.34-020634_amd64.deb does not help. Why this? I thought it should be fixed in upstream kernel 2.6.34, so why is it not working using that kernel?

Dominik (dominik-dbruhn) wrote :

3. Adding "acpi_sleep=sci_force_enable" to the Kernel-Commandline (like suggestes for various i5 lenovo thinkpads) doesn't help either.

It is likely that this bug also affects me on a Latitude E4310 (same CPU/video card).
My symptom is that the video does not turn on on resume. Anyway, I can switch to a console (ctrl+alt+f1) and then reboot via ctrl+alt+canc.

I also tried upgrading to Maverick, but without any success.

With a LiveCD the suspend/resume works only the first time I suspend. The second resume results in a spontaneous reboot.

Thanks for your work!

I've added Ubuntu Kernel PPA and I've installed linux-headers-2.6.35-2, linux-headers-2.6.35-2-generic, linux-image-2.6.35-2-generic (version 2.6.35-2.3~lucid1) but i get the same error trying to resume.

John Trostel (jtrostel-gmail) wrote :

starting up with notsc kernel option removes the AE_TIME errors but still doesn't return from suspend properly.

I _can_ ping or ssh to the box after resume though. So, it's running in my case, just not running the display correctly.. Can you ping or ssh Carlos?

Changed in linux (Ubuntu):
milestone: none → ubuntu-10.04.1
assignee: nobody → Chris Halse Rogers (raof)
Colin Watson (cjwatson) on 2010-07-20
Changed in linux (Ubuntu):
milestone: ubuntu-10.04.1 → ubuntu-10.04.2
Manoj Iyer (manjo) on 2010-07-20
Changed in linux (Ubuntu):
assignee: Chris Halse Rogers (raof) → Manoj Iyer (manjo)
status: Confirmed → Incomplete
Ameet Paranjape (ameetp) on 2010-07-28
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Steve Conklin (sconklin) on 2010-07-29
Changed in linux (Ubuntu):
status: Triaged → In Progress
Steve Conklin (sconklin) on 2010-08-03
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) on 2010-08-17
Changed in linux (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) on 2010-08-27
tags: added: verification-done
removed: verification-needed
Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
83 comments hidden view all 163 comments
CesarS (cesarsoplin) wrote :

With 2.6.32-24-generic Lucid, but, latitude e4310

same problem #119 #122, wake up : black screen

thank a lot

dragilla (dragilla) wrote :

I checked the workaround posted in comment #54 and it worked. But when I have a virtualbox launched and VM running and I put the system to sleep, the machine doesn't wake up properly - I can only see a cursor blinking. Should I create a bug report for this?

Kernel 2.6.32-24.43 (linux-image-2.6.32-24-generic) did NOT resolve the issue for me on an E6410ATG with Intel graphics running 64-bit Lucid.

Upon resume-from-suspend, my screen is black and backlight is off. I can turn the backlight on by Alt-Up, but the screen remains black. Switching to a virtual console and back does not help. Restarting GDM (/etc/init.d/gdm restart) does not help. I confirmed that the computer is not locked-up.

Booting works fine. Hibernate works fine. Power management is set to blank screen on lid closure, and that works fine as well (screen is displayed after opening lid.)

Running Lucid LTS on an E6410 with Intel HD graphics and Core i7, 64-bit. The kernel (linux-image-2.6.35-14-generic) in comment #103 worked beautifully for me; I can now suspend and resume to my heart's content. Thanks!

Oswald-p (oswaldpp) wrote :

Same problem here with Ubuntu 10.10 64bits on a E6410 (intel graphic card).

The screen does not resume after suspend and the computer needs to be "hard" power off.

O-p

Michal (mikeos) wrote :

I've got success with the latest 2.6.36 mainline kernel dev snapshot:

http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2010-10-13-maverick/
(don't try the rc7 on any older snapshot - just this one worked)

Using the standard Maverick 10.10 x64 installation which includes nVidia proprietary 260.x beta driver series

How-to:
1) installed the kernel headers, headers-generic, image from the above URL
2) make sure that dkms has rebuilt the nvidia.ko for this kernel, otherwise you're out of luck with Xorg
3) sudo chmod -x /usr/lib/pm-utils/sleep.d/94cpufreq (otherwise 2nd resume when running on batteries may fail; please report if this was needed by trying multiple suspend/resume cycles with AC power disconnected)

Reboot. No more frozen system stuck on black screen on resume, no matter if resumed while on AC or on battery power.

Michal (mikeos) wrote :

WARNING : I forgot to remind everyone that using pre-release kernels is dangerous, using kernel daily snapshots IS VERY DANGEROUS and could lead to data loss or any kind of irreversible damage to your system.

Users not willing to risk are advised to try the above method once the final version of 2.6.36 kernel is released, which is expected very soon..

bagl0312 (bagl0312) wrote :

I think I am affected by the same bug on a dell precision M4500 I7 CPU and graphic card Quadro FX 880M with ubuntu maverick 10.10 64bits.
Hibernate works, but suspend/resume does not work. The computer goes in suspend mode but it does not wakeup.

Øyvind Stegard (oyvinst) wrote :

Resume from suspend on Dell E6510 (BIOS A05) using Ubuntu Lucid 10.04 x86-64 fails (black screen on resume) with the linux-image-generic-lts-backport-maverick kernel (2.6.35.22.34) in Lucid proposed, but works with the standard Lucid kernel (2.6.32-25).

Nvidia driver is latest stable: 260.19.12, laptop has NVS 3100M graphics adapter. So the newer Maverick kernel regresses suspend/resume on this laptop (at least on Lucid).

Changed in linux (Ubuntu Maverick):
status: New → Invalid
Michal (mikeos) wrote :

Why marked as invalid? My testing (just using different kernels, otherwise keeping the same configuration):

- Lucid Kernel 2.6.32-25 -> OK
- Mainline 2.6.33 -> K.O.
- Mainline 2.6.34 -> K.O.
- Maverick 2.6.35 -> K.O.
- Mainline since 2.6.36rc8 -> OK*
- Natty 2.6.36-0 -> OK*

* second resume (only when resuming on battery power) mostly fails

bagl0312 (bagl0312) wrote :

I confirm that suspend/resume works very well on my dell precision M4500 with kernel 2.6.36 just released and ubuntu 10.10 amd64. It was not working with standard kernel for maverick 2.6.35

I followed suggestion #129 using kernel 2.6.36 taken from:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.36-maverick/

Up to now there is no need to apply:

sudo chmod -x /usr/lib/pm-utils/sleep.d/94cpufreq

since resume seems to work also running on battery without problems

I am also using latest nvidia drivers 260.19.12:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

Michal (mikeos) wrote :

I think I identified the problem on my system Dell Latitude E6410 with Intel i7 CPU.
Disabling Intel SpeedStep feature in BIOS does the trick. Battery life decrease seems insignificant thanks to power management assured by CPU C-states. What's interesting that the CPU multiplier is still variable (according to i7z) even with SpeedStep disabled, though the very low frequencies and turbo-boost frequency are never reached in contrast with SpeedStep enabled setup with ondemand governor.

Successfully tested on 20 consecutive suspend/resume cycles on battery, same on AC power.

Why does resume with SpeedStep enabled *only* fail when the machine is running on battery power remains unknown. Before forcibly disabling SpeedStep in BIOS I did a lot of different tests, disabling any possible PM scripts which either modified CPU governors (as e.g. /usr/lib/pm-utils/sleep.d/94cpufreq seems to do) or report the power state to other scripts (like /usr/lib/pm-utils/functions) forcing it to report that the machine is on AC-power even though it was not. Nothing was reliable enough.

Is it a BIOS bug? Someone with Dell Latitude e6410, BIOS rev.A05, Intel i7 M 620@2.67GHz can report the resume behavior when running on batteries with SpeedStep enabled? Both variants with either nVidia or Intel GFX should suffer from the same problem (if my laptop is not unique...)

Michal (mikeos) wrote :

When setting GRUB option to "acpi_sleep=nonvs" described here:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/656279/comments/41
the black screen on resume is fixed on Maverick kernel 2.6.35. With 2.6.36 kernel this GRUB option isn't necessary.
In both cases resume on battery (with SpeedStep enabled) fails due to CPU freezing like I already described.

Michal (mikeos) wrote :

Apparently my resume problem on batteries is caused by kernel race condition related to Intel Idle Driver. I filed a separate bug for this:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/665891

Shubh (shubh) wrote :

Same exact problem with my Dell Vostro 1088. It doesn't come out of resume. I just get a black screen. My touchpad scroll doesn't work too.

Michal (mikeos) wrote :

It has proven incorrect assuming that the problem is caused by linux CPU power management. With a special kernel, where cpufreq is modularized (http://www.linux-phc.org/) i was able to completely remove cpufreq thus finally nothing was managing CPU frequency scaling (P-states), I also disabled intel_idle driver which manages C-states. Btw. powertop looks really cute when the upper C-states and P-states monitoring area is empty ;-)
The result is still the same - system freezes on S3 resume from batteries.
I still confirm that with SpeedStep disabled in BIOS the laptop resumes perfectly with full CPU power management enabled; however this seems to be just a coincidence proving nothing about the real cause of the problem.
Same behavior observed with A03, A04 and A05 BIOS.

Anyone here with Latitude E6410 can test S3 resume on batteries and post the results including their HW/SW specs? Please try at least 5 successive suspend/resume cycles without AC-power plugged in.

It would be nice to know at minimum whether just a certain HW configuration is affected (e.g. models with nVidia card).

Radko Bankras (radko-bankras) wrote :

Mikeos,
By your request I have tried some things on my E6410 (i7 M620, nVidia, Ubuntu 10.10, 2.6.35-22-generic kernel). Resume from suspend fails when running on battery and works fine when using AC power. I have updated from A01 to A05 BIOS, which did not help to fix this issue. Also, I had the SpeedStep feature disabled in the BIOS and that did not help. I haven't tried the GRUB option yet. Let me know how I can help further.

Michal (mikeos) wrote :

Radko, your feedback is very appreciated. For 2.6.35 and older kernels you need to apply acpi_sleep option into GRUB like this:

1) $ sudo nano /etc/default/grub
2) Search for GRUB_CMDLINE_LINUX="" and make it look like GRUB_CMDLINE_LINUX="acpi_sleep=nonvs"
3) Save and run: $ sudo update-grub2
4) reboot

(instructions above are valid for GRUB 2 which comes by default since Lucid i believe)

With 2.6.36 kernels GRUB editing is no longer necessary.
Expected result: always resumes on AC; almost always fails on battery-power; always resumes on both AC and batteries with SpeedStep disabled in BIOS. Disabling SpeedStep (CPU Frequency Scaling) by other methods like forcing CPU governor to performance or unloading cpufreq module (which is not possible on standard recent kernels, because it is no more a separately loadable module) does not have the same effect like disabling SpeedStep in BIOS.

Paweł Paprota (ppawel) wrote :

I reported a similar bug in Archlinux's bugtracker:

https://bugs.archlinux.org/task/20886

My laptop is Dell E6510 with NVIDIA NVS 3100M. I've been affected by suspend/resume problems but recently (about 4-5 days) it just works... I am not sure if this is because of upgrading to 2.6.36 - it worked for a day or two on 2.6.35. Nothing else changed that I can recall. I am using pm-suspend for suspending.

@mikeos:
Suspend/resume works since I added the "acpi_sleep=nonvs" kernel option, without disabling SpeedStep in BIOS. (Haven't tried too extensively, but did it successfully 6-7 times.)

I'm on a Dell Latitude e6410, NVS 3100M (driver: 260.19.12), 2.6.35-22-generic #35-Ubuntu.

If I disable SpeedStep, I'm getting loads of 'MCP power or thermal limit exceeded' messages in /var/log/syslog.

Oswald-p (oswaldpp) wrote :

I have also tried the tip described by mikeos on post #141 on my E6410 (intel video card) but with no success...

I am using Ubuntu 64 bit with the kernel 2.6.35-22 generic as reported by Kristof Bajnok...

Don't understand what's happening here...

O-p

Michal (mikeos) wrote :

Oswald, the problem about which I am writing essays here seems to be very different from anyone elses problem like I realized today.
I suppose the workaround proposed in comment #54 could fix it for you.

-
Being desperate because of trying virtually any possible Linux kernel tweaking, various nVidia nouveau+proprietary drivers, modifying nVidia card registry, physically unplugging PCI cards, disabling everything possible in BIOS etc., I decided to install Windows 7 (tried both clean install and whole range of Dell drivers stuff) supposing that of course no such issue would appear. The contrary was true! Same problem under Windows. Dell technician is about to bring a replacement CPU, mainboard and battery. I'll report the results when replacements are done.

Paulo J. S. Silva (pjssilva) wrote :

As I said in comment #103 we should be careful not to hijack this bug report. The original bug report was about a E6410 with intel graphics and a core i5. I have such a machine as the original reporter and my laptop is resuming flawlessly with Ubuntu 10.10 kernel (2.6.35-22).

Are there any other people here with laptop with those specs who can confirm that the Macerick kernel works?

If that is the case, I would kindly suggest people with other hardware to open specific bugs. For example, people with core i7 that are having problems with resuming when speedstep is on in the bios. The same for people with nvidia cards. By doing so, we can allow this bug to be closed and have new specific bugs for other problems so that the developers can have better clues on how to solve them.

I have exactly a Dell E6410 with your specs and resuming works flawlessly for the Maverick kernel.

Keith (lutalo) wrote :

FYI, I also suffer from the suspend/hibernate crash issue, (I use a Dell Inspiron).

I recently installed the suspend tool found in the Ubuntu software center and my issue has been solved. I'd recommend the debuggers to cross reference that tool to see if it sheds any light on the situation and for those of you suffering from the issue, I'd try the tool to see if it resolves your problem.

On Ubuntu Software Center, select "system" and search "suspend"

"Smartly puts your computer to sleep (suspend RAM or disk)"

Oswald-p (oswaldpp) wrote :

Thank you Keith

Unfortunately it doesn't work on the E6410 (Core i7, intel Graphics HD).

O-p

On my machine (Core i7 M620, Intel Arrandale graphics) a reliable suspend / resume only works if:
* the ubuntu splash screen is disabled
* the system switches to a text console before suspend

The first can be achieved by removing the 'quiet splash' from the grub kernel command line.
The latter can e.g. be achieved by installing uswsusp and running s2ram.

Jim Ciallella (jimc) wrote :

A SOLUTION that worked for me.

Dell E6410, Core i7, Nvidia NVS 3100M that would not resume from suspend or hibernate. Backlight comes on, but screen remains black when it comes out of suspend.

Tried a bunch of things, read a bunch of thread. This worked in one quick change.

- Edit /etc/default/grub from the command line via sudo
- Set the GRUB_CMDLINE_LINUX_DEFAULT variable as follows:

GRUB_CMDLINE_LINUX_DEFAULT="nouveau.modeset=0 acpi_sleep=nonvs"

- Run “sudo update-grub” at the command-line
- Restart Ubuntu

Solution credit is due to http://vxlabs.com/2010/11/30/ubuntu-10-10-x86_64-on-your-dell-e6410-with-nvs-3100m-gpu/

Also, I found that deactivating the Nvidia driver through System >> Administration >> Additional Drivers would also prevent the suspend problem. The instant I re-enabled the Nvidia driver it would not resume. The fix mentioned immediately above works with the Nvidia driver enabled too.

Michal (mikeos) wrote :

Jim, does you E6410 resume from suspend reliably like this even when unplugged from AC power? E6410 of mine systematically freezes on second or third resume when running on batteries only. When it runs on AC adapter, resume is always reliable. I am not using Hibernate because of not willing to wear out the SSD.

@mikeos: I have the exact same symptoms with a Latitude E6500 although I didn't realise it doesn't occur when plugged in. I'll have to check that.

Beside that I also have failures going into suspend and even with the system spontaneously waking up from suspend with the lid closed(!) Do you recognize that as well?

Jim Ciallella (jimc) wrote :

RE: Solution #151

So far it suspends / restores very reliable. Works on battery or A/C. Works for suspend or hibernate (which is slow and I don't intend to use). Suspends properly whether I close the lid or use the Suspend menu option. Restores properly whether I open the lid or use the power button. I have yet to figure any combination that doesn't work.

I'm running Ubuntu 10.10, 64-bit, 2.6.35-23 kernel on a Dell E6410, Core i7, Nvidia NVS 3100M, 5GB RAM.

I had the exact same black screen on restore problem running the 32-bit. I tested and #151 fixed it on the 32-bit too.

Michal (mikeos) wrote :

Gaby: no such problem here with spontaneous resume from suspend. Could it be a Wake-On-LAN packet that is waking-up your laptop?

Jim: What's exactly your CPU Core i7 model? I tested different DDR3 RAM sizes from two distinct vendors, no difference. My CPU is Core i7-620 @ 2.66 GHz which seems to be the precondition for the issue to appear.

I dare to say that: any E6410 + GPU nVidia NVS 3100M + CPU Core i7-620 @ 2.66GHz = freeze on resume from STR on batteries sooner or later

BIOS rev. A04, A05, A06 plays no role as well as amount of installed RAM or its vendor or additional miniPCI devices. I didn't go that far to physically unplug the fingerprint reader or further HW hacking.

Funny. My 6500 has Intel Graphics so the nouveau setting won't do anything. I'm going to try the acpi_sleep=nonvs though.

Jim Ciallella (jimc) wrote :

I have a Core i7-620 @2.8GHz

The problem only happened for me when the NVIDIA driver is being used. With solution #151 I'm able to suspend reliably even with the NVIDIA driver. My feeling is that it's the NVIDIA video driver.

I don't know anything about the nouveau.modeset=0 acpi_sleep=nonvs values to speak intelligently about it, but if I knew where to start I'd be looking at how the NVS 3100M + the NVIDIA driver + the nouveau.modeset=0 acpi_sleep=nonvs settings work together.

Jim Ciallella (jimc) wrote :

Sorry, Core i7-640 @2.8GHz

Pete Graner (pgraner) on 2011-01-10
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Chris Van Hoof (vanhoof) on 2011-02-18
tags: added: hwe-blocker
Changed in linux (Ubuntu Maverick):
status: Invalid → Fix Released
Changed in archlinux:
status: New → Invalid
jhoechtl (johann-hoechtl) wrote :

This bug report is helplessly cluttered with various different problems and configurations. Nobody can draw any helpful information out of it.

An E6410 is equipped with an i5 processor and either Nvidia or Intel HD graphics. It certainly has no i7 installed.

There seems to be no reliable fix as of yet.

I can confirm this bug for Ubuntu 11.10, Linux deneb 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:27:26 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux for the Intel HD Graphics and BIOS Rev. A05

This bug report must not be closed as the bug persists.

Michal (mikeos) wrote :

> An E6410 is equipped with an i5 processor and either Nvidia or Intel
> HD graphics. It certainly has no i7 installed.
E6410 with Core i7 has been commonly available for purchase.

> There seems to be no reliable fix as of yet.
Depends for what. Apparently even the latest BIOS rev. A10 did not solve freezing on resume from suspend to RAM when the laptop is powered on batteries. Occurs on Windows as well. This is a hardware or BIOS bug. Ubuntu or Linux kernel cannot be blamed for it.

This hardware or BIOS bug causing the system to hang on resume (system completely frozen) should not be interchanged with black screen (video broken but otherwise the system is alive).

I would suggest that you open a more specific bug report for your issue, this one is helplessly cluttered like you said.

I have an E6410, Intel® Core™ i7 CPU M 620 @ 2.67GHz × 4
Nvidia NVS 3100M/PCI/SSE2
Dual Boot: Ubuntu 11.10 64-bit, Win 7 64bit
Bios was A06, now A09.

I've never had a problem with Win7 resuming from being suspended. Just Ubuntu. I tried many things over the past year and a half but nothing had worked. I'm not convinced that it is a hardware issue-- Try this. It's a simple hack but it works for me!

$ sudo cp /etc/acpi/lid.sh /etc/acpi/lid.sh.bak
$ sudo rm /etc/acpi/lid.sh
$ sudo cp /etc/acpi/sleepbtn.sh /etc/acpi/lid.sh

Michal (mikeos) wrote :

Is a hardware (BIOS) issue, nothing OS specific. Seems that A12 BIOS (maybe A11 which I did not test; A10 was still buggy) does fix the issue.

my laptop is not detect the hibernate option what i do.

Displaying first 40 and last 40 comments. View all 163 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.