Ubuntu

Lucid Live CD/USB freezes shortly after start

Reported by Ruben Verhack on 2010-05-01
162
This bug affects 33 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Hi,

I downloaded the ubuntu lucid amd64 final iso and did the sha256sum. I created a live USB and also burned the iso on a disc. Both produced the same error:

When I let it boot from the USB/CD it shows the purple splash with the "keyboard equals human"-icon, after that goes onto a black screen with a blinking cursor. When using the CD you can hear the CD spin down and no activity on the laptop.

When I press the keyboard while booting, I can choose different options, options "try ubuntu", "install ubuntu" and "check for errors" all fail in the same way.

As I'm not able to do much, I can't use apport or read logs (unless there is a way to do so?) I'll put as much information about this laptop as I'm able to find:

Intel® Core™ Duo T6600
(2.20 Ghz - 2 MB L2 cache)
15.6" LED widescreen
WXGA (1366 x 768 pixels)
Mobile GM45 chipset
4 GB DDR2 RAM
VGA: Mobile Intel® GMA 4500MHD
And it has currently Windows 7 installed

Thanks for reading this bug report, and hopefully this can be fixed?

EDIT: little detail though: when it hangs, I can reboot by pressing ctrl - alt - printScr - B

description: updated
Ruben Verhack (ruben-verhack) wrote :

Additional information, I found how to remove the "quiet splash" option and I can see now that hangs on this:

When I use the Live CD:
atkb.c: Spurious ACK on isa0060/serio0. Some program might be using the hardware directly.

And after a while and a sort of a stacktrace, I get all sorts of udevd error with workers that failed.

After some research, and thanks to this thread: http://ubuntuforums.org/showthread.php?p=9195971#post9195971 . I found that setting nomodeset, it works like a charme

Ruben Verhack (ruben-verhack) wrote :

No sorry, I hit Enter to fast, It still doesn't work, but it gets much much further, as far as I could follow the lines, it now said creating live session user and such, so that's at the end of the boot, not at the beginning anymore.

Now it halts with the cursor visible but not blinking, screen dimmed.

Hope this helps

Ruben Verhack (ruben-verhack) wrote :

Several threads on UF adressing this bug, or variants of this bug:

http://ubuntuforums.org/showthread.php?t=1463294
http://ubuntuforums.org/showthread.php?t=1467929
http://ubuntuforums.org/showthread.php?t=1466735
http://ubuntuforums.org/showthread.php?t=1465883

Workarounds being:
settings i915.modeset=0 of setting it to 1, setting xforcemesa ...

Affecting apparently mostly Dell's

(Still no workaround that 100% fixes my problem though, mine isn't a Dell, but from much smaller Belgian company Qforce)

As of what I understand, this is a regression between Beta 2 en the Release Candidate.

Walton (waltonp) wrote :

Same issue. I did an upgrade from 9.10 rather than an install. I get a badly configured splash screen, a pop up message about pulseaudio, then a black screen with cursor.

supersaber (ksaber66) wrote :

Same issue as Walton, I also upgraded from 9.10, via the internet.

Dell D400 with the Intel 855GM vid card.

Lampasona (lampasona-vito) wrote :

I have the same issue on a notebook with an i915 intel graphic card.
I tried to make a fresh install of ubuntu 10.04 from the liveCD but after booting it shows the purple splash with the "keyboard equals human"-icon and then hangs.
Previously the ubuntu 9.10 install from the liveCD went smoothly.

PostScript (postscript) wrote :

Same here. I'm on an old Compaq Presario 2200 running with an Intel 855GM chip. LiveCD install screen stays on the "keyboard equals human"-icon and then hangs on black. I removed the "quiet splash" option and it hung after attempting to install the wireless cards, but I think that has nothing to do with the problem.

I was able to boot from the LiveCD by following these instructions: http://ubuntuforums.org/showthread.php?p=9219366#4

You also might want to try this, just in case it works for you: http://ubuntuforums.org/showthread.php?t=1463294&page=2#14

PostScript (postscript) on 2010-05-03
Changed in ubiquity:
status: New → Confirmed
Changed in ubuntu:
status: New → Confirmed
PostScript (postscript) wrote :

I figured the bug is confirmed by the standards on https://wiki.ubuntu.com/Bugs/Status. If I'm wrong, please bear with me since this is the first time I'm doing this.

I was prusing around the bug lists when I found this:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/371774

The workaround I used (and the other workarounds suggested on http://ubuntuforums.org/showthread.php?p=9219366#4) all involved disabling or modifying xorg.conf. In fact, one workaround (that I haven't tried yet) is to replace xorg.conf with one that worked previously. Hence the link to the bug above - it sounds like this is a (relatively) simple configuration issue in xorg.conf.

Hope that helped.

Zhao Zheng (zhaozhengcn) wrote :

Just to confirm that adding i915.modeset=1 also helped me. I am using Dell Inspiron 500m with integrated graphics: Intel(R) 82852/82855 GM/GME Graphics Controller. My splash screen looks normal. I also have no problem with my wireless connection. I booted from a live USB (32-bt version).

Without the i915 setting, if I turn off the splash screen (Esc during splash), I could see that the system freezes after printing *Starting Common Unix Printing System: cupsd". However, I did not find any useful help after searching for the related issue. In the end, I get the ubuntu 10.04 running only by adding the i915 setting.

Noel (b-launchpad-lolith-net) wrote :

Adding i915.modeset=1 helped me get a Dell Inspiron 510m to load the installer.

Without manually adding that the install just dies with a black screen and the machine locks-up.

Adrian (ade-newton) wrote :

Same problem for me on a Toshiba Satellite A50.

Using the solution from the forum then nuked grub for me as the system dual booted with XP.

I have had to completly knock lucid on the head because of this on this laptop nd go back to 9.10 until an ISO is released with this bug fixed as I do not have the time to keep messing around. Disappointed.

Gary Scott (garygsscott) wrote :

Same problem with ATI Radeon 9250.

Jeremy Foshee (jeremyfoshee) wrote :

Walton and others,
    Please file new bugs for your issues, you are muddling the original reporters problems.

Thanks!

~JFo

Jeremy Foshee (jeremyfoshee) wrote :

rackstar,
     When you say 'each of the options fail in the same way' do you mean that the system freezes or that you see the same error? If you are seeing the same error, I need the exact text you see. Are you able to switch terminals and get to the dmesg?

Thanks!

~JFo

bastubis (pmg-gmx) wrote :

Dell Inspiron 500m - adding i915.modeset=1 made it bootable and it sort of works, but it boots painfully slowly then keeps locking and freezing during use. Skype crashes, media players crash. It's not really useable. i915.modeset=0 seems to be indistinguishable - just as messed up.

I tried this workaround: http://ubuntuforums.org/showthread.php?p=9219366#4 - with 2.6.34 rc6 upgrade it boots with a completely blank screen even with xforcevesa and I can't drop back to a commandline. I give up - looks like it's back to Karmic.

K7AAY (john-bartley) wrote :

2.6.32.16 did not have the problem on my Dell Latitude X300 w/ Intel integration graphics & I/O, but after I permitted Update Manager to bring me up to 2.6.32.22, it fails. Nomodeset did not solve the problem.

Peter (piw1) wrote :

I have the same problems on two of the 3 desktops in our household. Both the affected machines are i686, Core 2 Duo E8400 , 4GB RAM and GeForce 9600GT GPU, which run Karmic OK.
I have tried the recommended workarounds without success. I also downloaded 10.04-855gm with an earlier Kernel, but still got the black screen on boot.
Comments on some forums suggest that the problem appears to have been fixed in the Beta of Meerkat, so in the absence of a fix in Lucid it looks as if I will have less hassles if I soldier-on with Karmic until Meerkat is more mature.
Given that we enjoy Ubuntu through the altruism of so many good folk world-wide, I think that it is a tad churlish to be critical of unexpected bugs like this.
My main concern is that the eventual upgrade of Karmic to Meerkat will not require installing Lucid; which would be a classic catch 22.

David Sauvage (pariakanet) wrote :

I have been able to migrate from Ubuntu 9.10 to Ubuntu 10.04 (i386) on Dell inspiron 510m after installing [1] before the final reboot.

[1] 855GM glasen ppa to be able to load ubuntu on this dell
https://launchpad.net/~glasen/+archive/855gm-fix

The experimental package (855gm-fix-exp) works well for me

Their are some 10.04 LiveCD that have been built with this PPA kernel modules fix that solve this problem.

Will you please provide a link (or how to search) to find the 10.04 LiveCDs with this fix? I am having a similar problem, but not sure if it's identical I'd like to try this fix.
Thanks.

affects: ubuntu → ubiquity (Ubuntu)
Colin Watson (cjwatson) on 2012-10-16
no longer affects: ubiquity
affects: ubiquity (Ubuntu) → linux (Ubuntu)

Ruben Verhack, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc3

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments