CONFIG_DMAR is not set

Bug #552311 reported by sles on 2010-03-31
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Andy Whitcroft

Bug Description

10.04 has Bus options (PCI etc.)" -> "Support for DMA Remapping Devices" not set for generic and server images.
but it is necessary for KVM pci passthrough http://www.linux-kvm.org/page/How_to_assign_devices_with_VT-d_in_KVM
which is declared as supported since Ubuntu 9.04
http://www.ubuntu.com/servervirtualization

Roland Dreier (roland.dreier) wrote :

Just noticed this too. Maybe it's too late for 10.04 (which would be rather ugly) but I think CONFIG_DMAR is pretty safe as long as CONFIG_DMAR_DEFAULT_ON is not enabled.

sles (slesru) wrote :

IMHO, this should be not too late, if it is not possible to add this to generic, it is a must to create another image....

affects: ubuntu → kvm (Ubuntu)
Chuck Short (zulcss) on 2010-04-05
affects: kvm (Ubuntu) → linux (Ubuntu)
Jeremy Foshee (jeremyfoshee) wrote :

Hi sles,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 552311

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Roland Dreier (roland.dreier) wrote :

Yes, I just checked that CONFIG_DMAR is still turned off in the config used for 2.6.32-21. Testing the upstream build is kind of meaningless -- this is not really a kernel bug per se, but rather a problem with the configuration chosen as part of the Ubuntu packaging.

I understand that the message is automated but it would take about half a second to see that it is not appropriate for this bug.

tags: removed: needs-kernel-logs needs-upstream-testing
Roland Dreier (roland.dreier) wrote :

trivial to confirm; on an up-to-date system:

$ grep CONFIG_DMAR /boot/config-2.6.32-21-generic
# CONFIG_DMAR is not set

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
description: updated

Beyond DMAR there are other changes that I found were required to make Vt-d virtualisation work. I have reported these in Bug #639712

Scott Moser (smoser) on 2010-09-16
Changed in linux (Ubuntu):
importance: Undecided → Medium
Jamie Kirkpatrick (jamiekp) wrote :

This should get fixed as it does somewhat limit the utility of Ubuntu as a KVM host....I've had to compile a customized kernel to get PCI passthrough working.

Andy Whitcroft (apw) on 2011-01-07
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) wrote :

Ok this option is experimental, but it does sound key to kvm host mode. I have tried to enable it but with the option to disable it by default also enabled to reduce the regression risk, so to actually get this functionality you need to supply a kernel parameter. I have built some test kernels with these configuration options and posted them at the URL below. If those who can could test these kernels and confirm they do indeed enable the require functionality, please report any testing back here:

    http://people.canonical.com/~apw/lp552311-natty/

Andy Whitcroft (apw) wrote :

Can someone who has a working setup confirm that the test kernels as posted in comment #8 and report if they work?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Andy Whitcroft (apw) wrote :

Anyone able to test these kernels?

Stefan Lesicnik (stefanlsd) wrote :

Hi Andy,

I tried your kernel - system boots fine and seems to work. Unfortunately it looks like my board doesn't support the pass-through, so I am unable to test if it actually works.

From what I've seen from upstream / fedora - it looks like with kvm its fairly important and I would really like to see this change kept for newer kernels.

If i can help in any other way, let me know.

Andy Whitcroft (apw) on 2011-02-21
Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.38-5.32

---------------
linux (2.6.38-5.32) natty; urgency=low

  [ Andy Whitcroft ]

  * rebase to mainline 6f576d57f1fa0d6026b495d8746d56d949989161
  * [Config] updateconfigs following rebase to v2.6.38-rc6
  * [Config] enable CONFIG_DMAR
    - LP: #552311

  [ Upstream Kernel Changes ]

  * drm/i915: skip FDI & PCH enabling for DP_A
    - LP: #561802, #600453, #681877

  [ Major Kernel Changes ]

  * rebase from v2.6.38-rc5 to v2.6.38-rc6
    - LP: #718402
    - LP: #719524
    - LP: #721126
    - LP: #719691
    - LP: #722689
    - LP: #722310
 -- Andy Whitcroft <email address hidden> Tue, 22 Feb 2011 13:28:39 +0000

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers