WUSB54G not working out of the box

Bug #549383 reported by Jeff Joker on 2010-03-27
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Erik Wahlstrom

Bug Description

Hello,

I just upgraded fro, 9.10 to 10.04 beta (amd 64) and my usb wifi dongle was not working anymore, below is my dmesg

usb 1-4: reset high speed USB device using ehci_hcd and address 4
usb 1-4: firmware: requesting isl3887usb
usb 1-4: (p54usb) cannot load firmware isl3887usb (-2)!
usb 1-4: firmware: requesting isl3887usb_bare
p54usb: probe of 1-4:1.0 failed with error -2
usbcore: registered new interface driver p54usb

I found the answer here : http://wiki.debian.org/prism54#p54usb
=> the firmware is not installed automatically

affects: ubuntu → linux (Ubuntu)
tags: added: kernel-series-unknown
Jeff Joker (jeffjoker) wrote :

happens with 2.6.31 (normal (from the beta1 iso install via usb) and rt) and with 2.6.32 (upgraded after install)

Erik Wahlstrom (edub) wrote :

Confirmed on fresh daily build of Lucid (03/28/2010)

Followed instructions provided by the OP link and my prism54 usb device is now operational.

`uname -a`:
Linux tpad 2.6.32-17-generic #26-Ubuntu SMP Fri Mar 19 23:58:53 UTC 2010 i686 GNU/Linux

`lsusb`:
Bus 001 Device 008: ID 0846:4240 NetGear, Inc. WG111(v1) rev 2 54 Mbps Wireless [Intersil Prism54 Intersil 3886]

Relevant dmesg:
[ 10.488324] usb 1-1.1: reset high speed USB device using ehci_hcd and address 3
[ 10.592612] usb 1-1.1: firmware: requesting isl3887usb
[ 10.647431] usb 1-1.1: (p54usb) cannot load firmware isl3887usb (-2)!
[ 10.647435] usb 1-1.1: firmware: requesting isl3887usb_bare
[ 10.648479] p54usb: probe of 1-1.1:1.0 failed with error -2
[ 10.648505] usbcore: registered new interface driver p54usb

Jeff Joker (jeffjoker) wrote :

Still alive after fresh install of Beta 2

Jan Hoffmann (jan-hoffmann) wrote :

The package prism2-usb-firmware-installer seems to install a wrong version of the firmware and uses the wrong name. When renaming the file /lib/firmware/ru010803.fw to isl3887_usb dmesg gives the following error:

you are using an obsolete firmware. visit http://wireless.kernel.org/en/users/Drivers/p54 and grab one for "kernel >= 2.6.28"!
[ 1937.148003] phy4: cryptographic accelerator WEP:no, TKIP:no, CCMP:no

If downloading the firmwares from daemonizer.de through prism2-usb-firmware-installer would be ok (downloading from an git repository really isn't very different), I would suggest that the package downloads the listed on http://wireless.kernel.org/en/users/Drivers/p54#firmware

By the way, when plugging in the dongle first, the hardware drivers icon appeared in the notification area, but when opening the hardware drivers application it didn't find any drivers for it. Maybe there's an bug too, and the package prism2-usb-firmware-installer should be listed as driver there?

Robert Moerland (veel-mail) wrote :

For me, the solution was to install the linux-firmware-nonfree package. After that, the hardware was found and activated.

Jeremy Foshee (jeremyfoshee) wrote :

Hi Jeff,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 549383

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Jeff Joker (jeffjoker) wrote :

Hi,

I tried with a fresh install of the RC and problem is still there...

I'll be back with more details

Jeff Joker (jeffjoker) wrote :

I tried with kernel 34rc5 (latest in the mainline builds) with my actual install (the firmware had laready been copied manually in /usr/lib...) and I get a shorter list of available WiFi networks (in which mine is not present !!)
Here is the dmesg :

Changed in linux (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
Jeff Joker (jeffjoker) wrote :

Hello,

Tried again with release, problem still there:
- out of install : same error
- manual install of kernel 34rc5: not better
- manual adding of firmware: with generic kernel = ok but slow (see my other bug), with 34rc5 same error as above (not all WiFi available)

Thank you, Jeff, worked for me.

I downloaded the firmware firmware from the url http://daemonizer.de/prism54/prism54-fw/fw-usb/2.13.24.0.lm87.arm
I renamed the file 2.13.24.0.lm87.arm to isl3887usb
Then copied to the file isl3887usb to the pc into the folder /lib/firmware/
I replugged the usb dongle and working fine.

Alejandro Cuervo (a-cuervo) wrote :

Robert Moerland (#5) posted a solution that should work for many of you.

sudo apt-get install linux-firmware-nonfree

reboot. (or unplug and plug the usb wireless adapter)

Done

Erik Wahlstrom (edub) wrote :

Confirming that installing linux-firmware-nonfree solves the problem on a fresh install of Lucid.

Jeremy Foshee (jeremyfoshee) wrote :

after an additional review, this is expected behavior. the nonfree package should contain those drivers that are not covered by the license.

I'm closing this bug as Invalid.

~JFo

Changed in linux (Ubuntu):
status: Triaged → Invalid
Martinichka (m-lootsma) wrote :

I had linux-firmware-nonfree installed, but after an upgrade from 9.10 to 10.4 the device stopped to work.

First I tried #10, that worked for me. Because of the message #13 I checked my linux-firmware-nonfree, and it didn't seem to be updated. After updating linux-firmware-nonfree (and undo #10) the dongle also worked.

Why linux-firmware-nonfree was not updated by the dist-upgrade?

To post a comment you must log in.