Ubuntu

Screen backlight doesn't come on again after opening the lid

Reported by Kai Jauch on 2010-03-17
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Low
Unassigned

Bug Description

The backlight of the laptop display doesn't come back on after closing and opening the lid on a Dell Latitude E6400.

This was originally reported as bug #488328 and fixed in kernel 2.6.32-15 (using http://lists.freedesktop.org/archives/intel-gfx/2010-February/005902.html), but reappeared in 2.6.32-16 (which has the 2.6.33 drm stack in it).

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: kai 1584 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6adc000 irq 21'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:111d76b2,10280233,00100302 HDA:80862802,80860101,00100000'
   Controls : 25
   Simple ctrls : 16
Date: Wed Mar 17 10:51:49 2010
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=84850757-fc9c-4161-b84e-bbd91d0ae069
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20091209)
MachineType: Dell Inc. Latitude E6400
Package: linux-image-2.6.32-16-generic 2.6.32-16.25
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=68c17dde-1bec-405b-9c58-e3a2e72a7d4d ro crashkernel=384M-2G:64M,2G-:128M quiet splash
ProcEnviron:
 LANGUAGE=de_DE:de:en_GB:en
 PATH=(custom, user)
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.32
Reproducible: Yes
SourcePackage: linux
TestedUpstream: No
Uname: Linux 2.6.32-16-generic x86_64
dmi.bios.date: 05/11/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A14
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA14:bd05/11/2009:svnDellInc.:pnLatitudeE6400:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E6400
dmi.sys.vendor: Dell Inc.

Kai Jauch (kaijauch) wrote :
Chase Douglas (chasedouglas) wrote :

Just to be clear, the 2.6.32-16 kernel does contain the patch that fixed the 2.6.32-15 kernel, but it does not appear to be the complete fix anymore.

description: updated
Changed in linux (Ubuntu):
importance: Undecided → Low
Chase Douglas (chasedouglas) wrote :

@Kai:

Please test the latest 2.6.34 mainline kernel at http://kernel.ubuntu.com/~kernel-ppa/mainline/ to see if there's better behavior there. If not, I suggest opening a bug at bugzilla.kernel.org so upstream is aware of the issue. Please note the bug here if you do open one.

Thanks

Nicolò Chieffo (yelo3) wrote :

Maybe also using the latest intel drivers could help?

Nicolò Chieffo (yelo3) wrote :

Also note that this bug might be solved when solving this: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/535640

Nicolò Chieffo (yelo3) wrote :

Using mainline 2.6.34rc1 still has the same problem

Chase Douglas (chasedouglas) wrote :

@Nicolò Chieffo:

Your comment about the latest intel drivers jogged my memory. There's also the drm-intel-next kernels at the mainline ppa page that would be useful to try it. It contains changes that haven't hit Linus' tree yet.

Well, I didn't want to say drm drivers, but xorg drivers.
I've already tested the drm-next packages without success.
But, we really need to fix bug #535640 before doing additional testing here.

Changed in linux:
status: Unknown → Confirmed
yakuizhao (yakui-zhao) wrote :

Can you add the boot option of "drm.debug=0x04" and do the following test?
     1. get the output of "cat /proc/acpi/button/LID/*/state", dmesg, intel_reg_dumper before close the LID
     2. close the LID
     3. Open the LID
     4. Please login the system by using ssh and get the output of " cat /proc/acpi/button/LID/*/state", dmesg, intel_reg_dumper again.

Thanks.

This affects HP 2510p as well. Switching to another VT restores the display, so switching to VT1 and then back to Xorg is a usable workaround.

Jeremy Foshee (jeremyfoshee) wrote :

Hi Kai,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Kai Jauch (kaijauch) wrote :

I just tested version 2.6.34-999.201004021325 from the mainline builds, the problem is fixed there. The backlight goes off when I close the lid and comes back on when I open it.

tags: removed: needs-upstream-testing
Kai Jauch (kaijauch) wrote :

I also couldn't reproduce the problem in 2.6.32-19 from Lucid, it is fixed there.

Stuart Bishop (stub) on 2010-04-19
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux:
status: Confirmed → Fix Released
Changed in linux:
importance: Unknown → Medium

Kai Jauch, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/540134/comments/15 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

tags: added: bios-outdated-a34 needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.