[0x102801f6]: Totem movie player crashes when adjusting volume

Bug #530346 reported by Tom Louwrier on 2010-03-01
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Daniel T Chen
Lucid
Undecided
Unassigned

Bug Description

This happens quite often. I double-click an mp3 and when the player comes on, I adjust the volume. This hangs the player: sound and display freeze and controls don't react. After a few seconds the application closes altogether and I can restart it in the same way. Usally it works then.
I have the feeling it is related to adjusting the volume down, but I'm not quite sure.

Running Lucid amd64, updates twice a day, on a Dell Latitude 131L.

cheers
Tom

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: thomas 1605 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xc0000000 irq 16'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:14f12bfa,14f100c3,00090000 HDA:83847690,102801f6,00102201'
   Controls : 6
   Simple ctrls : 4
CheckboxSubmission: 41a9dc4bbc2c91d7f7445d204c57c74b
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Mon Mar 1 23:01:47 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB.utf8
 LANG=en_GB.utf8
 LC_MESSAGES=C
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SelectedCard: 0 SB HDA-Intel - HDA ATI SB
SourcePackage: alsa-driver
Symptom: audio
Title: [Conexant ID 2bfa] Playback problem
Uname: Linux 2.6.32-14-generic x86_64

Revision history for this message
Tom Louwrier (tom-louwrier) wrote :
Revision history for this message
Daniel T Chen (crimsun) wrote :

This is almost certainly a hardware/firmware bug. Please try the following workaround (of appending the text to the options snd-hda-intel line in /etc/modprobe.d/alsa-base.conf):

enable_msi=0

If that is insufficient, please use:

enable_msi=0 position_fix=1

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
summary: - [Conexant ID 2bfa]: Totem movie player crashes when adjusting volume
+ [0x102801f6]: Totem movie player crashes when adjusting volume
Revision history for this message
Tom Louwrier (tom-louwrier) wrote : Re: [Bug 530346] Re: [Conexant ID 2bfa]: Totem movie player crashes when adjusting volume

hi Daniel,

I tried both suggestions.
There was no line 'options snd-hda-intel' in
/etc/modprobe.d/alsa-base.conf at all, so I added it at the end.

'enable_msi=0' gave me an instant crash as described, no fun there.

Replaced it with 'enable_msi=0 position_fix=1' and rebooted (testing
some other things as well and want to be sure anyway)
So far I can drag the volume slider around and nothing crashes. Looking
good.

Attaching my modified /etc/modprobe.d/alsa-base.conf
I will report back in a couple of days to confirm either way; good or bad.

thanx
Tom

Revision history for this message
Daniel T Chen (crimsun) wrote :

Tom, thanks for testing. Will you please try one final permutation, which is to use only "position_fix=1" ?

Revision history for this message
Tom Louwrier (tom-louwrier) wrote : Re: [Bug 530346] Re: [0x102801f6]: Totem movie player crashes when adjusting volume

hi again Daniel

Tried that too, and dragging the volume slider still works fine without
hanging the player.
Seems fixed to me. Thanx.
Anything else I should try out?

Attaching my current version of /etc/modprobe.d/alsa-base.conf

cheers
Tom

Revision history for this message
Daniel T Chen (crimsun) wrote :
Changed in alsa-driver (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
status: Incomplete → Fix Committed
Revision history for this message
Tom Louwrier (tom-louwrier) wrote :

Very nice to see the actual workings of bug reporting, testing and
commitment of a fix.
Thank you!

cheers
Tom

On 04/03/10 15:51, Daniel T Chen wrote:
> http://mailman.alsa-project.org/pipermail/alsa-
> devel/2010-March/025859.html
>
> ** Changed in: alsa-driver (Ubuntu)
> Status: Incomplete => Fix Committed
>
> ** Changed in: alsa-driver (Ubuntu)
> Assignee: (unassigned) => Daniel T Chen (crimsun)
>
>

Martin Pitt (pitti) on 2011-02-04
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu Lucid):
status: New → Fix Committed
Steve Conklin (sconklin) on 2011-02-04
tags: added: verification-needed-lucid
Revision history for this message
Brad Figg (brad-figg) wrote :

This patch was applied as part of a stable, upstream release. Therefor it does not require verification.

tags: added: verification-done-lucid
removed: verification-needed-lucid
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package linux - 2.6.32-29.58

---------------
linux (2.6.32-29.58) lucid-proposed; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #716551

  [ Upstream Kernel Changes ]

  * net: fix rds_iovec page count overflow, CVE-2010-3865
    - LP: #709153
    - CVE-2010-3865
  * net: ax25: fix information leak to userland, CVE-2010-3875
    - LP: #710714
    - CVE-2010-3875
  * net: ax25: fix information leak to userland harder, CVE-2010-3875
    - LP: #710714
    - CVE-2010-3875
  * net: packet: fix information leak to userland, CVE-2010-3876
    - LP: #710714
    - CVE-2010-3876
  * net: tipc: fix information leak to userland, CVE-2010-3877
    - LP: #711291
    - CVE-2010-3877
  * inet_diag: Make sure we actually run the same bytecode we audited,
    CVE-2010-3880
    - LP: #711865
    - CVE-2010-3880

linux (2.6.32-29.57) lucid-proposed; urgency=low

  [ Steve Conklin ]

  * Tracking Bug
    - LP: #708864

  [ Tim Gardner ]

  * [Config] Set CONFIG_NR_CPUS=256 for amd64 server
    - LP: #706058

  [ Upstream Kernel Changes ]

  * Input: i8042 - introduce 'notimeout' blacklist for Dell Vostro V13
    - LP: #380126
  * tun: avoid BUG, dump packet on GSO errors
    - LP: #698883
  * TTY: Fix error return from tty_ldisc_open()
    - LP: #705045
  * x86, hotplug: Use mwait to offline a processor, fix the legacy case
    - LP: #705045
  * fuse: verify ioctl retries
    - LP: #705045
  * fuse: fix ioctl when server is 32bit
    - LP: #705045
  * ALSA: hda: Use model=lg quirk for LG P1 Express to enable playback and
    capture
    - LP: #595482, #705045
  * nohz: Fix printk_needs_cpu() return value on offline cpus
    - LP: #705045
  * nohz: Fix get_next_timer_interrupt() vs cpu hotplug
    - LP: #705045
  * nfsd: Fix possible BUG_ON firing in set_change_info
    - LP: #705045
  * NFS: Fix fcntl F_GETLK not reporting some conflicts
    - LP: #705045
  * sunrpc: prevent use-after-free on clearing XPT_BUSY
    - LP: #705045
  * hwmon: (adm1026) Allow 1 as a valid divider value
    - LP: #705045
  * hwmon: (adm1026) Fix setting fan_div
    - LP: #705045
  * amd64_edac: Fix interleaving check
    - LP: #705045
  * IB/uverbs: Handle large number of entries in poll CQ
    - LP: #705045
  * PM / Hibernate: Fix PM_POST_* notification with user-space suspend
    - LP: #705045
  * ACPICA: Fix Scope() op in module level code
    - LP: #705045
  * ACPI: EC: Add another dmi match entry for MSI hardware
    - LP: #705045
  * orinoco: fix TKIP countermeasure behaviour
    - LP: #705045
  * orinoco: clear countermeasure setting on commit
    - LP: #705045
  * x86, amd: Fix panic on AMD CPU family 0x15
    - LP: #705045
  * md: fix bug with re-adding of partially recovered device.
    - LP: #705045
  * tracing: Fix panic when lseek() called on "trace" opened for writing
    - LP: #705045
  * x86, gcc-4.6: Use gcc -m options when building vdso
    - LP: #705045
  * x86: Enable the intr-remap fault handling after local APIC setup
    - LP: #705045
  * x86, vt-d: Handle previous faults after enabling fault handling
    - LP: #705045
  * x86, vt-d: Fix the vt-d fault handling irq migration in the x2apic mode
    - LP: #705045
  * x8...

Read more...

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Julian Wiedmann (jwiedmann) wrote :

This quirk landed in mainline with 2.6.34

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers