1002:9552 [HP ProBook 4710s] With ATI restricted driver deactivated, GPU is overheating

Bug #488152 reported by Robert Roth on 2009-11-25
78
This bug affects 12 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Invalid
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-radeon

If I deactivate the ATI restricted driver, and then restart my computer, GPU temp is between 70-80 degrees celsius instead of the usual 40-50, withot doing anything, no application running, no effects.

lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M92 LP [Mobility Radeon HD 4300 Series] [1002:9552]
Running Ubuntu Karmic Koala

ProblemType: Bug
Architecture: i386
Date: Wed Nov 25 12:29:56 2009
DistroRelease: Ubuntu 9.10
MachineType: Hewlett-Packard HP ProBook 4710s
NonfreeKernelModules: wl fglrx
Package: xserver-xorg-video-radeon 1:6.12.99+git20090929.7968e1fb-0ubuntu1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-15-generic root=UUID=46d71c1a-9e58-4fa5-ab38-6043122bf91d ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: xserver-xorg-video-ati
Uname: Linux 2.6.31-15-generic i686
dmi.bios.date: 09/10/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68PZI Ver. F.0D
dmi.board.name: 3074
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 24.0D
dmi.chassis.asset.tag: CNU9410C2M
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68PZIVer.F.0D:bd09/10/2009:svnHewlett-Packard:pnHPProBook4710s:pvrF.0D:rvnHewlett-Packard:rn3074:rvrKBCVersion24.0D:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP ProBook 4710s
dmi.product.version: F.0D
dmi.sys.vendor: Hewlett-Packard
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-15-generic

Robert Roth (evfool) wrote :
Bryce Harrington (bryce) on 2009-12-05
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Toby Smithe (tsmithe) wrote :

Also the case on lucid, with RV620:

$ acpi -t
Thermal 0: ok, 90.0 degrees C

Bryce Harrington (bryce) on 2010-03-18
tags: added: karmic
Robert Hooker (sarvatt) on 2010-03-22
summary: - With ATI restricted driver deactivated, GPU is overheating
+ [RV710] With ATI restricted driver deactivated, GPU is overheating

Still happens on lucid, but now it is more critical, because Lucid does not support the binary fglrx driver, and with the radeon driver it is overheating.

Hm, 'acpi -t' does not display anything on my machine; however, by 'manual examination' (i.e. carefully touching the fanless cooler on the GPU) the temperature actually seems 'too hot' (in fact, it is hotter than with the proprietary fglrx driver). Are there other ways to get the actual temperature?

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Roth,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 488152

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 488152 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/488152

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
Richard Theil (richard-theil) wrote :

I can confirm the issue on Lucid. Brand new Sapphire Radeon HD4350, fresh Lucid install with current updates on a Core 2 Quad board. Heat measurements have been taken in three locations: 1.) Digital pyrometer aimed at passive heatsink over chip, 2.) Film sensor under heatsink next to chip, 3.) Discrete Sensor under heatsink on other side of circuit board. Pyrometer used is a Trotec TP4, Sensor controller is a no-name 8-channel thermometer for 5.25" drive slots. Readouts after settling (idle desktop display, very slight activity, no 3D):

Stock (open source) driver: 1.) 80 deg C, 2.) 68 deg C, 3.) 63 deg C
fglrx (enabled from settings): 1.) 62 deg C, 2.) 54 deg C, 3.) 50 deg C

So it looks like the die does run about 20 degrees hotter with the open drivers.

As an interesting sidenote, the Radeon replaces a Geforce 8400GS that became unreliable and then finally died yesterday. When I diagnosed the problem, the passive heatsink of the Geforce was too hot to touch even after the computer was powered down for a short while, which would hint at a similar problem.

Robert Roth (evfool) wrote :

I reconfirm it, without fglrx, on lucid with all updates, the GPU is still at 78 deg C when idling.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
Richard Theil (richard-theil) wrote :

Launchpad bug 570589 is somewhat of a more general duplicate of this, as it describes the problem with all ATI cards using KMS, not just the RV710 we discuss here. Mentioned there, and as an addendum to my post with the measurements, the dead Nvidia card was running the closed Nvidia driver under karmic, so the whole complex might reach even further.

madbiologist (me-again) wrote :

In addition to the Radeon power management patches included upstream in kernels 2.6.34 and 2.6.35, users with desktop systems may be interested in some new thermal monitoring work which has just landed upstream. This work makes it possible to monitor the internal GPU temperature on newer Radeon cards. See http://www.phoronix.com/scan.php?page=news_item&px=ODMxMQ for more information.

Nishant (nishant-singh28) wrote :

Same here on Dell Studio 1555 notebook running Ubuntu Maverick x64 with kernel 2.6.35-22 generic. ATI Mobility Radeon HD 4570. GPU temperature is around 50 with proprietary drivers and 70 with open source drivers. My battery life is also taking a massive hit, with the usual 6 hours down to ~3.5 hours. Don't want to give up the open source driver as the overall performance is better except for this issue.

Robert Roth (evfool) wrote :

This is getting ever worse, as Unity does not run with fglrx now (see bug #747802), so the only option to run Unity is with the open-source driver, with the laptop overheating.

madbiologist (me-again) wrote :

The thermal monitoring improvements mentioned in comment #9 were included upstream in kernel 2.6.36. Ubuntu 11.04 "Natty Narwhal" is using the 2.6.38 kernel.

Robert Roth (evfool) wrote :

My laptop is still running at above 70 degrees celsius in Natty with the opensource driver when started up, so most probably including the thermal monitoring improvements didn't fix it, and while using fglrx (only in classic mode, as Unity does have other fglrx issues) the temperature usually doesn't go above 50 degrees celsius. So something is still wrong, and this still seems to me a serious issue.

madbiologist (me-again) wrote :

Have you tried using the "dynpm" (dynamic) power managment setting? What about the "auto" power management profile? See comment #2 in bug #570589 and comment #19 in bug #557829. See http://www.phoronix.com/scan.php?page=news_item&px=ODIyOA for more information.

Robert Roth (evfool) wrote :

I've tried setting the power profile settings and dynpm, but nothing has changed, still running above 70 degrees celsius.

A launchpad user reports "If I deactivate the ATI restricted driver, and then restart my computer, GPU temp is between 70-80 degrees Celsius instead of the usual 40-50, without doing anything, no application running, no effects."

lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M92 LP [Mobility Radeon HD 4300 Series] [1002:9552]

MachineType: Hewlett-Packard HP ProBook 4710s

This was originally reported on Ubuntu 9.10 "Karmic Koala" with a 2.6.31-based kernel (which of course does not have power management support), but persists on an Ubuntu 11.04 "Natty Narwhal" pre-release with a 2.6.38-based kernel.

The problem is that this user reports "I've tried setting the power (management) profile settings and dynpm, but nothing has changed, still running above 70 degrees Celsius."

Sorry, I forgot to mention that the original launchpad bug is at https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/488152

FWIW, I'm using this card:
01:00.0 VGA compatible controller: ATI Technologies Inc RV630 [Radeon HD 2600 Series]
Under Debian's 2.6.38-2-amd64, and the temperature is currently 74°C according to the "sensors" command, and the card is nearly too hot to touch. I've never tried the proprietary driver.

Xavier - do the dynamic or profile-based power management settings work for you? This bug is about those settings not working.

If I understand things correctly, a hot GPU is to be expected when using the open-source driver without these settings.

Please see the power management section on this page to configure a lower power state:
http://wiki.x.org/wiki/RadeonFeature

Alex,

I read that page (didn't know it had something more useful than the progress table, thanks), and did a subsequent:
echo low >/sys/class/drm/card0/device/power_profile

Now it looks like my pc has deadlocked. I didn't get a prompt after that command, and all network connexions are stuck. I'll reboot it when I'm back home (the pc is at home, I'm at work), but in the meantime it means no more mails for me (it's also my mail server). I'll try to follow the bugzilla in the remaining time.

madbiologist (me-again) wrote :

Robert - Just to confirm what you said in comment #15 - you've tried these settings on Natty?

I have reported your bug upstream at https://bugs.freedesktop.org/show_bug.cgi?id=35988
Please subscribe yourself to this bug in case the developers have any further questions for you or in case they need a copy of your vbios.

Rafał Miłecki (zajec5) wrote :

What about
echo "low" > /sys/class/drm/card0/device/power_profile
?

Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
status: Unknown → Confirmed
Robert Roth (evfool) wrote :

@madbiologist: Yes, I have tried it on Natty, thanks for reporting it upstream, I have subscribed myself to that bug in case they need anything from me.
@Rafał Miłecki: with the low setting the temperature gets down to 66 degrees, but that's still way above the normal temperature with the proprietary driver.

Nishant (nishant-singh28) wrote :

I have tried switching to low power mode in the open source driver, but that affects desktop effects as well as movie performance. Both of them start framing under load. It also runs a lot hotter than the usual at around 64-65 while my idle is at around 55 in current weather.

Nishant (nishant-singh28) wrote :

And yes, I'll specify I'm running maverick 64 bit on a Mobility Radeon HD4570

(In reply to comment #3)
> Xavier - do the dynamic or profile-based power management settings work for
> you? This bug is about those settings not working.
>
> If I understand things correctly, a hot GPU is to be expected when using the
> open-source driver without these settings.

$ lspci | grep ATI
01:00.0 VGA compatible controller: ATI Technologies Inc M93 [Mobility Radeon HD 4500 Series]

This is an HP 4720s notebook. I have tried both "dynpm" and "low" settings, and while it does not lock up, it still runs hot - 60+ degrees, fan constantly on high.

Mine is a HP 4710s, with the same video card as Alexey's.

Soory, forgot to mention that I am the reporter of the launchpad bug, and I experience the computer running hot too.

madbiologist (me-again) wrote :

Nishant - it sounds like the power management is working for you, as the loss of performance is a known possible side effect, depending on how good the hardware is. Also your temperature has reduced by 5-6 degrees. How is the performance and temperature when using the medium power profile?

Nishant (nishant-singh28) wrote :

Medium was the worst. Barely any drop in temperature, and the performance drops down considerably.
Surprisingly, ATI manages to pull it off, despite being known for crappy drivers. I get good battery life as well as good graphics performance.

madbiologist (me-again) wrote :

OK, thanks for that info. Ubuntu 11.04 "Natty Narwhal" will be released in approximately 1 week. It contains some significant performance improvements for ATI cards, due to the implementation of KMS page-flipping and the switch from the classic Mesa (R600c) driver to the R600 Gallium3D (R600g) driver. See http://www.phoronix.com/scan.php?page=article&item=ubuntu_1104_radeon&num=1

Could you please test the low power profile on Natty once it is released and report back here?

Alexey Kotlyarov (koterpillar) wrote :

@madbiologist: just to confirm, the improvements are _over_ the current Natty state, or is it OK to test now?

madbiologist (me-again) wrote :

@Alexey - the performance improvements I mentioned in comment #23 are already in Natty, so you can test it now if you want. The only reason for waiting for the final release is that you may run into less other bugs.

Alexey Kotlyarov (koterpillar) wrote :

I'm already on Natty. Gave radeon another try, it runs at about 60 degrees, the fan turns on for a while, but not on maximum. This is not much different from fglrx temperature, so I'm happy.
This is hp 4720s with "ATI Technologies Inc M93 [Mobility Radeon HD 4500 Series] [1002:9555]" (per lspci).

Nishant (nishant-singh28) wrote :

@Axeley That's great news. I have an M92 HD4570, and if the temperatures are really that low, I'll be very happy to use it. I anyway get around 4 hours of movie time on my battery, it comes down to 3-3.5, but no ATI drivers, I'll be too happy. ATI drivers have been the source of all my troubles in Meerkat. Damn, why can't ATI make decent drivers just for once?

madbiologist (me-again) wrote :

That is indeed great news Alexey. Are you using the dynamic (dynpm) power management support or the profile-based power management support? I profile-based, which profile?

Now for the bad news. I have just learned that there is a serious regression in the 2.6.38 kernel used in Natty (the same kernel which contains the performance improvements I mentioned in comment #23): compared to Ubuntu 10.10, the power consumption on Ubuntu 11.04 for mobile devices is up about 10% on average but under some workloads, the power consumption is up by nearly 30%. This is unrelated to the ATI power management support or the ATI performance improvements as it occurs with Intel / ATI / NVIDIA graphics, but rather is elsewhere in the kernel and has occurred since 2.6.37. It is also still not fixed in 2.6.39-rc4. See http://www.phoronix.com/scan.php?page=article&item=linux_mobile_uffda&num=1 and http://www.phoronix.com/scan.php?page=news_item&px=OTM2NQ and http://www.phoronix.com/scan.php?page=article&item=ubuntu_natty_power&num=1 for further information.

I'm using the 'low' profile. The performance is acceptable, and 'dynpm'
flickers sometimes.

Yet another bad news is this is still hotter compared to 10.10 version
of fglrx, which didn't bring the fan on at all.

Just installed fglrx again in Natty. In 'maximum battery life' it is cooler than radeon in 'low' by ~5 degrees; on my laptop, fan doesn't even start.

Julien Olivier (julo) wrote :

I, too, suffer from this bug, running Natty, with the following video renderer: Gallium 0.4 on AMD RS880.

sushrut91 (sushrut91) wrote :

I confirm this bug. I am running Natty with Ati Mobility Radeon HD 550v. The Proprietary driver keeps the GPU cool upto 60 degrees and with the open source driver it idles at 80 degrees.

Thomas87 (knot-tomas) wrote :

I have same problem with Natty. My GPU temp is high after upgrade from Maverick. In the Maverick is everything ok. The temp was around 55 degree C in Maverick but now is around 62 degree C. Fan still works and CPU has high temp to.

My Graphic card is Ati Mobility Radeon X1400.

himynameiskevin (kevinpook) wrote :

Same problem here, it's been ongoing ever since I started using the gallium3d drivers. While the performance is better, I can't run 3D programs for very long without overheating. I tested this running Google Earth for a few minutes, and the GPU temperature reached 104C. The bottom of the laptop was also burning hot. In Win7 (blahh) I can run any 3D program (including graphic intensive games) endlessly without it coming close to overheating. Normal idle is around 76C with the gallium3d drivers, whereas it was closer to 55C previously.

The laptop is a Lenovo T60p with an ATI FireGL V5250 (Radeon x1700 as I recall). Problem occurs with Ubuntu and Arch Linux.

I have the same card on DELL Studio 15". I wouldn't say that power management does not work. I'm using "profile" method with "low" setting. After about ~20 mins of uptime this is the "sensors" output:

acpitz-virtual-0
Adapter: Virtual device
temp1: +57.0°C (crit = +100.0°C)
temp2: +58.0°C (crit = +100.0°C)
temp3: +65.0°C (crit = +100.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0: +53.0°C (high = +90.0°C, crit = +90.0°C)

coretemp-isa-0001
Adapter: ISA adapter
Core 1: +55.0°C (high = +90.0°C, crit = +90.0°C)

radeon-pci-0100
Adapter: PCI adapter
temp1: +69.0°C

# cat /sys/kernel/debug/dri/0/radeon_pm_info
default engine clock: 500000 kHz
current engine clock: 219370 kHz
default memory clock: 800000 kHz
current memory clock: 299250 kHz
voltage: 900 mV
PCIE lanes: 16

With "mid" setting temp goes beyond 70° C, and sometimes I experience GPU lockup when playing with heavy graphics (e.g. Flightgear simulator):

[ 4357.360138] radeon 0000:01:00.0: GPU lockup CP stall for more than 10000msec
[ 4357.360189] GPU lockup (waiting for 0x0007476B last fence id 0x0007476A)

Radeon pm feature are just not enough aggressive. With fglrx driver radeon-pci-0100 temp stays well below 60° C and fan doesn't run all the time.

Unfortunately Radeon driver isn't really usable for me on my laptop, but thank you for improving it. Fglrx driver isn't really an alternative for me.

(running radeon from git commit e8d0d437957b15252dfad775796a3949ed50dbcf Tue Jul 12 11:43:25 2011 -0400)

Peter Adolphs (futzilogik) wrote :

If this bug were a duplicate of bug #748080 ("ATI card fan is always on with opensource radeon driver"), then we wouldn't have a overheating problem, would we?

I have same problem with my Acer 4810TG notebook. The average temperature - is 70 degrees C. With proprietary driver - the temperature is 35-40 degrees C.

#lspci -nn| grep VGA
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M92 LP [Mobility Radeon HD 4300 Series] [1002:9552]

#uname -a
Linux 3.3.4-4.fc17.x86_64

#cat /sys/kernel/debug/dri/0/radeon_pm_info
default engine clock: 450000 kHz
current engine clock: 299530 kHz
default memory clock: 600000 kHz
current memory clock: 299250 kHz
voltage: 900 mV
PCIE lanes: 16

I'd tried to use dynpm and profile (low) options, but it doesn't help me.

I am willing to help with testing of the solution. A lot of people complain about the heat when using the open driver that causes them to use the proprietary driver.

Robert Roth, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc6

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

summary: - [RV710] With ATI restricted driver deactivated, GPU is overheating
+ 1002:9552 [HP ProBook 4710s] With ATI restricted driver deactivated, GPU
+ is overheating
affects: xserver-xorg-video-ati (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: bios-outdated-f.20 needs-upstream-testing
removed: needs-retested-on-lucid-by-june
madbiologist (me-again) wrote :

It won't help Thomas87 (knot-tomas) or himynameiskevin (kevinpook), but proper power management for AMD/ATI Radeon R600 and newer hardware is finally available in the 3.11 linux kernel. Ubuntu 13.10 "Saucy Salamander" is based on the 3.11 kernel and also includes the necessary updated radeon firmware. On Saucy, to use this power management for the AMD/ATI Radeon you will need to select it at boot by adding radeon.dpm=1 to your GRUB kernel boot options as described at https://help.ubuntu.com/community/Grub2/Troubleshooting#Editing_the_GRUB_2_Menu_During_Boot

See the blog post at http://www.botchco.com/agd5f/?p=57 for further information.

Unlike the older dynpm method, the new DPM method works with multiple monitors and there shouldn't be any flickering as the performance level changes are handled by dedicated hardware rather than the driver.

The currently under-development Ubuntu 14.04 "Trusty Tahr" is based on the 3.13 kernel which enables DPM by default (without needing the radeon.dpm=1 boot parameter I mentioned above) for Radeon HD 4000 through Radeon HD 7000 series graphics processors but with some specific ASICs being excluded. You can download a pre-release version at http://cdimage.ubuntu.com/daily-live/current/ and the final release is scheduled for April 17th, 2014 as per https://wiki.ubuntu.com/TrustyTahr/ReleaseSchedule

Changed in linux (Ubuntu):
status: Incomplete → Fix Released

Fix released downstream.

Changed in xserver-xorg-driver-ati:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.