[i945] X Freezes when compiz enabled

Bug #475429 reported by takashi torigoe on 2009-11-05
86
This bug affects 16 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Critical
linux (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Since upgrade to the 9.10 release, my screen freezes after visual effect (window move).
With visual effects disabled, there is no problem.
When freeze occurs, keyboard and mouse are unusable, but ssh login is OK.
So, I got Batchbuffer dump according to https://wiki.ubuntu.com/X/Troubleshooting/Freeze.
Dump is attached with this post.(dri_debug-20091105.tgz)

Operations
1. sudo INTEL_DEBUG=batch /etc/init.d/gdm restart
2. Set visual effects -> extra (compiz)
3. Window move by mouse operation.
4. Window swings (visual effect)
5. freeze occur
6. ssh & get Batchbuffer

ProblemType: Bug
Architecture: i386
Date: Thu Nov 5 22:44:34 2009
DistroRelease: Ubuntu 9.10
MachineType: MICRO-STAR INTERNATIONAL CO.,LTD MS-7314
Package: xserver-xorg-video-intel 2:2.9.0-1ubuntu2
ProcCmdLine: root=UUID=82b4912c-da31-4c6d-a6a8-af1f955b874a ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=ja_JP.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.31-14-generic i686
XsessionErrors:
 (gnome-settings-daemon:2653): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2653): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:2781): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:2824): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
dmi.bios.date: 07/14/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.1
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: MS-7314
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.1:bd07/14/2008:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7314:pvr1.0:rvnMICRO-STARINTERNATIONALCO.,LTD:rnMS-7314:rvr1.0:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvr1.0:
dmi.product.name: MS-7314
dmi.product.version: 1.0
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-14-generic
---
Architecture: i386
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091209)
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: MICRO-STAR INTERNATIONAL CO.,LTD MS-7314
Package: xserver-xorg-video-intel 2:2.10.0+git20100108.4902f546-0ubuntu0sarvatt
PackageArchitecture: i386
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-7-generic root=UUID=e1d041b6-3b07-4d6f-aae9-5fbce8eee93c ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=ja_JP.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-7.10-generic
RelatedPackageVersions:
 xserver-xorg 1:7.5+1ubuntu1
 libgl1-mesa-glx 7.8.0~git20100107.d699b672-0ubuntu0sarvatt
 libdrm2 2.4.17+git20091230.c5c503b5-0ubuntu0sarvatt3
 xserver-xorg-video-intel 2:2.10.0+git20100108.4902f546-0ubuntu0sarvatt
 xserver-xorg-video-ati 1:6.12.99+git20100104.48aa5064-0ubuntu0sarvatt
Tags: lucid
Uname: Linux 2.6.32-7-generic i686
UnreportableReason: これは正式な Ubuntu のパッケージではありません
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XorgConf:
 Section "Device"
  Identifier "my-945G"
  Driver "intel"
  Option "DebugFlushCaches" "1"
 EndSection
dmi.bios.date: 07/14/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.1
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: MS-7314
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.1:bd07/14/2008:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7314:pvr1.0:rvnMICRO-STARINTERNATIONALCO.,LTD:rnMS-7314:rvr1.0:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvr1.0:
dmi.product.name: MS-7314
dmi.product.version: 1.0
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.32-7-generic

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)
     Subsystem: Micro-Star International Co., Ltd. Device [1462:7314]

takashi torigoe (tt-hogehoge) wrote :
Bryce Harrington (bryce) on 2009-11-06
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-11-09
summary: - Intel 82945G/GZ Integrated Graphics Controller Freezes when compiz
- enabled
+ [i945] Intel 82945G/GZ Integrated Graphics Controller Freezes when
+ compiz enabled

I experience exactly the same problem.

ProblemType: Bug
Architecture: amd64
Date: Sun Dec 6 00:24:03 2009
DistroRelease: Ubuntu 9.10
MachineType: To Be Filled By O.E.M. MS-7210
Package: xorg 1:7.4+3ubuntu7
PackageArchitecture: amd64
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd quiet splash -- debian-installer/language=ru console-setup/layoutcode?=ru
ProcEnviron:
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-9.152-rt
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
Uname: Linux 2.6.31-9-rt x86_64
Xrandr:
 Error: command ['xrandr', '--verbose'] failed with exit code 1: Can't open display

dmi.bios.date: 12/21/2006
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.4
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: MS-7210
dmi.board.vendor: To be filled by O.E.M.
dmi.board.version: 300
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.4:bd12/21/2006:svnToBeFilledByO.E.M.:pnMS-7210:pvr300:rvnTobefilledbyO.E.M.:rnMS-7210:rvr300:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: MS-7210
dmi.product.version: 300
dmi.sys.vendor: To Be Filled By O.E.M.

Anton Litvinov (mirteney) wrote :

debug information

Anton Litvinov (mirteney) wrote :
Anton Litvinov (mirteney) wrote :

LsPci:

 00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)
  Subsystem: Micro-Star International Co., Ltd. Device [1462:7210]
  Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
  Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
  Latency: 0
  Interrupt: pin A routed to IRQ 16
  Region 0: Memory at ffa80000 (32-bit, non-prefetchable) [size=512K]
  Region 1: I/O ports at ec00 [size=8]
  Region 2: Memory at e0000000 (32-bit, prefetchable) [size=256M]
  Region 3: Memory at ffa40000 (32-bit, non-prefetchable) [size=256K]
  Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
   Address: 00000000 Data: 0000
  Capabilities: [d0] Power Management version 2
   Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
   Status: D0 PME-Enable- DSel=0 DScale=0 PME-
  Kernel driver in use: i915
  Kernel modules: i915

markusd112 (markusd112) wrote :

I have the same problem with Foxconn 45CS:

lspci:
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

ivan (telejet) wrote :

I've tried several things to fix this problem on my machine but the solution that work was easiest one.
Just install fusion-icon and enable compiz from it: no more freeze and 3D effects work like charm

takashi torigoe (tt-hogehoge) wrote :

Thanks for the info.
First time, I tried that, but it has not improved in my environment.
I found that, when "Fusion-icon->Compiz options->Indirect Rendering" checkbox is on, 3D effects work.

compiz can disable the direct rendering by the checkbox.
But other applications (ex. 3D screensaves, blender, ... ) cause freeze as well as before.
It seems to be caused by kernel driver's lock, but it resumed by killing the freezed application.
I think that intel driver for i945 have some issue in the Direct Rendering function.

Geir Ove Myhr (gomyhr) on 2010-01-01
tags: added: freeze
Geir Ove Myhr (gomyhr) wrote :

This comment goes to bug 400934, bug 451518, bug 475429, bug 500686,
bug 501875, bug 342675, bug 4611163 and 493111.

We have had several reports of freezes (GPU hangs) on i945 chipsets
(945G, 945GM and 945GME, all of which uses the GMA950 graphics core)
in Karmic. I would like to get some testing going so that we may
identify the cause and give upstream all the information they need
(and possibly some they do not need) so that they can fix this before
Lucid is out. I have set up a wiki page to coordinate the effort:
https://wiki.ubuntu.com/X/Lucidi945Freezes . There is a list of test
that I think will be useful in order to isolate where the problem is
and a table where you can fill in your test results. If we're lucky
there is only one underlying problem, and we will probably get
consistent test results. Otherwise, different test results may group
the problems in different categories.

I realize that doing all the tests can be quite time consuming (it
calls for tests on both Karmic and Lucid), and if you are only able to
do some of the tests it would be nice if you could fill in those cells
in the test result table.

My initial guess is that the bug is in mesa, since it seems to be
related to 3D operations. It would be nice if we could also get some
testing of different mesa versions, but I'm not aware of any that are
pre-built yet.

takashi torigoe (tt-hogehoge) wrote :

I have tried several test.
Results are below, because I don't know how to login the wiki page.

Gnome/KDE
 gnome
 (KDE is not tested)

Desktop effects
 with and without

Mouse pointer freezes
 yes

Kernel options that works
 acpi=off(nomodeset is no effect)
 no freeze, but there are some issue.
 - screen draw speed is very slow.
 - When compiz enabled, screen goes white blank.
    (Desktop Cube becomes white cube)
 - Render selection (direct/indirect) by compiz fusion icon is disabled.(fixed to indirect)

Lucid
 not tested

Karmic + xorg-edgers
 improved but still freeze
 (old xorg freezes immediately,
 new xorg freezes after several seconds.)

Lucid + xorg-edgers
 not tested

drm-intel-next kernel
 (using linux-image-2.6.32-997-generic_2.6.32-997.201001061342_i386)
 improved but still freeze
 (old kernel freezes immediately,
 new kernel freezes after several seconds.)

no-freeze kernel
 not tested

3D app with freeze
 compiz
 3d screensavers (euphoria is most often)

Geir Ove Myhr (gomyhr) wrote :

Thank you for testing. I have added your results to the wiki. In order to edit it yourself, you need to log in, but you can use your Launchpad ID and password.

I should note that what I think is currently the most important test is to find an older kernel that does not freeze. So far nobody has done that.

takashi torigoe (tt-hogehoge) wrote :

I tested several kernel. And I tested Lucid install cd.
Results are below.
kernel 2.6.30 seems to be fixed to indirect rendering.

Lucid install cd.
 freeze
2.6.31.4
 freeze

2.6.31.1-855gmtest599-git522bb74_gomyhr1
 freeze

2.6.31.1-855gmtest599-git522bb74_gomyhr2
 freeze

2.6.30-freezetest8
 no freeze, but
  - screen draw speed is very slow.
  - Render selection (direct/indirect) by compiz fusion icon is disabled.
2.6.30-02063010-generic
 no freeze, but
  - screen draw speed is very slow.
  - Render selection (direct/indirect) by compiz fusion icon is disabled.

dmesg when the freeze occurs( kernel 2.6.31)
[ 240.724047] INFO: task i915/1:299 blocked for more than 120 seconds.

[ 240.724056] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.

[ 240.724063] i915/1 D c08145c0 0 299 2 0x00000000

[ 240.724074] f642df04 00000046 f640326c c08145c0 f64034d8 c08145c0 99e9656a 00000015

[ 240.724089] c08145c0 c08145c0 f64034d8 c08145c0 99e9516f 00000015 c08145c0 e4a768c0

[ 240.724103] f6403240 f68cac14 f68cac18 ffffffff f642df30 c056f776 f703e480 f68cac1c

[ 240.724117] Call Trace:

[ 240.724135] [<c056f776>] __mutex_lock_slowpath+0xc6/0x130

[ 240.724143] [<c056f690>] mutex_lock+0x20/0x40

[ 240.724187] [<f8275c0a>] i915_gem_retire_work_handler+0x2a/0x70 [i915]

[ 240.724198] [<c0157a7e>] run_workqueue+0x6e/0x140

[ 240.724233] [<f8275be0>] ? i915_gem_retire_work_handler+0x0/0x70 [i915]

[ 240.724242] [<c0157bd8>] worker_thread+0x88/0xe0

[ 240.724251] [<c015c280>] ? autoremove_wake_function+0x0/0x40

[ 240.724259] [<c0157b50>] ? worker_thread+0x0/0xe0

[ 240.724266] [<c015bf8c>] kthread+0x7c/0x90

[ 240.724274] [<c015bf10>] ? kthread+0x0/0x90

[ 240.724283] [<c0104007>] kernel_thread_helper+0x7/0x10

[ 240.724314] INFO: task Xorg:1018 blocked for more than 120 seconds.

[ 240.724319] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.

[ 240.724325] Xorg D c08145c0 0 1018 987 0x00400004

[ 240.724334] e332fe2c 00003086 df2a4000 c08145c0 e3269bb8 c08145c0 7cce808c 00000015

[ 240.724348] c08145c0 c08145c0 e3269bb8 c08145c0 00000000 00000015 c08145c0 e3c60700

[ 240.724362] e3269920 f68cac14 f68cac18 ffffffff e332fe58 c056f776 00000000 f68cac1c

[ 240.724376] Call Trace:

[ 240.724384] [<c056f776>] __mutex_lock_slowpath+0xc6/0x130

[ 240.724392] [<c056f690>] mutex_lock+0x20/0x40

[ 240.724425] [<f8275943>] i915_gem_sw_finish_ioctl+0x43/0xa0 [i915]

[ 240.724467] [<f80dc6c0>] drm_ioctl+0x180/0x360 [drm]

[ 240.724505] [<f8275900>] ? i915_gem_sw_finish_ioctl+0x0/0xa0 [i915]

[ 240.724516] [<c0314fc4>] ? rb_erase+0xb4/0x120

[ 240.724524] [<c05707da>] ? _spin_lock_irqsave+0x2a/0x40

[ 240.724533] [<c015f405>] ? __remove_hrtimer+0x25/0x70

[ 240.724541] [<c015fc63>] ? hrtimer_try_to_cancel+0x33/0x80

[ 240.724550] [<c014947e>] ? do_setitimer+0x23e/0x300

[ 240.724568] [<c01f4cf3>] vfs_ioctl+0x73/0x90

[ 240.724575] [<c01f4fc1>] do_vfs_ioctl+0x71/0x310

[ 240.724583] [<c014957b>] ? sys_setitimer+0x3b/0x90

[ 240.724590] [<c01f52bf>] sys_ioctl+0x5f/0x80

[ 240.724598] [<c010336c>] syscall_call+0x7/0xb

takashi torigoe (tt-hogehoge) wrote :

I read comment of bug 500686.
Then I tested 2.6.31-rc6, rc7, rc1.
As a result, all of them are freezed.
In my environment, newest no-freeze kernel is 2.6.30-02063010-generic.

Geir Ove Myhr (gomyhr) wrote :

Thank you for testing this, takashi. Would it be possible for you to narrow it down a bit further by testing the daily built kernels from http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/ ? From the dates of 2.6.30 (which does not freeze) and 2.6.31-rc1 (which does freeze), I think the change from no-freeze to freeze should be between 2009-06-10 and 2009-06-25 or so.

takashi torigoe (tt-hogehoge) wrote :

OK.
Results are below. 2009-06-17, 18, 19 are not tested, because there are no i386 image.
From 2009-06-19a, 3D graphics performance is greatly improved.( glxgears fps increased 500 to 2000. )
I think that, the improvement is because of direct rendering.

Results:
 2009-06-16
  linux-image-2.6.30-999-generic_2.6.30-999.200908041829_i386.deb 05-Aug-2009 10:40 24M
  linux-image-2.6.30-999-generic_2.6.30-999.200908041656_i386.deb 04-Aug-2009 18:25 24M
   no freeze, but
    - screen draw speed is very slow.
    - Render selection (direct/indirect) by compiz fusion icon is disabled.

 2009-06-19a
  linux-image-2.6.30-999-generic_2.6.30-999.200909032144_i386.deb 03-Sep-2009 23:25 27M
   freeze
   very small screen (720x400)

Geir Ove Myhr (gomyhr) wrote :

Thank you again, Takashi. I would like to forward your bug upstream so that more competent people than me may have a look at it. The developers at Intel usually get happier if we supply bugs from more recent software versions. So I'm wondering if you test Lucid (either by upgrading, testing a LiveCD or installing on a separate partition). Then upgrade to the xorg-edgers PPA (https://launchpad.net/~xorg-edgers/+archive/ppa) to get the latest versions of everything. Finally, make the following /etc/X11/xorg.conf:

Section "Device"
 Identifier "my-945G"
 Driver "intel"
 Option "DebugFlushCaches" "1"
EndSection

If this configuration doesn't have other serious problems (sometimes xorg-edgers contain code that are a bit too recent, in that case, use the ppa-purge program available from that PPA to downgrade again), a fresh batchbuffer dump may be more useful than the previous one. Also, run `apport-collect 475492` in order to upload fresh log files here. If the xorg-edgers PPA doesn't work well enough or you have other problems with it, you can do the batchbuffer dump and apport-collect without it.

takashi torigoe (tt-hogehoge) wrote :

I tested Lucid and Lucid+xorg-edgers.
( Lucid install & xorg-edgers ppa to sources.list & apt-get upgrade )
Both of them have same problem.

I tried to get batchbuffer dump, but I couldn't it.
The reason is that, the lucid kernel hangs up during "sudo cp -r /sys/kernel/debug/dri/0/i915* dri_debug-$datestr".
It seems that "/sys/kernel/debug/dri/0/i915_regs" causes hung up.
(The kernel hungs up when executing "cat /sys/kernel/debug/dri/0/i915_regs" with console.)

For the record, I got batchbuffer dump except "/sys/kernel/debug/dri/0/i915_regs".
Should I post the dump here?

Thank you for testing.

> For the record, I got batchbuffer dump except "/sys/kernel/debug/dri/0/i915_regs".
> Should I post the dump here?

Yes, or if you would like to try, you can try the latest
intel-drm-next kernel from
http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/ . It has
this patch: http://lists.freedesktop.org/archives/intel-gfx/2009-December/005250.html
which should fix the problem. However, if I remember correctly,
apport-collect will only run with standard ubuntu kernels.

Download full text (3.8 KiB)

Forwarding a freeze bug from Ubuntu user takashi torigoe:
  https://bugs.launchpad.net/bugs/475429
There are several other reports of freezes on 945G and 945GM in Ubuntu, but this seems to have more information.

[Problem]
GPU hangs on i945G when compiz is enabled. When compiz isn't enabled, 3D screensavers (especially euphoria) can make it hang. Bug is originally reported on Ubuntu 9.10, but has been verified with drm-intel-next kernel from 201001061342 and with the development verision 10.04 with xorg-edgers and the logs are taken from there.

[Original report]

Since upgrade to the 9.10 release, my screen freezes after visual effect (window move).
With visual effects disabled, there is no problem.
When freeze occurs, keyboard and mouse are unusable, but ssh login is OK.
So, I got Batchbuffer dump according to https://wiki.ubuntu.com/X/Troubleshooting/Freeze.
Dump is attached with this post.(dri_debug-20091105.tgz)

Operations
1. sudo INTEL_DEBUG=batch /etc/init.d/gdm restart
2. Set visual effects -> extra (compiz)
3. Window move by mouse operation.
4. Window swings (visual effect)
5. freeze occur
6. ssh & get Batchbuffer

I found that, when "Fusion-icon->Compiz options->Indirect Rendering" checkbox is on, 3D effects work.
compiz can disable the direct rendering by the checkbox.
But other applications (ex. 3D screensaves, blender, ... ) cause freeze as well as before.
It seems to be caused by kernel driver's lock, but it resumed by killing the freezed application.
I think that intel driver for i945 have some issue in the Direct Rendering function.

Kernel options that works
 acpi=off(nomodeset is no effect)
 no freeze, but there are some issue.
 - screen draw speed is very slow.
 - When compiz enabled, screen goes white blank.
    (Desktop Cube becomes white cube)
 - Render selection (direct/indirect) by compiz fusion icon is disabled.(fixed to indirect)

When trying older kernels, freeze seems to be introduced between 2.6.30 and 2.6.31-rc1, but using 2.6.30 seems to turn off direct rendering.

Architecture: i386
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091209)
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: MICRO-STAR INTERNATIONAL CO.,LTD MS-7314
Package: xserver-xorg-video-intel 2:2.10.0+git20100108.4902f546-0ubuntu0sarvatt
PackageArchitecture: i386
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-7-generic root=UUID=e1d041b6-3b07-4d6f-aae9-5fbce8eee93c ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=ja_JP.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-7.10-generic
RelatedPackageVersions:
 xserver-xorg 1:7.5+1ubuntu1
 libgl1-mesa-glx 7.8.0~git20100107.d699b672-0ubuntu0sarvatt
 libdrm2 2.4.17+git20091230.c5c503b5-0ubuntu0sarvatt3
 xserver-xorg-video-intel 2:2.10.0+git20100108.4902f546-0ubuntu0sarvatt
Tags: lucid
Uname: Linux 2.6.32-7-generic i686
UnreportableReason: これは正式な Ubuntu のパッケージではありません
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XorgConf:
 Section "Device"
  Identifier "my-945G"
  Driver "intel"
  Option "DebugFlushCaches" "1"
 EndSection
dmi.bios.date: 07/14/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bio...

Read more...

Created an attachment (id=32598)
Batchbufer dump. i915_regs excluded, since reading it causes hangs on this machine

Created an attachment (id=32599)
BootDmesg.txt

Created an attachment (id=32600)
CurrentDmesg.txt

Created an attachment (id=32601)
PciDisplay.txt

Created an attachment (id=32602)
XorgLog.txt

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Thank you, Geir Ove Myhr.
I executed apport collect 475429. ( with Lucid normal kernel )
And, the batchbuffer dump I got yesterday is attatched here.

> this patch: http://lists.freedesktop.org/archives/intel-gfx/2009-December/005250.html
This patch simply disable the i915_regs.
So, the dump I got will be same result.

Geir Ove Myhr (gomyhr) wrote :

Thank you for the logs. If you can also get the batchbuffer dump, that would be nice.

I'm a little puzzed about the kernel you are using. It is reported as 2.6.32-7.10-generic. This was replaced already on Dec 11, which is quite a while ago and the latest kernel in should be Lucid is 2.6.32-10.14. Did you install using a alpha1 without doing `apt-get dist-upgrade` afterwards? Or are you using an alpha1 LiveCD?

takashi torigoe (tt-hogehoge) wrote :

> If you can also get the batchbuffer dump, that would be nice.
The batchbuffer is attached in #37.
It contains batchbuffer except i915_regs file.
I think that there is no problem because the i915_regs file is disabled by the patch.(http://lists.freedesktop.org/archives/intel-gfx/2009-December/005250.html)

> Did you install using a alpha1 without doing `apt-get dist-upgrade` Or are you using an alpha1 LiveCD?
I just install Lucid by alpha1 LiveCD. (and xorg-edgers)
So I did not run "apt-get dist-upgrade".

Geir Ove Myhr (gomyhr) wrote :

> > If you can also get the batchbuffer dump, that would be nice.
> The batchbuffer is attached in #37.
Thank you. I posted comment #38 before I saw comment #37.

I have forwarded this bug upstream at https://bugs.freedesktop.org/show_bug.cgi?id=26016 . Could you register at freedesktop.org and add yourself to the CC-field on that bug so that you may answer any questions the intel developers might have? I will also follow the upstream bug report and if you need help with any questions that you get (e.g. you don't know how to do what they ask in Ubuntu), you may ask here.

Thank you.

> https://bugs.freedesktop.org/show_bug.cgi?id=26016 . Could you register
> at freedesktop.org and add yourself to the CC-field on that bug so that

OK. I did it.

I have uploaded an older version of mesa to my "old" PPA: https://launchpad.net/~gomyhr/+archive/old/+packages . By testing this, we can find out if this is caused by a bug in mesa which is introduced after version 7.5.

Unfortunately, installing it is probably not as easy as just adding the PPA to /etc/apt/sources and do `sudo apt-get update; sudo apt-get upgrade`, since the version in the PPA is older than then one in karmic and I didn't do any PPA magic to make it want to upgrade anyway. The easiest way I can think about is probably to download all the deb-files for your architecture (*i386.deb) to an empty folder and do a `dpkg -i -O *.deb` in that folder. That will install only the packages that already have an installed version on your system.

If Karmic freezes with this version, I can try to go all the way back to the Jaunty version.

PS: I don't have a Karmic installation (I only have Jaunty and Lucid) so I haven't had a chance to test that the packages even work.

PPS: Do you still have Karmic on your system or did you install Lucid in its place? I didn't quite get if you installed from the LiveCD or simply booted it.

g_jensen@swbell.net (g-jensen) wrote :

I recently upgraded from 9.04 to 9.10 and experienced the same freezing with the same video hardware. However, I switched the window manager to metacity, and then continued with research on compiz. When I would run compiz --replace, there were a multitude of errors listed because it could not find /usr/lib/libdecorations.so.0. When I looked at the files installed by the package libdecorations0 on my machine, it showed that /usr/lib/libdecorations.so.0 was not there. I found a different ubuntu karmic distribution package for libdecorations0 and installed it manually. It did have the file and installed it correctly. I then re-ran compiz --replace and it is working fine, no freeze (its only been a few hours though).

In doing research about Karmic, there was mention of adding a kernel option i915.modeset=1, so i set that too. However, I don't know if that has anything to do with it though.

g_jensen, thank you for investigating this and sharing your results. I
think the libdecoration0 problem is different from the one reported
here, though. This is since libdecoration0 is a compiz library, and
this problem has been reported even without compiz when other OpenGL
programs are used. Looking at the lists of files at
http://packages.ubuntu.com/karmic/libdecoration0, it seems that all
packages contain the file /usr/lib/libdecoration.so.0 (not
libdecorations.so.0, but I assume you misspelled it since you
misspelled the package name).

Also, the kernel option i915.modset=1 should do nothing in Karmic
since that is already the default.

Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed

> I have uploaded an older version of mesa to my "old" PPA: https://launchpad.net/~gomyhr/+archive/old/+packages . By testing this, we can find out if this is caused by a bug in mesa which is introduced after version 7.5.

Geir, I tested the older mesa package, but I got freeze.
As a result, there are no change with older mesa.

strel-core (strelmail) on 2010-02-05
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Bryce Harrington (bryce) on 2010-02-09
description: updated
Geir Ove Myhr (gomyhr) wrote :

For anyone on Lucid, I have uploaded a version of Lucid's libdrm to my PPA which has this patch: http://cgit.freedesktop.org/mesa/drm/commit/?id=4f0f871730b76730ca58209181d16725b0c40184 .

This patch is supposed to fix many of the freeze problems that has occurred lately. The PPA is at https://launchpad.net/~gomyhr/+archive/standard .

takashi torigoe (tt-hogehoge) wrote :

I don't use Lucid for now. So I build patched libdrm for my karmic.
I still got freeze, but the problem (below) might be fixed I think.
> In Ubuntu 9.04 the screen lock, but back when the mouse is moved.

I tried to find out the cause of freeze.
First, I run the euphoria as ' strace /usr/lib/xscreensaver/euphoria --badmath 2>./logd 1>logd2'
Next, 'killall euphoria' after freeze.

logd is below.
ioctl(4, 0xc0086457, 0xbfeade88) = 0
ioctl(4, 0x4020645d, 0xbfeade80) = 0
ioctl(4, 0xc0086457, 0xbfeade88) = 0
ioctl(4, 0x4020645d, 0xbfeae030) = 0
ioctl(4, 0x4020645d, 0xbfeae050) = 0
ioctl(4, 0x40286454, 0xbfeae058) = 0
ioctl(4, 0xc0086457, 0xbfeae008) = 0
ioctl(4, 0x400c645f, 0xbfeadfc4) = 0
ioctl(4, 0x4020645c, 0xbfe9e000) = 0
--- SIGTERM (Terminated) @ 0 (0) ---

ioctl 0x4020645c is executed before killed.
ioctl 0x4020645c is DRM_IOCTL_I915_GEM_PREAD.
ioctl DRM_IOCTL_I915_GEM_PREAD is called by drm_intel_gem_bo_get_subdata in intel_bufmgr_gem.c:856.
I wrote check code to find out that the freeze occred in DRM_IOCTL_I915_GEM_PREAD.

check code:(freeze time count)
      struct timeval tv,tv2;
      long lusec;
      gettimeofday( &tv, NULL );
  ret = ioctl (bufmgr_gem->fd, DRM_IOCTL_I915_GEM_PREAD, &pread);
      gettimeofday( &tv2, NULL );
      lusec = (tv2.tv_sec - tv.tv_sec)*1000000L-tv.tv_usec+tv2.tv_usec;
      printf("%ld¥n", lusec);

log by printf is below.
234
230
255
252
236
251
82744282
256
246
238
242
255

The result indicates that, euphoria is freezed (82 sec) until killed.
It seemed that the freeze is caused by DRM_IOCTL_I915_GEM_PREAD.

Changed in xserver-xorg-video-intel:
status: Confirmed → In Progress
Bryce Harrington (bryce) on 2010-02-25
tags: added: lucid
Geir Ove Myhr (gomyhr) wrote :

With the latest drm-intel-next kernel there is a commit that will record the failed batch buffer to /sys/kernel/debug/dri/0/i915_error_state. Could you test that kernel and upload it along with Xorg.0.log and dmesg output from the same time?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Confirmed
status: Confirmed → Incomplete
status: Incomplete → Confirmed
Geir Ove Myhr (gomyhr) wrote :

Btw, I have updated the information at https://wiki.ubuntu.com/X/Troubleshooting/Freeze to reflect the status.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
takashi torigoe (tt-hogehoge) wrote :

I install the latest drm-intel-next kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2010-02-24/ .
And I got batchbuffer dump.
 sudo service apport start force_start=1
 mkdir dri_debug-$datestr
 sudo cp -r /sys/kernel/debug/dri/0/i915* dri_debug-$datestr
 sudo intel_gpu_dump > dri_debug-$datestr/intel_gpu_dump.txt
 dmesg > dri_debug-$datestr/dmesg.txt
 cp /var/log/Xorg.0.log dri_debug-$datestr/
 sudo cp /var/log/gdm/\:0.log dri_debug-$datestr/gdm.log
 sudo tar czf dri_debug-$datestr.tgz dri_debug-$datestr/

The batchbuffer dump is attached.
i915_error_state shows "no error state collected".

Bryce Harrington (bryce) on 2010-02-27
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2010-02-27
tags: added: compiz
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High

Created an attachment (id=33630)
dri_debug tarball

From downstream: Takashi has tested with drm-intel-next kernel that should detect a GPU hang and add information to i915_error_state. Possibly, this is because he uses Ubuntu 9.10 and not 10.04 now. Not sure which packages are relevant.

-- from downstream --

I install the latest drm-intel-next kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2010-02-24/ .
And I got batchbuffer dump.
 sudo service apport start force_start=1
 mkdir dri_debug-$datestr
 sudo cp -r /sys/kernel/debug/dri/0/i915* dri_debug-$datestr
 sudo intel_gpu_dump > dri_debug-$datestr/intel_gpu_dump.txt
 dmesg > dri_debug-$datestr/dmesg.txt
 cp /var/log/Xorg.0.log dri_debug-$datestr/
 sudo cp /var/log/gdm/\:0.log dri_debug-$datestr/gdm.log
 sudo tar czf dri_debug-$datestr.tgz dri_debug-$datestr/

The batchbuffer dump is attached.
i915_error_state shows "no error state collected".

Bryce Harrington (bryce) on 2010-03-02
summary: - [i945] Intel 82945G/GZ Integrated Graphics Controller Freezes when
- compiz enabled
+ [i945] [i945] Intel 82945G/GZ Integrated Graphics Controller Freezes
+ when compiz enabled
Bryce Harrington (bryce) on 2010-03-02
summary: - [i945] [i945] Intel 82945G/GZ Integrated Graphics Controller Freezes
- when compiz enabled
+ [i945] Intel 82945G/GZ Integrated Graphics Controller Freezes when
+ compiz enabled

*** Bug 26898 has been marked as a duplicate of this bug. ***

Bumping the priority down on this bug, only because we don't expect to have this fixed in time for the release that's coming together right now.

-Carl

Bryce Harrington (bryce) on 2010-04-08
summary: - [i945] Intel 82945G/GZ Integrated Graphics Controller Freezes when
- compiz enabled
+ [i945] X Freezes when compiz enabled

Hallo,
    I have a similar problem. I'm running a fully updated (up to 17-apr-2010) 9.10 on a Toshiba A100 with a intel 945 chipset. When desktop effects are enabled (extra), the screen, mouse, keyboard and power button are freezed when a full HD monitor is connected to the vga port and I try to run it at 1920x1080. The laptop lcd screen is at 1280x800.
The freeze doesn't happen if the external screen is run at 1024x768.
If the desktop effects are disabled, no freeze occurs even when the external monitor is at 1920x1080.

I can run the laptop with full desktop effects with no problem at all for days when only the laptop lcd is used and no external monitor is connected.

Also, sometimes I can enable the external monitor at 1920x1080 both with and without the laptop lcd enabled at the same time, with full desktop effetcs enabled. The success rate is higher if power up the laptop with the external monitor already connected and turned on.

uname -a

Linux marcello-laptop 2.6.31-21-generic #59-Ubuntu SMP Wed Mar 24 07:28:56 UTC 2010 i686 GNU/Linux

Patrick Craenen (bootpanic) wrote :

I'm experiencing the same problem with both Karmic and Lucid

My hardware is a MSI mainboard MS-7536 with an Intel 945G/GZ Integrated Graphics chip.

If i can be of any assistance please let me know.

catchpramod (catchpramod) wrote :

I also have the same problem, I been having this since Karmic and in Lucid too. My system freezes when I try to enable any visual effects other than Normal. So for nearly 1 year I am using my pc in normal visual effects :(

takashi torigoe (tt-hogehoge) wrote :

I rebuild the kernel with debug enabled.
And I tried to investigate the freeze problem.
But, kernel configuration(attached with this post) works fine.
I couldn't reproduce the problem with the kernel.
There might be some problems with lock sequence of the intel driver.

configuration change:
cpu arch -> atom ( still freeze with this change )
debug feature show in below is enabled.

> CONFIG_DEBUG_SPINLOCK=y
> CONFIG_DEBUG_MUTEXES=y
> CONFIG_DEBUG_LOCK_ALLOC=y
> CONFIG_PROVE_LOCKING=y
> CONFIG_LOCKDEP=y
> CONFIG_LOCK_STAT=y
> CONFIG_DEBUG_LOCKDEP=y
> CONFIG_TRACE_IRQFLAGS=y
> CONFIG_DEBUG_SPINLOCK_SLEEP=y
> CONFIG_DEBUG_LOCKING_API_SELFTESTS=y
4950a4957
> CONFIG_TRACER_MAX_TRACE=y
> CONFIG_IRQSOFF_TRACER=y
> CONFIG_SYSPROF_TRACER=y
> CONFIG_FUNCTION_PROFILER=y

A page-flipping bug. The Q2 release should have most of these fixed, at least the known ones...

Geir Ove Myhr (gomyhr) wrote :

According to a comment on the upstream bug report, this bug is probably fixed in intel's Q2 release (http://intellinuxgraphics.org/2010Q2.html). Maverick doesn't have libdrm 2.4.21 yet, but should otherwise be up to date. Also, Lucid with xorg-edgers and a new mainline build of the kernel (https://wiki.ubuntu.com/KernelTeam/MainlineBuilds) should contain all the updates.

The kernel patches are upstream as part of 2.6.35-rc4:

commit 1afe3e9d4335bf3bc5615e37243dc8fef65dac8f
Author: Jesse Barnes <email address hidden>
Date: Fri Mar 26 10:35:20 2010 -0700

    drm/i915: gen3 page flipping fixes

    Gen3 chips have slightly different flip commands, and also contain a bit
    that indicates whether a "flip pending" interrupt means the flip has
    been queued or has been completed.

    So implement support for the gen3 flip command, and make sure we use the
    flip pending interrupt correctly depending on the value of ECOSKPD bit
    0.

    Signed-off-by: Jesse Barnes <email address hidden>
    Signed-off-by: Eric Anholt <email address hidden>

commit 83f7fd055eb3f1e843803cd906179d309553967b
Author: Jesse Barnes <email address hidden>
Date: Mon Apr 5 14:03:51 2010 -0700

    drm/i915: don't queue flips during a flip pending event

    Hardware will set the flip pending ISR bit as soon as it receives the
    flip instruction, and (supposedly) clear it once the flip completes
    (e.g. at the next vblank). If we try to send down a flip instruction
    while the ISR bit is set, the hardware can become very confused, and we
    may never receive the corresponding flip pending interrupt, effectively
    hanging the chip.

    Signed-off-by: Jesse Barnes <email address hidden>
    Signed-off-by: Eric Anholt <email address hidden>

I believe that this fixes the page-flipping issues on i945.

Geir Ove Myhr (gomyhr) wrote :

According to the upstream bug report, two commits to the kernel should fix this bug. The commits are included in the current Maverick kernel. Could you verify that this now works in Maverick?

Tomas Tunkl (tunklt) wrote :

It still freezes with latest build of Maverick (14th July).

Geir Ove Myhr (gomyhr) wrote :

Tomas, the question in comment #59 was meant for the original reporter of the bug, takashi torigoe (sorry for not specifying that). These kind of bugs may look exactly the same but have totally different underlying causes, so your freeze may be an unrelated bug.

If you are the experiencing freezes in Maverick, please file a new bug report about it. In the bug reporting process Launchpad is pretty eager to lead you towards possible duplicates. While that makes sense for most packages, you can ignore that for graphics-related bugs. We (and the upstream developers) would rather have many duplicate bug reports than people contributing their information to a bug reports which turns out to be different from their bug.

There is some automatic freeze-detection set up in Maverick, which may tell you about the problem and offer to send a bug report. If that does not happen, please file a new bug report with the "ubuntu-bug" command, which will gather a lot of useful information for you.

I see you have a new Launchpad account. Welcome! I hope you can contribute to making Ubuntu better.

(In reply to comment #10)
> The kernel patches are upstream as part of 2.6.35-rc4:
[...]
> I believe that this fixes the page-flipping issues on i945.

Seems it didn't the current Ubuntu 10.10 (Maverick) development kernel is based on 2.6.35-rc5 and it still happens.

The original reporter says downstream:

It still freezes with Maverick (13th July), same as Tomas.

$cat /sys/kernel/debug/dri/0/i915_error_state
no error state collected

dmesg is attatched here.
dmesg shows that the freeze is caused by mutex lock.

It may be caused by below sequence.
1. mutex locked and not unlocked.
2. DRM_IOCTL_I915_GEM_PREAD wait the lock.
3. dmesg shows error ( 120s after freeze ).

Created an attachment (id=37104)
dmesg output with Ubuntu kernel 2.6.35-8.13 (based on -rc5)

takashi torigoe (tt-hogehoge) wrote :

It still freezes with Maverick (13th July), same as Tomas.

$cat /sys/kernel/debug/dri/0/i915_error_state
no error state collected

dmesg is attatched here.
dmesg shows that the freeze is caused by mutex lock.

It may be caused by below sequence.
1. mutex locked and not unlocked.
2. DRM_IOCTL_I915_GEM_PREAD wait the lock.
3. dmesg shows error ( 120s after freeze ).

Geir Ove Myhr (gomyhr) wrote :

Thank you, takashi. I have reopened the upstream bug report and copied your comment and dmesg there. There will probably be more questions in the upstream bug report. Please answer those there directly.

(In reply to comment #11)
> dmesg is attatched here.
> dmesg shows that the freeze is caused by mutex lock.
>
> It may be caused by below sequence.
> 1. mutex locked and not unlocked.
> 2. DRM_IOCTL_I915_GEM_PREAD wait the lock.
> 3. dmesg shows error ( 120s after freeze ).

Or it's a missed interrupt ;-)

Want to place a bet?

(In reply to comment #13)

There were 2 problem, I think.

 (1) screen lock at any time.
 (2) screen lock when 3D use (blender, compiz, ...).

Both of them show the similar dmesg error (lock time over 120s).
But, (1) is unlocked by mouse move or keyboard interrupt.
And, (1) might be fixed by 2.6.35-rc4.

> Or it's a missed interrupt ;-)

I'll bet below :-)

1. mutex locked
2. missed interrupt -> not unlocked.
3. DRM_IOCTL_I915_GEM_PREAD wait the lock.
4. dmesg shows error ( 120s after freeze ).

Beyond the usual fixes in 2.6.35, 2.6.36-rc2 contains a patch to fixup missed interrupts,

http://cgit.freedesktop.org/~ickle/drm-intel drm-intel-fixes

contains a patch for one observed source of missed interrupts and

http://cgit.freedesktop.org/~ickle/drm-intel drm-intel-next

contains an enhanced hangcheck.

I tested 2.6.36-rc3.
The Freeze may be fixed.
But I got dmesg below.

[ 114.364014] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU idle, missed IRQ.
[ 352.800012] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU idle, missed IRQ.
[ 355.488019] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU idle, missed IRQ.
[ 366.724024] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU idle, missed IRQ.

[ 114.364014] is caused by blender.
Others are caused by blender or compiz.

Changed in xserver-xorg-video-intel:
importance: Unknown → High
status: In Progress → Confirmed
Changed in xserver-xorg-video-intel:
importance: High → Unknown
status: Confirmed → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → High
Changed in xserver-xorg-video-intel:
status: Unknown → Invalid
Bryce Harrington (bryce) wrote :

This appears to have been fixed by kernel drm commit b0b544cd37c060e261afb2cf486296983fcb56da, posted in January. The fix is probably already available in natty's kernel, but will leave it to the kernel team to verify.

Changed in xserver-xorg-video-intel:
importance: High → Unknown
status: Invalid → Unknown
affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
status: Unknown → Fix Released
Timo Aaltonen (tjaalton) wrote :

The commit in question is indeed included in the natty kernel.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.