Boot halts on Toshiba L505

Bug #472183 reported by mikep554 on 2009-11-03
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by poolvibe
Nominated for Jaunty by mikep554
Nominated for Karmic by poolvibe
Nominated for Lucid by Frank Sandoval

Bug Description

Booting from live CD or installed system on Toshiba L505D-S5992 will fail with message: '/sbin/modprobe -b acpi:lnxvideo:' unexpected exit with status 0x0009. I can only boot by choosing the "acpi=off" option for the live cd or by adding "acip=off" to the end of the kernel line in /boot/grub/grub.cfg. This is with both 9.04 and 9.10.

Laptop has an ATI Radeon 4100/4200 video card (have seen both model numbers listed in different locations).

lspci reports this for the video: 01:05.0 VGA compatible controller: ATI Technologies Inc Device 9712

lspci -nn reports: 01:05.0 VGA compatible controller [0300]: ATI Technologies Inc Device [1002:9712]

ProblemType: Bug
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mikep 1563 F.... knotify4
                      mikep 1586 F.... kmix
 /dev/snd/controlC1: mikep 1586 F.... kmix
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xd2400000 irq 5'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,1179ff12,00100001 HDA:11c11040,11790001,00100200'
   Controls : 17
   Simple ctrls : 11
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xd2310000 irq 7'
   Mixer name : 'ATI RS690/780 HDMI'
   Components : 'HDA:1002791a,00791a00,00100000'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined
   Playback channels: Mono
   Mono: Playback [off]
Date: Mon Nov 2 19:48:31 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=092105e2-1654-41b1-bed8-4093e5be59da
InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: TOSHIBA Satellite L505D
NonfreeKernelModules: fglrx
Package: linux-image-2.6.31-14-generic 2.6.31-14.48
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=56762fb6-1081-4c85-9699-604ec732ffd4 ro quiet splash acpi=off
ProcEnviron:
 LANGUAGE=
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-14-generic N/A
 linux-firmware 1.24
RfKill:

SourcePackage: linux
Uname: Linux 2.6.31-14-generic x86_64
XsessionErrors:
 (polkit-gnome-authentication-agent-1:1590): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (npviewer.bin:1832): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class: ELFCLASS64
dmi.bios.date: 09/07/2009
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 1.00
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: AMD
dmi.chassis.version: None
dmi.modalias: dmi:bvnInsydeCorp.:bvr1.00:bd09/07/2009:svnTOSHIBA:pnSatelliteL505D:pvrPSLV6U-00L001:rvnTOSHIBA:rnPortablePC:rvrBaseBoardVersion:cvnAMD:ct10:cvrNone:
dmi.product.name: Satellite L505D
dmi.product.version: PSLV6U-00L001
dmi.sys.vendor: TOSHIBA

mikep554 (mikep-mikepowells) wrote :
cgharty (christopher-harty) wrote :

I am having the same problem on my Toshiba X205-9810 with 9.10. I did not have the issue with 9.04. I can boot with acpi="off" or acpi="ht" but other boot parameters will fail.

MacRules (macrules) wrote :

I have the same problem on a Toshiba A200.
This was no issue in 9.04 so clearly a bug as far as I am concerned.
Please fix this, there is a patch around for this acpi thing.
acpi=off as kernel option boots the machine, but then function keys and powermanagement do not work.

Very big show stopper!
If any more info needed, please ask.

mikep554 (mikep-mikepowells) wrote :
Changed in linux (Ubuntu):
status: New → Confirmed

I have this problem on a new Toshiba Satellite L500 with AMD Turion Ultra II x2 and ATI Mobility Radeon 4100 graphics. Can only boot 9.10 64-bit Ubuntu LiveCD or installed 9.10 64-bit Ubuntu OS if use acpi=off. Otherwise it will freeze with message "acpi:lnxvideo:' unexpected exit with status 0x0009".

Tried the following and they all do NOT fix the problem:
 - noapic
 - nolapic
 - uninstall splash screens
 - upgraded to kernel version 2.6.31

It's very frustrating because without acpi I don't get any battery monitor & various other power management things that are important for using laptop. Also I'd like to point out that if I weren't an experienced Linux user I wouldn't have known to try fiddling with the acpi options, or how to edit grub2 menu so that's the default. A "normal" user would have been completely at a loss here and thus might come away with a bad first impression of Ubuntu if they tried it on these new Satellite laptops, so I hope you are able to fix the problem soon.

mikep554 (mikep-mikepowells) wrote :

FYI, I found others dealing with this bug at http://bugzilla.kernel.org/show_bug.cgi?id=14679

There is a patch located at http://bugzilla.kernel.org/attachment.cgi?id=23958 which resolved my issues. This is a Toshiba ACPI BIOS bug. It looks to be specific to Toshiba laptops with the Insyde BIOS and ATI graphics cards/chipsets. The patch has a workaround for the broken ACPI functionality.

Instructions for compiling this patch into a custom kernel can be found at http://ubuntuforums.org/showthread.php?t=1301101&page=8 , in post # 71.

Changed in linux:
status: Unknown → Incomplete
Changed in linux:
status: Incomplete → Fix Released
Changed in linux:
importance: Unknown → Medium

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.