On Hibernate: btusb_bulk_complete: hci0 urb f2fdbe00 failed to resubmit (1)

Bug #461632 reported by Renjoy on 2009-10-27
148
This bug affects 29 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

On Hibernate, system prints the below error message.

btusb_bulk_complete: hci0 urb f2fdbe00 failed to resubmit (1)

dmesg attached to the bug report.

Renjoy (renjoy) wrote :
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in linux.

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → linux (Ubuntu)
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:

apport-collect 461632

This will help us to find and resolve the problem. Bear in mind that you may need to install the python-launchpadlib package from the universe repository. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report. Thanks in advance!

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in linux (Ubuntu):
status: New → Incomplete

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC861-VD Analog [ALC861-VD Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC861-VD Analog [ALC861-VD Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: renjoy 1675 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd0500000 irq 22'
   Mixer name : 'Realtek ALC861-VD'
   Components : 'HDA:10ec0862,17aa8e2d,00100001 HDA:11c11040,11c10001,00100200'
   Controls : 19
   Simple ctrls : 12
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=ae8e0e41-a985-4162-9c0d-7966c51abafd
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
MachineType: LENOVO 0768E2U
NonfreeKernelModules: wl nvidia
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=f1751916-828b-4ff9-aeb9-7b7c59dae1fb ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_IN
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-14-generic N/A
 linux-firmware 1.24
RfKill:
 1: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 04/30/07
dmi.bios.vendor: LENOVO
dmi.bios.version: 63ET62WW
dmi.board.name: CAPELL VALLEY(NAPA) CRB
dmi.board.vendor: LENOVO
dmi.board.version: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnLENOVO:bvr63ET62WW:bd04/30/07:svnLENOVO:pn0768E2U:pvr3000N100:rvnLENOVO:rnCAPELLVALLEY(NAPA)CRB:rvrNotApplicable:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.name: 0768E2U
dmi.product.version: 3000 N100
dmi.sys.vendor: LENOVO

Renjoy (renjoy) wrote : BootDmesg.txt
Renjoy (renjoy) wrote : IwConfig.txt
Renjoy (renjoy) wrote : Lspci.txt
Renjoy (renjoy) wrote : Lsusb.txt
Renjoy (renjoy) wrote : UdevDb.txt
Renjoy (renjoy) wrote : UdevLog.txt
Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC861-VD Analog [ALC861-VD Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC861-VD Analog [ALC861-VD Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: renjoy 1675 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd0500000 irq 22'
   Mixer name : 'Realtek ALC861-VD'
   Components : 'HDA:10ec0862,17aa8e2d,00100001 HDA:11c11040,11c10001,00100200'
   Controls : 19
   Simple ctrls : 12
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=ae8e0e41-a985-4162-9c0d-7966c51abafd
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
MachineType: LENOVO 0768E2U
NonfreeKernelModules: wl nvidia
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=f1751916-828b-4ff9-aeb9-7b7c59dae1fb ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_IN
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-14-generic N/A
 linux-firmware 1.24
RfKill:
 2: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 04/30/07
dmi.bios.vendor: LENOVO
dmi.bios.version: 63ET62WW
dmi.board.name: CAPELL VALLEY(NAPA) CRB
dmi.board.vendor: LENOVO
dmi.board.version: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnLENOVO:bvr63ET62WW:bd04/30/07:svnLENOVO:pn0768E2U:pvr3000N100:rvnLENOVO:rnCAPELLVALLEY(NAPA)CRB:rvrNotApplicable:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.name: 0768E2U
dmi.product.version: 3000 N100
dmi.sys.vendor: LENOVO

Renjoy (renjoy) wrote : IwConfig.txt
Renjoy (renjoy) wrote : Lspci.txt
Renjoy (renjoy) wrote : Lsusb.txt
Renjoy (renjoy) wrote : UdevDb.txt
Renjoy (renjoy) wrote : UdevLog.txt

Hi,

I have the same problem on a Dell D830. The message appears both on hibernate and when waking up again.
Bluetooth still appears to work fine though.

Cheers

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: Alessio 30499 F.... knotify4
                      Alessio 30564 F.... kmix
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf3300000 irq 22'
   Mixer name : 'IDT 92HD81B1C5'
   Components : 'HDA:111d76d5,102802c0,00100302'
   Controls : 27
   Simple ctrls : 17
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=9543f50c-4b5a-41b9-b416-18e3a0364832
MachineType: Dell Inc. Vostro 1720
NonfreeKernelModules: nvidia
Package: linux 2.6.31.15.28
PackageArchitecture: amd64
ProcCmdLine: root=/dev/mapper/Commedia-PrimoMobile ro i8042.reset quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/tcsh
 LANGUAGE=
 LC_COLLATE=POSIX
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-15-generic N/A
 linux-firmware 1.25
Uname: Linux 2.6.31-15-generic x86_64
UserGroups: adm admin audio cdrom dialout libvirtd lpadmin plugdev pulse pulse-access sambashare
WpaSupplicantLog:

dmi.bios.date: 04/08/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A02
dmi.board.name: 0P369J
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnDellInc.:bvrA02:bd04/08/2009:svnDellInc.:pnVostro1720:pvrNull:rvnDellInc.:rn0P369J:rvr:cvnDellInc.:ct8:cvrN/A:
dmi.product.name: Vostro 1720
dmi.product.version: Null
dmi.sys.vendor: Dell Inc.

Alessio (al-ba) wrote : IwConfig.txt
Alessio (al-ba) wrote : Lspci.txt
Alessio (al-ba) wrote : Lsusb.txt
Alessio (al-ba) wrote : RfKill.txt
Alessio (al-ba) wrote : UdevDb.txt
Alessio (al-ba) wrote : UdevLog.txt
Ruben Verhack (ruben-verhack) wrote :

I can confirm this in Jaunty and Karmic (both up to date) on an Acer Aspire 9420 (non-free: nvidia).

It seems to only slow down the hibernating and waking, but doesn't cause any problems afterwards.

Changed in linux (Ubuntu):
status: New → Confirmed
swests (simon-thewests) wrote :

This also affects Dell Latitude D620 running fully patched Karmic.

Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: simon 1775 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xefffc000 irq 21'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:83847690,102801c2,00102201 HDA:14f12bfa,14f100c3,00090000'
   Controls : 12
   Simple ctrls : 7
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=cca79d3b-fe26-41bb-a711-45d74102a95f
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: Dell Inc. Latitude D620
NonfreeKernelModules: nvidia wl
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-17-generic root=UUID=117c41b8-457f-45b8-ad83-3ee5185e821c ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-17-generic N/A
 linux-firmware 1.25
Uname: Linux 2.6.31-17-generic x86_64
UserGroups:

dmi.bios.date: 05/16/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A10
dmi.board.name: 0JK187
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA10:bd05/16/2008:svnDellInc.:pnLatitudeD620:pvr:rvnDellInc.:rn0JK187:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D620
dmi.sys.vendor: Dell Inc.

swests (simon-thewests) wrote :

But I do get a different hex number...

[ 4200.409117] btusb_bulk_complete: hci0 urb ffff88005b589840 failed to resubmit (1)
[ 4200.409233] btusb_bulk_complete: hci0 urb ffff88005b589780 failed to resubmit (1)
[ 4200.409260] btusb_intr_complete: hci0 urb ffff88005b589e40 failed to resubmit (1)

The only other Bluetooth message is
[ 4204.892132] btusb 1-2.4:1.0: no reset_resume for driver btusb?
[ 4204.892134] btusb 1-2.4:1.1: no reset_resume for driver btusb?

Gondlar (gondlar) wrote :

I can confirm this on an HP Pavillion PC. The hex numbers are different every time. I have unplugged my bluetooth USB stick and didn't get any notifications about this, but I noticed something else: This also occurs when you unplug the bluetooth device, so it seems this isn't connected to hibernating but to shutting down bluetooth. Can anyone confirm this?

When hibernating:
[27221.073119] btusb_bulk_complete: hci0 urb e8b58f00 failed to resubmit (1)
[27221.074115] btusb_bulk_complete: hci0 urb e7c05580 failed to resubmit (1)
[27221.075115] btusb_intr_complete: hci0 urb e7c05f80 failed to resubmit (1)

When plugging off the bluetooth USB stick:
[29259.649078] btusb_bulk_complete: hci0 urb ca576780 failed to resubmit (19)
[29259.649088] btusb_intr_complete: hci0 urb ca576000 failed to resubmit (19)
[29259.650075] btusb_bulk_complete: hci0 urb ca576b80 failed to resubmit (19)
[29259.650212] btusb_send_frame: hci0 urb c9faa500 submission failed

[29298.093089] btusb_bulk_complete: hci0 urb f0fb0380 failed to resubmit (19)
[29298.093100] btusb_intr_complete: hci0 urb f0fb0900 failed to resubmit (19)
[29298.094090] btusb_bulk_complete: hci0 urb f0fb0800 failed to resubmit (19)
[29298.094233] btusb_send_frame: hci0 urb c560a680 submission failed

I can confirm this bug on my laptop Samsung Q310 (with Karmic). On hibernate I get “btusb_bulk_complete: hci0 urb * failed to resubmit”. It slows down the hibernation, so it's nearly faster to turn off/on the laptop than going hibernate. Hope this bug would be fixed in Lucid.

Unfortunately this reproduces in Lucid.

Pinguinhood (marcozambon88) wrote :

I have an HP Pavilion dv5 and I Had the same problem(now I have Ubuntu lucid,but I had the same problem with Hardy,Intrepid and Karmic).
When ibernating

[ 2987.189471] btusb_intr_complete: hci0 urb f37c0d00 failed to resubmit (1)
[ 2987.190468] btusb_bulk_complete: hci0 urb f37c0d80 failed to resubmit (1)
[ 2987.191469] btusb_bulk_complete: hci0 urb f37c0e00 failed to resubmit (1)

Result of dmesg command attached

Rob S (rps) wrote :

Having exactly the same problem as Pinguinhood on a Mac mini running updated Lucid 2.6.32-22-powerpc #36-Ubuntu:

[ <#> ] btusb_intr_complete: hci0 urb <#> failed to resubmit (1)
[ <#> ] btusb_bulk_complete: hci0 urb <#> failed to resubmit (1)
[ <#> ] btusb_bulk_complete: hci0 urb <#> failed to resubmit (1)

(Can't leave machine powered on all the time, so back to MacOSX 10.5...)

thejudge (judgejules04) wrote :

I have an xps m1530 and have the same issue
dmesg
[ 1016.952420] btusb_intr_complete: hci0 urb ffff8801fbe8cb40 failed to resubmit (1)
[ 1016.953421] btusb_bulk_complete: hci0 urb ffff8801fbe8cc00 failed to resubmit (1)
[ 1016.954420] btusb_bulk_complete: hci0 urb ffff8801fbe8ccc0 failed to resubmit (1)

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed
Shouri Chatterjee (shouri) wrote :

I have seen this on my
(1) HP tx2000
(2) Dell inspiron n5010
on
(1) karmic
(2) lucid
(3) maverick

The bug is still there in maverick. I have not been using bluetooth on a regular basis at all. When I do use it, it works. I don't see any issue using bluetooth after a hibernate.

Hibernate is very slow because of this. There seems to be some sort of a time-out.

Tomi Hukkalainen (tpievila) wrote :

Happens occasionally on MacBook when trying to hibernate, resulting in a completely frozen system. Haven't been able to determine what exactly causes it, at least it's not related to using bluetooth (as I don't have any bt devices).

hawthornso23 (hawthorn) wrote :

Happens still in Maverick on a DELL E6510.

Justin (justin-wzy) wrote :

Happens in Lucid on Thinkpad X200S.

Shutting down bluetooth stops the notification.. Reopen it does not resume the notification..

My workaround is to leave bluetooth off as default and turn it on when needed.

hari1 (harbhag-sohal) wrote :

This bug is still present in Ubuntu 10.10 64bit on my Dell Inspiron N5010

jnns (jnns) wrote :

…as well as on my Fujitsu-Siemens Amilo Si3655 (running Maverick x86_64).

Janis Petersons (bakape) wrote :

Confirmed on Fujitsu-Siemens Amilo Mini Ui3520. Hibernation not working.

Constantine (theaspect) wrote :

same eeepc 1015 pem with Maverick

PeteGordon (petegordon007) wrote :

I can confirm this bug on a Samsung NC10 running up to date Maverick 10.10

I can confirm this bug on Dell Inspiron N5010 running Natty 11.04 up to date

On Thu, May 12, 2011 at 10:25 PM, Pete <email address hidden> wrote:
> I can confirm this bug on a Samsung NC10 running up to date Maverick
> 10.10
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/461632
>
> Title:
>  On Hibernate: btusb_bulk_complete: hci0 urb f2fdbe00 failed to
>  resubmit (1)
>
> Status in “linux” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  On Hibernate, system prints the below error message.
>
>  btusb_bulk_complete: hci0 urb f2fdbe00 failed to resubmit (1)
>
>  dmesg attached to the bug report.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/461632/+subscribe
>

--
Harbhag Singh Sohal
www.harbhag.wordpress.com

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix

#99 Brad, would you please (or anyone else) make clear which “series” is meant under: “This bug was filed against a series that is no longer supported”?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments