[need 2.6.34] Karmic RC tries to load rt2870sta AND rt2800usb. Results in no WiFi

Bug #460323 reported by SilverWave on 2009-10-25
140
This bug affects 22 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Jeremy Foshee
Declined for Lucid by Jeremy Foshee
Declined for Maverick by Jeremy Foshee

Bug Description

Karmic seems to try and load rt2870sta AND rt2800usb.
Breaks wireless connectivity.
Worked in Ubuntu 9.04 - Jaunty.

Confirmed Workaround:
Put the line 'blacklist rt2800usb' in /etc/modprobe.d/blacklist.conf and you are able to use wireless.

Details:
Tenda W322U 11N Wireless USB Adapter
Ubuntu 9.10 RC - Karmic

Linux neon 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009 x86_64 GNU/Linux
Ubuntu 2.6.31-14.48-generic

lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 06a3:8021 Saitek PLC Eclipse II Keyboard
Bus 001 Device 006: ID 05e3:1205 Genesys Logic, Inc. Afilias Optical Mouse H3003
Bus 001 Device 004: ID 0409:0059 NEC Corp. HighSpeed Hub

Bus 001 Device 002: ID 148f:2870 Ralink Technology, Corp.

Bus 001 Device 003: ID 0dbf:9001 Quik Tech Solutions
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Others having this issue:
http://ubuntuforums.org/showthread.php?t=960642&page=7

This bug is about devices that DON'T work BEFORE blacklisting of rt2800usb and DO work AFTER blacklisting it. If your device doesn't work even after blacklisting rt2800usb then please file a new bug.

Changed in linux (Ubuntu):
status: New → Confirmed
ctsdownloads (matt-hartley) wrote :

No go, the blacklisting does not work for me.

From dmesg:

[27214.535307] rt2870sta: module is from the staging directory, the quality is unknown, you have been warned.
[27214.537342] rtusb init --->
[27214.537380] usbcore: registered new interface driver rt2870
[27409.120657] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[27538.076667] ADDRCONF(NETDEV_UP): wlan0: link is not ready

lsusb:

Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 046d:08d7 Logitech, Inc. QuickCam Communicate STX
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 015: ID 7392:7718
Bus 001 Device 007: ID 046d:09a2 Logitech, Inc. QuickCam Communicate Deluxe/S7500
Bus 001 Device 006: ID 1267:0103 Logic3 / SpectraVideo plc G-720 Keyboard
Bus 001 Device 005: ID 046d:c01e Logitech, Inc. MX518 Optical Mouse
Bus 001 Device 004: ID 03f0:7e04 Hewlett-Packard DeskJet F4100 Printer series
Bus 001 Device 003: ID 04cc:1521 Philips Semiconductors USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

(note that nothing else shows up for that device)

iwconfig:

lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:""
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          Tx-Power=16 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Running:
Ubuntu 9.10 RC - Karmic
Edimax ew7718UN

Device is seen as wlan0 instead of ra0 as it should. Using Wicd, I can set it to ra0 which allows my own network to show up, but it will not connect. Help.

Matt Hanyok (matthew-hanyok) wrote :

some extra information to add. I have two rt2870 USB devices here. One is a Linksys WUSB600N (ID 1737:0071 Linksys) and the other is an Edimax ew7717UN (ID 7392:7717) which is slightly different than the device that ctsdownloads is using.

If I add the line "blacklist rt2870sta" to /etc/modprobe.d/blacklist.conf, neither of the devices appears to function. They see some networks, but not my own (which is wifi-n with WPA-PSK security) however they can not connect to any of these networks.

Blacklisting the "rt2800usb" module, however, allows both devices to function.

ctsdownloads: rt2800usb was brought into the 2.6.31 kernel (see http://kernelnewbies.org/LinuxChanges for a changelog, it's listed in section 14.3), so that may explain why it's now being identified as "wlan0" instead of "ra0". Although mine is showing ra0 while using rt2870sta - did you reboot after blacking the rt2800usb driver? Have you tried force removing it (sudo modprobe rt2800usb)?

Is it possible that it is just a matter of getting device IDs added to the newer rt2800usb driver? I remember that needed to be done when rt2870sta was included during the 9.04 alphas.

Matt Hanyok (matthew-hanyok) wrote :

er, sorry, that line to force the removal of the module should be "sudo modprobe -r rt2800usb".

Forgot the "-r".

njparton (njparton) wrote :

I did try 'sudo rmmod rt2800usb' at some point but I will try it again now to see if that has any effect. I did reboot after making the change to the blacklist file.

lsusb lists my usb adapter as '7718' after the colon so I don't think it's identified correctly/fully. However after a fresh install, the option to enable wireless connection is ticked when right clicking on network manager in the top right of the screen but I don't have any connections listed under the wireless section or a ra0 or wlan0 in the interfaces file. This is strange as the 9.10 RC did have a wlan0 listed (but not working). Something small has changed between the RC and final release in this area.

I'm in Vista at the moment so give me half an hour to reboot and try.

njparton (njparton) wrote :

Well I've blacklisted rt2800usb and tried to manuall unload it. I've also added rt2870sta to /etc/modules but I still don't have a wireless connection. Below are the relevant bits from dmesg, lsusb and iwconfig for my setup:

dmesg:

[ 7.687026] rt2870sta: module is from the staging directory, the quality is unknown, you have been warned.
[ 7.688926] rtusb init --->
[ 7.688948] usbcore: registered new interface driver rt2870

lsusb:

Bus 001 Device 002: ID 7392:7718
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 046d:08ad Logitech, Inc. QuickCam Communicate STX
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 002: ID 046d:c025 Logitech, Inc. MX500 Optical Mouse
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 0204:6025 Chipsbank Microelectronics Co., Ltd CBM2080 Flash drive controller
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

iwconfig:

lo no wireless extensions.
eth0 no wireless extensions.

What's interesting is that 9.10 beta gave me a wlan0 entry in network manager (although I couldn't get it working). Now I don't have anything.

xdemo (xoxdemo) wrote :

Same issue with Belkin F5D8053v4 Wireless USB Dongle.

Symptoms of issue: Cannot detect access points. (no internet/network)

Fixed with:

Step1: add "blacklist rt2800usb" to:
           /etc/modprobe.d/blacklist.conf
Step2: add "rt2870sta" to:
           /etc/modules
Step3: Reboot.

Internets is now working perfectly.

xdemo (xoxdemo) wrote :

Forgot to mention, above was with x86_64.

waka (wakabayashi60) wrote :

My key doesnt work, its a Hercules HWNU-300, I tried to blacklist but that doesnt work. Can you please help me, I cant find a solution on the internet.

Sorry for my english, i'm french ;)

FF8Jake (ff8jake) wrote :

Hi Everyone,

I would like to confirm blacklisting the rt2800usb driver and adding rt2870sta module brought my wireless back online. Here is my device info:

ff8jake@machine:~$ lsusb | grep rt2
Bus 001 Device 004: ID 07d1:3c09 D-Link System DWA-140 802.11n Adapter [ralink rt2870]

However, I am now experiencing EXTREMELY slow initial connections. An example of such would be a telnet test to google on port 80:

ff8jake@machine:~$ telnet google.com 80

(at this point, there is a 5 or so second delay. ^C does not abort the telnet process til this delay is done)

Trying 74.125.45.100...
Connected to google.com.
Escape character is '^]'.
^]

telnet> quit
Connection closed.
ff8jake@machine:~$

Reading on the rt2870sta driver it seems that it may be somewhat buggy so I assume it is to blame. Will be very happy to get rt2800usb working. :)

feffemannen (fredrik-ellborg) wrote :

I would also like to confirm this. Blacklisting rt2800usb solved it though. My device:
Bus 002 Device 002: ID 148f:2870 Ralink Technology, Corp.

Phil Hannent (phil-hannent) wrote :

I can confirm that blacklisting the rt2800usb worked for my device:

148f:3070 Ralink Technology, Corp.

I am on 64bit ubuntu 9.10

Blacklisting worked for my device airlink101 model#wll6070

njparton (njparton) wrote :

Despite this working for all these other adapters, could I please confirm that this is still a bug for the Edimax EW-7718Un USB adapter. The above solutions do not work for this adapter which uses the same ralink chipset.

term7599 (jwb7599-gmail) wrote :

Works now doing that!

Bryan (bryan-meatspace) wrote :

Here's a patch based on rt3070-2.6.31-compile.patch, which I found by googling. The rt2870 code is almost identical; I fixed up the first hunk for rt_linux.c.

Edimax EW-7718Un now works for me under 2.6.31 (Karmic). Incidentally, another workaround is just to boot an older kernel and compile the unpatched driver.

Bryan (bryan-meatspace) wrote :

Here's a patch based on rt3070-2.6.31-compile.patch, which I found by googling. The rt2870 code is almost identical; I fixed up the first hunk for rt_linux.c.

Edimax EW-7718Un now works for me under 2.6.31 (Karmic). Incidentally, another workaround is just to boot an older kernel and compile the unpatched driver.

njparton (njparton) wrote :

That's great, how would I use the patch? Thanks

Bryan (bryan-meatspace) wrote :

cd 2009_0820_RT2870_Linux_STA_V2.2.0.0
patch -p1 < rt2870-2.6.31.patch

Then compile and install according to the directions. You still need to blacklist rt2800usb. In my case I also had to add rt2870 to /etc/modules, and the following to /etc/rc.local:

# hack for wireless
ifconfig ra0 up
pkill NetworkManager

Not sure why the nm isn't bringing up the interface on its own (was the same with 2.6.28).

Having the same problem.

System: ubuntu 9.10, kernel 2.6.31
Device: encore enuwi-n3

Initial condition:
I was getting my devices listed as wlan0, but it was unable to find networks.

What I did first:

1. Blacklisted both rt2780sta and rt2800usb
-> NO Wireless at ALL

What I did later:

1. Tried to compile new rt2870 driver
-> Compiler errors

And then:

1. Blacklisted rt2800usb driver
2. Load rt2780sta
-> NO Wireless at ALL

And finally:

1. Blacklisted rt2800usb driver
3. Compile rt2870 with patch applied (success)
2. Load rt2780sta
-> NO Wireless at ALL

Now there is only a chance to try: reinstall the WHOLE system as indicated by WiseGuy1020..

But is this really necessary??? I am thinking in buying several meters of UTP cable instead...

Please help.

Bryan (bryan-meatspace) wrote :

After modprobe rt2780sta, did you try

ifconfig ra0 up
pkill NetworkManager

until I did this iwconfig showed nothing for ra0; it's needed on every boot. I also tried ditching the hated NetworkManager and using an ra0 stanza with wireless-* in /etc/network/interfaces instead, but that didn't quite work either. The interface associated to the AP (according to iwconfig), but no pings.

ricardisimo (ricardisimo) wrote :

Hello everyone. Blacklisting 2800 and adding 2780 got my connection up and running. However, something is definitely up with the connection, at least with regards to my browser. It seems to take forever to get started, and then crawls after that most often. Meanwhile, once I am connected to the Internet, if I launch Pan (my binary newsreader) it speeds along at the rates I used to see generally under Jaunty (150-300 kbps).

What gives? I'm assuming that this has something to do with ports, since I know newsreaders and browsers vary in at least that regard. Is this something that will eventually be fixed? How can I help to diagnose the problem? Thanks for everything that you do.

hope they fix this soon, made a xbmc machine i'd like to get 'n' working with.

I can confirm this is working with Tenda W311U 150Mb usb adapter. The chip reported by lsusb is actually 148F:3070 which would mean Ralink RT3070 but since I had no patch for RT3070 driver I decided to use 2009_0820_RT2870 driver and the patch supplied by Bryan.
I blacklisted rt2800usb and also rt3070sta (which was a result of my previous compiling of the RT3070 Ralink driver but without patch and it didn't work).
I also used the # hack for wireless Bryan posted.
After that my W311U is able to create ad-hoc wireless network with 150Mb speed. I am only using it for that and have no networks around me to test more.
Just another note, blacklisting rt2800usb made Karmic try to use rt2870sta driver which comes with it but for my adapter that wasn't working well. The network created was reported with speed 1Mb and my netbook very close by couldn't connect at all. I don't know whether the patch did the job, or a combination of the Ralink RT2870 driver and the patch, but in my case don't count on the built in rt2870sta after blacklisting rt2800usb. Compiling took just few steps and it worked for this adapter.

shane_flaten (shaneison) on 2009-12-08
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Incomplete
ricardisimo (ricardisimo) wrote :

I'd just like to confirm that what I described above is still the case: web browsing exceptionally slow, while newsreader zips along at usual speeds.

Is this a different bug? Should I file a bug report elsewhere? How would i test to see what is actually the cause of the problem... which package? Thank you for everything you do.

ricardisimo (ricardisimo) wrote :

OK. Something has changed in the past day or two. I'm zipping along at full speed from the get-go. I don't know what you folks did, if anything, but thanks!

STaRMaN (jarizaro) wrote :

I have a Conceptonic 150N usb dongle: Bus 002 Device 010: ID 148f:3070 Ralink Technology, Corp.
with chipset rt3070

In kubuntu karmic 64 bits, it doesnt work.

i tried with:
 - 2009_1110_RT3070_Linux_STA_v2.1.2.0.tar.bz2
and
 - RT2870_LinuxSTA_V2.3.0.0.tar.tar.bz2

from ralink site. I compile them. Drivers (both) detect network, and try to connect. But any driver work with WPA. Detect the network ok, and try to connnect, but it's always question for the key (as invalid key. but key is valid indeed).

I compile both drivers with options os/linux/config.mk with:
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
HAS_WPA_SUPPLICANT=y

any solutions?

STaRMaN (jarizaro) wrote :

AGHH, my fail.... i forgot i have mac filter in my router!. Now i have added it.

I installed again RT2870_LinuxSTA_V2.3.0.0.tar.tar.bz2 , and i did the first time "sudo make" only... , we have to do "sudo make" and "sudo make install" (i forgot the this too..)

/etc/modprobe.d/blacklist.conf:
#conceptronic 150n
blacklist rt2800usb
blacklist rt2870sta

/etc/modules:
#conceptronic 150n
rt3070sta

Now its working all ok, and speed is very good.

Thanks to all.

STaRMaN (jarizaro) wrote :

A fitfall in my last comment: The last driver i have installed is: 2009_1110_RT3070_Linux_STA_v2.1.2.0.tar.bz2 , and not RT2870_LinuxSTA_V2.3.0.0.tar.tar.bz2.

Sorry.

logari81 (logari81) on 2010-03-09
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
logari81 (logari81) on 2010-03-09
description: updated
logari81 (logari81) wrote :

I find the discussion in this bug report quite offtopic. People, it is nice to find solutions for problems, but it is preferable if this is done in an appropriate thread. This Bug Report affects firstly the following device
Bus 001 Device 002: ID 148f:2870 Ralink Technology, Corp.
and secondly devices that DON'T work BEFORE blacklisting of rt2800usb and DO work AFTER the blacklisting of this module. If your device doesn't work even after blacklisting rt2800usb then please file a new bug.

The conflict between rt2800usb and rt2870sta seems to be a general problem for several wireless adapters. On karmic we have confirmed this behaviour for the following devices:

Bus 001 Device 002: ID 0b05:1731 ASUSTek Computer, Inc. ASUS 802.11n Network Adapter
Bus 001 Device 003: ID 7392:7711
Bus 001 Device 003: ID 0df6:0017 Sitecom Europe B.V. WL-182

On Lucid:
Bus 001 Device 002: ID 0b05:1731 ASUSTek Computer, Inc. ASUS 802.11n Network Adapter

All these devices work fine after blacklisting rt2800usb

xdemo (xoxdemo) wrote :

Came back to this bug after testing lucid beta

Bus 001 Device 002: ID 050d:8053 Belkin Components
Works fine after blacklisting rt2800usb (same result in karmic)

Paul McEnery (pmcenery) wrote :

On current lucid beta this device:

Bus 001 Device 004: ID 7392:7711

Works perfectly after blacklisting rt2800usb

shclim (shclim) wrote :

I've just installed Ubuntu 10.04 amd64 and my TP-LINK TL-WN727N (see lsusb output below) doesn't work even after blacklisting rt2800usb and rt2870sta. It used to work fine on Ubuntu 9.10 amd64 by blacklisting rt2800usb

lsusb | grep Ralink
Bus 001 Device 005: ID 148f:3070 Ralink Technology, Corp.

Now, in Ubuntu 10.04, if I blacklist rt2800usb (and restart etc) the device and my networks show up in the GUI network applet. However, it can't connect to them using "WPA & WPA2". It tries to connect but then after ~1 minute re-asks for my Wifi key. My other dongle however (0ace:1215 ZyDAS WLA-54L 802.11bg) connect fine.

Any ideas?

Euyuil (euyuil) wrote :

Yes, same as #32. I've installed Ubuntu 10.04. But my 148f:3070 Ralink Technology, Corp. (Tenda W311U) didn't work. I've tried to block rt2870sta and another time rt2800usb. But the problem is still not solved.

Matt Hanyok (matthew-hanyok) wrote :

This is still happening for me in 10.04.

with rt2800usb blacklisted (using rt2870sta):
Linksys WUSB600N (ID 1737:0071) - system freezes on boot
Edimax ew7717UN (ID 7392:7717) - works fine

with rt2870sta blacklisted (using rt2800usb):
Linksys WUSB600N (ID 1737:0071) - doesn't see all wifi networks
Edimax ew7717UN (ID 7392:7717) - doesn't seem to detect this device is present

shclim (shclim) wrote :

Following on from #32. I've changed the Wifi seurity on my router to WEP (instead of "WPA & WPA2") and now it connects!

Moneta Funzionata (djmonkey1) wrote :

The status of this bug on my machine is as follows:

For 9.10, I must blacklist both rt2800usb and rt2870sta in order for wireless to connect.

For 10.04, I must blacklist only rt2800usb in order for wireless to connect.

The wireless card I use is a Rosewill RNX-N100.

Kika (kika-proo) wrote :

I don't want to change my security to WEP (in my opinion WEP is not security at all...)
Is there any solution in problem #32 spoke about? Anything new to try?

Stinger (e-mindahl) wrote :

Confirming bug on Lucid 10.04.
Can this bug please be assigned to somebody who can solve it ?

Re #32
I have a TL-WN727N too
I blacklisted rt2800usb in /etc/modprobe.d/blacklist.conf while I was using my ASUS WL-167g,
pulled the ASUS WL-167g out and plugged the TL-WN727N in, it connected instantaneously.

Im using WPA2 Personal with AES encryption, no trouble so far :-)

lsusb | grep Ralink

Bus 001 Device 006: ID 148f:3070 Ralink Technology, Corp.

Stinger (e-mindahl) wrote :

Just rebooted
Still online with my TL-WN727N, WPA2 Personal AES

Confirming that blacklisting rt2800usb works for the TL-WN727N too

Brian Pitts (bpitts) wrote :

Partially working for me with lucid and a TP-LINK TL-WN727N.

After blacklisting rt2800usb, it can associate with an unencrypted network, However, it can't associate with a network using WPA2 encryption.

With kernel 2.6.34 (as suggested in Bug #580926 ), I can connect to a WPA2 network.

I can provide more information if it is helpful and may results in the WPA2 connection problem being fixed in lucid. Just let me know what to send.

summary: - Karmic RC tries to load rt2870sta AND rt2800usb. Results in no WiFi
+ [need 2.6.34] Karmic RC tries to load rt2870sta AND rt2800usb. Results
+ in no WiFi
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Maik Wagner (mtwagner) wrote :

I am currently testing the RC of Maverick Meerkat 10.10 and would like to inform you that I got an USB-Stick with the following ID working:

Bus 001 Device 003: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter

I am not sure if I am running full speed but I can connect to my hidden wireless network okay and didn't have to do any blacklisting.

Moneta Funzionata (djmonkey1) wrote :

I have confirmed this bug to exist on my machine running the 10.10 RC. Wireless would start ok out of the box but would work for no more than a few a minutes. Blacklisting rt2800USB solved the issue.

Matt Hanyok (matthew-hanyok) wrote :

I see this was marked as "fix committed" but I have to disagree - as of the release version of 10.10 it is still happening. The Edimax adapter I am using is recognized by rt2800usb and tries to work but loses it's connection almost immediately after connecting. Using rt2870sta gets it to work properly. And it is STILL loading both of the drivers.

Karel Marik (kaja-marik) wrote :

I can confirm this wifi dongle is working out of the box on my Ubuntu 10.10. I just plug it in the USB and configured connection. Excellent done!

getnet GN-331U
Bus 001 Device 003: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Nick (morrownr) wrote :

Bug #549801 is likely a duplicate of this bug. It is not marked fix committed.

I'd like to test this fix. What release (alpha, beta or ga) should have this fix?

To post a comment you must log in.