Ubuntu

acer aspire 6930 karmic. network hardware not recognized. No lan or wlan. Works in Jaunty

Reported by Chris Chastain on 2009-10-22
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Andy Whitcroft
Nominated for Karmic by Chris Chastain

Bug Description

Binary package hint: yelp

Ubuntu does not recognize network hardware on Acer Aspire 6930. There is no Lan or Wlan. Work just fine in Jaunty

ProblemType: Bug
Architecture: i386
Date: Wed Oct 21 20:38:23 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/yelp
Package: yelp 2.28.0-0ubuntu2
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: yelp
Uname: Linux 2.6.31-14-generic i686

summary: - acer aspise 6930 karmic. network hardware not recognized. No lan or
+ acer aspire 6930 karmic. network hardware not recognized. No lan or
wlan. Works in Jaunty
affects: yelp (Ubuntu) → ubuntu
Ben Somers (somanyrobots) wrote :

I am also affected by this bug. Attaching lspci of my working, 9.04 system. I'll boot up off a liveCD later and get the broken lspci.

I'm affected by this bug too... The same pc: acer 6930...

I'll try with ubuntu 64bit

with karmic alpha5 all was working... (under wubi), so I think this is a regression

/var/log

Fixed the problem by downloading ubuntu kernel 2.6.32 rc5. Network problem seems to be solved with new kernel.

Changed in ubuntu:
status: New → Confirmed

Sorry Chris, how did you install the kernel without internet access???

(I compile kernel by myself everytime, mine is a clean install and I have not the dependencies...)

I reinstalled Jaunty, installed the new kernel to see if it would work. It did so I copied the kernel files to a flash drive, installed karmic. Installed the kernels from the flash drive and everything works fine. Writing this from that computer now. Hope this helps some.

I cannot install jaunty because I give my cd to a friend and on my new pc I have 4 primary partition... So I have to make a backup and format the entire disk... (I don't know wky acer should make 4 primary partitions on their computer...)

So I'll backup my pc, reinstall windows 7, install jaunty, compile the kernel, make deb file, upgrade to karmic, install new kernel...

For the first time I think this is a little fail for karmic QA and kernel mantainers... :(

Love ubuntu, but not this time... :)

I don't like to install jaunty because I want grub 2 on a clean install...

Locutus, (love the name by the way i'm a trekkie) I have only ubuntu on my computer. I downloaded the already compiled kernel from ubuntu's kernel backport. I found from one of the bugs you related this bug. I don't know why you have so many partitions. I only use windows in virtualision. I tried every "major" distro" to solve my problem. From Arch to Fedora. Any distro running kernel 2.6.31 has the same problem. Google "ubuntu kernel backports 2009". Find kernel 2.6.32. lastest. Down load all the x64 from another computer save them either on a cd or flash drive and install them in karmic. They are already .deb files. click all three files and yout ready to go. Let me know if I help anymore

Alexander Sack (asac) wrote :

comment https://bugs.edge.launchpad.net/ubuntu/+bug/457760/comments/6 suggests its fixed in latest upstream kernel

commnet https://bugs.edge.launchpad.net/ubuntu/+bug/457760/comments/5 refers to ubuntu linux bug and upstreawm bug.

... moving to linux package for further triaging.

affects: ubuntu → linux (Ubuntu)
Andy Whitcroft (apw) wrote :

Ok the patch mentioned on the upstream bug report linked above is applied to some test kernels for another bug, if those who are affected by this could test these kernels and report back here. Thanks! The kernels are at the URL below:

    http://people.canonical.com/~apw/lp418933-karmic/

Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Confirmed → Incomplete
Andy Whitcroft (apw) wrote :

We have multiple confirmations that the fixes here are related to the fixes in that above test kernel. I am dupping this bug against the master for this h/w combination, bug #407824.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.