Ubuntu

BOTH Network controller: Intel Corporation Wireless WiFi Link 5100 AND Ethernet controller: Marvell Technology Group Ltd. 88E8040T PCI-E Fast Ethernet Controller (rev 12) FAIL TO LOAD!

Reported by Daniel Bair on 2009-08-01
128
This bug affects 36 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Andy Whitcroft
Karmic
Medium
Andy Whitcroft

Bug Description

SRU Justification:

Impact: Another regression caused by

commit 5d423ccd7ba4285f1084e91b26805e1d0ae978ed
Author: Yinghai Lu <email address hidden>
Date: Wed May 6 08:07:52 2009 -0700

    x86/pci: remove rounding quirk from e820_setup_gap()

Fix: This has been fixed in upstream stable 2.6.31.6

commit b1b68701171493b1a744cc6c350e9b515201e7f0
Author: Yinghai Lu <email address hidden>
Date: Sun Oct 11 14:17:16 2009 -0700

    pci: increase alignment to make more space for hidden code

---

BOTH:
02:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040T PCI-E Fast Ethernet Controller (rev 12)
DO NOT WORK in Karmic BUT they used to in Hardy and Jaunty.
--------------------------------------------------

ProblemType: Bug
Architecture: amd64
Date: Sat Aug 1 17:46:22 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=03418502-fcf1-4352-9afd-0355c6be1141
MachineType: TOSHIBA Satellite P305
Package: linux-image-2.6.31-4-generic 2.6.31-4.23
ProcCmdLine: root=UUID=3e92def0-56f7-4fb9-ba3a-07df17d3cc95 ro quiet splash nmi_watchdog=0
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-4.23-generic
RelatedPackageVersions: linux-backports-modules-2.6.31-4-generic 2.6.31-4.5
SourcePackage: linux
Uname: Linux 2.6.31-4-generic x86_64
dmi.bios.date: 03/05/2009
dmi.bios.vendor: TOSHIBA
dmi.bios.version: V3.00
dmi.board.name: Satellite P305
dmi.board.vendor: TOSHIBA
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvrV3.00:bd03/05/2009:svnTOSHIBA:pnSatelliteP305:pvrPSPC8U-01400Q:rvnTOSHIBA:rnSatelliteP305:rvrNotApplicable:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: Satellite P305
dmi.product.version: PSPC8U-01400Q
dmi.sys.vendor: TOSHIBA

Daniel Bair (danielbair) wrote :
Hannes Koller (hannes-koller) wrote :

Similar Problem here on my Dell E6500 (Intel Corporation Wireless WiFi Link 5100).

Using the Network Manager I am unable to connect to a wireless network.

Using th commandline "iwlist scan" sometimes finds my wireless network and sometimes it does not. But no matter if the network is found I am always unable to connect.

dmesg says

ADDRCONF(NETDEV_UP): wlan0: link is not ready

acidbits (acidbits) wrote :

*Bump*

Same here. Toshiba U400-200 laptop, it has same ethernet/wireless controllers. They do not work with current 9.10 Beta.

acidbits (acidbits) on 2009-10-15
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: i386
acidbits (acidbits) on 2009-10-15
tags: added: karmic
tnat (tom-nat) wrote :

Same here, SMC EZ Connect g USB2 adapter, using zd1211rw with firmware 4725.

acidbits (acidbits) wrote :
acidbits (acidbits) wrote :

Confirmed, I've applied patch from:

http://bugzilla.kernel.org/show_bug.cgi?id=13940#c3

recompiled patched kernel, installed it, reboot ... and ethernet/wireless interfaces are back. :-)

Nice, but I need 64-bit...

On Thu, Oct 15, 2009 at 5:39 PM, acidbits <email address hidden> wrote:

> Confirmed, I've applied patch from:
>
> http://bugzilla.kernel.org/show_bug.cgi?id=13940#c3
>
> recompiled patched kernel, installed it, reboot ... and
> ethernet/wireless interfaces are back. :-)
>
> --
> BOTH Network controller: Intel Corporation Wireless WiFi Link 5100 AND
> Ethernet controller: Marvell Technology Group Ltd. 88E8040T PCI-E Fast
> Ethernet Controller (rev 12) FAIL TO LOAD!
> https://bugs.launchpad.net/bugs/407824
> You received this bug notification because you are a direct subscriber
> of the bug.
>

acidbits (acidbits) wrote :

Problem is'nt ethernet/wireless controller drivers. Problem comes from 2.6.31 (in 2.6.30 it worked) kernel & memory allocation when ACPI is enabled.

I tried changing laptop's wireless card for an atheros, and problem was still there.

You can either:

- Boot kernel with ACPI disabled, as stated ad bugzilla.kernel.org. (haven't tried)
- Patch and build a new kernel, even if it is 64bit.
- Wait till the patch is included in a karmic kernel update.
- Use a USB wireless dongle. I did to get linux source, and kernel tools to build a new one.

Cheers

Daniel Bair (danielbair) wrote :

Booting with ACPI disabled sounded like it caused performance issues, but
comment #36 <http://bugzilla.kernel.org/show_bug.cgi?id=13940#c36> (
http://bugzilla.kernel.org/show_bug.cgi?id=13940#c36) sounded promising:

On the bright side, booting with pci=use_crs in both the latest kernel and
2.6.31 fixes the problem.

On Fri, Oct 16, 2009 at 6:32 AM, acidbits <email address hidden> wrote:

> Problem is'nt ethernet/wireless controller drivers. Problem comes from
> 2.6.31 (in 2.6.30 it worked) kernel & memory allocation when ACPI is
> enabled.
>
> I tried changing laptop's wireless card for an atheros, and problem was
> still there.
>
> You can either:
>
> - Boot kernel with ACPI disabled, as stated ad bugzilla.kernel.org.
> (haven't tried)
> - Patch and build a new kernel, even if it is 64bit.
> - Wait till the patch is included in a karmic kernel update.
> - Use a USB wireless dongle. I did to get linux source, and kernel tools to
> build a new one.
>
> Cheers
>
> --
> BOTH Network controller: Intel Corporation Wireless WiFi Link 5100 AND
> Ethernet controller: Marvell Technology Group Ltd. 88E8040T PCI-E Fast
> Ethernet Controller (rev 12) FAIL TO LOAD!
> https://bugs.launchpad.net/bugs/407824
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Daniel Bair (danielbair) wrote :

Confirmed: pci=use_crs works beautifully!

-Daniel

On Fri, Oct 16, 2009 at 3:52 PM, Daniel Bair <email address hidden> wrote:

> Booting with ACPI disabled sounded like it caused performance issues, but
> comment #36 <http://bugzilla.kernel.org/show_bug.cgi?id=13940#c36> (
> http://bugzilla.kernel.org/show_bug.cgi?id=13940#c36) sounded promising:
>
> On the bright side, booting with pci=use_crs in both the latest kernel and
> 2.6.31 fixes the problem.
>
>
>
> On Fri, Oct 16, 2009 at 6:32 AM, acidbits <email address hidden> wrote:
>
>> Problem is'nt ethernet/wireless controller drivers. Problem comes from
>> 2.6.31 (in 2.6.30 it worked) kernel & memory allocation when ACPI is
>> enabled.
>>
>> I tried changing laptop's wireless card for an atheros, and problem was
>> still there.
>>
>> You can either:
>>
>> - Boot kernel with ACPI disabled, as stated ad bugzilla.kernel.org.
>> (haven't tried)
>> - Patch and build a new kernel, even if it is 64bit.
>> - Wait till the patch is included in a karmic kernel update.
>> - Use a USB wireless dongle. I did to get linux source, and kernel tools
>> to build a new one.
>>
>> Cheers
>>
>> --
>> BOTH Network controller: Intel Corporation Wireless WiFi Link 5100 AND
>> Ethernet controller: Marvell Technology Group Ltd. 88E8040T PCI-E Fast
>> Ethernet Controller (rev 12) FAIL TO LOAD!
>> https://bugs.launchpad.net/bugs/407824
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>
>

acidbits (acidbits) wrote :

Just moved to GRUB2. Sombebody knows where to set pci=use_crs in GRUB2?

Daniel Bair (danielbair) wrote :

Edit /etc/default/grub and change to:

GRUB_CMDLINE_LINUX_DEFAULT="pci=use_crs quiet splash"

-Daniel

On Mon, Oct 19, 2009 at 10:01 AM, acidbits <email address hidden> wrote:

> Just moved to GRUB2. Sombebody knows where to set pci=use_crs in GRUB2?
>
> --
> BOTH Network controller: Intel Corporation Wireless WiFi Link 5100 AND
> Ethernet controller: Marvell Technology Group Ltd. 88E8040T PCI-E Fast
> Ethernet Controller (rev 12) FAIL TO LOAD!
> https://bugs.launchpad.net/bugs/407824
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Andy Whitcroft (apw) wrote :

Ok the patch mentioned on the upstream bug report linked above is applied to some test kernels for another bug, if those who are affected by this could test these kernels and report back here. Thanks! The kernels are at the URL below:

    http://people.canonical.com/~apw/lp418933-karmic/

Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Confirmed → Incomplete
Daniel Bair (danielbair) wrote :

The patch appears to work, both the wireless and wired nics are working
now.
BTW, I had been using the kernel setting pci=use_crs at boot to get my nics
to work.
I removed that setting to test this kernel, so it looks good so far.

On Tue, Nov 10, 2009 at 1:54 PM, Andy Whitcroft <email address hidden> wrote:

> Ok the patch mentioned on the upstream bug report linked above is
> applied to some test kernels for another bug, if those who are affected
> by this could test these kernels and report back here. Thanks! The
> kernels are at the URL below:
>
> http://people.canonical.com/~apw/lp418933-karmic/
>
>
> ** Changed in: linux (Ubuntu)
> Status: Confirmed => Incomplete
>
> ** Changed in: linux (Ubuntu)
> Assignee: (unassigned) => Andy Whitcroft (apw)
>
> --
> BOTH Network controller: Intel Corporation Wireless WiFi Link 5100 AND
> Ethernet controller: Marvell Technology Group Ltd. 88E8040T PCI-E Fast
> Ethernet Controller (rev 12) FAIL TO LOAD!
> https://bugs.launchpad.net/bugs/407824
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Andy Whitcroft (apw) wrote :

Ok that is to sets of testing confirming this as a good fix. This fix is under review now for inclusion via SRU. Watch this bug for status updates.

Changed in linux (Ubuntu Karmic):
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → Medium
status: New → In Progress
Andy Whitcroft (apw) wrote :

The lucid kernel has this fix applied already, closing there.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Fix Released
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Stefan Bader (smb) on 2009-11-12
description: updated
Changed in linux (Ubuntu Karmic):
status: In Progress → Fix Committed
BarisBlaq (barisblaq) wrote :

I have an acer aspire 6930g, the fixes Andy Whitcroft had posted on https://bugs.launchpad.net/ubuntu/+source/linux/+bug/418933 had worked for me.

However, I now see the description changed to "fix committed" but the Karmic kernel update of today (2.6.31.15.50 I think) again wasn't able to setup wired or wireless connection. So I reverted back to the fix uploaded by Andy.

Maybe I'm misreading the status, but just wanted to point out that today's Karmic kernel update does not work.

patmalcolm91 (patmalcolm91) wrote :

I can also confirm that 2.6.31.15.50 (64 bit) in karmic does not fix this problem.

Appiah (appiah) wrote :

Same here, had to revert the kernel update.
No internet connection on the new kernel

jdobry (jdobry) wrote :

Oppps!
After today update to version
Linux jd-ntb 2.6.31-15-generic #50-Ubuntu SMP Tue Nov 10 14:53:52 UTC 2009 x86_64 GNU/Linux
2.6.31.15.28

It also fali. I must revert kernel to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/418933 and it's work.

Maarten Goris (maarten-goris) wrote :

Same here, update to 2.6.31-15-generic didn't fix the problem.

Appiah (appiah) wrote :

OK so I thought it was "Fix Released" to Karmic but it still says "Fix Commited"
And thats why the fix was not included in the updated.

We have to wait :)

BarisBlaq (barisblaq) wrote :

oh.. well i'm a noob so bear with me please =P

in the status on top of this page it says both "fix released" and "fix committed".. i thought normal progression was first " fix released" which i thought meant "there is a work around this problem" (like the kernel uploaded thanks to Andy) and then "fix committed" meaning the fix got into the normal (or mainstream? not sure of the jargon sorry) kernel.

thats what i was trying to point out, that the kernel update from "normal" karmic didn't work.. is it the next update from that on which will have the fix?

Marco (0m3g4) wrote :

fix committed is first step, fix released is second step. now, this bug is "fix released" in lucid but "fix committed" in karmic, infact the code fix is committed in mainstream karmic kernel but the new kernel isn't released yet (.deb isn't available). so, wait...

jerico (jericop) wrote :

I have never applied a patch before, but I have worked with dpk. I have tried numerous times to get this working with no success.
I downloaded all the files from http://people.canonical.com/~apw/lp418933-karmic/ and installed all the .deb packages. Sometimes in different orders. The installs seemed to work well, but when I reboot, I still have not network access (wired or wireless). I have a Toshiba with Intell Wifi 5100.

I have no clue how to apply a patch and the instructions I have found online suggest that I would apply the patch prior to creating a .deb package.

My question is, how can I get this version of the kernel installed so I can get the network hardware working. Is there a certain order for what packages to install first. Am I supposed to do something with the patch file?

Any help would be greatly appreciated. I enjoyed using Ubuntu 8.10 on my laptop in the past, but I want to take advantage of the new features of 9.10.

try this:
sudo gedit /boot/grub/grub.cfg

and add in the line with your kernel (after quiet splash) this: pci=use_crs

it works for me!

regards

Marco (0m3g4) wrote :

@LocutusOfBorg

it works for me too....so i think that new kernel with code fix will be available soon :)

@Marco
I just compiled new kernel 2.6.32...

Works so fine! :)

Accepted linux into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
patmalcolm91 (patmalcolm91) wrote :

I can confirm that this update fixes the problem.

BarisBlaq (barisblaq) wrote :

I have enabled Proposed in sources but I dont see any kernel updates there

patmalcolm91 (patmalcolm91) wrote :

I had to install the package linux-generic (which always depends on the latest generic kernel available) in order for the upgrade to happen. this is because successive kernel versions are stored in completely different packages, rather than just new versions of the same package, so a metapackage is needed to "upgrade." (this is my best understanding of it and may not be the most accurate description)

Martin Pitt (pitti) on 2009-12-14
tags: added: verification-done
removed: verification-needed

This update works beautifully

I confirm that too...

2009/12/14 LocutusOfBorg <email address hidden>

> This update works beautifully
>
> --
> BOTH Network controller: Intel Corporation Wireless WiFi Link 5100 AND
> Ethernet controller: Marvell Technology Group Ltd. 88E8040T PCI-E Fast
> Ethernet Controller (rev 12) FAIL TO LOAD!
> https://bugs.launchpad.net/bugs/407824
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
--
Cumprimentos

Augusto Campos
<email address hidden>
<email address hidden>
<email address hidden>
<email address hidden>

Launchpad Janitor (janitor) wrote :
Download full text (11.9 KiB)

This bug was fixed in the package linux - 2.6.31-17.54

---------------
linux (2.6.31-17.54) karmic-proposed; urgency=low

  [ John Johansen ]

  * SAUCE: AppArmor: Fix oops after profile removal
    - LP: #475619
  * SAUCE: AppArmor: Fix Oops when in apparmor_bprm_set_creds
    - LP: #437258
  * SAUCE: AppArmor: Fix cap audit_caching preemption disabling
    - LP: #479102
  * SAUCE: AppArmor: Fix refcounting bug causing leak of creds
    - LP: #479115
  * SAUCE: AppArmor: Fix oops there is no tracer and doing unsafe
    transition.
    - LP: #480112

  [ Leann Ogasawara ]

  * Revert "[Upstream] (drop after 2.6.31) usb-storage: Workaround devices
    with bogus sense size"
    - LP: #461556
  * Revert "[Upstream] (drop after 2.6.31) Input: synaptics - add another
    Protege M300 to rate blacklist"
    - LP: #480144

  [ Tim Gardner ]

  * [Config] udeb: Add squashfs to fs-core-modules
    - LP: #352615

  [ Upstream Kernel Changes ]

  * Revert "e1000e: swap max hw supported frame size between 82574 and
    82583"
    - LP: #461556
  * Revert "drm/i915: Fix FDI M/N setting according with correct color
    depth"
    - LP: #480144
  * Revert "agp/intel: Add B43 chipset support"
    - LP: #480144
  * Revert "drm/i915: add B43 chipset support"
    - LP: #480144
  * Revert "ACPI: Attach the ACPI device to the ACPI handle as early as
    possible"
    - LP: #327499, #480144
  * SCSI: Retry ADD_TO_MLQUEUE return value for EH commands
    - LP: #461556
  * SCSI: Fix protection scsi_data_buffer leak
    - LP: #461556
  * SCSI: sg: Free data buffers after calling blk_rq_unmap_user
    - LP: #461556
  * ARM: pxa: workaround errata #37 by not using half turbo switching
    - LP: #461556
  * tracing/filters: Fix memory leak when setting a filter
    - LP: #461556
  * x86/paravirt: Use normal calling sequences for irq enable/disable
    - LP: #461556
  * USB: ftdi_sio: remove tty->low_latency
    - LP: #461556
  * USB: ftdi_sio: remove unused rx_byte counter
    - LP: #461556
  * USB: ftdi_sio: clean up read completion handler
    - LP: #461556
  * USB: ftdi_sio: re-implement read processing
    - LP: #461556
  * USB: pl2303: fix error characters not being reported to ldisc
    - LP: #461556
  * USB: digi_acceleport: Fix broken unthrottle.
    - LP: #461556
  * USB: serial: don't call release without attach
    - LP: #461556
  * USB: option: Toshiba G450 device id
    - LP: #461556
  * USB: ipaq: fix oops when device is plugged in
    - LP: #461556
  * USB: cp210x: Add support for the DW700 UART
    - LP: #461556
  * USB: Fix throttling in generic usbserial driver
    - LP: #461556
  * USB: storage: When a device returns no sense data, call it a Hardware
    Error
    - LP: #400652, #461556
  * arm, cris, mips, sparc, powerpc, um, xtensa: fix build with bash 4.0
    - LP: #461556
  * intel-iommu: Cope with broken HP DC7900 BIOS
    - LP: #461556
  * futex: Detect mismatched requeue targets
    - LP: #461556
  * futex: Fix wakeup race by setting TASK_INTERRUPTIBLE before queue_me()
    - LP: #461556
  * tpm-fixup-pcrs-sysfs-file-update
    - LP: #461556
  * TPM: fix pcrread
    - LP: #461556
  * Bluetooth: Disconnect HIDRAW devices on disconnect
    - LP...

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released

Hi,

Thanks for this. It gave me the solution with Intel 5100 AGN on EliteBook 6930p with lucid beta (Linux MX-201470 2.6.32-17-generic #26-Ubuntu SMP Sat Mar 20 02:23:45 UTC 2010 x86_64 GNU/Linux). I was unable to connect network with wifi.

And it work fine adding pci=use_crs in /etc/default/grub
followed by an updage-grub, as suggested by LocutusOfBorg (2009-11-29 #27).

Does it mean anyway that the problem is there again in lucid ?

Have a nice day

May be I was a bit too optimistic...

dmesg (only one package on try... but it is always like that)

[ 2683.631282] iwlagn 0000:03:00.0: free more than tfds_in_queue (0:1)
[ 2683.830292] wlan0: direct probe to AP 00:18:84:88:1f:a6 timed out
[ 2720.845090] wlan0: direct probe to AP 00:18:84:88:1f:a6 (try 1)
[ 2720.846072] iwlagn 0000:03:00.0: free more than tfds_in_queue (0:1)
[ 2721.040060] wlan0: direct probe to AP 00:18:84:88:1f:a6 (try 2)
[ 2721.041002] iwlagn 0000:03:00.0: free more than tfds_in_queue (0:1)
[ 2721.240193] wlan0: direct probe to AP 00:18:84:88:1f:a6 (try 3)
[ 2721.241317] iwlagn 0000:03:00.0: free more than tfds_in_queue (0:1)
[ 2721.440212] wlan0: direct probe to AP 00:18:84:88:1f:a6 timed out

I also tried manually, nothing convinient.

Really ugly... I'm updating my lucid beta too... I have the same controller, so I'll try to see if I see a regression of this bug

Just updated to 2.6.32-18-generic and I cannot reproduce this bug anymore.

Re,

sorry but I am not really a specialist and I do not know what exactly to check. Maybe I should go on another forum to try to solve my problem, but I do where.

that's my grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=use_crs"

I also updated to 2.6.32-18-generic

Detail of wifi controller

sudo lspci -vvnn -d 1002:95c4
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Mobility Radeon HD 3400 Series [1002:95c4]
 Subsystem: Hewlett-Packard Company Device [103c:30dc]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 32
 Region 0: Memory at c0000000 (32-bit, prefetchable) [size=256M]
 Region 1: I/O ports at 7000 [size=256]
 Region 2: Memory at d8300000 (32-bit, non-prefetchable) [size=64K]
 Expansion ROM at d8320000 [disabled] [size=128K]
 Capabilities: [50] Power Management version 3
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [58] Express (v2) Legacy Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
   ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
   MaxPayload 128 bytes, MaxReadReq 128 bytes
  DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
  LnkCap: Port #0, Speed 5GT/s, Width x16, ASPM L0s L1, Latency L0 <64ns, L1 <1us
   ClockPM- Suprise- LLActRep- BwNot-
  LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
 Capabilities: [a0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
  Address: 00000000fee0200c Data: 41c9
 Capabilities: [100] Vendor Specific Information <?>
 Kernel driver in use: radeon
 Kernel modules: radeon

iwconfig wlan0
wlan0 IEEE 802.11abgn ESSID:"XXXXXXXXX"
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          Tx-Power=15 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off

no way to get AP even with the sudo iwconfig wlan0 ap xx:xx:xx:xx:xx:xx

I tried with various wifi router (without key, WEP, WPA) no success...

with the right lspci it is better

sudo lspci -vvnn -d 8086:4237
03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection [8086:4237]
 Subsystem: Intel Corporation Device [8086:1211]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 31
 Region 0: Memory at d8100000 (64-bit, non-prefetchable) [size=8K]
 Capabilities: [c8] Power Management version 3
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
  Address: 00000000fee0300c Data: 41c1
 Capabilities: [e0] Express (v1) Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 unlimited
   ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset+
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+ FLReset-
   MaxPayload 128 bytes, MaxReadReq 128 bytes
  DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
  LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <128ns, L1 <32us
   ClockPM+ Suprise- LLActRep- BwNot-
  LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
 Capabilities: [100] Advanced Error Reporting <?>
 Capabilities: [140] Device Serial Number 70-fe-f0-ff-ff-65-1e-00
 Kernel driver in use: iwlagn
 Kernel modules: iwlagn

Sorry for the trooble. I discover what was the problem. Main antenna was unconnected of the main componant... conected it works perfectly as mentionned in my first message. Thanks for having taken sometimes to check.
Have a nice evening.

Really good news... :)

You can remove pci=use_crs because is not needed anymore!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.