no sound from integrated speakers (Realtek ALC269, snd-hda-intel driver)

Bug #445889 reported by Dan Lenski on 2009-10-07
This bug affects 14 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

I'm using a brand-new Acer AS1410 notebook/netbook, with Ubuntu 9.10 Netbook Remix. The manufacturer reports the audio chip as Realtek ALC269, although lspci says it's an Intel ICH9 HD Audio Controller (pci id 8086:293c).

With the snd-hda-intel driver, configured for analog output, the sound card works correctly with headphones plugged in. However, with no headphones plugged in, there is *no sound* from the integrated speakers.

This includes the PC speaker beep. I modprobe pcspkr and try to get a beep, and there's nothing.

I know that the internal speakers work fine under Windows Vista Home Premium with the supplied drivers from Realtek.

I've tried some of the suggestions about tweaking the model parameter of snd-hda-intel module: None of these makes a difference. Regardless of the chosen model name, I get the following warning in /var/log/messages:

hda_codec: Unknown model for ALC269, trying auto-probe from BIOS...

Any ideas what might be causing this bug?

ProblemType: Bug
Architecture: i386
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
 /dev/snd/controlC0: dlenski 2418 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
 Card hw:0 'Intel'/'HDA Intel at 0xd4500000 irq 22'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:10ec0269,1025029b,00100004 HDA:80862802,80860101,00100000'
   Controls : 23
   Simple ctrls : 12
Date: Wed Oct 7 19:16:54 2009
DistroRelease: Ubuntu 9.10
MachineType: Acer Aspire 1410
Package: linux-image-2.6.31-11-generic 2.6.31-11.38
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=b41da73a-d227-4ee1-b9e7-092cda40dbb6 ro quiet splash
 PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
 linux-backports-modules-2.6.31-11-generic N/A
 linux-firmware 1.20
SourcePackage: linux
Tags: ubuntu-unr
Uname: Linux 2.6.31-11-generic i686 09/08/2009
dmi.bios.vendor: INSYDE
dmi.bios.version: v0.3117
dmi.board.asset.tag: Base Board Asset Tag Base Board Product Name
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrv0.3117:bd09/08/2009:svnAcer:pnAspire1410:pvrv0.3117:rvnAcer:rnBaseBoardProductName:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion: Aspire 1410
dmi.product.version: v0.3117
dmi.sys.vendor: Acer

Dan Lenski (lenski) wrote :
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Dan Lenski (lenski) wrote :

Well... after playing around in Linux for a while, trying to get the internal speakers to work, I went back to check the Windows settings. And *now* the internal speakers don't work in Windows either. Verrrry strange. I tried a hard reboot, tried removing and reinstalling the battery, tried reinstalling the Realtek Audio drivers in Windows... still nothing.

Is it possible that this hardware stores some state in NVRAM or something like that, which neither Windows nor Linux driver normally accesses??

Dan Lenski (lenski) wrote :

Okay, I've got the situation slightly improved...

I read HD-audio.txt in the kernel documentation ( and it mentioned the great frequency of problems with internal speaker outputs with this driver.

It explained that the following /var/log/messages error is not a huge deal *IF* the BIOS is correctly configured:

  hda_codec: Unknown model for XXXXXX, trying auto-probe from BIOS...

Well, presumably my BIOS is *not* correctly configured, since neither Linux nor Windows can use the internal speaker with the default settings.

So, as suggested by HD-audio.txt, I tried different "model" parameter values with snd-hda-intel (list of choices is here: I tried the "model=basic" option listed for the ALC269 codec.

And now the internal speakers work!!! *But* there are other problems:

(1) When I plug headphones into the heaphone jack, the internal speakers are not muted. There is apparently no way to get this to happen automatically with the basic model. (Pulseaudio gets confused if I try to tweak the front vs. headphone settings separately via Alsamixer... but I'll call that a Pulseaudio bug.)

(2) Alsamixer doesn't know about the correct microphone input options for this computer

(3) There's a little red LED inside the headphone jack which is supposed to be used to transmit digital audio using IEC958 or S/PDIF. With the "model=auto" setting, I can turn this LED on or off by enabling or disabling "digital audio" via the mixer controls. But with the "model=basic" setting, the LED stays off. Although I don't have the equipment to use digital audio myself, I assume that it wouldn't work with "model=basic".

SUMMARY: Basically, it seems that there is a BIOS problem on this computer that does not set up the correct defaults to allow the internal speakers to work. So probably a new snd-hda-intel "model profile" should be constructed for this notebook. I would be happy to explore this further, if someone would give me advice on how to get started doing it. Thanks!!

Jim Lieb (lieb) wrote :

Some of these settings are in nvram. What is interesting is the WinXP also gets lost. Try checking Acer for a BIOS update and if they have a help line, as for their help to get XP to work again. This can give clues wrt getting Karmic to work as well. If the BIOS is in its present confused state, neither we nor MS can do a sensible default. Once XP is happy, we can then work on snd_hda+ac269 to make them happy.

Dan Lenski (lenski) wrote :

Hi Jim, thanks for the reply! By NVRAM, do you mean the BIOS NVRAM? Is there any way to access it without possibly trashing the BIOS?

I did get in touch with Acer's customer support, who were not so helpful. At first they told me it must be a hardware issue, which of course I was suspicious of. Then after I figured out the speakers *do* work under Linux, ignoring the BIOS settings, they said that I would still have to send it to them to diagnose the problems. I told them I had applied the latest BIOS updates, and they admonished me that updating the BIOS was risky and dangerous (even with the official Acer images???). So, not so useful :-p. But you can read the whole back-and-forth on the incident by clicking here:
and then entering the email address <email address hidden>

Two days ago, they released another BIOS update and I was hoping that would fix the problem... but it doesn't.

If the issue is in the NVRAM, I don't understand why BIOS updates don't fix it, since they seem to erase all the other BIOS setting stored in NVRAM.

So, weird bug... if I could figure out how to read the NVRAM settings and tweak them into a format that snd_hda_intel could use, I could probably fix it.

Jim Lieb (lieb) wrote :

Dan, You can't really read the nvram, actually this is battery powered CMOS RAM in the RTC, because every bios puts its own version specific stuff in there. A bios flash usually keeps those values or at the very least resets them to the factory default if the new version re-shuffles the memory structure. The flashing does not touch the rtc ram in any event.

Sure, flashing bios is dangerous in that if it gets interrupted, you have a silicon brick on your hands although you can get a bios back/re-flashed on some southbridge implementations if they implement a bios bootstrap that can load an image from floppy/cd.

Does Win/XP still not recognize the speakers or did that get fixed? If Win/XP now works properly, we can address the Linux issue. If not, your bios settings are still hosed and will need to be reset.

Most BIOSs have a "factory settings" menu option. If they didn't have you do that, give it a go after noting and saving what you changed. If that doesn't do it, go to the next step...

The following procedure is based on what has been around for ages on deskside/top PCs. I have an HP laptop whose wireless access went over the edge and resetting to factory didn't do the deed, requiring this procedure to bring it back. This may not be the case with your netbook. The mfr's cut corners everywhere on these little boxes and this may not be possible and/or require the customer to be taking bits apart which makes any tech support person queasy. This may be why they wanted you to RMA the unit. They know where the secret snaps and buttons are to crack the case without damaging the plastic. Check with Acer first!

You clear the settings completely by removing the chicklits battery on a conventional mboard. Some boards may have a "clear cmos" jumper to do this. How this is done on your laptop/netbook, I don't know. What you are doing w/ this procedure is discharging the CMOS RAM power which clears it. The bios checksums this data every time you make a settings change so clearing ram is detected by the bogus checksum. This will cause the bios to re-init the ram to factory defaults. Win/XP *should* work after this.

Dan Lenski (lenski) wrote :

Hey Jim, unfortunately resetting the BIOS settings to factory defaults doesn't fix the issue (either under Linux or Windows). I'm wondering if the "factory default" settings offered by the BIOS don't match the actual factory default settings of the as-shipped laptop :-(

I'll try to find out if there's an easy way to remove the CMOS backup battery on this laptop.

I'm unclear on why you say that the CMOS RAM/NVRAM can't be read by software... isn't that what the snd_hda_intel driver does when it tries to use the BIOS settings??

Pat Colangelo (pcolangelo-73) wrote :

"So, as suggested by HD-audio.txt, I tried different "model" parameter values with snd-hda-intel (list of choices is here: I tried the "model=basic" option listed for the ALC269 codec."

How do i change the model parameter values?

Dan Lenski (lenski) wrote :

Pat, if you explicitly modprobe the sound driver, you can do it like this:

# modprobe snd-hda-intel model=basic

Or you can edit /etc/modprobe.d/alsa-base.conf and add the line:

options snd-hda-intel model=basic

This will cause the correct options to be loaded automatically. In practice, I've found that changing the model option does not have a reliable effect after unloading and reloading the driver, so you should probably edit alsa-base.conf, and then reboot.

Dan Lenski (lenski) wrote :

I read with great interest about a recent change to the HDA audio driver in the 2.6.32 kernel:

Apparently, there's now a module option to communicate hardware details or quirks to the HDA driver *without* recompiling or reloading it. Does this mean I could experiment with HDA sound settings more easily now? Does anyone know if there's any documentation written on how to do so under the 2.6.32 kernel?

Arwin Tugade (arwin-tugade) wrote :

Well I just got a Sony Vaio VPCEB15FM and I have the same problem of the card being detected but no sound from the speakers or headphone jack. I tried the module option but none of them fixed my issue.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: INTEL HDMI 0 [INTEL HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 7: INTEL HDMI 1 [INTEL HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

There is this tool that lets you flip settings around but the changes aren't persistant:

To get my speakers working, I ran the hda_analyzer above and under "Node[0x19]" at the bottom in a pane called "Widget Control", I flipped the VREF to "HIZ" and that did the trick. Because I'm impatient, I flipped this value in the kernel source tree I'm using (stable



Recompiled and it's persistent. This is just informational and is by no means a official solution, so use it at your own risk, I just wanted to get this out of the way so I can get on to using my laptop.


with kernel 2.6.32-20 the sound is back ( i own a vaio e series with alc269 ) BUT it is too low! even if i played with alsamixer and set everything to max its still very low. Great job guys! keep working ;)

Mark Kaehny (kaehny) wrote :

I will add I have had the same problem with Sony Vaio and my current workaround:
Sony Vaio VPCEB15FX with ALC269 just like comment 11 above. I grabbed the hda-verb program compiled and installed it and used:
sudo hda-verb /dev/snd/hwC0D0 0x19 SET_PIN_WIDGET_CONTROL 0x22

which is essentially the same thing as suggested in #11 above.

To recap:
Symptoms - Sound works perfectly in Windows and in VM of 9.10 Ubuntu
Installed 10.04 Kubuntu beta 2 in new partition and there was NO sound anywhere - internal speakers or headphones. I tried all the alsa config file tricks in Comprehensive Sound card nothing worked, snooping I saw this as an option and tried it and it works. So I copied the command to startup script since it needs to be run after every bootup.

One caveat - the sound level is acceptable to me, but it is really too low. I have kmix maxed out on everything and it is just ok in volume. I suspect I may be in the state #12 is in. Some base level needs to be upped. This is for both internal speakers and headphones.

Also the F3 - Mute keyboard option works but the F4 (Vol down and F5 Vol up keys do not work).

I have not checked what kernel beta 2 is using.

Vladimir Hidalgo (vlad88sv) wrote :

Linux aurox 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 i686 GNU/Linux

Vaio VPCEB15EL, sound does not work.

Aplay output:
**** Lista de PLAYBACK dispositivos hardware ****
tarjeta 0: Intel [HDA Intel], dispositivo 0: ALC269 Analog [ALC269 Analog]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0
tarjeta 0: Intel [HDA Intel], dispositivo 3: INTEL HDMI [INTEL HDMI]
  Subdispositivos: 1/1
  Subdispositivo #0: subdevice #0

Guilhem Lettron (guilhem-fr) wrote :

I think this bug is quite important.

We have many Dell Optiplex 980 who have this bug.
I don't want to go on all of my computers to change "model=basic" ...

Looks like this is fixed upstream for Sony Vaio users with ALC269 with the following patch:

tags: added: alc269
David Henningsson (diwic) wrote :

I believe this issue is about to be fixed. Can you please try installing , reboot and report back whether it fixes your problem?

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Timothy Kross (timkross) wrote :

Thank you sir, it worked. My headphone jack works now, and internal (and external) mics do too.

Theresa (theresa) wrote :

David, i've installed your deb file, but alas it's still not working for me :(

i took a screenshot of my kmix preferences, maybe you can give me a clue what i'm doing wrong, because i think my head cant take much more banging against the wall :((((((

hmm i don't think i have anything muted...but what am I doing wrong? i just cant get a noise out of my internal microphone when using skype....

PLEASE help....

Timothy Kross (timkross) wrote :


My mic was muted after I installed that deb (it didn't work before the deb).Open gnome-volume-control and in the input tab, unmute the mic. And check if it then works.

Theresa (theresa) wrote :

dear all,

to keep you updated, i finally found the solution to my problem!!

for anyone who's interested or has the same problem:

i had to add the following line at the end of /etc/modprobe.conf/alsa-base.conf:

options snd-hda-intel model="olpc-xo-1_5"

i then rebooted, and then both the mic finally worked and the speaker allowed me a higher volume :)

Yoni Baciu (yonibaciu) wrote :

I confirm that installing fixed the no-sound problem in the headphones.

Hardware: Inspiron 17R, Ubuntu 10.04

Thank you!

I confirm that installing fixed the problem with no sound on Sony VAIO VPCEB1M1E, in Ubuntu Lucid 10.04.

Thanks for taking care of that bug!

BTW, bug 534372 seems to be a duplicate of this one, as I got the exact same symptoms, and the workaround from that bug (using hda-verb) works for me.

Vita Stejskal (vita.stejskal) wrote :

I too confirm that the fixes the problem. My laptop is Asus K52DR and the devices as reported by 'aplay -l' are:

vita@vita-laptop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC259 Analog [ALC259 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Also alsamixer now correctly shows the 'headphone' control. Thanks for fixing this bug!

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Grayside (grayside) wrote :

I am seeing this issue still. Ubuntu 10.10, Asus N61JQ

Setting options snd-hda-intel model="olpc-xo-1_5" or options snd-hda-intel model="basic" does not seem to do anything.
Installing gets a response of having a bunch of obsoleted modules, and does not appear to do anything. Lots of restarting involved.

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

quil10 (quil10) wrote :

I also have been experiencing this issue. Plugging earphones in didn't cause the speakers to mute and the microphone didn't record anything. The solution was to comment out the following line in /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel model=lifebook

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers