Comment 13 for bug 445889

Mark Kaehny (kaehny) wrote :

I will add I have had the same problem with Sony Vaio and my current workaround:
Sony Vaio VPCEB15FX with ALC269 just like comment 11 above. I grabbed the hda-verb program compiled and installed it and used:
sudo hda-verb /dev/snd/hwC0D0 0x19 SET_PIN_WIDGET_CONTROL 0x22

which is essentially the same thing as suggested in #11 above.

To recap:
Symptoms - Sound works perfectly in Windows and in VM of 9.10 Ubuntu
Installed 10.04 Kubuntu beta 2 in new partition and there was NO sound anywhere - internal speakers or headphones. I tried all the alsa config file tricks in Comprehensive Sound card nothing worked, snooping I saw this as an option and tried it and it works. So I copied the command to startup script since it needs to be run after every bootup.

One caveat - the sound level is acceptable to me, but it is really too low. I have kmix maxed out on everything and it is just ok in volume. I suspect I may be in the state #12 is in. Some base level needs to be upped. This is for both internal speakers and headphones.

Also the F3 - Mute keyboard option works but the F4 (Vol down and F5 Vol up keys do not work).

I have not checked what kernel beta 2 is using.