[boot-experience] status/debugging text incorrectly appears on boot

Bug #444362 reported by Jane Silber on 2009-10-06
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned
linux-restricted-modules (Ubuntu)
Undecided
Unassigned
lsb (Ubuntu)
High
Unassigned

Bug Description

IIRC, we took a decision several releases ago that there should be no text that scrolls by the user in a normal boot. In the Karmic beta there are about 10-15 lines of status/debugging text that appear between grub and the new splash sequence. I didn't capture them all, but they are something like
- creating preliminary keymap
- preparing restricted drivers
- setting up app armor
- etc

I have done a normal dist upgrade from 9.04 to Karmic Beta, not special verbose settings or anything.

Jane Silber (silbs) wrote :

I'm un-duping this from #441615, #438229, #441902. All of those are about the splash not appearing/not working. This bug, in contrast, is about text appearing before the splash screen. It is as if quiet mode is turned off (and, iirc, we have made quiet the default).

tags: added: regression-potential
Andy Whitcroft (apw) wrote :

Those sounds like messages comming from sysV init scripts as they start various services. This is likely not kernel related. Will try and figure out which packages are involved.

Andy Whitcroft (apw) on 2009-10-07
Changed in linux (Ubuntu):
status: New → Invalid
summary: - status/debugging text incorrectly appears on boot
+ [boot-experience] status/debugging text incorrectly appears on boot
Kees Cook (kees) wrote :

Hm, is there any way to get a movie of this? Speaking for AppArmor, it _should_ be correctly handling the "quiet" option (it was fixed for the new initramfs hook), but prior to Karmic this wasn't a problem. (Perhaps the lack of usplash hiding it is the issue?)

Jane Silber (silbs) wrote :

Video of boot attached.

I also have this bug. The initial usplash isn't working, so we see the init messages until xsplash is loaded.

Note: usplash works correctly if you cleanly install the beta, but not when you upgrade from 9.04

Steve Langasek (vorlon) wrote :

These are definitely not from sysvinit scripts, they happen much earlier - and a number of them are definitely kernel messages:

[ 28.893465] type=1505 audit(1255945942.583:2): operation="profile_load" pid=595 name=/usr/share/gdm/guest-session/Xsession

There are a number of such messages, as well as messages from the ext3 driver:

[ 27.380727] EXT3-fs: dm-4: orphan cleanup on readonly fs

and a message when swap starts:

[ 31.382239] Adding 1048568k swap on /dev/mapper/dario-swap. Priority:-1 extents:1 across:1048568k

as well as one when the kernel considers whether it has a hibernate image to resume from:

[ 15.183599] PM: Starting manual resume from disk

AFAICS, none of these messages should appear when booting with 'quiet'.

This is high-priority for lucid, although now that usplash is on by default in karmic again it doesn't need to be fixed for the karmic release.

Changed in linux (Ubuntu):
importance: Undecided → High
status: Invalid → Triaged
Steve Langasek (vorlon) wrote :

I also see the llist of post-kernel messages, which do come from sysvinit scripts:

 * Setting preliminary keymap...
 * Preparing restricted drivers...
 * Starting early crypto disks...
 * Starting remaining crypto disks...
 * Starting AppArmor profiles
 * Setting up console font and keymap...
 * Starting init crypto disks...
 * sda5_crypt (running)...

This looks like a bug in either lsb-base (which provides the common log functions these scripts are all calling), or in upstart (for not setting up the expected environment for these scripts). I'll have a look.

FWIW, I no longer see those messages. For me at least, it seems to have
been fixed in some of the updates that have come out during the beta period.

Steve Langasek (vorlon) wrote :

Reassigning this to the lsb package for now.

affects: apparmor (Ubuntu) → lsb (Ubuntu)
Changed in lsb (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in linux-restricted-modules (Ubuntu):
status: New → Invalid
Changed in console-setup (Ubuntu):
status: New → Invalid

From the kernel side of things, this should have been resolved with the following commit. As a result, I'm marking the linux kernel task as Fix Released. Thanks.

ogasawara@yoji:~/ubuntu-karmic$ git show 9385ea99ffbab9d5ad46976c71c3fca59c20021b
commit 9385ea99ffbab9d5ad46976c71c3fca59c20021b
Author: Tim Gardner <email address hidden>
Date: Thu Oct 8 11:42:36 2009 -0600

    UBUNTU: SAUCE: Raise the default console 'quiet' level to 2

    In the interests of providing a clean boot experience, i.e., a blank screen
    before X starts, supress noisy driver messages.

    See https://lists.ubuntu.com/archives/kernel-team/2009-October/007476.html
    for the original diatribe.

    Signed-off-by: Tim Gardner <email address hidden>

Changed in linux (Ubuntu):
status: Triaged → Fix Released
tags: added: regression-release
removed: regression-potential
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments