Ubuntu

NC10 fails to up and down the brightness

Reported by Steve Kowalik on 2009-08-06
82
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Unknown
linux (Ubuntu)
Medium
Unassigned
Nominated for Karmic by Cedric F.

Bug Description

Hitting the brightness keys on a Samsung NC10 has no effect.

ProblemType: Bug
Architecture: i386
Date: Thu Aug 6 15:23:34 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=542e817b-4e7b-48d6-a44a-2f5f96e777d0
MachineType: SAMSUNG ELECTRONICS CO., LTD. NC10
Package: linux-image-2.6.31-5-generic 2.6.31-5.24
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-5-generic root=UUID=8e34b89d-31a5-4e94-bc5b-7175d61ad011 ro quiet splash
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
RelatedPackageVersions: linux-backports-modules-2.6.31-5-generic N/A
SourcePackage: linux
Tags: ubuntu-unr
Uname: Linux 2.6.31-5-generic i686
dmi.bios.date: 12/11/2008
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: 04CA.MP00.20081211.KTW
dmi.board.name: NC10
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvr04CA.MP00.20081211.KTW:bd12/11/2008:svnSAMSUNGELECTRONICSCO.,LTD.:pnNC10:pvrNotApplicable:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNC10:rvrNotApplicable:cvnSAMSUNGELECTRONICSCO.,LTD.:ct10:cvrN/A:
dmi.product.name: NC10
dmi.product.version: Not Applicable
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

Steve Kowalik (stevenk) wrote :
Mathieu Marquer (slasher-fun) wrote :

Confirming, and adding some weird facts :
* Creating /etc/modprobe.d/something.conf with "options i915 modeset=0" has no effect
* Adding "i915,modeset=0" to grub kernel command line displays a "i915,modeset=0 unknown, ignoring", *however* I can correctly set the brightness after booting with this supposed-to-be-unknown-option

Let me know if you need additionnal details.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: xorg-needs-kernel-fix
Mathieu Marquer (slasher-fun) wrote :

Actually the grub option doesn't always works (I'd better say "almost never works")...

Mathieu Marquer (slasher-fun) wrote :

OK, the right grub option was "nomodeset". With that option, KMS is disabled (so Ctrl+Alt+Fx takes a "long" time), and I can normally set the brightness with the Fn Up/Down keys.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Jarmo Ilonen (trewas) wrote :

A kernel patch for backlight support for (few) samsung laptops was presented by Greg K-H in
http://lkml.org/lkml/2009/8/16/274 . Apparently it is not included in upstream final 2.6.31 kernel.

Mathieu Marquer (slasher-fun) wrote :

It seems the bug has been fixed in Intel driver 2.9.0
http://bugs.freedesktop.org/show_bug.cgi?id=20963

Changed in linux:
status: Unknown → Fix Released
Mathieu Marquer (slasher-fun) wrote :

I've tried Intel 2.9.0 graphics driver, without any improvement, so it seems that patching the kernel is not an option to solve this issue.

trtl (pdersjant) wrote :

Updated Karmic works fine. It started to work somewhere around (ie a couple of days before) the beta release.

Philip Lowman (philip-yhbt) wrote :

The latest Karmic doesn't work for me (NC10). The Gnome Power Manager Brightness Applet reports "Cannot get laptop panel brightness" and the hotkeys do not function.

If this is relevant at all (briefly mentioned in the Freedesktop bug entry) there are no files in the /sys/class/backlight directory.

Cedric F. (c-fachinetti) wrote :

It affect me too...

Why this bug does not appear in the karmic's bug ?

trendzetter (trendzetter) wrote :

Aspire timeline 5810T same problem

Cedric F. (c-fachinetti) wrote :

Nec versa m4200, same problem.

Pete Graner (pgraner) wrote :

@trendzetter & @Cedric F.

While this is the same symptom it s not the same bug, these types of bugs are very hardware specific. Could you please open a new bug for each of your models with:

ubuntu-bug linux

Thanks

tags: added: regression-potential
Cedric F. (c-fachinetti) wrote :

Is that freedesktop fix will be integrate to karmic ?

bigjimlefou (bigjimlefou) wrote :

same for me on samsung N110

trendzetter (trendzetter) wrote :

@Pete Graner: I already did: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/428054
I am under the impression that a wide range of intel grafic cards has the same problem or similar problems with controlling the backlight under KMS. Searching the bugs and forums certainly indicates that. I can't understand why intel is not fixing this. I bought intel onboard because I thought they were cool with linux and GPL. Maybe I am just to inpatient but it wouldn't be no unnecessary luxury to have this in the final karmic release.

Philip Lowman (philip-yhbt) wrote :

As reported on bug #397617, the easiest way to resolve this problem is to update the BIOS on your NC10.

I just updated to version 11CA and the brightness up/down keys are now working again!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.