xrandr backlight property control missing (when using KMS?)

Bug #428054 reported by trendzetter on 2009-09-11
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by trendzetter

Bug Description

Binary package hint: xserver-xorg-video-intel

xrandr is missing a backlight property:
$ xrandr --prop
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
 EDID_DATA:
  00ffffffffffff0030e4020200000000
  00130103802313780a28659759548e27
  1e505400000001010101010101010101
  010101010101561d56c6500020303020
  350059c2100000190000000000000000
  00000000000000000000000000fe004c
  4720446973706c61790a2020000000fc
  004c503135365748332d544c41310039
 scaling mode: Fullscreen
  supported: Non-GPU Fullscreen No scale Aspect
   1366x768 60.0*+
   1360x768 59.8
   1024x768 60.0
   800x600 60.3
   640x480 59.9
DVI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)

xbacklight -set 10
No outputs have backlight property

The buttons on my keyboard activate the brightness control on screen but the brightness does not change.
I am using a fresh karmic install. I read something about KMS. Karmic is using KMS by default I read. It seems to be related to these posts:
http://bugs.freedesktop.org/show_bug.cgi?id=20963

ProblemType: Bug
Architecture: amd64
Date: Fri Sep 11 20:42:15 2009
DistroRelease: Ubuntu 9.10
MachineType: Acer Aspire 5810T
Package: xserver-xorg-video-intel 2:2.8.1-1ubuntu1
PccardctlIdent:

PccardctlStatus:

ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-10-generic root=UUID=d9aeca27-f2de-4b4b-ac98-9ff714300820 ro quiet splash libata.force=noncq usbcore.autosuspend=1
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.32-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu3
 libdrm2 2.4.13-1ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu1
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.31-10-generic x86_64
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 06/24/2009
dmi.bios.vendor: INSYDE
dmi.bios.version: V1.23
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Aspire 5810T
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrV1.23:bd06/24/2009:svnAcer:pnAspire5810T:pvrV1.23:rvnAcer:rnAspire5810T:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: Aspire 5810T
dmi.product.version: V1.23
dmi.sys.vendor: Acer
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-10-generic

trendzetter (trendzetter) wrote :
Bryce Harrington (bryce) on 2009-09-13
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Matti Viljanen (direc85) wrote :

Confirming on Acer Aspire 2920 w/ Intel 965GM, Karmic up-to-date.

When using Fn-Left or Fn-Right to adjust brightness, the bar on the screen moves, but display does not change. *).

Running "xorg --prop" is missing backlight control. However:

me@acer:/proc/acpi/video/GFX0$ cat DD0[1-5]/brightness
<not supported>
<not supported>
levels: 10 20 30 40 50 60 70 80 90 100
current: 60
<not supported>
<not supported>

So, DD01, DD02, DD04 and DD05 claim not to support backlight, but DD03 does.

*) The brightness DOES change, when trying to reduce brightness when /proc/acpi/video/GFX03/brightness is already at minimum (10), or when trying to increase brightness when the bar it's at maximum (100). Then brightness changes to dim or bright. Is that really minimum and maximum brightness, I really can't tell...

trendzetter (trendzetter) wrote :

Seems to me that this might be a mayor issue. I don't know how many people are affected but many people are buying notebooks with these intel graphic chips. Not being able to adjust brightness is a serious problem for usability.
I have the intel GMA4500MHD chip.

trendzetter (trendzetter) wrote :

People looking for a temporary workaround can try this:
Add GRUB_CMDLINE_LINUX="nomodeset acpi_backlight=vendor" in /etc/default/grub and run update-grub.

Matti Viljanen (direc85) wrote :

trendzetter, that workaround does not work for me. And, the recent kernel update, with backlight fix on Intel driver, didn't help neither. Nor both of them together...

executorvs (executorvs) wrote :

Matti,

while not a perfect solution the command "xrandr --output LVDS --set BACKLIGHT_CONTROL native" will make screen brightness work (if not perfectly) when entered. it is not persistent and needs to be reentered on boot either manually or by setting it as a startup process.

Matti Viljanen (direc85) wrote :

Cheers for the hint, executorvs!

However, that doesn't work. The options I have for xrandr BACKLIGHT_CONTROL are native, legacy, combination and kernel, and none of them makes any difference.

The only difference to my comment #2 is that now I can see and select different backlight control methods. (Should have written xrandr --prop instead...)

Matti Viljanen (direc85) wrote :

I'm closing this bug, since now the BACKLIGHT_CONTROL property is visible and usable. Not still being able to adjust the backlight is a different issue, and there exists many bug reports, as mentioned in comment #4.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
trendzetter (trendzetter) wrote :

The backlight property only shows up when using nomodeset. I can us it to control the backlight then but it's still missing even with the latest updates and KMS enabled.

$ dpkg-query -s xserver-xorg-video-intel
Package: xserver-xorg-video-intel
Status: install ok installed
Priority: optional
Section: x11
Installed-Size: 1588
Architecture: amd64
Version: 2:2.9.0-1ubuntu1

$ xrandr --prop
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
 EDID_DATA:
  00ffffffffffff0030e4020200000000
  00130103802313780a28659759548e27
  1e505400000001010101010101010101
  010101010101561d56c6500020303020
  350059c2100000190000000000000000
  00000000000000000000000000fe004c
  4720446973706c61790a2020000000fc
  004c503135365748332d544c41310039
 scaling mode: Fullscreen
  supported: Non-GPU Fullscreen No scale Aspect
   1366x768 60.0*+
   1360x768 59.8
   1024x768 60.0
   800x600 60.3
   640x480 59.9
DVI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)

Matti Viljanen (direc85) wrote :

Changing status back to confirmed. Thanks for the post/comment, trendzetter.

The last time I checked it, it was there, now it isn't... The weird thing is, that the backlight control actually works as expected (using quick keys), for me, without xrandr --prop showing anything...

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → Confirmed
trendzetter (trendzetter) wrote :

Good news everyone. I just noticed Acer made available a bios-update that fixes the issue of controlling the backlight when using KMS on the timeline 5810T. Download bios version 2.30 and install using freedos on a usbstick.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers