failed to allocate wireless device

Bug #404596 reported by syscon-hh on 2009-07-25
126
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Ubuntu China Edition
Fix Released
High
Nominated for Trunk by dan-linux
linux (Ubuntu)
Medium
Unassigned
Declined for Karmic by Steve Conklin
Declined for Lucid by Steve Conklin

Bug Description

Binary package hint: linux-image-2.6.31-4-generic

DISTRB_ID=Ubuntu
DISTRIB_RELEASE=9.10
DISTRIB_CODENAME=karmic
DISTRIB_DESCRIPTION="Ubuntu Karmic (developement branch)"

Kernel in use: (all on the same machine tested, multiboot)
linux-image-2.6.30-10-generic - 2.6.30-10.12 (i386)
linux-image-2.6.31-4-generic - 2.6.31-4.22 (i386)
linux-image-2.6.30-10-generic - 2.6.30-10.12 (amd64)
linux-image-2.6.31-4-generic - 2.6.31-4.22 (amd64)

Booting with the images 2.6.30-10-generic (i386 as well as amd64) I can use my build-in wireless (provided by Ralink RT61) without any restrictions, booting with the images 2.6.31-4-generic the wireless card failed to allocate - see the relevant informations of "dmesg.log" attached (have a look to 2.6.31-4 >> item [11.973744] + [12.343156]. It is used allways the same laptop "MSI 270" with AMD Turion 64 dual core. These circumstances started with the kernel-2.6.31-2 edition, updated and testing first time.

For identification of devices you'll find the lspci-print.

The relevant drivers loaded you'll find in the attached lsmod-prints (identified by "-30" and "-31" respectively. (has been sorted for verification)

For Information: I tried a seperate USB-WLAN-stick (US.Robotic with p54 chip) additionally - it has been rejected on kernel-2.6.31-x too. On the other hand these stick works sufficent on an other machine (Intel board and P4-CPU) with above kernel(s) incl. 2.6.31-x in the same environment - see attachment "added usb-stick".

syscon-hh (syscon-kono) wrote :
syscon-hh (syscon-kono) wrote :
syscon-hh (syscon-kono) wrote :
syscon-hh (syscon-kono) wrote :
syscon-hh (syscon-kono) wrote :
description: updated
syscon-hh (syscon-kono) wrote :
description: updated
dan-linux (dan-linux) wrote :

I have the same Problem

lord-carlos (carl-egal) wrote :

I got the same Problem with debian and the 2.6.31 kernel.
So i tryed to locate the bug with git bisect, but i never used it before.
After recompiling the kernel for 20th time, git bisect told me that he found the "bad" commit:

git bisect good
5a9940118a616266183c53a9ee4352feadb9c2e8 is first bad commit

I tried to make a patch out of it. but it did not work. I hope i could help.

David Volgyes (david.volgyes) wrote :

I got the same problem too but I think the cause is an Ubuntu specific patch or something similar.
For me 2.6.30.10-generic from Karmic does not work but this works:

http://blog.robertalks.com/index.php/2009/09/10/kernel-2-6-31-final-released-for-debianubuntu-final/

The source and the compile options are published.
You should check the difference between the two kernels and You will find the bug.

I've noted issues with RT61PCI driver that were only resolved till I upgraded to kernel version 2.6.31. See my notes under:

https://bugs.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.27/+bug/287711/comments/35
and
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/366170/comments/9

Note that you will need the latest version of the Ralink firmware and install it in /lib/firmware (ignore any other posts you've seen regarding the rt61 card and editing some mystical .dat file).

Also note that the order in which you initialize/confgure the RT61PCI cards has changed.

mvoncken (mvoncken) wrote :

Same problem:
MSI S271 (rebranded aldi laptop)
Working on 2.6.28-15-generic.
Broken on 2.6.31-4-generic

Changed in linux (Ubuntu):
status: New → Confirmed
dan-linux (dan-linux) wrote :

I have the same problem.

Here is what i get with dmesg
[ 8.717656] rt61pci 0000:05:09.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
[ 8.722574] phy0 -> rt61pci_init_eeprom: Error - Invalid RF chipset detected.
[ 8.722620] phy0 -> rt2x00lib_probe_dev: Error - Failed to allocate device.
[ 8.722689] rt61pci 0000:05:09.0: PCI INT A disabled

"lspci | grep Ethernet" shows me
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)

 "lspci | grep Network" shows me
Network controller: RaLink RT2561/RT61 rev B 802.11g

 "lspci -nnvv " with kernel 2.6.31 shows me
05:09.0 Network controller [0280]: RaLink RT2561/RT61 rev B 802.11g [1814:0302]
 Subsystem: Micro-Star International Co., Ltd. Device [1462:b833]
 Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Interrupt: pin A routed to IRQ 22
 Region 0: Memory at 70000000 (32-bit, non-prefetchable) [size=32K]
 Capabilities: <access denied>
 Kernel modules: rt61pci

My card works perfectly with kenel 2.6.30

 "lspci -nnvv " with kernel 2.6.30 shows me
05:09.0 Network controller [0280]: RaLink RT2561/RT61 rev B 802.11g [1814:0302]
 Subsystem: Micro-Star International Co., Ltd. Device [1462:b833]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 22
 Region 0: Memory at 80000000 (32-bit, non-prefetchable) [size=32K]
 Capabilities: <access denied>
 Kernel driver in use: rt61pci
 Kernel modules: rt61pci

I hope that someone can use these information to find the Problem.

bassie (ubuntu-com) wrote :

After upgrade from 9.04 to 9.10 (beta 4) the same problem here on my Medion MD96360 (= MSI S271)

Here the usual information

~$ uname -r
2.6.31-14-generic

~$ dmesg
[ 18.418233] rt61pci 0000:05:09.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
[ 18.423162] phy0 -> rt61pci_init_eeprom: Error - Invalid RF chipset detected.
[ 18.423167] phy0 -> rt2x00lib_probe_dev: Error - Failed to allocate device.
[ 18.423181] rt61pci 0000:05:09.0: PCI INT A disabled

~$ lspci | grep Ethernet
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)

~$ lspci | grep Network
05:09.0 Network controller: RaLink RT2561/RT61 rev B 802.11g

~$ lspci -nnvv
05:09.0 Network controller [0280]: RaLink RT2561/RT61 rev B 802.11g [1814:0302]
 Subsystem: Micro-Star International Co., Ltd. Device [1462:b833]
 Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Interrupt: pin A routed to IRQ 22
 Region 0: Memory at 70000000 (32-bit, non-prefetchable) [size=32K]
 Capabilities: <access denied>
 Kernel modules: rt61pci

Antoine Pairet (b-ly) wrote :

Hi!
I have the same hardware and the bug seems to be solved as I experience no problem anymore. Could you please confirm this and mark the bug as fixed?

lspci | grep Net
09:04.0 Network controller: RaLink RT2561/RT61 rev B 802.11g

lsmod | grep rt
exportfs 4412 1 nfsd
rt61pci 20576 0
crc_itu_t 1852 1 rt61pci
rt2x00pci 7900 1 rt61pci
rt2x00lib 29756 2 rt61pci,rt2x00pci
led_class 4096 1 rt2x00lib
input_polldev 3716 1 rt2x00lib
mac80211 181236 2 rt2x00pci,rt2x00lib
cfg80211 93052 2 rt2x00lib,mac80211
eeprom_93cx6 1916 1 rt61pci
parport 35340 2 ppdev,lp
agpgart 34988 3 ttm,drm,ati_agp

syscon-hh (syscon-kono) wrote :

Can't confirm any changes. Same experiences as above described.

Antoine can you please provide the output/information of

> uname -rm
> dmesg (relevant lines of init of rt61...)
> ubuntu desktop

bassie (ubuntu-com) wrote :

No changes at my computer after "update-manager -d" performed 24OCT09@21:20 hrs UTC.

~$ uname -rm
2.6.31-14-generic i686

~$ lspci | grep Net
05:09.0 Network controller: RaLink RT2561/RT61 rev B 802.11g

~$ dmesg
[ 16.149084] cfg80211: Calling CRDA to update world regulatory domain
[ 16.339428] rt61pci 0000:05:09.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
[ 16.344363] phy0 -> rt61pci_init_eeprom: Error - Invalid RF chipset detected.
[ 16.344368] phy0 -> rt2x00lib_probe_dev: Error - Failed to allocate device.
[ 16.344382] rt61pci 0000:05:09.0: PCI INT A disabled
[ 17.089203] cfg80211: World regulatory domain updated:

~$ ubuntu desktop
ubuntu: command not found

You mean; Gnome?
Version 2.28.1

xcablex (xcablex) wrote :

Just upgraded to ubuntu 9.10 and here we are...wifi (rt61) is gone.

~$ uname -rm
2.6.31-14-generic i686

~$ lspci | grep Net
05:09.0 Network controller: RaLink RT2561/RT61 rev B 802.11g

~$ dmesg
[ 29.100241] rt61pci 0000:05:09.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
[ 29.105176] phy0 -> rt61pci_init_eeprom: Error - Invalid RF chipset detected.
[ 29.105181] phy0 -> rt2x00lib_probe_dev: Error - Failed to allocate device.
[ 29.105194] rt61pci 0000:05:09.0: PCI INT A disabled

help !

pmar (pmar-74) wrote :

after upgrade from 9.04 to 9.10 (and also on live 9.10) :: i have experienced the same problem with rt61 driver.

wlan working on: 2.6.28-16-generic
wlan broken on: 2.6.31-14-generic

[uname/dmesg/lscpi] the same as of Bassie (post of 2009-10-21)

Fessor (michaelbastholm) wrote :

I can also confirm that rt2561/rt61 stoped working aften upgrading from 9.04 to 9.10 and that it seems to be a problem within the kernel because experienced the same as pmar (posted 2009-11-02)

bassie (ubuntu-com) wrote :

Update to new kernel:

~$ uname -rm
2.6.31-15-generic i686

~$ lspci | grep Net
05:09.0 Network controller: RaLink RT2561/RT61 rev B 802.11g
~$ dmesg
...
[ 13.428865] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 13.497091] cfg80211: Calling CRDA to update world regulatory domain
[ 14.054793] cfg80211: World regulatory domain updated:
[ 14.054797] (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 14.054801] (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 14.054805] (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 14.054808] (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 14.054812] (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 14.054816] (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 15.891589] rt61pci 0000:05:09.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
[ 15.896246] phy0 -> rt61pci_init_eeprom: Error - Invalid RF chipset detected.
[ 15.896295] phy0 -> rt2x00lib_probe_dev: Error - Failed to allocate device.
[ 15.896351] rt61pci 0000:05:09.0: PCI INT A disabled
[ 16.777676] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
...

Still the same problem...
Anybody????

bliss (bliss) wrote :

Hey, just a question i dont't know mutch of kernel development :)

I found this change:
http://patchwork.kernel.org/patch/38068/

maybe it has something todo with our problem because of the message "rt61pci_init_eeprom: Error - Invalid RF chipset"?

I dont't know how old this patch is, but i think it coult fit that it was for 2.6.31?

Sorry for my bad english :)

sudopod (constantinexiii) wrote :

Douglas Moyes's fix in #10 worked for me.

I just got the firmware from Ralink's website for my specific card, installed the .bin files in /lib/firmware, reset the system, and was able to associate with the access point with no problem.

Using rt2561 on Ubuntu Server 9.10.

Haim (haimc) wrote :

@ sudopod & Douglas Moyes

The fix seems to be suggesting using the Ubuntu 9.10 as is, and just re-installing (copying) the firmware

"With the latest version of the Linux kernel ,version 2.6.31, I do not have any trouble with the RT61PCI driver, with the latest firmware. Note that this is the driver that ships with the Linux kernel, not the one from the driver developer's website."

9.10 comes with 2.6.31 so this suggests you are just using the standard install of ubuntu and replacing the firmware??

However the firmware on their site is from 2008 and earlier so ubuntu must have these versions.
http://www.ralinktech.com/support.php?s=2

So I'm a bit confused what you guys have exactly done to get this working

Cheers Haim

ps
Dlink G630 rev E, also not working in ubuntu 9.10,
Says it loads firmware, then nothing.

bassie (ubuntu-com) wrote :

Tried the fix too.

Copied the file rt2561.bin (sudo cp rt2561.bin /lib/firmware/rt2561.bin) from the ralink website.
(http://www.ralinktech.com/support.php?s=2)

But still no wifi-connection due to the same errors.
Any more suggestions?

Haim (haimc) wrote :

OK, sorry, turns out this wasn't my issue. My rt61pci device is now working.

Booted up and is now fine, I think it was just that the settings had to be set to the device, seems it couldn't be set and then the module reloaded...well basically i don't know what happened, but works now.

Dlink DWL-g630 rev E (cardbus) working.

(WTH Ubuntu China Edition...)
This is just link to Bugzilla of Linux Kernel.

Changed in cnubuntu:
status: Unknown → Confirmed
bassie (ubuntu-com) wrote :
lord-carlos (carl-egal) wrote :

git clone git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-2.6.31.y.git
git revert 5d423ccd7ba4285f1084e91b26805e1d0ae978ed
Compile
Install
restart
The rt61pci module works fine for me again.

lord-carlos (carl-egal) wrote :

update:
booting with pci=use_crs fixed the Problem too. So you don't need to recompile.

bassie (ubuntu-com) wrote :

Tanx to lord-carlos I can use my inboard wifi again.
I used the second option and put the 'pci=use_crs' with the boot options in the menu.lst form grub.

Everythings up and running.

lodie (lodewiek) wrote :

I would also like to thank lord-carlos!
adding 'pci=use_crs' to the second line of grub bootmenu item seems to have fixed the problem!
I've a rebranded msi271 (aldi) with rt61pci card!

thanks to lord-carlos!
also 'pci=use_crs' worked to me. I cannot test cause there is no spots around here, but error spamming is stopped.
I've old msi 271x with rt2500pci card.

http://marc.info/?l=linux-kernel&m=126022647325204&w=2
It should be patch without "pci=use_crs" (From kernel.org bugzilla #14460, see assigns.)

But I can't test it cause I don't have more MSI's AMD laptop machines...

from kernel.org bugzilla #14460
I tested it without "pci=use_crs" and work. (I'm on wireless spot)

dan-linux (dan-linux) wrote :

This Problem is still there in lucid. I also have this problem with kernel 2.6.33 rc3

dan-linux (dan-linux) on 2010-01-12
description: updated

The patch noted in the upstream bug 14460 has already been applied upstream via the following commit:

commit 99935a7a59eaca0292c1a5880e10bae03f4a5e3d
Author: Yinghai Lu <email address hidden>
Date: Sun Oct 4 21:54:24 2009 -0700

    x86/PCI: read root resources from IOH on Intel

Examining a bit more, this patch should be available as of the 2.6.33-rc1upstream kernel.

ogasawara@emiko:~/linux-2.6$ git describe --contains 99935a7a59eaca0292c1a5880e10bae03f4a5e3d
v2.6.33-rc1~321^2~108
ogasawara@emiko:~/linux-2.6$ git tag --contains 99935a7a59eaca0292c1a5880e10bae03f4a5e3d
v2.6.33-rc1
v2.6.33-rc2
v2.6.33-rc3
v2.6.33-rc4
v2.6.33-rc5
v2.6.33-rc6
v2.6.33-rc7

However, @dan-linux noted in the previous comment this still seems to be an issue for him as of the 2.6.33-rc3 kernel. Dan can you attach the output of 'sudo lspci -vnvn' as well as your dmesg output with the latest upstream kernel?

@sysconn-hh, since you are the original bug reporter, can you test the latest 2.6.33-rc7 upstream kernel and verify this is still an issue for you? http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33-rc7/ . Please let us know your results. Thanks.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
syscon-hh (syscon-kono) wrote :

The performance is unchanged - with the latest kernel too.

The supplement at the end of the kernelline "pci=use_crs" helps as in past.

Added logs: dmesg + lspci -vnvn (both as plaintext)

syscon-hh (syscon-kono) wrote :
syscon-hh (syscon-kono) wrote :

Same bad experiences with the i386-kernel 2.6.33-020633rc8

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
dan-linux (dan-linux) wrote :

Hi, I tested my wlan again on a fresh installed Kubuntu lucid.
I tried it first with the Kernel 2.6.32 then with the mainline Kernel 2.6.33 rc8.
In both cases the wlan didnt worked.

I have a 12" notebook from Medion called MD96369.

Here are the logs

dan-linux (dan-linux) wrote :

It seems to work now with the workaround of booting with pci=use_crs.
It works with both Kernels. But it seems to be slower.

Why do I have to use this "pci=use_crs"?

Can someone explain me this? :-)

fretchen (fretchen) wrote :

I have this card too. Under Karmic I were able to load the wifi by using "rfkill unblock wifi". Now I updated to lucid amd64.
I don't have the option to start the wfi in the networ-manager anymore.

iwconfig is giving me:
wlan0 IEEE 802.11bg ESSID:off/any
          Mode:Managed Access Point: Not-Associated Tx-Power=off
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off

and lspci is giving me:
04:09.0 Network controller: RaLink RT2561/RT61 rev B 802.11g

rfkill unblock wifi doesn't work anymore.

Fred

pci=use_crs didnt work to my case.
I tried also a different card with the same chip (rt2561) and kernel just doesnt see it.

Changed in cnubuntu:
status: Confirmed → Fix Released
Changed in cnubuntu:
importance: Unknown → High
Steve Conklin (sconklin) wrote :

This patch has not been backported by the upstream maintainers for earlier kernels, and does not meet the Ubuntu SRU guidelines: https://wiki.ubuntu.com/KernelTeam/KernelUpdates

Since the use of pci=use_crs appears to be a valid workaround, I'm setting this to wontfix for Karmic and Lucid.

Here is an explanation of pci=use_crs:

http://lwn.net/Articles/373551/

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.