snd-hda-intel powersave option and "CLICK" from speakers

Bug #381201 reported by Nicolò Chieffo on 2009-05-28
496
This bug affects 109 people
Affects Status Importance Assigned to Milestone
linux (Fedora)
Fix Released
Medium
linux (Ubuntu)
Undecided
Ubuntu Audio Team
Nominated for Karmic by unggnu

Bug Description

I've got a laptop with
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
        S00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
        Subsystem: Dell Device 0233
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 21
        Region 0: Memory at f6adc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intelubsystem: Dell Device 0233
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 21
        Region 0: Memory at f6adc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

since kernel -6 (but I don't remember the exact version, anyway the update was pulled in this week), my sound card once every minute (or better to say randomly, I don't understand what triggers it) emits a sound from speakers which sounds like 'TOC'.
I think this sound is caused by the power save options that were enabled in the module snd-hda-intel

This sound also comes out if the volume is mute, or set to 0%

ProblemType: Bug
Architecture: amd64
Date: Thu May 28 09:53:58 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=f2f2f06b-2789-4704-8267-388f1e8bc9ca
MachineType: Dell Inc. Latitude E6400
Package: linux-image-2.6.30-6-generic 2.6.30-6.7
ProcCmdLine: root=UUID=0f5f2103-da7b-4e52-ab7f-df158e2f816a ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-6.7-generic
RelatedPackageVersions:

SourcePackage: linux
Uname: Linux 2.6.30-6-generic x86_64
dmi.bios.date: 12/17/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.name: 0RX493
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd12/17/2008:svnDellInc.:pnLatitudeE6400:pvr:rvnDellInc.:rn0RX493:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude E6400
dmi.sys.vendor: Dell Inc.

Nicolò Chieffo (yelo3) wrote :

Architecture: amd64
ArecordDevices:
 **** Lista di CAPTURE dispositivi hardware ****
 scheda 0: Intel [HDA Intel], dispositivo 0: STAC92xx Analog [STAC92xx Analog]
   Sottoperiferiche: 2/2
   Sottoperiferica #0: subdevice #0
   Sottoperiferica #1: subdevice #1
AudioDevicesInUse:
 UTENTE PID ACCESSO COMANDO
 /dev/snd/controlC0: yelo3 4328 F.... mixer_applet2
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6adc000 irq 21'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:111d76b2,10280233,00100302 HDA:80862802,80860101,00100000'
   Controls : 30
   Simple ctrls : 17
DistroRelease: Ubuntu 9.10
Package: alsa-base 1.0.20+dfsg-1ubuntu4
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=it_IT.UTF-8
ProcVersionSignature: Ubuntu 2.6.30-6.7-generic
Uname: Linux 2.6.30-6-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Nicolò Chieffo (yelo3) wrote :
Nicolò Chieffo (yelo3) wrote :
Nicolò Chieffo (yelo3) wrote :
Nicolò Chieffo (yelo3) wrote :
Nicolò Chieffo (yelo3) wrote :
Nicolò Chieffo (yelo3) wrote :
Nicolò Chieffo (yelo3) wrote :
Nicolò Chieffo (yelo3) wrote :
Nicolò Chieffo (yelo3) wrote :

A similar problem arises on my LG S1 (driver snd-hda-intel model=lg). As a result, no sound output is possible with pulseaudio and there is only very limited sound output with KDE4 (specifically amarok remains silent). However the problem vanishes if the line

options snd-hda-intel power_save=10

is commented out in /etc/modprobe.d/alsa-base.conf as a workaround.

Nicolò Chieffo (yelo3) on 2009-06-22
summary: - snd-hda-intel powersave option and TOC from speakers
+ snd-hda-intel powersave option and "CLICK" from speakers
Alex Wauck (awauck) wrote :

This also happens with my chipset:
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)

On my system, it is a loud pop rather than a click. It can be very jarring and disruptive, especially when sound is not expected. Muting PulseAudio has no effect on it, so hearing such a loud noise when sound is thought to be muted can be very jarring.

Craig Estep (craigy) wrote :

Another side-effect of the powersave option is that there is a delay between when you start playing a sound, and when you actually hear it. This results in the first ~10 seconds being lost (not played).

Florian Schweikert (kelvan) wrote :

I got "Clicks" with power_save=10 on my Dell Latitude E6500.
Karmic amd64

Daniel Ellis (danellisuk) wrote :

I have rounded up three other bugs which are duplicates of this. I have made the others duplicates because this has the lowest ID (I hope that is the appropriate method).

I also had this issue when testing Karmic Alpha 5. The popping was quite severe, which made me look into the problem as I was worried about damaging the speakers. Bernhard Gehl's comment about disabling the power saving has resolved the issue for me.

I also found this section on the archlinux alsa wiki, which ties up exctly with this issue:

http://wiki.archlinux.org/index.php/ALSA#Pops_when_Starting_and_Stopping_Playback.3F

[quote]Some modules can power off your sound card when not in use. this can make an audible noise when powering down your sound card. If you find this annoying try "modinfo snd-MY-MODULE", and look for a module option that adjusts or disables this feature. for example: to disable the power saving mode using snd-hda-intel add "options snd-hda-intel power_save=0" in /etc/modprobe.d/modprobe.conf. or try it with "modprobe snd-hda-intel power_save=0"[/quote]

To tell the truth my audio chip does not emit anymore the clicks from
the front speakers, so in the drivers there is a fix without having to
disable power management.
But unfortunately I hear clicks when using the headphones

Jens Georg (yg-jensge) wrote :

Can confirm the nasty clicks and them going away when disabling powersaving

Quite a few HDA (and other sound cards) are known to make faint "plopp" or other noises when powering down/up. For some cards these noises can be suppressed in software, however for others this appears not to be possible (according to some HDA driver devs at least, as discussed a Plumbers conf). It would be nice if we could have a blacklist in the kernel that makes sure power saving is only enabled for those where this plopp sound is known to not exist.

As a side note: OpenSuse disables all power management for sound cards on power plug/unplug via a script in/usr/lib/pm-utils/power.d/sound-pm. mjg59 thinks this is not a good idea we should follow, saying that what isn't acceptable in AC mode isn't acceptable in battery mode either. And I guess I agree.

But where is that list? Every release we try to enable the power savings and each time we end up disabling it.

Also, I've got a machine that turns the speaker LED orange to indicated the sound is muted.... and that happens when we turn off the power to the card even though we're not really muted.

Matthew Brooks (mjbrooks) wrote :

Also occurs with:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

Disabling powersaving mitigates the issue.

cue (keino) wrote :

I can confirm that since I have exactly the same issue.
Since a few days I have also this pop-sound nearly every mInute or when I click on items which would trigger a sound.

excerpt lspci:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

uname -a:
2.6.31-12-generic #41-Ubuntu SMP Wed Oct 7 19:37:12 UTC 2009 x86_64 GNU/Linux

One question:
Where do I disable powersaving which was suggested as a workaround here?

cue (keino) wrote :

Ok, my posting was relevant to the 9.10 beta test.
With the todays soundlib update, the click or pop noice disturbance is gone!

The problem persists on my MacBook3,1.

unggnu (unggnu) on 2009-10-14
Changed in linux (Ubuntu):
status: New → Confirmed
unggnu (unggnu) wrote :

This is getting nuts. Even my onboard pc sound card gives this stupid clicks. I really think this feature should be disabled until there is non clicking or a proper way to determine if it is a mobile computer or not. And if it doesn't work without the clicking it should be disabled by default. Everyone who wants to save 0.5 or less Watt can add one line on his own in rc.local or similar.

Emanuel Steen (kozz) wrote :

I also still have this issue, see #405298 for hardware specs. (Just saying as it seems to have been solved for some.)

I've been having this issue by using Kubuntu Karmic live cd (alpha 6 and beta releases). For now, using those two releases I can confirm the bug.

Computer: HP DV 2240BR

Pci audio device list:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
        Subsystem: Hewlett-Packard Company Unknown device 30b2
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 23
        Region 0: Memory at d4340000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>

About comment #21, will be tested against the final release...

Bálint Magyar (balintm) wrote :

I can confirm this bug on my Clevo M541N.

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
 Subsystem: CLEVO/KAPOK Computer Device 5405
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 22
 Region 0: Memory at d0540000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
  Address: 0000000000000000 Data: 0000
 Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
   ExtTag- RBE- FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
   MaxPayload 128 bytes, MaxReadReq 128 bytes
  DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
  LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
   ClockPM- Suprise- LLActRep- BwNot-
  LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
 Capabilities: [100] Virtual Channel <?>
 Capabilities: [130] Root Complex Link <?>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

Aries K (outatime0001) wrote :

Confirmed here as well on my Acer M1640 Desktop.

Urschl (bigurschl) wrote :

Confirmed on DELL e6400 ubuntu 9.10 beta + updates till 15.10.09

cue (keino) wrote :

The pop noise disturbance is back again after suspend mode!
I don't have the pop noise when I trigger a sound by e.g. clicking on an menu icon.
That belonged to the symptomatic in #20.
There is just a pop noise ones a Minute.

Here is my context:

uname -a
2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009 x86_64 GNU/Linux

excerpt lspci:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

I observed one thing in the syslog:

Oct 18 13:58:23 beyond-laptop pulseaudio[2304]: ratelimit.c: 180 events suppressed
Oct 18 13:58:35 beyond-laptop wpa_supplicant[1536]: CTRL-EVENT-SCAN-RESULTS
Oct 18 13:59:08 beyond-laptop pulseaudio[2304]: ratelimit.c: 179 events suppressed
Oct 18 14:00:35 beyond-laptop wpa_supplicant[1536]: CTRL-EVENT-SCAN-RESULTS
Oct 18 14:01:34 beyond-laptop pulseaudio[2304]: ratelimit.c: 152 events suppressed
Oct 18 14:01:59 beyond-laptop pulseaudio[2304]: ratelimit.c: 182 events suppressed
Oct 18 14:02:35 beyond-laptop wpa_supplicant[1536]: CTRL-EVENT-SCAN-RESULTS
Oct 18 14:03:54 beyond-laptop pulseaudio[2304]: ratelimit.c: 180 events suppressed
Oct 18 14:04:35 beyond-laptop wpa_supplicant[1536]: CTRL-EVENT-SCAN-RESULTS
Oct 18 14:06:24 beyond-laptop pulseaudio[2304]: ratelimit.c: 177 events suppressed
Oct 18 14:06:35 beyond-laptop wpa_supplicant[1536]: CTRL-EVENT-SCAN-RESULTS

I hope this information helps.
All the best and thank you so much for your work!

cue

philinux (philcb) wrote :

Affects me with this hardware.
Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)

Emanuel Steen (kozz) wrote :

I reinstalled Ubuntu using the RC yesterday and now the clicking sound has disappeared. My old installation was really old and had been upgraded through a lot of Ubuntu releases. I guess some upgrade somewhere did something different than a new installation.

Tested today using Karmic RC live CD. Bug persists!
See comment #25 for hardware caracteristics.

Peter Ivanov (peto-ivanov) wrote :

Same bug here.

00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
 Subsystem: Hewlett-Packard Company Device 30b7
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0 (500ns min, 1250ns max)
 Interrupt: pin B routed to IRQ 21
 Region 0: Memory at b0000000 (32-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel
00: de 10 6c 02 06 00 b0 00 a2 00 03 04 00 00 80 00
10: 00 00 00 b0 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 3c 10 b7 30
30: 00 00 00 00 44 00 00 00 00 00 00 00 0b 02 02 05

Workaround with commenting out the powersaving option in alsa-base.conf worked.

Changed in linux (Ubuntu):
assignee: nobody → Ubuntu Audio Team (ubuntu-audio)
Daniel Ellis (danellisuk) wrote :

I have tested this with a fresh install of the release version of Ubuntu 9.10 desktop 64bit. The clicking / popping still exists.

I can confirm that editing the file /etc/modprobe.d/alsa-base.conf and changing the following line fixes the problem:-

  options snd-hda-intel power_save=10 power_save_controller=N
to
  options snd-hda-intel power_save=0 power_save_controller=N

I have marked bug #442463 as a duplicate of this because this bug was reported earlier. However the other bug was triaged as Medium, so please can someone with the appropriate permission now mark this bug as Medium? Thanks.

Jay Sherby (jaysherby) wrote :

This bug also affects my Thinkpad R61e. Changing alsa-base.conf as shown above also fixes it for me. Attached is my lspci output.

bug67 (bug0067) wrote :

I am confirming this issue on my Compaq Presario V3020. The posted "options snd-hda-intel power_save=0" did NOT resolve this issue for me.

Kevin Knerr (ld-barthel) wrote :

I am confirming this on my Toshiba P105-S9339 with fresh Karmic installed.

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

Changing alsa-base.conf does NOT resolve the issue--or at least not permanently. When I got home from work today, the pop/click was back and /sys/module/snd_hda_intel/parameters/power_save held the value of 10.

If I enter a root terminal, I can 'echo 0 > /sys/module/snd_hda_intel/parameters/power_save' to obtain some relief. (sudo does not work for this--I get a permission denied. I've not yet checked to see if this is a sudo configuration issue or a /sys issue).

whoop (tiredandnumb) wrote :

Affected by bug using 82801H (ICH8 Family) HD Audio Controller. Ubuntu 9.10 64 bit (not a fresh install).

innominate (natenate) wrote :
Sharath (sharathcshekhar) wrote :

I confirm the bug on my Laptop HP DV6500. I'm facing this ever since i upgraded to Karmic..

Daniel T Chen (crimsun) wrote :

Just comment out the options snd-hda-intel line in
/etc/modprobe.d/alsa-base.conf

ViViD (vivnet) wrote :

I also have this issue with the onboard sound on my Asus A8S-x. Confirmed workaround in /etc/modprobe.d/alsa-base.conf works.

John Souter (john-souter) wrote :

I have this with Karmic Koala (Ubuntu 9.10) on the following system (output from lspci):

00:00.0 Host bridge: ATI Technologies Inc RD780 Northbridge only dual slot PCI-e_GFX and HT1 K8 part
00:02.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (external gfx0 port A)
00:04.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port A)
00:0a.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port F)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3c)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control
01:00.0 VGA compatible controller: ATI Technologies Inc R580 [Radeon X1900]
01:00.1 Display controller: ATI Technologies Inc Device 7260
02:00.0 SATA controller: JMicron Technology Corp. JMB362/JMB363 AHCI Controller (rev 02)
02:00.1 IDE interface: JMicron Technology Corp. JMB362/JMB363 AHCI Controller (rev 02)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
04:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)

pbernery (philippe-bernery) wrote :

I also have the issue till I updated to Ubuntu 9.10 (was on 9.04 before).
I only have this issue on X-Plane, a game that uses OpenAL as its sound system. Other system sounds (like the login sound) works well, as well as listening music with rhythmbox.

I join my lspci.

Philippe

Can confirm this bug in my laptop. Disabling power save line and rebooting worked for me.

Here is my alsa-info.txt

zorrito (mich-delbianco) wrote :

confirm bug on an hp dv6373ea, even when earphones are plugged

zorrito (mich-delbianco) wrote :

confirm workaround /etc/modprobe.d/alsa-base.conf set to
   options snd-hda-intel power_save=0 power_save_controller=N
works

lhecking (lhecking) wrote :

Same problem on a non-Intel device:

01:00.1 Multimedia audio controller: Neomagic Corporation NM2360 [MagicMedia 256ZX Audio]
        Subsystem: Dell Device 0091
        Flags: medium devsel, IRQ 5
        Memory at f9800000 (32-bit, prefetchable) [size=8M]
        Memory at fda00000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: <access denied>
        Kernel driver in use: NeoMagic 256
        Kernel modules: snd-nm256

Module does not have a power_save option, so the workaround doesn't apply.

This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

John J. Clinton (john-mysnmp) wrote :

Confirm work around fixes it on Compqa Presario V6000:

jupiter% lspci ~
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
05:05.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
05:05.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
05:05.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 0a)
05:05.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 05)
05:05.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)
05:08.0 Ethernet controller: Intel Corporation PRO/100 VE Network Connection (rev 02)

bdoe (bdoe-att) wrote :

I had this problem, but I managed to fix it by a rather different approach than the workarounds already posted here. I have an HP Pavilion dv9830 laptop, and noticed that the light in my keyboard media strip's mute button would turn from blue (supposed to indicate not-muted) to orange (supposed to indicate muted) about 15 seconds after the last sound has played. The next sound played after that would turn the light blue again, but would also make a loud "pop" sound when the light changes, and I'd notice the first half-second or so of the sound would be clipped off. Now, although this mute button light works as it should in Windows, it has never worked properly in Ubuntu. In fact, if I mute the sound either through the button or through the speaker icon in my notifications area, the sound mutes, but the light stays blue. This leads me to believe that the light turning orange in Ubuntu is actually indicating that the sound card is being powered off.

So, I went into /etc/pulse/default.pa, found the following line:

 load-module module-suspend-on-idle

and commented it out. I then restarted Pulseaudio (killall -9 pulseaudio, and let it respawn), and now the light stays blue, and there's no more popping or clicking when a sample is played.

I don't think the popping/clicking when the sound card is being woken up is a bug. At least, it's not a software bug, and it's nothing that Ubuntu can control or fix. It is a hardware issue caused by powering up the sound circuitry. Therefore, I believe the best way to resolve this issue is not to remove the powersave feature, as it can be an important feature for netbooks and laptops. Rather, the way to resolve this issue is to add an option to PA Prefs to enable or disable Powersave mode and to set the delay time; and have this option disabled by default.

I would prefer an user space solution for this problem. Any default behaviour is not ideal in this case, because:

a) if this function is off - it might be obsolete with new HDA driver code
b) if this function is on - cracks on hw on/off

Perhaps, a mixer control like "Power Save" might be introduced, so users can touch this behaviour in a GUI.

Gannin (spacesword) wrote :

I also have this bug. Changing the power save setting for the sound system as found here:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/442463/comments/4

Fixed the issue for me.

jjjjeremy (jeremy-liem) wrote :

Had the same problem.
Fixed by by disabling "options snd-hda-intel power_save=10"

lspci

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
06:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
08:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

smotocel (smotocix) wrote :

after disabling the power save on intel... the sound it's work fine to me. you have a lspci report from my machine.

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
05:05.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
05:05.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
05:05.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 0a)
05:05.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 05)
05:05.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)
05:08.0 Ethernet controller: Intel Corporation PRO/100 VE Network Connection (rev 02)

Workaround setting /etc/modprobe.d/alsa-base.conf to "options snd-hda-intel power_save=0 power_save_controller=N" works in fresh ubuntu karmic install.
See #25 for hardware list.

poet_imp (paul-lemmons) wrote :

Reading through the comments I see that everybody is confirming that updating alsa-base.conf "fixes" the problem. Actually, it does not. It works around the problem. The problem persists. The battery life on my laptop is precious and every minute eeked out by means of power saving is another minute I get to use my computer before I have to run for an electrical source (In airports this can often be a fruitless quest).

So, while working around the problem is simple. It still needs attention and the problem still needs resolution.

(In reply to comment #4)
> Perhaps, a mixer control like "Power Save" might be introduced, so users can
> touch this behaviour in a GUI.

Uh, I dont think forwarding this problem to the user really brings us forward.

We could add a couple of rules for this udev. I am pretty sure I can convince Kay to accept rules into udev for this, although this looks a like a lot of work to maintain...

Alternatively this could be maintained as part of the alsa mixer init db?

*** Bug 548123 has been marked as a duplicate of this bug. ***

Mourougan (mourougan-a) wrote :

My Compaq laptop also had the same issue.

Attached the output of lspci.

vernerd (vernerd-reg) wrote :

I had same issue with my Acer Aspire 5920, but the workaround solved it. Thank you guys.

Ola Persson (smurfen) wrote :

I have an HP 530 with the same problem. Setting the power save value to 0 instead of 10 worked fine. lspci output attached.

*** Bug 539304 has been marked as a duplicate of this bug. ***

This issue is listed as one of the Common F12 bugs:
https://fedoraproject.org/wiki/Common_F12_bugs#hda-clicks

In the absence of a list of known good/bad models we really should default to the safe choice (e.g. disable powersaving).

wrigley (wrigleyster) wrote :

Confirming the popping, it occurs less frequently, only when the sound card is activated after having powered down.

Far more annoying though is an extremely high pitched "hissing" sound (for lack of a better word), that starts whenever the card powers down. My father cannot hear it, (he is approaching 55yrs) but the rest of us hear it clearly. It might be static gathering because I don't tend to notice the sound until the computer has run for a few hours.

so far it seems both pop and hiss are fixed by the workarounds, either in /etc/modprobe.d/alsa-base.conf or /etc/pulse/default.pa (as suggested by #50)

Hardware
EeeTop 1602
lspci:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

Software
Fresh Karmic Koala install
uname -a
Linux EeeBuntu 2.6.31-16-generic #53-Ubuntu SMP Tue Dec 8 04:01:29 UTC 2009 i686 GNU/Linux

echo 0 > /sys/module/snd_hda_intel/parameters/power_save first helped but when I change volume sound crackling again! only volume at %100 no crackling. Any clue ?

F13 Beta Blocker criterion 14 says: "In most cases, the installed system must be able to play back sound with gstreamer-based applications". This bug isn't exactly "sound doesn't work at all" but it is listed on Common Bugs and is apparently fairly visible. Nominating as F13Target.

Since kernel builds around 2.6.32.3 HDA powersaving has been disabled by default (CONFIG_SND_HDA_POWER_SAVE_DEFAULT=0) in both F-12 and devel branches.

Jörn Dreyer (j.dreyer) wrote :

added a few bugs as duplicates before finding out the devs wanted it to be seperate bugs, sry

Ward Muylaert (ward-muylaert) wrote :

Had the same problem, commenting out the power save option solved it for me.

ward@sekhmet:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC1200 Analog [ALC1200 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC1200 Digital [ALC1200 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

csrobins (csrobins) wrote :

I haven't had any clicking issues, but whenever I started playing any sound, the volume would be very low for the first 5-10 seconds, then jump to full (not the sliders, but the actual volume). The workaround which disabled power saving has stopped this annoying problem.

***:~$ uname -a
Linux *** 2.6.31-19-generic #56-Ubuntu SMP Thu Jan 28 01:26:53 UTC 2010 i686 GNU/Linux
***:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC268 Digital [ALC268 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Jacopo Moronato (jmoronat) wrote :

Back in Natty, with one of the latest kernel update.

franco_bez (franco-bez) wrote :

I found that setting the Module-options

power_save=0
and
power_save_controller=N

in
/etc/modprobe.d/alsa-base.conf

get's overwritten in Natty in the file:

/usr/lib/pm-utils/power.d/intel-audio-powersave

I changed the line

INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}
to
INTEL_AUDIO_POWERSAVE=false

Now Natty keeps the hda_intel adapter power_save settings as desired

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
palimmo (palimmo) wrote :

useful also in Ubuntu 11.10
Thanks to #65

Sebastian Klus (klus-spam) wrote :

Confirmed - it's still an issue in 11.10 and #65 worked on 11.04 and also works on 11.10!

palimmo (palimmo) wrote :

Same problem in ubuntu 12.04!

jonbonjovi (jonbonjovi-84) wrote :

Does #65 fix in 12.04 too?

Rosca Stefan (sarvigalava) wrote :

click sound when google chrome is opened.
sudo su
echo 0 > /sys/module/snd_hda_intel/parameters/power_save
Script resolves the problem but need to execute after every boot

Rosca Stefan (sarvigalava) wrote :

#65 fixed my problem. Thanks ;)

Tormod Volden (tormodvolden) wrote :

Please follow comment #66, "If this issue still exists in a supported series, please file a new bug."

Claudio Pascalis (geistwc) wrote :

Having the same problem as #71
Thanks for the fix!
Ubuntu 12.04 on a Samsung RF711 S05

bpu (bpu) wrote :

Was having the same problem as described in #71 (except I am using Linux Mint 13 "Maya", which is based on Ubuntu.)

Found a possible solution to the constant clicking from my laptop's speakers. See the following links:

http://ddurdle.blogspot.ca/2012/07/google-chrome-popping-sound.html

https://support.google.com/chrome/bin/answer.py?hl=en&answer=108086

Regards to everyone.

Acer AS5742-6814 / Intel Core i3 2.53 GHz / Linux Mint 13 "Maya"

SND_HDA powersaving defaults can be changed for kernels in current (F16+) releases (looks like no plopp sounds here)?

Fifoxtasy (philipp-foerster) wrote :

i also had the issue with a high pitched noise (see #59) when no sound was playing since upgrading to LinuxMint KDE 18.1.

Comment #50 has the solution, thank you so much

Fifoxtasy (philipp-foerster) wrote :

actually it seems i had to combine the solutions of #65 and #50 to get rid of the high pitch noise
thanks again
(sorry for the repost wrong quote)

Changed in linux (Fedora):
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.