Comment 32 for bug 373821

Henrique Barbosa (hmjbarbosa) wrote :

Hello all,

I read this bug report and a thousand of howto's on the net but I still can't get my MF622 working properly.
I'm using Jaunty (fresh install) with Kernel 2.6.28-12-generic on a HP Pavillion dv2137us. Not sure if I should
post this here or in the original bug report http://bugs.launchpad.net/ubuntu/+source/hal-info/+bug/305968

Below I try to describe step by step what I tried so far.

(1) Before doing any changes:

The modem only works if I have it pluged in before booting. Pluging it in after boot makes it permanently
stick as 19d2:2000. usb_modeswitch can't change it. The reason seem to be that the device is ignored
(because of unusual_devs.h) and never get mounted, so that it can't be dismounted and switched to 0x0001.

(2) Modifying 10-modem.fdi (Paulo Neto's posts)

I've tried that but no success so far. I also tried to erase all 0x19d2 entries but the one about product 0x0001.
It also didn't work. By the way, firstly I tried only removing fdi-cache and restarting hal and udev by:

sudo /etc/init.d/hal restart
sudo /etc/init.d/udev restart

and then I tried rebooting... Same result, it doesn't work.

(3) Modifying 20-broken-usb-sticks.fdi (Paulo Neto's posts)

Same here, it doesn't make any difference.

(4) usb_modeswitch + udev rules

Following some howto's on the net, I configured usb_modeswitch and setup a udev rule to switch 0x2000
to 0x0001 and modprobe for usbserial at 0x0001 automatically. That didn't work either. Well, I should expect
that because usb_modeswitch wasn't doing its job on the command line before.

(5) Fixing unusual_devs.h

Tried that but got a compilation error:

ubuntu/qc-usb/quickcam.h:509: error: field ‘vpic’ has incomplete type
ubuntu/qc-usb/quickcam.h:511: error: field ‘vwin’ has incomplete type
ubuntu/qc-usb/qc-driver.c: In function ‘qc_v4l_init’:
ubuntu/qc-usb/qc-driver.c:2285: error: ‘VIDEO_PALETTE_RGB24’ undeclared (first use in this function)
ubuntu/qc-usb/qc-driver.c:2285: error: (Each undeclared identifier is reported only once

Can someone confirm which command should we use to recompile the kernel after removing 0x19d2
from unusual_devs.h? I did:

sudo apt-get install linux-kernel
cd /usr/src
sudo tar -xjf linux-source-2.6.28.tar.bz2
cd linux-source-2.6.28
gksu gedit drivers/usb/storage/unusual_devs.h
sudo make defconfig

By the way, we would have to do it every time we get a kernel update, right?. It would definitelly be better
if the kernel got fixed once and for all.

(6) New network manager.

My NM reports 0.7.0.100, I will try 0.7.1 and report back later today.

(7) New kernel

I'll try 2.6.29 or karmic and report back later today.

Regards,
Henrique