boot option ACPI=off needed with ASUS P5VD2-MX Motherboard

Bug #372375 reported by Johan van der Lingen on 2009-05-05
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Invalid
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

I could boot Kubuntu 8.04 without problems. Now I installed 9.04 and it cannot boot without adding the boot option "ACPI=off" first.
I am using kernel 2.6.28-11-generic.
Not sure what info is exactly needed to solve this, please inform me.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:

apport-collect 372375

This will help us to find and resolve the problem. Bear in mind that you may need to install the python-launchpadlib package from the universe repository. Thanks in advance!

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete

Thank you for providing instructions. Unfortunately I chose "Read Public Data only" or so, while Apport needed "Change all data (including Private Data)" or so.
Wonder why it needs these permissions, but I decided to allow it to change all data. I revoked the permission to assign it again, but now it fails with the error beneat. It seems like more people have this same problem:

Logging into Launchpad...
Traceback (most recent call last):
  File "/usr/bin/apport-collect", line 131, in <module>
    lp = login()
  File "/usr/bin/apport-collect", line 48, in login
    launchpad = Launchpad(credentials, launchpad_instance, cache_dir)
  File "/usr/lib/python2.6/dist-packages/launchpadlib/launchpad.py", line 60, in __init__
    self._wadl = self._browser.get_wadl_application(self._root_uri)
  File "/usr/lib/python2.6/dist-packages/launchpadlib/_browser.py", line 230, in get_wadl_application
    url, media_type='application/vd.sun.wadl+xml')
  File "/usr/lib/python2.6/dist-packages/launchpadlib/_browser.py", line 212, in _request
    raise HTTPError(response, content)
launchpadlib.errors.HTTPError: HTTP Error 401: Unauthorized

Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: linux None [modified: /var/lib/dpkg/info/linux.list]
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=nl_NL.UTF-8
 LANGUAGE=
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Solved that by removing
/home/~user/.cache/apport/launchpad.credentials
and filed a bug for it.

The apport data should now have been sent.

aberner (berner) wrote :

Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
Package: linux None [modified: /var/lib/dpkg/info/linux.list]
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=de_AT.UTF-8
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

aberner (berner) wrote :

Same here.

Motherboard Asus P5VD2-MX does not work with 2.6.28 . Only if you do "acpi=off" it comes up.
I also have a Nvidia 7600 GS which does not work with "acpi=off" (fallback to low-graphics-mode).
If I additionally add "noacpi" it starts with the nvidia-driver (v180) but hangs after some minutes.

I use BIOS Version 1007. There is allready a Version 1017, but in changelog is nothing with ACPI.

Up to Ubuntu 8.10 I had no problems with that machine.

Brian Murray (brian-murray) wrote :

I'm sorry the correct command to gather information for this bug report is:

apport-collect -p linux-image-`uname -r` 372375

This will gather kernel and hardware specific log files which will be quite helpful. Thanks in advance.

aberner (berner) wrote :

Architecture: i386
DistroRelease: Ubuntu 9.04
HibernationDevice: RESUME=UUID=7b4d4251-13a2-49bb-a7dc-6073f1fc068f
MachineType: System manufacturer System Product Name
Package: linux-image-2.6.30-020630-generic 2.6.30-020630
PackageArchitecture: i386
ProcCmdLine: root=UUID=f6b08cd2-d88d-4221-85da-fb512ad32e56 ro acpi=off quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=de_AT.UTF-8
ProcVersionSignature: Error: [Errno 2] No such file or directory: '/proc/version_signature'
Uname: Linux 2.6.30-020630-generic i686
UserGroups:

aberner (berner) wrote :
aberner (berner) wrote :
aberner (berner) wrote :
aberner (berner) wrote :
aberner (berner) wrote :
aberner (berner) wrote :
aberner (berner) wrote :
aberner (berner) wrote :
aberner (berner) wrote :
aberner (berner) wrote :

Did "apport-collect" but with wrong kernel - I'm just testing 2.6.30 :/
I'll do it later again with 2.6.28 kernel.

I just tested mainline kernels:
* 2.6.29-02062904-generic
* 2.6.30-020630-generic
both kernels work well with "acpi=off".

If I remove "acpi=off" kernel 2.6.29 behaves same as 2.6.28 (delivered with ubuntu 9.04) - systems hangs at "loading, please wait..."
Kernel 2.6.30 without "acpi=off" did little bit more - ubuntu boot-screen came but then system hangs. IO-problems with harddisk. See (real) screenshot in the attachement.

Architecture: i386
CurrentDmesg:
 [ 18.876851] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
 [ 18.986337] eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
 [ 29.536445] eth0: no IPv6 routers present
DistroRelease: Ubuntu 9.04
HibernationDevice: RESUME=UUID=7b4d4251-13a2-49bb-a7dc-6073f1fc068f
MachineType: System manufacturer System Product Name
Package: linux-image-2.6.28-11-generic 2.6.28-11.42
PackageArchitecture: i386
ProcCmdLine: root=UUID=f6b08cd2-d88d-4221-85da-fb512ad32e56 ro acpi=off quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=de_AT.UTF-8
ProcVersionSignature: Ubuntu 2.6.28-11.42-generic
Uname: Linux 2.6.28-11-generic i686
UserGroups:

aberner (berner) wrote :
aberner (berner) wrote :
aberner (berner) wrote :
aberner (berner) wrote :
aberner (berner) wrote :
aberner (berner) wrote :
aberner (berner) wrote :
aberner (berner) wrote :
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged

Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: linux None [modified: /var/lib/dpkg/info/linux.list]
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_IE.UTF-8
Uname: Linux 2.6.29-02062904-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

shayguitarra (sheamus) wrote :

Sorry, I've been booting with 2.6.29 I'll upload the data for 2.6.28 later on.

shayguitarra (sheamus) wrote :

Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: linux None [modified: /var/lib/dpkg/info/linux.list]
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_IE.UTF-8
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

aberner (berner) wrote :

shayguitarra got a MSI K9N SLI Platinum motherboard (I know it form bug #343268), but maybe it's the same problem as on Asus P5VD2-MX motherboard.

shayguitarra (sheamus) wrote :

It seems that way. Thanks aberner, forgot to copy those details over when I joined this thread.

shayguitarra (sheamus) wrote :

I've tried the new kernel 2.6.30 after solving a problem with the nvidia 180.44 driver. I installed a new version 180.60 instead.

It boots without acpi=off but it gives me this message:
[Firmware Bug]: powernow-k8: No compatible ACPI-PCSS objects found
[Firmware Bug]: powernow-k8: Try again with latest BIOS.

guillermolisi (guillermolisi) wrote :

Architecture: i386
DistroRelease: Ubuntu 9.04
HibernationDevice: RESUME=UUID=a0767259-47f7-4020-9d9a-35740bc8bc6c
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia
Package: linux-image-2.6.28-13-generic 2.6.28-13.44
PackageArchitecture: i386
ProcCmdLine: root=UUID=72c5d05e-b996-4634-9cd3-130716ed6404 ro noapic nolapic splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LANGUAGE=
ProcVersionSignature: Ubuntu 2.6.28-13.44-generic
Uname: Linux 2.6.28-13-generic i686
UserGroups: adm admin bacula cdrom dialout disk lpadmin plugdev root sambashare users

guillermolisi (guillermolisi) wrote :
guillermolisi (guillermolisi) wrote :
guillermolisi (guillermolisi) wrote :
guillermolisi (guillermolisi) wrote :
guillermolisi (guillermolisi) wrote :
guillermolisi (guillermolisi) wrote :
guillermolisi (guillermolisi) wrote :
Andres Mujica (andres.mujica) wrote :

aberner & guillermolisi are using the exact same board.

I've checked bios updates for the board and it's respective processors are fully supported by the bios revision in use.

From the Asus forums there's a suggestion that may -or not- apply please test it too ( http://vip.asus.com/forum/view.aspx?id=20080629000308890&board_id=1&model=M2N&page=1&SLanguage=en-us )

I'd suggest updating to latest BIOS (1017) http://support.asus.com/download/download.aspx (Motherboard - Socket 775 - P5VD2-MX) and report this issue at upstream bugzilla http://bugzilla.kernel.org/

Once the ticket is open, please let us now to link this report against it.

Changed in linux (Ubuntu):
assignee: nobody → Andres Mujica (andres.mujica)

Hallo Andres,

I added http://bugzilla.kernel.org/show_bug.cgi?id=13685

Changing the ACPI options in BIOS only gives me this:
If I select S1 only, my screen throws some text which end with "End trace"
If I select S3 only, the system hangs at "Loading, please wait..."
If I select the default option (both S1&S3), the result may vary between the two above.

Architecture: i386
DistroRelease: Ubuntu 9.04
HibernationDevice: RESUME=UUID=e3ddf61d-a3b0-4937-a381-4dbd8f673278
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia
Package: linux-image-2.6.28-11-generic 2.6.28-11.42
PackageArchitecture: i386
ProcCmdLine: root=UUID=212e9773-780a-463d-af1a-e9bcb36cdff7 ro acpi=off noapic nolapic xforcevesa quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=nl_NL.UTF-8
 LANGUAGE=
ProcVersionSignature: Ubuntu 2.6.28-11.42-generic
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

guillermolisi (guillermolisi) wrote :

Hello Andres

I've made all the tests you've advised. Update/upgrade the BIOS to the last version Asus released, changed the ACPI BIOS options, as Johan did, and tried several kernel versions from 2.6.28.11 thru 2.6.30 without success.

Andres Mujica (andres.mujica) wrote :

@Johan is really important to test with latest kernel from MainLine

https://wiki.ubuntu.com/KernelMainlineBuilds
http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/

an get the apport-collect data with this kernel so we can add the logs to upstream.

Thanks for get the report.

@Guillermo: Thanks for the tests, let's work with Johan while the bug is taken upstream, that way we won't fill up that report with too many logs.

Changed in linux (Ubuntu):
assignee: Andres Mujica (andres.mujica) → nobody
status: Triaged → Incomplete

This folder seems to contain the latest i386 packages: http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2009-06-12/

This kernel doesn't boot at all, it gives me a kernel panic. Do you have any suggestions? (i.e. other packages?)

Changed in linux:
status: Unknown → Confirmed
aberner (berner) wrote :

I just testet that kernel:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.31-rc1-fix1/
For fun and because there are no i386 in the daily builds of 2.6.30.

Result is that it works without "acpi=off".

I can confirm that 2.6.31-rc1-fix1 works without acpi=off.

I couldn't test if acpi functions were indeed working, though.
(I needed to reinstall my video driver, then got some error about the wrong gcc version. A few steps further I seem to have completely ruined g++, won't reinstall, configure or anything).

Update:
I re-installed Kubuntu and added the 2.6.31-rcx1-fix1 kernel. When I choose "Shut down", the computer finally turns itself off :-)
Seems like this is repaired.

Andres, can you recommend any further steps possibly needed?

I also tested v2.6.30 and that one is also ACPI-enabled.

Only bad thing is that I can't get the nvidia driver working.

Changed in linux:
status: Confirmed → Incomplete

In fact... can anyone reproduce the error with the 2.6.28-11 kernel?

I can boot mine without "acpi=off" now. I have applied new updates, but I also re-installed Kubuntu.

aberner (berner) wrote :

Latest Ubuntu Kernel 2.6.28-13 without acpi=off still hangs at "Loading, please wait".

Changed in linux:
status: Incomplete → Invalid

@Aberner: did you try boot options 'noapic' and/or 'nolapic'? They are required for me to boot. Otherwise I also get "Loading, please wait".

Andres Mujica (andres.mujica) wrote :

Thanks aberner and Johan for your tests.

According to upstream bug comments and the ones here since 2.6.30 the acpi=off is not needed, so this would get fixed in Karmic.

I don't really think that it's feasible to backport a patch here, however that is up to the kernel team.

Also it's pretty important that you test with the alpha releases in Karmic (with the livecd should suffice), so it doesn't reappear.

Thanks in advance

Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
Jeremy Foshee (jeremyfoshee) wrote :

Marking Fix Released.

-JFo

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.