Ubuntu

wifi module rtl8180 freezes the system

Reported by Jérémy Subtil on 2009-04-28
88
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Debian
New
Unknown
Fedora
Confirmed
Unknown
linux (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Jeremy Foshee
Declined for Jaunty by Jeremy Foshee
Declined for Karmic by Jeremy Foshee
Declined for Lucid by Jeremy Foshee
Declined for Maverick by Jeremy Foshee

Bug Description

On computers with some rtl818x chip based wifi cards, when module rtl8180 is modprobed this causes a complete freeze of the system.

This issue is severe for two reasons:
* computers with such wifi cards aren't able to connect to their network via wifi through a native linux driver;
* because rtl8180 is modprobed at startup, when a new user tries Ubuntu on such computer, the liveCD will show a black screen without any error message, and then the user will blame Ubuntu.

Although there are already some similar bug reports, they are all too specific to another hardware so the aim of this report is to centralize any information about actual system freezes caused by rtl8180 modprobes. In addition, this bug has been initially described in previous bug #152527.

Affected Ubuntu releases: Intrepid, Jaunty, Karmic

Affected wifi cards :
* MSI PC54G3 III (chipset RTL8185L)
* Zyxel G-302 V3

Workarounds:
* ndiswrapper:
    * works on Intrepid but not on Jaunty
* manual install of Realtek's supported driver:
    * at least it seems it prevents the system from freezing
    * still in testing: some can connect to the network, some not

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
LsUsb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
NonfreeKernelModules: nvidia
Package: linux-image-2.6.27-14-generic 2.6.27-14.33
ProcCmdLine: root=UUID=94814e6a-5868-4218-85ea-ff6550520509 ro quiet splash
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.27-14.33-generic
SourcePackage: linux
UnreportableReason: Ceci n'est pas un authentique paquet Ubuntu

Jérémy Subtil (bigmadwolf) wrote :
Massimo (massimobattiato) wrote :

Bug related to Wi-FI card model Zyxel G-302 V3, Ubuntu 8.10, 9.04 (installed) and either CD live.

In order to report this bug, I'll give answers to questions I found here:
https://wiki.ubuntu.com/X/Troubleshooting/Freeze
paragraph "Stock Reply for "random freeze" bugs".

- First freeze occurred while launching Live CD's Ubuntu 8.10 and 9.04, 32bit: black screen and freezed mouse's pointer.
- After installation of Ubuntu 9.04 32bit, freeze occurred many times during boot and randomly during session.
- No typical applications or actions preceded the freeze but only system boot.
- Not related with Compiz on/off.
- No errors messages (EE) reported in Xorg.0.log.
- All the freezes solved removing the Zyxel G-302 V3 card.

Daniel Letzeisen (dtl131) wrote :

I have a D-Link DWL-520 (rev.d) card, which uses this chipset.

I have found that Debian-based distros don't load the rtl8180 module for this card automatically for some reason. IIRC, when I try using the driver manually, it doesn't work. When trying Fedora (10) or Arch Linux, they load the module automatically. Unfortunately, it only works at a low speed for a limited amount of time.

I have been able to use Realtek's native Windows XP-64 drivers with ndiswrapper (using the amd64 version of Ubuntu or other Linux), but the native 32-bit XP drivers don't work for me with ndiswrapper (I tried Xubuntu 8.10 32-bit).

description: updated
Jérémy Subtil (bigmadwolf) wrote :

I've been able to load rtl8180 module whithout freeze in Intrepid by compiling the "official" source code v1030 provided by Realtek (http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=24&PFid=1&Level=6&Conn=5&DownTypeID=3&GetDown=false&Downloads=true#352).

My wifi card MSI PC54G3 III can now connect to my WPA network using wpa-supplicant, but it can't get any IP adress by DHCP using dhclient. I haven't tried to set a custom IP adress yet.

description: updated
description: updated
aatoma (antonio-toma) wrote :

In Jaunty I was still able to compile and use the Realtek provided Linux driver, as pointed out by Jérémy, but the upgrade to 2.6.31 kernel in Karmic broke that.
Now this bug is preventing me to use wireless. Any news about this bug?

mf (mat-fletcher) wrote :

I use rtl8180. Ubuntu 9.04. and and ubuntu 9.10

If i try to connect to a Wep netwrok i get a freeze and have to hard power cycle the machine to get it back. Nothing is written to /var/log/messages

I can live with this since i dont really use wep anywhere important.

Main issue is that the when connected to wpa and wpa2 networks my connection drops out at random. Usually when i most need it. I am currently unable to download more than 2MB of data.

Everything appears to still be connected but the traffic just stops. I have to stop the networking via Gnome network manager and start it again, where it will work straight away until the next time it craps out.

It is unusable in this state.

I've rebuilt this system a few times and have the same issue each time.

Card works fine in windows so not a hardware fault.

aceperry (perrychow) wrote :

I have a similar problem as mf in post #6. Using the Zonet ZEW1505 card with rt8185L chipset and the rtl8180 kernel driver, running wpa2, the connection starts up ok, weak signal compared to older wireless, and then drops out randomly. Sometimes the connection doesn't come back without a reboot of the computer. I'm going to try the windows driver as soon as I figure out how to get jaunty to use that exclusively.

aceperry (perrychow) wrote :

Oops, I meant Karmic and not jaunty on my last message.

tags: added: karmic

Having a Zyxel G-302 v3, I can confirm this bug. The system will freeze out at any moment : it can be during the boot or during the user session, but it will freeze for sure if you try to connect to a wifi network.

For information, similar issues occur with Fedora, though it happens only while trying to connect or during shutdown, see https://bugzilla.redhat.com/show_bug.cgi?id=501109

Jérémy Subtil (bigmadwolf) wrote :

This issue is present since Ubuntu Jaunty. To fix it, we do need to report it upstream as it sounds lik the other GNU/Linux distributions are affected as well.

Until there is no fix released for this bug, rtl8180 kernel module should be blacklisted in Lucid. It is inconceivable to let computers with such hardware freezing at boot with any error message and any log. IMHO the worst thing is that this is impossible to run the Ubuntu Live CD at all, so it gives a very bad impression for the first time Linux user.

You're probably right on your first point, though I'm not sure how to file the bug upstream. A concerted complaint from every distro accompagnied by a blacklist would probably be more efficient. The question is : do some cards work successfully with this driver ?

And you're definitely right on the second point. PLEASE blacklist this buggy driver or at least (in case it may work for lucky people) warn the user from activating it !!!

BTW, just installed Debian stable, same issue.

Changed in fedora:
status: Unknown → Confirmed
Marc Schaefermeyer (mtschaef) wrote :

I have a Dell C600 with a D-Link Air DWL-650 that apparently uses the RTL8180L as found when issuing the "sudo lspci"
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8180L 802.11b MAC (rev 20)
On a Fresh install of 9.10 the wireless card works great. When I update to the latest header "2.6.31-16" the card is not found. I have to add the driver via the "ndisgtk" which finds the card. But as soon as it connects to my wireless network everything freezes. The only way to get around it is to power down and pull the wireless pcmci card and connect via an RJ45 cable.
I have tried compiling a new kernal via multiple different posts, to no avail.
My work around is to reload from CD the 9.10 and not update to the latest kernal.
The kernal that works is the "linux-image-2.6.31-14-generic".

Jeremy Salwen (jeremy.salwen) wrote :

I would just like to note that I am getting the exact same problem. When I modprobe the rtl8180 driver (for an 8185 card), the system immediately freezes. It used to do so on startup until I removed the card. Now the driver doesn't load automatically, so I can boot up, but as soon as I modprobe it, instant complete freeze (SysRq commands don't even work). I've repeatedly read about how it is necessary to report an upstream bug, but has anyone done it? How would you do so?

Changed in debian:
status: Unknown → New
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Confirmed
Jeremy Foshee (jeremyfoshee) wrote :

Declining the Maverick specific nomination for now and leaving this open against the actively developed Ubuntu kernel (which happens to be Maverick at this time). Will re-open the nomination should a fix be narrowed down which we can confirm specifically resolves this issue in Maverick.

~JFo

I'm experiencing this problem on my Msi Wind u100 that has the rlt8187 chipset.
The system freezes shortly after suspend.This only happens when I'm running on battery. When I initially boot on battery the wi-fi works fine. Then after I suspend and resume it freezes after about 5 seconds. Resuming without the wi-fi turned on works but the system freezes as soon as I toggle it on.
I attached my kern.log with all messages from resume until the system freezes.

Correction: its the rtl8187se chipset

David (david.regev) wrote :

I’m experiencing the same issue as CirclingTheSun on the same machine. The strange thing is that these freezes were rare when I was running Lucid, but have started occurring consistently after upgrading to Maverick. Specifically, if I am on battery and the machine has resumed from suspect, then the system freezes after a few seconds. If wireless is disabled, this does not happen, but the freeze happens anyway a few seconds after you re-enable it.

A similar related issue that I saw already with Lucid: if a wireless network’s settings change (such as opening it up) while connected to it, the whole system freezes. This happens even when plugged in.

The original behaviour that I described has made computing on the go quite difficult. If there’s something I can do to help, I would be glad to do it.

Bruce Le (thelionkrap) wrote :

I have the Belkin F5D7000 v7032 and it is causing the described bug on ubuntu Maverick 10.10. I am not sure of the exact chipset the card uses, but I know that it is driver rtl8180 that causes the freeze, and when I blacklist that driver, ubuntu boots normally, but obviously the wifi card does not work. This behavior also happens in Fedora 14.

David (david.regev) wrote :

I just checked if this was fixed in the Natty beta. It’s not. I’m surprised such a regression has remained for so long. As I explained, this is a pretty severe bug. It makes it nearly impossible, for example, to load up a bunch several web pages, suspend, and then resume on the go while still being able to use WiFi.

Is there anything at all I can do to help get this fixed?

David (david.regev) wrote :

I just discovered a workaround, courtesy of bug 656745 comment 0. This is what it said:

in /etc/default/grub change:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=off"
and run "sudo update-grub"

floid (jkanowitz) wrote :

Does pcie_aspm=off as described in #21 do anything in systems that predate PCI-E?

jhansonxi (jhansonxi) wrote :

With Ubuntu 10.04 (Lucid Lynx) on an old Intel D845GBV (PCI/AGP) motherboard and a CompUSA 1244-00000403-010 PCI wireless card with an RTL8185L chip, "pcie_aspm=off" did not prevent the system from hard freeezing (not even magic sysreq keys work) during boot. With "acpi=off" the system boots successfully.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix

This problem persists in the current Natty release.

Albert Pool (albertpool) wrote :

Thank you for letting us know, Mr. Kupper. I was just going to buy a second-hand RTL8180, but that will be another card after reading this.

Glad I could help, even more glad will I be when this bug can be fixed.
(As a side-note, the card works with ndis-wrapper and the windows drivers, if this is an option for you. But you'll need to blacklist the driver in order to boot.)

Re-opening for Natty as bug #839019.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.