ext4: find_group_flex failed, fallback succeeded dir

Bug #367065 reported by Lutfi on 2009-04-26
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Jaunty
Medium
Leann Ogasawara

Bug Description

SRU Justification:

Impact: In Jaunty, the syslog is getting flooded with "ext4: find_group_flex failed, fallback succeeded dir" messages that could result in the logs filling up.

Fix: Backport two simple patches to print the find_group_flex() warning only once

Testcase: Install and run a default Jaunty kernel and confirm that the logs may sometimes fill with repeated warnings of "ext4: find_group_flex failed, fallback succeeded dir". Reinstall with a patched Jaunty kernel and this warning should only appear once.

=====

I just fresh install Jaunty. And using ext for / partision. Running quite fast. But i found here on /var/log/syslog:

Apr 26 07:23:08 djin kernel: [44757.548788] ext4: find_group_flex failed, fallback succeeded dir 107195
Apr 26 07:23:11 djin kernel: [44760.925873] ext4: find_group_flex failed, fallback succeeded dir 6795
Apr 26 07:23:11 djin kernel: [44761.078875] ext4: find_group_flex failed, fallback succeeded dir 7756
Apr 26 07:23:36 djin kernel: [44786.091891] ext4: find_group_flex failed, fallback succeeded dir 23308
Apr 26 07:23:38 djin kernel: [44787.629756] ext4: find_group_flex failed, fallback succeeded dir 107195
Apr 26 07:24:16 djin kernel: [44825.620102] ext4: find_group_flex failed, fallback succeeded dir 23308
Apr 26 07:24:16 djin kernel: [44825.767912] ext4: find_group_flex failed, fallback succeeded dir 23308
Apr 26 07:24:16 djin kernel: [44825.878233] ext4: find_group_flex failed, fallback succeeded dir 23308
Apr 26 07:24:26 djin kernel: [44835.919518] ext4: find_group_flex failed, fallback succeeded dir 23308
Apr 26 07:24:31 djin kernel: [44841.162643] ext4: find_group_flex failed, fallback succeeded dir 107195
Apr 26 07:24:50 djin kernel: [44860.233831] ext4: find_group_flex failed, fallback succeeded dir 107448
Apr 26 07:24:57 djin kernel: [44867.241969] ext4: find_group_flex failed, fallback succeeded dir 23308
Apr 26 07:25:07 djin kernel: [44877.273712] ext4: find_group_flex failed, fallback succeeded dir 23308
Apr 26 07:25:18 djin kernel: [44887.385821] ext4: find_group_flex failed, fallback succeeded dir 23308
Apr 26 07:25:24 djin kernel: [44894.204686] ext4: find_group_flex failed, fallback succeeded dir 23308
Apr 26 07:25:28 djin kernel: [44897.657049] ext4: find_group_flex failed, fallback succeeded dir 11673
Apr 26 07:25:28 djin kernel: [44897.856677] ext4: find_group_flex failed, fallback succeeded dir 11673
Apr 26 07:25:28 djin kernel: [44897.861306] ext4: find_group_flex failed, fallback succeeded dir 11668
Apr 26 07:25:28 djin kernel: [44897.969788] ext4: find_group_flex failed, fallback succeeded dir 11668
Apr 26 07:25:28 djin kernel: [44898.191049] ext4: find_group_flex failed, fallback succeeded dir 11673
Apr 26 07:25:28 djin kernel: [44898.319899] ext4: find_group_flex failed, fallback succeeded dir 11673
Apr 26 07:25:29 djin kernel: [44898.779675] ext4: find_group_flex failed, fallback succeeded dir 23308
Apr 26 07:25:38 djin kernel: [44907.504471] ext4: find_group_flex failed, fallback succeeded dir 107195
Apr 26 07:25:42 djin kernel: [44911.560031] ext4: find_group_flex failed, fallback succeeded dir 107195
Apr 26 07:25:54 djin kernel: [44923.833836] ext4: find_group_flex failed, fallback succeeded dir 23308
Apr 26 07:26:01 djin kernel: [44930.975396] ext4: find_group_flex failed, fallback succeeded dir 34
Apr 26 07:26:06 djin kernel: [44936.098596] ext4: find_group_flex failed, fallback succeeded dir 107195
Apr 26 07:26:07 djin kernel: [44937.030323] ext4: find_group_flex failed, fallback succeeded dir 23308
Apr 26 07:26:10 djin kernel: [44940.144091] ext4: find_group_flex failed, fallback succeeded dir 107195
Apr 26 07:26:25 djin kernel: [44955.293136] ext4: find_group_flex failed, fallback succeeded dir 23308

I dunno what problem. But it's like the GUI is fine.

I had the same messages after corrupting filesystem via "vaporised HDD power wires" ;-)
>> run fsck on the affected partition(s) --> no further messages!

affects: ubuntu → linux (Ubuntu)

Stranger. After restart, that error message gone :-D
Never show anymore

On Mon, Apr 27, 2009 at 6:08 AM, Alessandro Ghersi
<email address hidden> wrote:
> ** Package changed: ubuntu => linux (Ubuntu)
>
> --
> ext4: find_group_flex failed, fallback succeeded dir
> https://bugs.launchpad.net/bugs/367065
> You received this bug notification because you are a direct subscriber
> of the bug.
>

-None- (mike-nycmoma) wrote :

I have the same messages an hour ago in /var/log/messages at the yesterday clear installed jaunty-server:
Apr 28 22:16:04 server kernel: [ 4616.302298] ext4: find_group_flex failed, fallback succeeded dir 228018
Apr 28 22:16:04 server kernel: [ 4616.304474] ext4: find_group_flex failed, fallback succeeded dir 228018
Apr 28 22:16:04 server kernel: [ 4616.337123] ext4: find_group_flex failed, fallback succeeded dir 228018
Apr 28 22:16:04 server kernel: [ 4616.340460] ext4: find_group_flex failed, fallback succeeded dir 228018
Apr 28 22:16:04 server kernel: [ 4616.342315] ext4: find_group_flex failed, fallback succeeded dir 228018
Apr 28 22:16:04 server kernel: [ 4616.344385] ext4: find_group_flex failed, fallback succeeded dir 228068
Apr 28 22:16:04 server kernel: [ 4616.346948] ext4: find_group_flex failed, fallback succeeded dir 228074
Apr 28 22:16:04 server kernel: [ 4616.349241] ext4: find_group_flex failed, fallback succeeded dir 228074
Apr 28 22:16:04 server kernel: [ 4616.351677] ext4: find_group_flex failed, fallback succeeded dir 228074
Apr 28 22:16:04 server kernel: [ 4616.356487] ext4: find_group_flex failed, fallback succeeded dir 228074
Apr 28 22:16:09 server kernel: [ 4621.313340] __ratelimit: 1945 callbacks suppressed
Apr 28 22:16:09 server kernel: [ 4621.313344] ext4: find_group_flex failed, fallback succeeded dir 229590
Apr 28 22:16:09 server kernel: [ 4621.314929] ext4: find_group_flex failed, fallback succeeded dir 229590
Apr 28 22:16:09 server kernel: [ 4621.318208] ext4: find_group_flex failed, fallback succeeded dir 229590
Apr 28 22:16:09 server kernel: [ 4621.322265] ext4: find_group_flex failed, fallback succeeded dir 229590
Apr 28 22:16:09 server kernel: [ 4621.325094] ext4: find_group_flex failed, fallback succeeded dir 229590
Apr 28 22:16:09 server kernel: [ 4621.326953] ext4: find_group_flex failed, fallback succeeded dir 229590
Apr 28 22:16:09 server kernel: [ 4621.328415] ext4: find_group_flex failed, fallback succeeded dir 229590
Apr 28 22:16:09 server kernel: [ 4621.334436] ext4: find_group_flex failed, fallback succeeded dir 229590
Apr 28 22:16:09 server kernel: [ 4621.340309] ext4: find_group_flex failed, fallback succeeded dir 229590
Apr 28 22:16:09 server kernel: [ 4621.346933] ext4: find_group_flex failed, fallback succeeded dir 229590
Apr 28 22:16:15 server kernel: [ 4627.544248] __ratelimit: 559 callbacks suppressed
..... etc...

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Per this thread: http://thread.gmane.org/gmane.linux.kernel/805361 this is only a warning, and not an error. The fact that the warning is printed often is a slight annoyance that will be fixed in a future kernel release. Because it is "by design" I am going to mark this bug as invalid.

@ Theodore Ts'o, if you have anything farther to add, feel free. :)

Changed in linux (Ubuntu):
status: New → Invalid
Theodore Ts'o (tytso) wrote :

In some cases, this syslog warning can be emitted at a very high rate, potentially causing /var/log to fill up. So I would strongly encourage Ubuntu to consider back-porting two very simple commits into the Jaunty kernel as an interim measure: 2842c3b54 and 6b82f3cb2 in the mainline kernel.

Changed in linux (Ubuntu):
status: Invalid → Confirmed

Marking this Fix Released against the actively developed Karmic kernel as both patches Ted referenced are already in the Karmic kernel. I've opened a Jaunty nomination for these to be backported.

Changed in linux (Ubuntu Jaunty):
importance: Undecided → Medium
status: New → Triaged
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
tags: added: ext4
Changed in linux (Ubuntu Jaunty):
assignee: nobody → Leann Ogasawara (leannogasawara)
status: Triaged → In Progress

Hi All,

I backported the patches Ted referenced in comment #5 and built some test kernels:

http://people.canonical.com/~ogasawara/lp367065/

Unfortunately it sounded like these messages didn't always appear, but if you could please test and let me know if it does happen to resolve this issue that'd be great (ie the message should be printed once rather than repeatedly). Ideally we'd prefer to have confirmed positive feedback from testing before we submit this for a Stable Release Update for Jaunty. However, I will ask the Ubuntu kernel team to also take these into consideration as Ted pointed out they do seem do be pretty simple patches with very low risk of regression. Thanks.

Nafallo Bjälevik (nafallo) wrote :

 Hi Leann,

The test kernel seems to work for me. I'll run it for a while and see if I'll get another one of these messages. Haven't seen it since I rebooted for the kernel.

description: updated
PowerUser (i-am-sergey) wrote :

Got same error messages. Are they harmless? Were files or dirs affected anyhow or this is just warning?

Theodore Ts'o (tytso) wrote :

It's harmless; it was just a warning that the workaround had triggered. A better fix was dropped into the next version of the Linux kernel.

Stefan Bader (smb) on 2009-09-08
Changed in linux (Ubuntu Jaunty):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Accepted linux into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-15.52

---------------
linux (2.6.28-15.52) jaunty-proposed; urgency=low

  [ Stefan Bader ]

  * Revert "SAUCE: ACPI: Populate DIDL before registering ACPI video device
    on Intel"
    - LP: #423296
  * SAUCE: Allow less restrictive acpi video detection
    - LP: #333386

  [ Upstream Kernel Changes ]

  * include drivers/pci/hotplug/* in -virtual package
    - LP: #364916
  * ext4: don't call jbd2_journal_force_commit_nested without journal
    - LP: #418197
  * ext4: fix ext4_free_inode() vs. ext4_claim_inode() race
    - LP: #418197
  * ext4: fix bogus BUG_ONs in in mballoc code
    - LP: #418197
  * ext4: fix typo which causes a memory leak on error path
    - LP: #418197
  * ext4: Fix softlockup caused by illegal i_file_acl value in on-disk
    inode
    - LP: #418197
  * ext4: Fix sub-block zeroing for writes into preallocated extents
    - LP: #418197
  * jbd2: Call journal commit callback without holding j_list_lock
    - LP: #418197
  * ext4: Print the find_group_flex() warning only once
    - LP: #367065
  * ext4: really print the find_group_flex fallback warning only once
    - LP: #367065

linux (2.6.28-15.51) jaunty-proposed; urgency=low

  [ Colin Ian King ]

  * SAUCE: wireless: hostap, fix oops due to early probing interrupt
    - LP: #254837

  [ Leann Ogasawara ]

  * Add the atl1c driver to support Atheros AR8132
    - LP: #415358
  * Updating configs to enable the atl1c driver
    - LP: #415358

  [ Stefan Bader ]

  * Revert "SAUCE: input: Blacklist digitizers from joydev.c"
    - LP: #300143
  * SAUCE: Fix the exported name for e1000e-next
    - LP: #402890
  * SAUCE: Fix incorrect stable backport to bas_gigaset
    - LP: #417732
  * SAUCE: Remove the atl2 driver from the ubuntu subdirectory
    - LP: #419438

linux (2.6.28-15.50) jaunty-proposed; urgency=low

  [ Colin Ian King ]

  * SAUCE: radio-maestro: fix panics on probe failure
    - LP: #357724
  * SAUCE: HDA Intel, sigmatel: Enable speakers on HP Mini 1000
    - LP: #318942

  [ Jerone Young ]

  * SAUCE: Fix Soltech TA12 volume hotkeys not sending key release in
    Jaunty
    - LP: #397499

  [ John Johansen ]

  * SAUCE: remove AppArmor debug check for calls from interrupt context
    - LP: #350789

  [ Manoj Iyer ]

  * SAUCE: Fix kernel panic when SELinux is enabled.
    - LP: #395219

  [ Matthew Garrett ]

  * SAUCE: ACPI: Populate DIDL before registering ACPI video device on
    Intel

  [ Michael Frey (Senior Manager, MID ]

  * SAUCE: Fix for internal microphone for Dell Mini10V
    - LP: #394793

  [ Tim Gardner ]

  * SAUCE: Added e1000e from sourceforge.
    - LP: #402890

  [ Upstream Kernel Changes ]

  * Input: synaptics - report multi-taps only if supported by the device
    - LP: #399787
  * ftdi_sio: fix kref leak
    - LP: #396930, #376128
  * IPv6: add "disable" module parameter support to ipv6.ko
    - LP: #351656

 -- Stefan Bader <email address hidden> Thu, 27 Aug 2009 15:09:06 +0200

Changed in linux (Ubuntu Jaunty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers