Ubuntu 9.04 freezes when using rt kernel

Bug #366952 reported by Michele Gambirasi on 2009-04-25
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I'm trying ubuntu 9.04 Jaunty on a Shuttle XPC SG33G5M with G33 chipset (GMA 3100 graphics) and core2duo E6550.

I used it for some hours with generic kernel and it seems all OK.
Now I'm trying to switch to linux-rt: after some minutes of use the system completely freeze, including mouse and keyboard, so I must reset it manually.

This happens both with 32 and 64bit, on ubuntu and ubuntustudio.

affects: ubuntu → linux (Ubuntu)
Josh Green (josh-resonance) wrote :

I'm also getting lockups on my Ubuntu Studio 9.04 system. I've tried the -rt kernel, the generic kernel and Daniel T Chen's kernel (see #367671). At first I suspected an issue with PulseAudio running rt SCHED_FIFO and starving the CPU. But now PulseAudio is not running RT on my system and I'm getting complete lockups with generic and Daniel's kernel and with the -rt kernel I get lockups related to the root file system (applications continue to run, but any process attempting to write to the rootfs locks up). I created a bug for this last issue: #372856

Are you using ext4? I suspect that might be the problem with the generic kernels locking up too, but I haven't been able to get a OOPs message from those, due to complete system lockup.

Edetano (edetano) wrote :

Hi, i switched to rt kernels as a workaround for a lot of problems with generic kernel and SATA disks. Now it runs fine, and it seems fsck will be no used again for a long time, but the system freezes randomly every 3-4 hours (oh, old windows days are back, lol).Mis system is:
-Kubuntu 9.04 i386
-Intel Core Duo
-Asus moterboard with ICH7 chipset
-2 gb dual chanel kingstom RAM
-Seagate barracuda ST 3500320AS SATA Hd,
-Point of View Nvidia 9400 GT grafic card
-LG DVDRAM wirtter
-Realtek 8139 chipset ethernet card

Previusly, it happened in the same system except for an old Seagate 8GB ATA disc instead of the SATA.

It happened both with the nv non 3D driver and with the propietary driver, installed with envying.
It doesn't sems to be any app related with the freeze, since it happend while surfing the web with firefox, listening music with amarok, while on youtube... and while playing freeciv :-).
It happened too while the X server wasn't runing: I switched to tty1 and killed kdm, then switched back to tty7 and plonk! black screen and no response at all.

Josh Green (josh-resonance) wrote :

Edetano: Are you using ext4? It sounds like you might be from your comment on fsck not needing to be used for a long time.

Edetano (edetano) wrote :

No Josh, I'm using ext3. What I mean is that the use of the rt kernel solved my problems with sata discs. I sufered this bug:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/217920

What make me do a lot o fsck.

Josh Green (josh-resonance) wrote :

Ok. So either you are experiencing the same lockup and its not ext4 related or its a different lockup. I haven't gotten a lockup in quite some time now, but I'm not sure if it is fixed or why it would be (perhaps software updates).

Josh Green (josh-resonance) wrote :

I ended up building my own kernel using make-kpkg and stock Linux 2.6.29.4, with the .config from /boot/config-2.6.28-3-rt. No lockups in several days now, so whatever issue I was having is fixed in at least 2.6.29.4. I have not tested latency with this kernel, so I'm not sure how well it performs in regards to software running RT.

Edetano (edetano) wrote :

Yes, 2.6.29.4 seems to be free of the sata timeout bug and doesn't freeze.

My 9.04 system is up to date, and I'm on kernel 2.6.28-14. So is 2.6.29.4 in 9.10 or what?

Jeremy Foshee (jeremyfoshee) wrote :

Hi Michele,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/lucid.

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 366952

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers