Ubuntu

Computer hangs up (freeze) and reports SATA errors during disk checking after reboot

Reported by AnatolyVolodko on 2008-04-15
86
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Nominated for Hardy by AnatolyVolodko
Declined for Intrepid by Steve Langasek
linux (Ubuntu)
High
Unassigned
Nominated for Hardy by AnatolyVolodko
Declined for Intrepid by Steve Langasek

Bug Description

Computer hangs up and reports SATA errors during (auto) disk checking after reboot.

I have tried kernel boot flags:
pci=routeirq noacpi
the issue (freeze, (manual reset), root FS check and SATA errors) remains....

This was many times at casual moments. I thought before it is related to Power managment...
Now I am not sure...

Motherboard: Biostar TA 780G
Processor: AMD Athlon 64 X2 5200
Memory: 4Gb
OS: Ubuntu Hardy (Beta 1) AMD 64 bit
Integrated video (and Compiz) works well now....

Kernel log (see full in attachment):

Linux version 2.6.24-16-generic (buildd@yellow) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #1 SMP Thu Apr 10 12:47:45 UTC 2008 (Ubuntu 2.6.24-16.30-generic)

Apr 15 23:28:53 anatolhome kernel: [ 94.342757] PPP Deflate Compression module registered

*********************************

This is нang up moment: Apr 15 23:29:xx
This time I have run keyboard test (Ubuntu hardware test)
But it is not repeatable....

Display seems OK, but keyboard and mouse do not respond totally....

***********************************
Reboot after manual reset:

Apr 15 23:40:45 anatolhome kernel: Inspecting /boot/System.map-2.6.24-16-generic
Apr 15 23:40:45 anatolhome kernel: Loaded 28313 symbols from /boot/System.map-2.6.24-16-generic.
Apr 15 23:40:45 anatolhome kernel: Symbols match kernel version 2.6.24.
Apr 15 23:40:45 anatolhome kernel: Loaded 22814 symbols from 94 modules.
Apr 15 23:40:45 anatolhome kernel: [ 0.000000] Linux version 2.6.24-16-generic (buildd@yellow) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #1 SMP Thu Apr 10 12:47:45 UTC 2008 (Ubuntu 2.6.24-16.30-

*************************************************************************
Root FS check is started
*************************************************************************

Please see (this messages is repeatable):

Apr 15 23:41:30 anatolhome kernel: [ 88.461221] ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x80000 action 0x2 frozen
Apr 15 23:41:30 anatolhome kernel: [ 88.461228] ata1: SError: { 10B8B }
Apr 15 23:41:30 anatolhome kernel: [ 88.461232] ata1.00: cmd c8/00:68:47:d0:96/00:00:00:00:00/e3 tag 0 dma 53248 in
Apr 15 23:41:30 anatolhome kernel: [ 88.461233] res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
Apr 15 23:41:30 anatolhome kernel: [ 88.461237] ata1.00: status: { DRDY }
Apr 15 23:41:30 anatolhome kernel: [ 88.576695] ata1: soft resetting link
Apr 15 23:41:30 anatolhome kernel: [ 88.658127] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Apr 15 23:41:30 anatolhome kernel: [ 88.660449] ata1.00: configured for UDMA/133
Apr 15 23:41:30 anatolhome kernel: [ 88.660458] ata1: EH complete
Apr 15 23:41:30 anatolhome kernel: [ 88.666676] sd 0:0:0:0: [sda] 234441648 512-byte hardware sectors (120034 MB)
Apr 15 23:41:30 anatolhome kernel: [ 88.667594] sd 0:0:0:0: [sda] Write Protect is off
Apr 15 23:41:30 anatolhome kernel: [ 88.667597] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
Apr 15 23:41:30 anatolhome kernel: [ 88.667824] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA

AnatolyVolodko (anatolyvolodko) wrote :
AnatolyVolodko (anatolyvolodko) wrote :
AnatolyVolodko (anatolyvolodko) wrote :

More old messages

AnatolyVolodko (anatolyvolodko) wrote :
AnatolyVolodko (anatolyvolodko) wrote :
AnatolyVolodko (anatolyvolodko) wrote :
AnatolyVolodko (anatolyvolodko) wrote :

Now (after last update) Ubuntu booting is very slow (10 min+++)...

I have not waited and boot to Vista (x64).
It seems Vista works OK and I see Ext2 partion by ExtIFS .

AnatolyVolodko (anatolyvolodko) wrote :

After reboot and check the disk with the same SATA errors Ubuntu(Hardy x64) works about 8 hours OK...

AnatolyVolodko (anatolyvolodko) wrote :

More info about my hardware:
Motherboard:
Biostar TA780G M2+ 6.x
http://www.biostar.com.tw/app/en-us/t-series/content.php?S_ID=344
http://www.biostar.com.tw/app/en-us/t-series/bios.php?S_ID=344
Bios (Upload Date 2008-03-26):
http://www.biostar.com.tw/upload/Bios/A78gm324.bst

Processor: AMD Athlon 64 X2 5200

Ubuntu architecture: AMD64

description: updated
Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: New → Triaged

My freezes are most probable during Synaptic update process while network pptp-connection exists....
(but it is not fully repeatable)

see also:
https://bugs.launchpad.net/ubuntu/+bug/214321

I have tried to boot in VMWare (under Vista) from the same physical disk.
In VMWare the bug is fully repeatable. See picture in attachment.

This is "lspci -vvv > lspci.log" under Ubuntu 64

Similar experience observed with Hardy Heron 8.04.

Version x86_64
Processor: Intel 9600 Quad
Memory: 8GB
Disk: 1GB SATA
Dual PCI-2e(16) graphics cards: evga 9600GT (512) and evga 8800GT (512)
Shuttle Motherboard

Behavior is intermittent but frequent.
Freeze seems not to be a hangup but repeated error reports to the console as
the delay timing is changed.

kiev1 (sys-sys-admin) wrote :
Download full text (12.8 KiB)

HELP!

The system droops periodically, it is sometimes impossible to reboot her - file system is not accessible.

I changed hard drive and sata port, became a little better, but then errors appeared again

HELP!

#tail /var/log/syslog

May 19 21:17:17 mserv kernel: [ 5987.403157] ata4.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2
May 19 21:17:17 mserv kernel: [ 5987.403186] ata4.01: BMDMA stat 0x46
May 19 21:17:17 mserv kernel: [ 5987.403209] ata4.01: cmd c8/00:20:2f:e9:e8/00:00:00:00:00/f3 tag 0 dma 16384 in
May 19 21:17:17 mserv kernel: [ 5987.403210] res 51/84:00:4e:e9:e8/84:00:03:00:00/f3 Emask 0x30 (host bus error)
May 19 21:17:17 mserv kernel: [ 5987.403245] ata4.01: status: { DRDY ERR }
May 19 21:17:17 mserv kernel: [ 5987.403262] ata4.01: error: { ICRC ABRT }
May 19 21:17:17 mserv kernel: [ 5987.403286] ata4: soft resetting link
May 19 21:17:17 mserv kernel: [ 5987.605196] ata4.01: configured for UDMA/133
May 19 21:17:17 mserv kernel: [ 5987.605216] ata4: EH complete
May 19 21:17:17 mserv kernel: [ 5987.628483] sd 3:0:1:0: [sda] 312581808 512-byte hardware sectors (160042 MB)
May 19 21:17:17 mserv kernel: [ 5987.628526] sd 3:0:1:0: [sda] Write Protect is off
May 19 21:17:17 mserv kernel: [ 5987.628530] sd 3:0:1:0: [sda] Mode Sense: 00 3a 00 00
May 19 21:17:17 mserv kernel: [ 5987.628585] sd 3:0:1:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA

Hardy Heron 8.04/Core2Duo 3Gz :

#lshw

    description: Desktop Computer
    product: MS-7267
    vendor: MSI
    version: 2.2
    serial: To Be Filled By O.E.M.
    width: 32 bits
    capabilities: smbios-2.3 dmi-2.3 smp-1.1 smp
    configuration: boot=normal chassis=desktop cpus=0 uuid=00020003-0004-0005-0006-000700080009
  *-core
       description: Motherboard
       product: MS-7267
       vendor: MSI
       physical id: 0
       version: 2.2
       serial: To be filled by O.E.M.
       slot: To Be Filled By O.E.M.
     *-firmware
          description: BIOS
          vendor: American Megatrends Inc.
          physical id: 0
          version: 080012 (09/18/2006)
          size: 64KiB
          capacity: 448KiB
          capabilities: isa pci pnp apm upgrade shadowing escd cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer int10video acpi usb ls120boot zipboot biosbootspecification
     *-cpu
          description: CPU
          product: Intel(R) Pentium(R) 4 CPU 3.00GHz
          vendor: Intel Corp.
          physical id: 4
          bus info: cpu@0
          version: Intel(R) Pentium(R) 4 CPU 3.00GHz
          serial: To Be Filled By O.E.M.
          slot: CPU 1
          size: 3GHz
          capacity: 3GHz
          width: 64 bits
          clock: 200MHz
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx x86-64 constant_tsc pebs bts sync_rdtsc pni monitor ds_cpl est cid cx16 xtpr lahf_lm
        *-cache:0
             description: L1 cache
             physical id: 5
             slot: L1-Cache
             size: 16KiB
             cap...

Removing the linux-source-2.6.24 task since beginning with the Hardy release cycle kernel bugs should be reported against the "linux" kernel package. This report already has been assigned appropriately to the "linux" package. Thanks.

Changed in linux-source-2.6.24:
status: New → Invalid
Trax (forum-traxbyte) wrote :

This still seems to be an issue on 2.6.24-19 and on 2.6.26-4, at least for me with my D945GCLF board. SATA is entirely unusable.

Is there any news on the bug?

bonkers (b-bobcat) wrote :

I have same errors, but at hashing/reading data on SATA hdd with NCQ, after this read-write errors files on hdd was corrupt
any news? :(
mb intel 915gav/200Gb samsung sata hdd

bonkers (b-bobcat) wrote :

inWindows checkdisk find 4kb in bad sectors ! (4096 per cluster)
It is necessary to refuse use Ubuntu until then bug it will to be fixed. :(

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

pwmg (paul-geraedts) wrote :

I have also the problem on my PC with AMD Athlon 1250Mz with AMIBIOS 2001

I've successfully installed Xubuntu Intrepid Ibex 8.10 Alpha 5. When I reboot after the installation, the booting proces stops:

exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0 frozen
ata1.00: status: {DRDY}

I've had the same error in Hardy on the same PC.

kiev1 (sys-sys-admin) wrote :

and if to try Debian ?

pwmg (paul-geraedts) wrote :

Debian installer of Lenny also does not work; Etch's does work.

So i can install Etch, then upgrade to Lenny; and the booting of Lenny after install works.

In the case of Ubuntu both Hardy and Intrepid Ibex i can install it, but can not boot afterwards anymore.

So for this PC i stay on Lenny, sadly...

Trax (forum-traxbyte) wrote :

The 2.6.27 kernel (with Hardy) does not help in my case. Only this time I get

[ 714.650458] ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6
[ 714.650519] ata3.00: BMDMA stat 0x26
[ 714.650577] ata3.00: cmd 25/00:00:00:34:20/00:04:00:00:00/e0 tag 0 dma 524288 in
[ 714.650582] res 51/84:ff:01:35:20/84:02:00:00:00/e0 Emask 0x30 (host bus error)
[ 714.650708] ata3.00: status: { DRDY ERR }
[ 714.650757] ata3.00: error: { ICRC ABRT }
[ 714.650819] ata3: soft resetting link

kiev1 (sys-sys-admin) wrote :

use ide hdd instead sata, or debian/redhat (((

Trax (forum-traxbyte) wrote :

Unfortunately for me, I can't. My system in running on the intel atom board D945GCLF. It has 2 SATA ports and only one PATA port. The latter port is connected to a CF card (via CF2IDE adapter).

alien013 (kondakci) wrote :

Hi everybody,

I guess i have similar problem.. I am using Ubuntu Hardy, this is a Sony Vaio VGN S660 laptop (old one). I am new to linux, by the way..

Here is some information, please inform me when u need any info i need to solve the problem since this is only computer that i use and it freezes a lot, like having a heart stroke :)

uname -a
Linux vaio 2.6.24-19-generic #1 SMP Wed Aug 20 22:56:21 UTC 2008 i686 GNU/Linux

in attechment dmesg for fresh restart and log file

jonie (jonie) wrote :

Same here, Toshiba Satellite M70 (i915, Hitachi SATA I disk w/NCQ), Intrepid 2.6.27-3. Moving to -4 kernel makes system completely unstable and unusable, kernel reports I/O errors on the hard disk. When kernel -3 with all_generic_ide option is used there are lockups too, but soft ones only.

alien013 (kondakci) wrote :

Well... I have news..

First of all i had to format since it became unbearable and veryyy freezyyy.. So i formatted and install Kubuntu 8.04 which has kernel version 2.6.24-3-generic. The problem solved.. Everything was fine until i upgraded my OS with kernel 2.6.24.19 thenn again it was a disaster...

Then i had to format again.. This thime i upgraded everything but latest kernel 2.6.26.19...

why do i have problem with the latest version ?? any help ??

thanxx...

alien013 (kondakci) wrote :
Download full text (27.6 KiB)

This is my final dmesg.. i guess i have a little problem since while starting my system freezes a litte, but i dont know how to solve it... since i am a beginner :) yuppyyyyy

[ 0.000000] Linux version 2.6.24-3-generic (buildd@vernadsky) (gcc version 4.2.3 20071223 (prerelease) (Ubuntu 4.2.2-4ubuntu3)) #1 SMP Thu Jan 3 23:30:29 UTC 2008 (Ubuntu 2.6.24-3.5-generic)
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
[ 0.000000] BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000d8000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000003fe90000 (usable)
[ 0.000000] BIOS-e820: 000000003fe90000 - 000000003fe9d000 (ACPI data)
[ 0.000000] BIOS-e820: 000000003fe9d000 - 000000003ff00000 (ACPI NVS)
[ 0.000000] BIOS-e820: 000000003ff00000 - 0000000040000000 (reserved)
[ 0.000000] BIOS-e820: 00000000e0000000 - 00000000f0006000 (reserved)
[ 0.000000] BIOS-e820: 00000000f0008000 - 00000000f000c000 (reserved)
[ 0.000000] BIOS-e820: 00000000fed20000 - 00000000fed90000 (reserved)
[ 0.000000] BIOS-e820: 00000000ff000000 - 0000000100000000 (reserved)
[ 0.000000] 126MB HIGHMEM available.
[ 0.000000] 896MB LOWMEM available.
[ 0.000000] Entering add_active_range(0, 0, 261776) 0 entries of 256 used
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0 -> 4096
[ 0.000000] Normal 4096 -> 229376
[ 0.000000] HighMem 229376 -> 261776
[ 0.000000] Movable zone start PFN for each node
[ 0.000000] early_node_map[1] active PFN ranges
[ 0.000000] 0: 0 -> 261776
[ 0.000000] On node 0 totalpages: 261776
[ 0.000000] DMA zone: 32 pages used for memmap
[ 0.000000] DMA zone: 0 pages reserved
[ 0.000000] DMA zone: 4064 pages, LIFO batch:0
[ 0.000000] Normal zone: 1760 pages used for memmap
[ 0.000000] Normal zone: 223520 pages, LIFO batch:31
[ 0.000000] HighMem zone: 253 pages used for memmap
[ 0.000000] HighMem zone: 32147 pages, LIFO batch:7
[ 0.000000] Movable zone: 0 pages used for memmap
[ 0.000000] DMI 2.3 present.
[ 0.000000] ACPI: RSDP signature @ 0xC00F6780 checksum 0
[ 0.000000] ACPI: RSDP 000F6780, 0014 (r0 PTLTD )
[ 0.000000] ACPI: RSDT 3FE97449, 0048 (r1 Sony V0 20051109 PTL 0)
[ 0.000000] ACPI: FACP 3FE9CE78, 0084 (r2 Sony V0 20051109 PTL 50)
[ 0.000000] ACPI: DSDT 3FE989FD, 447B (r1 Sony V0 20051109 PTL 100000E)
[ 0.000000] ACPI: FACS 3FEADFC0, 0040
[ 0.000000] ACPI: APIC 3FE9CEFC, 0068 (r1 Sony V0 20051109 PTL 50)
[ 0.000000] ACPI: BOOT 3FE9CFD8, 0028 (r1 Sony V0 20051109 PTL 1)
[ 0.000000] ACPI: MCFG 3FE9CF9C, 003C (r1 Sony V0 20051109 PTL 5F)
[ 0.000000] ACPI: SSDT 3FE983AA, 064F (r1 Sony V0 20051109 PTL 20030224)
[ 0.000000] ACPI: SSDT 3FE97D0E, 069C (r1 Sony V0 20051109 PTL 20030224)
[ 0.000000] ACPI: SSDT 3FE978C9, 0277 (r1 Sony V0 20051109 PTL 20030224)
[ 0.000000] ACPI: SSDT 3FE976AA, 021F (r1 Sony V0 2005...

jonie (jonie) wrote :

For me it seems to be enough to disable hpet support in kernel (boot with hpet=disable). It does not only remove soft lockups, but in my case it's also a workaround for sata errors.

alien013 (kondakci) wrote :

thanx for reply..

but how can i disable hpet... i am just a beginner :)

and can we sure about this is the problem ?? i want to upgrade my kernel but when i upgrade it frezes a lot.. and i cant do anything.. once i upgrade how can go back to previous settings if something goes wrong...

thanxx again...

jonie (jonie) wrote :

If you'd like to try whether it helps, just add hpet=disable to the kernel lines in /boot/grub/menu.lst:

For example:

title Ubuntu intrepid (development branch), kernel 2.6.27-4-generic
root (hd0,2)
kernel /boot/vmlinuz-2.6.27-4-generic root=UUID=75ffa061-25f6-44b8-ac61-07452816b281 ro quiet splash hpet=disable
initrd /boot/initrd.img-2.6.27-4-generic
quiet

Other details may vary in your setup, this is only an example.

alien013 (kondakci) wrote :

Thanx for the reply...

Since now I am using 2.6.24-3 kernel i cannot understand whether it will help or not unless i upgrade my kernel to 2.6.24-19...

i will try this but let me first ask how can i replace my old kernel if it does not work for me??

on the other hand, today first time my computer freeze while its opening, then I rebooted and it was gone, everything was okey as far as I understand.. How is it possible to occur once such a freezing ?

alien013 (kondakci) wrote :

I have news... I updated my kernel to 2.6.24-21-generic and then for a while everything was okey.. I also disabled hpet.. After a while it started to freeze again.. And today again, especially while i am using firefox... I am sending my dmesg that tcopied after started freezing, at the and u can see Emask, Frozen etc. errorss.

Are these errors possible to be related bad sectors on my hard drive ?? I cannot say i have been gently to my laptop... Its highly probable drive contains bad sectors..

There are lots of topics about this problem however every time people ask to send dmesg and other stuff that i really dont understand.. Then im lost.. So i really need help..

Thanxx...

jonie (jonie) wrote :

It doesn't look like there are bad sectors. You may also try all_generic_ide (this will disable some advanced features like NCQ) together with hpet=disable. My fix was for Intrepid (2.6.27) and I have no clue if it works for older versions. I can only confirm after a few days that my laptop never froze again since hpet has been disabled.

alien013 (kondakci) wrote :

I changed my /boot/grub/menu.lst as you suggested "all_generic_ide hpet=disable" now it is working properly.. If i have problem i will let you know..

thanx for everythin

Sauron (sauron-zechateau) wrote :

I've experienced system Freezes while upgrading from Gutsy to Hardy. SO, 2-3 month later, I get back to Gutsy. After that, I've fresh installed Ibex and for now, I experience the same bug.
I'm going to test the hpet=disable add line into the Grub menulist.
I'll tell you if it rocks or not, 'cause I know of to crash my system : I just have to downolad some files from a disk to another and try to check my mails or surf with Firefox.

See you !

Sauron (sauron-zechateau) wrote :

I'm back : My PC freezed once again, with the "hpet=disable" command.
The problem seems deeper.

Yesterday, I had a very similar problem with a computer that never had this
problem before. I googled and found a very interesting forum discussion with one
person that had experienced this issue. (
http://ubuntuforums.org/showthread.php?t=598837 ) He tried to resolve it using 3
different motherboards, with 2 different HDD, with several GNU/Linux
distribution and several SATA cables. Always the problem was there. Someone
argued that SATA cables are often crappy cables, and that he had to replace
almost 20 cables in 4 years. He proposed then to try with a cable of better
quality. This is what our first guy did, he bought a SATA2 cable of better
quality that the SATA ones delivered with the motherboards and his problem was
solved.

I then try to just disconnect my SATA cable and connect it back and my problem
was also solved. I also compared a bunch of SATA cables I have and there
actually is a noticeable difference between them. Some have their contacts that
are hardly visible, other very prominent contacts. The last will least be prone
to problems than the first.

Maybe this won't work for all of you but it could be worth give it a try. Maybe
there are false contacts due to a bad cable in conjunction with the vibrations
inside the tower.

--
Giovanni

Sauron (sauron-zechateau) wrote :

Hello !

Thanks for your message. I tried to answer previously you but my PC freeze...
The solution you give is interresting, but I have IDE disks and find good IDE maps will be hard (I think).
I've read the post you mentionned and his problem doesn't look to be the same : i have ne problem to boot and my PC freeze only since Hardy and now Ibex. And I'm not the only one.

so, I still searching... :) but I'm going to check my IDE maps anyway.

Thanks again for your help !

Ewout (ewout-ewout) wrote :

Hi!

I am experiencing the same ATA errors (Emask..), and have tried numerous things without finding a solution yet.
The following is the case:

- the fact that Emask errors are occurring is not obvious, initially the problem just shows as HALD hanging when starting. But when disabling that process it just 'hangs' somewhere else. Only when going to single user mode and changing HALD to start without detaching and full logging to the console, it shows the errors (I cannot log in to the system when HALD 'hangs')
- the problem manifests itself both on SATA harddisks as well as PATA harddisks (tried a SATA 500g, SATA 160g, PATA 80g), so I'm doubting my harddisks or harddisk cables are failing.
- the problem manifests itself only on Ubuntu Hardy, Ubuntu Intrepid and Debian Lenny. Debian Etch and Ubuntu Gutsy work just fine. The weird thing is that Ubuntu Hardy did work before (as I've used it for mythtv for over a year)... When I'm now installing it it doesn't work anymore.. To me it seems that a new kernel feature is the culprit or triggers some very common hardware problem that occurs for many people.
- I've tried disabling several devices and busses in the BIOS, but no luck (USB, Serial, Parallel, Audio, PATA, SATA, FDC, HPET; of course not all together, else I couldn't boot ubuntu)
- I've tried the recommendation above with all_generic_ide and hpet=disable on the kernel line, with and without HPET disabled in the BIOS. No luck.
- I've tried ripping all unnecessary hardware (USB cardreader, PCI wificard, USB DVD-ROM), no luck
- tried other RAM, no luck

My hardware configuration:
- Shuttle SD32G2 Barebone (http://www.shuttle.eu/en/desktopdefault.aspx/tabid-72/170_read-13568/)
 * Shuttle FD32 Motherboard
 * Intel 945G (Lakeport-G) + ICH7 Chipset
 * Award V6.0PG BIOS, 4MBit flash memory BIOS
 * Bios Version SD32S30E
- Intel Core 2 Duo E6420 CPU

since changing RAM and HDDs didn't solve anything I'm guessing they are not important to specify here..

Just now I upgraded my BIOS to version SD32S30G, and was able to boot my system without problems for 10+ times, so it seems it is solved anyway. (I have been debugging this problem about two months back also, but back then there wasn't a new BIOS version yet; so if you're using a shuttle also and running into the same problems, check whether there's a new BIOS version available)

Bye!

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

qwerty (escalantea) wrote :

Monitor the "Dirty" values in " cat /proc/meminfo" ... if the values remain high (... are not cleaned frequently enough) then the problem might be the "pdflush" configuration.

If the problem is the "pdflush" then check this link :
https://bugs.launchpad.net/ubuntu/+bug/270794/comments/12

... I hope it helps.

Edetano (edetano) wrote :

I suffered this bug with 2 diferents motherboards (Asus and Asrock) and with kubuntu 8.04.2, 8.10 and 9.04. Madriva Spring 2009 and OpenSuse 11.1. The only thing that worked for me, was to use the linux-rt kernel, or an older one (I recovered the data with an 2007 Knoppix 5.1 live cd, the only that was able to complete a fsck -c). Now with the real time kernel I have random crashes, but this is another history.

Edetano (edetano) wrote :

The last stable kernel from kernel.org, 2.6.29.2 seems to solve the problem.

IAmDaveMyers (davemyers) wrote :

Deal all.

I don't know if I'm seeing a similar problem or not, I suspect I may have a HDD error problem but it causes some interesting knock on effects.

Running Ubuntu Hardy on an AMD64 quad core system, attached to an Hitachi raid device controler (although not using this as a "raid" type device).
2.6.24-24-server

My problem.

I have a large number of reports of I/O errors on 2 of my HDD.
they are reported as `DRDY`

One of the drives (sdd) is not being automounted (as it simply fails permanently), the other has an intermittend problem (sdh).

sdh is included in the fstab file for autmount.
However on the occasions that it fails it seems to prevent the other HDD from mounting in their correct locations also?

As I say I believe that the disk sdh is also "in need of replacement" so that is not the concern, my issue is that I have 8 disks in this machine, and a backup procedure pointing to them at specified locations.

When sdh doesn't mount correctly it seems to throw out the mount point of all the other devices.

I don't know what error logs to send or what files I need to copy over to you, if you ask I will supply.

Please note however that last time we had this problem after a shutdown (left for 10 minutes) and a reboot the problem dissappeared. so for now I should be able to send copies of the files / messages after a "known good" boot procedure.

I am also only assuming that this may be related to this bug? if you think it is better reported elsewhere please say, as I have not read all the posts - but I feel that it is related to the above problems in some way.

Best regards.

David

Richard Huddleston (rhuddusa) wrote :

I believe I'm experiencing this bug on Intel DQ45CB (ICH10) jaunty server x64 2.6.28-13-server using all 5 sata connections for hard drives. I've tried rotating the power cables, hard drives, and sata cables, still it is always happening on ata5. other than this, everything appears to work fine on that sata port. I have hpet enabled ... I have not tried disabling it.

Should I even be worried about this?

[ 21.604330] ata5: SATA max UDMA/133 abar m2048@0xd0521000 port 0xd0521300 irq 2299
[ 25.170022] ata5: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 25.176387] ata5.00: ATA-7: SAMSUNG HD103UJ, 1AA01118, max UDMA7
[ 25.176390] ata5.00: 1953525168 sectors, multi 16: LBA48 NCQ (depth 31/32)
[ 25.182851] ata5.00: configured for UDMA/133
[ 25.604968] ata5: exception Emask 0x10 SAct 0x0 SErr 0x10000 action 0xe frozen
[ 25.605012] ata5: irq_stat 0x00400000, PHY RDY changed
[ 25.605048] ata5: SError: { PHYRdyChg }
[ 25.605083] ata5: hard resetting link
[ 26.370022] ata5: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 26.382852] ata5.00: configured for UDMA/133
[ 26.382857] ata5: EH complete

Günter (guenter-grodotzki) wrote :

same problem here:

Asrock ALiveNF6G-GLAN
AMD Athlon 4050e

tried with sata harddisk, ide harddisk.

ubuntu jaunty / karmic all got the problem.

heheman3000 (mizzao) wrote :

I have this problem on an Asus A8JS (Intel ICH7) with several Hitachi Travelstar hard drives I've tried.

Starting from kernel 2.6.26 or so, I would randomly get these errors and eventually the kernel would mount / readonly and I would have to reboot to get anything done. The errors are completely random - sometimes it works for several days at a time and others I can't even get to the gdm login screen. At first I thought it was the hard drive gone bad but after going through several RMAs the Hitachi people started getting suspicious.

Stuff like the following is common in dmesg - the drive eventually gets turned down all they way to UDMA/33 before the kernel gives up. Switching to a 2.6.29 kernel lately reduces the number of hard resets but still eventually messes up.

ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6
ata1.00: BMDMA stat 0x26
ata1.00: cmd ca/00:08:6d:5c:b4/00:00:00:00:00/e6 tag 0 dma 4096 out
         res 51/84:00:74:5c:b4/84:03:00:00:00/e6 Emask 0x30 (host bus error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ICRC ABRT }
ata1: soft resetting link
ata1.00: configured for UDMA/33
ata1: EH complete
sd 0:0:0:0: [sda] 195371568 512-byte hardware sectors: (100 GB/93.1 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6
ata1.00: BMDMA stat 0x26
ata1.00: cmd ca/00:08:8d:40:12/00:00:00:00:00/e8 tag 0 dma 4096 out
         res 51/84:00:94:40:12/84:03:00:00:00/e8 Emask 0x30 (host bus error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ICRC ABRT }
ata1: soft resetting link
ata1.00: configured for UDMA/33
ata1: EH complete

Looks like I've been mounted read only again, time to reboot...

heheman3000 (mizzao) wrote :

Something I forgot to add in my last post:

The problem might be associated with a buggy allocation of resources in the BIOS. For more information, see this link:

http://bugzilla.kernel.org/show_bug.cgi?id=7883

This explains why BIOS updates might be fixing this problem for some of you.

CrazyAlex25 (crazyalex25) wrote :

VIA V6421A chipset.
ata1.00: status: { DRDY ERR }
ata1.00: error: { ICRC ABRT }
ata1: soft resetting link
ata1.00: configured for UDMA/33
ata1: EH complete
sd 0:0:0:0: [sda] 195371568 512-byte hardware sectors: (100 GB/93.1 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6
ata1.00: BMDMA stat 0x26
ata1.00: cmd ca/00:08:8d:40:12/00:00:00:00:00/e8 tag 0 dma 4096 out
         res 51/84:00:94:40:12/84:03:00:00:00/e8 Emask 0x30 (host bus error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { ICRC ABRT }
ata1: soft resetting link
ata1.00: configured for UDMA/33
ata1: EH complete

Barry Drake (b-drake) wrote :

Right. This seems to be the closest to what I'm experiencing. I'm using a Dell Inspiron Mini 10v running Lucid Netbook version (up to date today).

When a forced disk check (fsck) ran at boot time, the system froze with a value of 71% on the splash screen. Disabling the splash showed that fsck completed, and a further couple of lines of boot process were output. I have no record of precisely what these were. Sorry!

For the moment, I've put GRUB_CMDLINE_LINUX="noapic, nolapic, noacpi" in /etc/default/grub and run sudo update-grub. Since then, the forced disk check has occurred twice without freezing. I had looked at plymouth bug #554737 as behaviour here is identical, but I'm informed that if the above grub instruction overrides the problem, it has to be a kernel bug .... so I'm here.

I'm able to carry out any tests you ask, but have little knowledge of kernel or grub behaviour. I'm very willing to learn though.

Regards, Barry.

Quadro (rgquadro) wrote :

my dmesg for this bug

Jeremy Foshee (jeremyfoshee) wrote :

Quadro,
   Please file a new bug for me using 'ubuntu-bug linux' from the terminal window. This will provide me with specific details on your machine environment and will help us narrow what is causing this bug.

Thanks!

~JFo

BadBrains (m-pehlivanov) wrote :

Same here
2011?
freeze everything, cannot go ctrl+alt+f1 or alt+f1, whatever.

BadBrains (m-pehlivanov) wrote :

another one dmesg

BadBrains (m-pehlivanov) wrote :

when i copy a video file from my sata drive on pci controller, on the same drive, and everything freeze. when i copy same file from sata drive to ide drive everything is fine, no freeze and file is same size.
sometimes when i try to read dvd from dvd samsung, sata dvd rw on SATA PCI Controller, freezin' everything again!
Can somebody explain or help?

velle johan (johanvelle) on 2011-08-21
Changed in ubuntu:
status: Invalid → Fix Released

AnatolyVolodko, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.