2.6.28-11:ext4:hald:sys_open:security_file_alloc -> cascade of 'bugs' -> CPU stopped

Bug #348731 reported by Rocko on 2009-03-25
16
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

[This bug have a netconsole log attached: http://launchpadlibrarian.net/25957909/10.1.1.11-netconsole.log ]

The latest 2.6.28-11-generic#37 kernel (amd64) has frozen twice in the last 24 hours on my PC, ie locked up completely (with indicator lights flashing) and needing a hard reset by holding down the power button.

The first time I was using it (I was moving the mouse), but the second time it was just idling when it locked some time between 3:50 and 7:44 am, as shown in the syslog:

Mar 26 03:29:14 pegasus-jaunty NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Mar 26 03:29:14 pegasus-jaunty NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
Mar 26 03:30:01 pegasus-jaunty /USR/SBIN/CRON[32557]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd 2>/dev/null)
Mar 26 03:39:01 pegasus-jaunty /USR/SBIN/CRON[487]: (root) CMD ( [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$(/usr/lib/php5/maxlifetime) -print0 | xargs -n 200 -r -0 rm)
Mar 26 03:40:01 pegasus-jaunty /USR/SBIN/CRON[587]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd 2>/dev/null)
Mar 26 03:50:01 pegasus-jaunty /USR/SBIN/CRON[1017]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd 2>/dev/null)
Mar 26 07:44:10 pegasus-jaunty syslogd 1.5.0#5ubuntu3: restart.

This is on the latest Jaunty. It's a Dell XPS M1530 that was running nvidia 185.13 the first time it locked up, and 180.41 the second time. There's no information in any of the logs - syslog shows the last message at 3:50.

Prior to this, I haven't had any lockups for quite some time (it was the iwlagn driver causing it in Intrepid but that bug was fixed some time ago).

Paul Dufresne (paulduf) wrote :

Could you do:
apport-collect 348731
please? I think sudo is not mandatory... but I am not sure. 348731 being the number of this bug.
This is a trick on Jaunty to add the infos that would have been added if you would have done:
ubuntu-bug -p linux
to report the bug.

Changed in linux:
status: New → Incomplete

Architecture: amd64
Dependencies:

DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: linux None [modified: /var/lib/dpkg/info/linux.list]
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
Uname: Linux 2.6.28-11-generic x86_64
UserGroups:

Cool trick! Does the info help any? I thought I'd already included most of that info in the original report.

Rocko (rockorequin) wrote :

It just happened again:

Mar 26 13:50:01 pegasus-jaunty /USR/SBIN/CRON[29639]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd 2>/dev/null)
Mar 26 13:50:03 pegasus-jaunty NetworkManager: <info> (wlan0): supplicant connection state: completed -> group handshake
Mar 26 13:50:03 pegasus-jaunty NetworkManager: <info> (wlan0): supplicant connection state: group handshake -> completed
Mar 26 13:56:47 pegasus-jaunty syslogd 1.5.0#5ubuntu3: restart.

Three freezes in less than 24 hours!

Paul Dufresne (paulduf) wrote :

All linux's bugs reports at a minimum should contain the output of the following commands:

    * uname -a > uname-a.log
    * cat /proc/version_signature > version.log
    * dmesg > dmesg.log
    * sudo lspci -vvnn > lspci-vvnn.log

These four files should be attached to the bug report (not pasted into comments, as it makes things harder to read, and formatting is completely broken). Please note the comment about dmesg output below.

It is also important to identify your hardware in the title of the bug to allow easy searching.

Rocko (rockorequin) wrote :

I'll attach those files then.

Rocko (rockorequin) wrote :
Rocko (rockorequin) wrote :
Rocko (rockorequin) wrote :

I reinstalled linux-image yesterday after the last crash, just in case, and it did make it through the night without crashing this time.

Rocko (rockorequin) wrote :

There's a post on http://identi.ca/ (http://identi.ca/ketil) from 13 hours ago that says:

"My #Jaunty has also had 2 hard locks with everything freezing ine the 36 hours since upgrading. Nothin short of a brutal restart has helped."

so it might not be an isolated problem.

Rocko (rockorequin) wrote :

It just did it again. This is a critical bug for me. Is there anything I can do to help debug it?

Rocko (rockorequin) wrote :

And it did it again just now (I had installed nvidia 180.29 module in case it was the newer modules doing something bad)...

This indicates someone else also had a kernel panic with similar symptoms recently: https://bugs.launchpad.net/ubuntu/+bug/317781/comments/189

Paul Dufresne (paulduf) wrote :

Is there something that would looks like a crash log in /var/log/kern.log ?

I suggest you read:
https://help.ubuntu.com/community/DebuggingSystemCrash

I have seens some errors related to your SD memory card in your dmesg.log.
I doubt it has something to do, but yet, you could try to avoid using it a while.

Paul Dufresne (paulduf) wrote :

Well, one way to help would simply to let it run idle on a console:
Ctrl-Alt-F1
like all night long, and hoping to see a crash report happens on the console.
Well, that is if you have a digital camera to take a picture of your screen.

Making a memory test as described on:
https://help.ubuntu.com/community/MemoryTest would be good.
Watchout for https://bugs.launchpad.net/bugs/256012 however.

Rocko (rockorequin) wrote :

Here's the kernel.log from yesterday, in case it helps. The system crashed twice yesterday, one time just a few minutes after I'd rebooted with the nvidia 180.29 module in case it was nvidia causing the problems. The crash was around 16:00.

The only 'unusual' thing I can see is that at one point it complains about write errors to various devices, /dev/sdc and /dev/sdd for example. This is probably because I suspended with these devices attached and resumed without, and the file system isn't checking they are actually there before trying to write to them.

I did a BIOS memory test after the first panic but I'll also try the long one, just to rule it out.

When it does crash, I can't use the keyboard at all, so switching to a console isn't an option. I'll try leaving it in console mode in case of a crash (but the fault text usually scrolls off the window so it might not be complete).

Perhaps a good idea for a kernel enhancement is: in the event of a crash, it should revert to a console and display the error, just so you can always see it?

Rocko (rockorequin) wrote :

Memory checked out fine; it's less than a year old, so I didn't expect any problems.

I doubt it's anything to do with the mmcblk device, because I've had the kernel panic whether or not I used the SD card.

Paul Dufresne (paulduf) wrote :

Thank you for the memory check, and verifying it is not linked to SD card.

You could check or attach /var/log/kern.log.0 file too.

If you have an other computer to connect to it (or from it), you could try one of the following:
-Remote Debugging in https://help.ubuntu.com/community/DebuggingSystemCrash
-https://wiki.ubuntu.com/KernelTeam/Netconsole (which could be a bit too technical however).

Paul Dufresne (paulduf) wrote :

Now I think about it, the first option will probably not work (keyboard lights flashing indicating something bad enough that the kernel decide it is better to stop everything).

Which leads to second option: Netconsole.

Rocko (rockorequin) wrote :

kern.log.0 shows a general protection fault in it (see attached), but I think that happened during shutdown (usplash). The kernel rarely manages to restart the computer on a shutdown or restart cycle, but stops instead near the end of shutdown (no consoles show any output) and needs to be restarted with a ctrl-alt-del. Obviously it's not a kernel panic though. Might this be related?

I've been leaving it with a console on the display while unattended, but it has been running fine now since Friday afternoon. The kernel got an update yesterday as well. I'll see about setting up netconsole but I only have another computer to send output to when I'm at home and most of the crashes have happened at work.

god-mok (god-mok) wrote :

I got the same problem but a little worse: my whole home partition disappears after the freeze. The only thing i could do is to format it. It doesn't matter if it is a upgrade or fresh install that runs some hours, sometimes if i try to install new packages.

I checked it with fsck, and it found many bad blocks (ext3 and ext4, i tried both), but the corrected files were gone after that.i couldn't even see the partition under a livecd. Gparted showed me a undefined partition.

The strange is it only happens with the upgrade to kernel 2.6.28-10 or newer. 2.6.28-9 works fine. After the upgrade the system seems to work but after a while the content of windows (like Nautilus) disappears, only the borders were seen (white, clean box even without the menu bar and buttons) and the configuration folder (in case of Nautilus) "/home/god-mok/.nautilus" disappeared. It happened the same with Firefox, kde and gnome, but not with xchat-gnome. Most programs didn't work and lost it configuration files, but some (like xchat-gnome) did work.

I installed on the beta new packages, and than Synaptic told me, that the catch files are defect or it could not write any files because it got no rights. The problem here was the same: the folder disappeared. After that Synaptic wouldn't run (like Firefox or Nautilus). Adept didn't worked and under terminal i get only a abort message because the catch had problems (same as Synaptic) or nothing. Once Nautilus told me something about "nfs folder not available" and than it won't run. I don't use nfs :)

My only solution for me is not to upgrade but do normal updates, so i'm stuck at kernel 2.6.28-9. Maybe i should write a bug report of my own...

Rocko (rockorequin) wrote :

Wow! As far as I know, I haven't lost anything due to these crashes, except for some zero-length object files created by the ext4 file system (I was doing a build at the time of the freeze, and the zero-length files is a known separate bug or 'feature'). Also, I found 2.6.28-10 to be stable - so far, it has only been 2.6.28-11#37 that has had the kernel panic. The 2.6.28-11#38 kernel hasn't crashed yet.

Paul Dufresne (paulduf) wrote :

god-mok said:
>Maybe i should write a bug report of my own...

Indeed.
The fact that for Rocko it was stable with 2.6.28-10 and not for you suggest that it is a different bug.
Even if it was not the case, it is hard to say if these kind of bugs are the same just by symptoms.

Rocko (rockorequin) wrote :

It hasn't panicked now during near-continuous operation for almost four days, so I suspect that the issue was located in the #37 release of the kernel (especially since a couple of others reported lock-ups with the Jaunty beta) but it is no longer in #38.

Rocko (rockorequin) wrote :

I spoke too soon: kernel 2.6.28-11#38 just panicked when I went to close a Firefox tab. The screen turned off; the keyboard is unresponsive; and the caps lock, wireless etc lights are flashing.

This time though there was some information in the log files that might be relevant:

Sys log:

Apr 1 19:57:23 pegasus-jaunty kernel: [24461.232049] VM: killing process Xorg
Apr 1 19:57:23 pegasus-jaunty kernel: [24461.264558] swap_free: Bad swap offset entry 80000000000000

Kern log:

Apr 1 19:57:23 pegasus-jaunty kernel: [24461.232049] VM: killing process Xorg
Apr 1 19:57:23 pegasus-jaunty kernel: [24461.264558] swap_free: Bad swap offseApr 1 20:03:52 pegasus-jaunty kernel: Inspecting /boot/System.map-2.6.28-11-generic

Rocko (rockorequin) wrote :

I've got netconsole running now in the hope that I'll get a crash while at home. The only output it logged during boot was a message about ucvideo, which I get every time I boot:

Apr 1 23:17:33 10.1.1.11 [ 10.601911] uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -32 (exp. 26).

In case it's relevant, at the time of the latest panic I was running nvidia 180.44. The only other non-free modules in the system are the virtualbox vboxdrv 2.1.4 kernel module and its associated vboxnetflt module (but no virtual machines were running and in any case I've been running this for several months before the first kernel panic). I'm also running the Adobe Flash 10 64-bit alpha plugin in Firefox, but I doubt that this should be able to cause a kernel panic (and I was running it for a month without any issues before the first kernel panic).

What might decide to kill Xorg all of a sudden (ie as per the sys log message in my last comment)? It happened immediately after I clicked on the 'close tab' button in Firefox - the screen just went completely black and the lights started flashing.

Paul Dufresne (paulduf) wrote :

I was not sure either what was this VM when I saw it first.
Searching this on google I soon realized that this is Virtual Memory Manager.
It looks like you did miss virtual memory, so Linux decided to find a good program to kill (linux kernel keep a score for that, OOM score I think, Out Of Memory score) to decide which one to kill.

You should probably:
cat /proc/meminfo (maybe post the result here)
to check if swap partition is mounted and active.

Rocko (rockorequin) wrote :

Right at the moment, gparted reports that the swap partition is mounted, and I'm pretty sure it has been for all of the kernel panics. I've got 4GB of RAM and 4GB of swap, and the system usually reports it is using most of the RAM (with lots of cache though) and hardly any swap.

Do you mean that you think the VMM tried to use swap memory, or that it ran out of swap+ram (ie all 8GB got used up)? Could it be a problem with a corrupted swap format, or with the VMM driver?

/proc/meminfo holds:

MemTotal: 3998928 kB
MemFree: 649344 kB
Buffers: 246928 kB
Cached: 1738916 kB
SwapCached: 5060 kB
Active: 1327720 kB
Inactive: 1718776 kB
Active(anon): 864672 kB
Inactive(anon): 210036 kB
Active(file): 463048 kB
Inactive(file): 1508740 kB
Unevictable: 3592 kB
Mlocked: 3592 kB
SwapTotal: 4192924 kB
SwapFree: 4182332 kB
Dirty: 16 kB
Writeback: 0 kB
AnonPages: 1060880 kB
Mapped: 134260 kB
Slab: 187976 kB
SReclaimable: 164268 kB
SUnreclaim: 23708 kB
PageTables: 26428 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
WritebackTmp: 0 kB
CommitLimit: 6192388 kB
Committed_AS: 2036820 kB
VmallocTotal: 34359738367 kB
VmallocUsed: 102856 kB
VmallocChunk: 34359611387 kB
HugePages_Total: 0
HugePages_Free: 0
HugePages_Rsvd: 0
HugePages_Surp: 0
Hugepagesize: 2048 kB
DirectMap4k: 2359752 kB
DirectMap2M: 1832960 kB

Rocko (rockorequin) wrote :

This is the log entry from atop approx seven minutes before the crash, in case it helps any. It doesn't look like anything was using a lot of memory other than cache (if I'm reading it right, it reports only 21MB free RAM but the most memory-hungry process is Xorg with only 3%). Looking through the atop logs, 21MB is unusually low though.

Rocko (rockorequin) wrote :

To rule out a bad hdd on the swap partition, I did a badblocks -w on it and it passed.

Rocko (rockorequin) wrote :

Here are two more atop logs from as I near as I can get to the first two panics.

This one is for the first one mentioned in this bug report. There were logs every ten minutes until this time; the next one was the reboot at 07:44 so it seems reasonable to assume that the panicked panicked between 03:58 (this report) and 04:08.

Rocko (rockorequin) wrote :

This atop log is from a panic that happened in the afternoon. Firefox is taking 5% of memory for some reason.

Rocko (rockorequin) wrote :

I tried loading the system to force it to use swap by starting two VMs, each with 1800MB of memory, but what happened was that as soon as it started to hit swap (according to atop), X became completely unresponsive except for the mouse cursor - it didn't try to kill anything or kernel panic, it just thrashed the disk continously. After 15 minutes of a frozen X session I gave up and hard reset it.

Rocko (rockorequin) wrote :

I managed to trap a kernel panic ("NULL pointer dereference") with netconsole - see attached. I sure hope this helps fix it.

Paul Dufresne (paulduf) wrote :

Marking bug as confirmed, sine we now have a possible Oops trace.

I am trying to search a bit on Internet...

Apr 2 19:24:50 10.1.1.11 [ 3125.417784] iwlagn: index 0 not used in uCode key table.
http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1922

Searching update_curr linked to:
Apr 2 19:25:52 10.1.1.11 [<ffffffff8023de64>] update_curr+0x154/0x170
does not link to much, except maybe that:
http://lkml.org/lkml/2008/9/5/364

About:
Apr 2 19:25:52 10.1.1.11 [ 3187.804012] WARNING: at /build/buildd/linux-2.6.28/kernel/smp.c:333 smp_call_function_mask+0x21a/0x220()
I found:
http://patchwork.kernel.org/patch/94/

Rocko (rockorequin) wrote :

Just noting that I don't think the iwlagn bug is relevant to the panic - I often see this in the message log and it doesn't appear to affect normal operation. Also, it happened a good two seconds before the actual panic.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Rocko (rockorequin) wrote :

This is a log of another kernel oops, just in case it might be relevant. I get this almost every time I shutdown the PC, and I have to hit ctrl-alt-del to get it to continue. Note that it doesn't cause a complete panic though so it might not be related to this bug at all.

Rocko (rockorequin) wrote :

Update: I haven't had a kernel freeze since I captured that oops on the 2nd of April. There have been a couple of kernel iterations since then (I'm now on 2.6.28-11.41). It might also be relevant that I've been using the backports module, which gives a new wireless stack, since approx the 6th of April.

Rocko (rockorequin) wrote :

Having said that, I just got a complete kernel freeze on *another* laptop with a freshly installed and updated Jaunty beta on it when I tried to run Firefox.

uname -a gives:

Linux galactica-jaunty 2.6.28-11-generic #41-Ubuntu SMP Wed Apr 8 04:38:53 UTC 2009 i686 GNU/Linux

Again, there is no information in the logs.

Attached is an lspci -vvnn from that PC.

summary: - kernel freeze in 2.6.28-11 (Dell XPS M1530)
+ kernel freeze in 2.6.28-11

This second laptop froze again this morning sometime after the daily cron job started at 7:35. By 8:35 it had locked solid. There aren't any relevant messages in the logs.

Diego Schulz (dschulzg) wrote :

My system (toshiba a305-s6894) panicked two times in less than 3 hours today. I'm also suspecting this has something to do with the iwlagn module.

lspci | grep -i wireless
03:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100.

Frequently I see those ugly messages from iwlagn in tty01 when shutting down, something like

iwlagn: Error: Response NULL in 'REPLY_ADD_STA'

Couldn't see the actual panic messages, system became unresponsive, ALT+Sysreq+anykey didn't help.

Rocko (rockorequin) wrote :

I see those REPLY_ADD_STA messages as well. I'm running the linux-backports-modules now on my main computer which has a new wireless stack and the main computer hasn't frozen in two weeks.

However, my second laptop isn't running iwlagn - it's using ipw2200 - and it has panicked twice in three days.

Rocko (rockorequin) wrote :

Could this be related to bug #348836 (ext4: panic working with large files)? I'm using ext4 on both of the laptops that have kernel panicked, and they do have some large (10GB or so files) on them. I think some of the panics I experienced (on both laptops) happened around the time that the locate database was being updated.

Rocko (rockorequin) wrote :

My main laptop just froze again shortly after I resumed it (syslog attached; it crashed between 15:36 and 15:41, but there's nothing in the logs as usual and I didn't have the ethernet attached to catch the panic).

The laptop is running kernel 2.6.28-11-generic #42 now, which is supposed to fix bug #348836, so that can't be the problem.

The only other recent change was that earlier I uninstalled l-b-m because the wireless keeps dropping out on an 11N network so I have been using the standard wireless compatibility stack.

Jaunty is definitely not ready for release with kernel panics like this one happening.

Rocko (rockorequin) wrote :

Another panic: netconsole managed to capture a long sequence of kernel oopses and the panic - see attached.

Paul Dufresne (paulduf) on 2009-04-25
description: updated
summary: - kernel freeze in 2.6.28-11
+ 2.6.28-11:ext4:hald:sys_open:security_file_alloc -> cascade of 'bugs' ->
+ CPU stopped
Rocko (rockorequin) wrote :

Just a note: I've been using 2.6.30.rc3 from the weekly builds for over a week now on both my PCs and haven't had a repeat of any kernel freezes.

I tried 2.6.30.rc4 but the kernel oopses on X startup due to a bug in the bluetooth module, and this kills enough processes that X doesn't run properly.

Kabe2007 (kabe2007) wrote :

Same thing here - let me know how I may help. Not so often kernel panics, but random write errors into hard disk files (that resulted in 0 bye files and even once a lost ext3 partition) that start when I use the wireless network.

In my case, it is related to the wireless card Intel 5100, and when I am using the network.

I was doing fine with 8.10 and this started to happen with 9.04. I managed to "solve" the problem by disabling the wireless card (modprobe -r iwlagn) but of course that is not an optimum solution.

There were several bugs that were exactly like this one (i.e. check bug 276990) but supposedly were already solved.

I will start using the backport modules (as the other bug report described) and let everybody know if it helped. Any additional help appreciated.

Rocko (rockorequin) wrote :

Kabe2007, are you using any ext4 partitions? My assumption is that this panic is something to do with ext4 rather than wireless since the backports modules did not stop these panics happening.

I've still not had a crash since I started using the 2.6.30.rc series. There are, of course, multiple bugfixes for both ext4 and wireless in the 2.6.30 kernel.

Kabe2007 (kabe2007) wrote :

SOLVED (FOR ME!!)

Rocko,

Thanks for the comment. I solved the bug and I confirm it was related to the wireless card.

I spent some time looking for help and I found that the bug was somewhat common, but difficult to identify given it does not impact wireless directly but gave random errors.

I installed the linux wireless drivers (latest, May 30rd) from

http://wireless.kernel.org/en/users/Download

And the problem was solved!! (so far)

Thanks everybody for the help.

cue (keino) wrote :

I also discovered system freeze on my Thinkpad T61p since Ubuntu 9.4.
I already tried to report the behaviour in https://bugs.launchpad.net/ubuntu/+bug/391085.
Maybe it was not clear enough, sorry for my poor English.

I could some how catch some error according to the kernel bug:
Jul 21 01:23:33 beyond-laptop kernel: [ 6676.977905] ------------[ cut here ]------------
Jul 21 01:23:33 beyond-laptop kernel: [ 6676.977914] kernel BUG at /build/buildd/linux-2.6.28/mm/slub.c:2743!

I attach the error.txt file which contains the whole log excerpt and the file requested in #5.
The freezing happens when my Thinkpad is on the docking station.

I hope it helps to help me/us.

thanx,
cue

cue (keino) wrote :
cue (keino) wrote :
cue (keino) wrote :
cue (keino) wrote :
cue (keino) wrote :

It must be Murphy, it just happens again and NOT in DOCKING MODE!
So I can exclude Docking Station issues...

Here an excerpt of syslog:

Aug 2 13:17:15 beyond-laptop kernel: [36410.082309] ftdi_sio 4-1:1.0: FTDI USB Serial Device converter detected
Aug 2 13:17:15 beyond-laptop kernel: [36410.082353] usb 4-1: Detected FT8U232AM
Aug 2 13:17:15 beyond-laptop kernel: [36410.082434] usb 4-1: FTDI USB Serial Device converter now attached to ttyUSB0
Aug 2 13:17:15 beyond-laptop NetworkManager: <info> (ttyUSB0): ignoring due to lack of mobile broadband capabilties
Aug 2 13:20:01 beyond-laptop /USR/SBIN/CRON[10395]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd 2>/dev/null)
Aug 2 13:25:02 beyond-laptop /USR/SBIN/CRON[10568]: (root) CMD ([ -x /usr/lib/sysstat/sa1 ] && { [ -r "$DEFAULT" ] && . "$DEFAULT" ; [ "$ENABLED" = "true" ] && exec /usr/lib/sysstat/sa1 $SA1_OPTIONS 1 1 ; })
Aug 2 13:30:01 beyond-laptop /USR/SBIN/CRON[10677]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd 2>/dev/null)
Aug 2 13:30:33 beyond-laptop kernel: [37207.630925] ------------[ cut here ]------------
Aug 2 13:30:33 beyond-laptop kernel: [37207.630935] kernel BUG at /build/buildd/linux-2.6.28/mm/slub.c:2743!
Aug 2 13:30:33 beyond-laptop kernel: [37207.630940] invalid opcode: 0000 [#1] SMP
Aug 2 13:30:33 beyond-laptop kernel: [37207.630947] last sysfs file: /sys/devices/pci0000:00/0000:00:1f.2/host0/target0:0:0/0:0:0:0/block/sda/sda3/stat
Aug 2 13:30:33 beyond-laptop kernel: [37207.630954] Dumping ftrace buffer:
Aug 2 13:30:33 beyond-laptop kernel: [37207.630959] (ftrace buffer empty)
Aug 2 13:30:33 beyond-laptop kernel: [37207.630962] CPU 0

----------------------------------------

I connected a processor charging station via USB - FTDI USB Serial Device converter.

I made report according to the AMD64 Java to serial already here: https://bugs.launchpad.net/ubuntu/+source/rxtx/+bug/361635. That is solved on my side, since I can connect the device over Java to serial bridge successfully.

But it still seems to be quit instable on the level below that.
It did run stable on former Ubuntu versions 8.10 AMD64 and 8.4 AMD64.

I hope that rings a bell to someone.

all the best,
cue

tags: added: ext4
tags: removed: ext4

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.