Ubuntu

Java to serial does not work in Jaunty on amd64 anymore

Reported by cue on 2009-04-15
100
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Arduino
Unknown
Unknown
rxtx (Ubuntu)
Medium
Alessio Igor Bogani

Bug Description

After attending the Jaunty-Beta procedure the communication from Java VM to Serial does not work anymore.

I placed the corresponding jar and so file at the right place.

Here are some summarizing details:
------
Java VM: Java HotSpot(TM) 64-Bit Server VM (11.3-b02 mixed mode linux-amd64)
Problematic frame:
C [librxtxSerial.so+0x6462] read_byte_array+0x52
------

I will attach the whole log file to this issue.
The log-file's footer includes system overview details as well.

Thank you for your time and effort,

cue

Related branches

lp:~abogani/ubuntu/lucid/rxtx/rxtx-fix-361635
Andrew Starr-Bochicchio: Approve on 2010-01-29
Luke Yelavich: Pending requested 2009-12-15
Emmet Hikory: Pending requested 2009-12-15
Daniel Holbach: Pending requested 2009-12-09
cue (keino) wrote :
cue (keino) wrote :

Is there anybody with a hint or a comment at least?

all the best,
cue

stkz (ron-huizing) wrote :

Same problem,
also on AMD64 platform, RXTX was working fine on previous Ubuntu versions, now on released 9.04 is does not work anymore.
Exactly the same error message, as soon as serial communication in the Java application starts.

Clues would be appreciated.
Best regards,
Stkz

I have the same problem. Running Ubuntu 9.04 amd64 final (release) Desktop, using Live CD.

I am running Arduino IDE 0012 64bit, which uses RXTX for serial port. I can transfer programs to Arduino,so some data can be transferred trough serial.

When I open serial console and change the speed to 115200 bit/s, program crashes with an error message: "Problematic frame: # C [librxtxSerial-2.1-7.so+0x8333] read_byte_array+0x43".

It works with 32bit. I'm running tests, so I have just tested exactly the same steps on 32 bit version: Ubuntu Desktop 9.04 Final i386 live cd.

I did not have this problem with amd64 Ubuntu 8.10 release. (Even though it has other problem with Arduino, avr and long ints).

Some other people are seeing this too. Arduino forums: worked with 8.10 amd64, broken with 9.04 amd64, no bypass found:
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1238062036/7

Two users say they have bypassed this bug:
>> If you're in a hurry to get your arduino IDE running you could get the
>> 32bit version with a 32bit Java instead of the x86_64 version
>> I have [Arduino IDE] 0011-i386 and [Arduino IDE] 0012-i386 running
>> on Fedora x86_64 with a 32bit Java
> Thanks for the suggestion! I emerged the 32 bit emulation sun JRE on my
> gentoo box, and all librxtxSerial (32 bit) doesn't barf. Thanks!
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1228827993

I have described similar setups for running 32bit Arduino on 64bit OS . They were created when there was no 64 bit edition of Arduino IDE.
http://sulautetut.fi/content/arduinon-kehitysymp-rist-n-asentaminen-ubuntu-linuxille
http://myy.helia.fi/~karte/arduino_editor_on_64_bit_ubuntu_gutsy.html

I have not yet tried if they fix the RXTX 64 bit problem.

enyone (enyone) wrote :

Same bug here..

exactt (giesbert) wrote :

can confirm the problem for Jaunty AMD64

# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f344f8f4333, pid=1738, tid=139862649780560
#
# Java VM: OpenJDK 64-Bit Server VM (14.0-b08 mixed mode linux-amd64 )
# Distribution: Ubuntu 9.04, package 6b14-1.4.1-0ubuntu7
# Problematic frame:
# C [librxtxSerial-2.1-7.so+0x8333] read_byte_array+0x43

affects: ubuntu → rxtx (Ubuntu)
Changed in rxtx (Ubuntu):
status: New → Confirmed
exactt (giesbert) wrote :
exactt (giesbert) wrote :

it works for me when using version 2.2pre1 from rxtx.org. there are some 64-bit fixes mentioned on the start page.

just wanted to let you know...

cue (keino) wrote :

@exacct:
Thank you, I checked it with 2.2pre2 from rxtx.org and it seems to work.
So it was not an Ubuntu issue like it appears now.

Should the issue be closed then?

Thank you for your help!

cue

dumpa (dumpita) wrote :

@exactt @cue
Can you explain this?
I have the same bug, and didn't understood your comment.
thanks

exactt (giesbert) wrote :

the package provided with ubuntu is broken. at least on AMD64. just download the 2.2pre2 version from rxtx.org and it should work as expected. see also the wiki at rxtx.org for more information.

Felix (apoapo) wrote :

I'll enclose my logs to. Same problem as reported before i think.

summary: - Java to serial does not work in Jaunty anymore
+ Java to serial does not work in Jaunty on amd64 anymore
Alessio Igor Bogani (abogani) wrote :

Hi,

Fix is already in upstream. I attach the backported version.
Building and running tests already done (only on amd64 sorry).
Please le me know if I should provide that fix in debiff format.

Ciao,
Alessio

Alessio Igor Bogani (abogani) wrote :

This package don't seem works on amd64 at all. For this reason i raise it importance to Medium.

Changed in rxtx (Ubuntu):
importance: Undecided → Medium
Heavy Rail (heavyrail) wrote :

Confirm bug at amd64 Jaunty. Error log attached. 2.2pre2 binary from rxtx.qbang.org works well.

JoshuaLutz (josh-lutz) wrote :

Confirmed in amd64 Karmic also.

Alessio Igor Bogani (abogani) wrote :

I propose this debdiff for fix this bug.
I have also propose a bzr branch via lp for do the same.

Changed in rxtx (Ubuntu):
assignee: nobody → Alessio Igor Bogani (abogani)
fredm (fredm) wrote :

Upgrading to rxtx 2.2pre2 solved it for me too -- running Ubuntu 9.10 (karmic) 64-bit. The download link is http://rxtx.qbang.org/pub/rxtx/rxtx-2.2pre2-bins.zip.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rxtx - 2.1.7r2-4ubuntu1

---------------
rxtx (2.1.7r2-4ubuntu1) lucid; urgency=low

 * Backport of fix for 64 bit systems
   Source code changes have been backported from development
   snapshot tarball (rxtx-2.2pre2.zip) downloaded from
   http://rxtx.qbang.org/wiki/index.php/Download
   These changes are related to int/long handling into src/SerialImp.c
   and src/SerialImp.h
   - LP: #361635
 -- Alessio Igor Bogani <email address hidden> Tue, 09 Dec 2009 20:46:12 +0100

Changed in rxtx (Ubuntu):
status: Confirmed → Fix Released
joklin (joindre-cedric) wrote :

Hello

Confirmed in amd64 Karmic

I had the same probleme and i fix it in changing the rxtx version

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.