Ubuntu

Extremely loud and intrusive system beep with (some?) HD Audio devices

Reported by Pete Goodall on 2009-02-19
202
This bug affects 32 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Andy Whitcroft
Jaunty
Medium
Luke Yelavich
Lucid
Medium
Andy Whitcroft

Bug Description

SRU justification:

Impact: Having the speaker beep enabled for snd-hda-intel cards produces a very intrusive noise which is more annoying than helpful.

Fix: For now disable the system beep in that driver.

Testcase: Working in a virtual terminal doing some action that causes a beep.

---

I am seeing this problem on Jaunty and have been since I first installed. I am currently running Ubuntu 9.04 Alpha 4 with updates as of 18 Feb 2009. The current system beep is *EXTREMELY* annoying (even more annoying than people who feel the need to write in all caps). I'm surprised my ear drums have not burst yet (I'm not kidding). This sound is what I imagine I would hear if I were to stick my tongue into a 240V socket, except that might hurt less.

This same laptop worked fine with Intrepid and Hardy. Though sound doesn't work today it has certainly worked in the past. Regardless of whether any other system sound works the Annoying System Beep (tm) persists. I don't dare use headphones for fear the system might decide to beep.

I have tried disabling the system beep a number of ways:

 * blacklisted pcspkr in /etc/modprobe.d/blacklist
 * Add `xset b off` and `xset b 0 0 0` in various session files
 * Add `set bell-style none` in ~/.bashrc and ~/.profile

I am now able to turn it off in the GNOME Sound preferences (thanks Bug #325778!), but that doesn't stop the system from beeping when in a virtual terminal or if I'm not running X at all. Regardless, turning the sound off is merely a work-around. I have not yet tried shutting down, but the system used to beep then too (different bug afaik).

$ lspci -vv -s 00:1b.0
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
 Subsystem: Dell Device 0209
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 21
 Region 0: Memory at f6ffc000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

Please let me know what information might be useful.

Related branches

Robbie Williamson (robbiew) wrote :

Assigning to Luke Yelavich (audio focal point for Foundations team) for an initial analysis.

Luke Yelavich (themuso) wrote :

Part of this can be solved by muting the recently added PC Beep control on hda soundcards. As for general disabling for everybody however, I will dig deeper, add tasks where necessary, and change packages accordingly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-utils - 1.0.18-1ubuntu9

---------------
alsa-utils (1.0.18-1ubuntu9) jaunty; urgency=low

  [ Daniel T Chen ]
  * adjust_init_hda_db.patch: Account for shifted db range of
    some HDA codecs (from upstream git HEAD)

  [ Luke Yelavich ]
  * mute PC Beep on hda cards that support it during initial volume setup
    (LP: #331589)

 -- Luke Yelavich <email address hidden> Fri, 20 Feb 2009 14:31:24 +1100

Changed in alsa-utils:
status: In Progress → Fix Released
Andy Whitcroft (apw) wrote :

@pete -- thank you for that description :). I had the same issue. There are two parts to this. First, the beep is now monstrous, and second the default beep in readline is now on rather than off (which bash uses). I sorted the beep being used in all of my terminals, in x or not by adding the following to /etc/inputrc and loging out/in:

    set bell-style none

As to why the beep is monstrous all of a sudden, well this isn't general, I have on laptop which shows this, the rest are ok. So it must be hardware specific in some sense at least.

Pete Goodall (pgoodall) wrote :

@Andy - Thx for the tip. I will try that.

This is definitely not fixed. I have just updated, and when I mistyped my password in GDM I almost leaped out of my skin. I made the fundamental mistake of keeping my headphones on when re-booting, and have (thankfully) lived to regret it. Are we any closer on this bug? Is there additional information I can supply, such as hardware information? We absolutely cannot release with the system beep in this state.

It has been solved, at least for initial installs. Pete, what you will have to do is go into the mixer, and turn down/mute the "PC Beep" control. That will get rid of that loud beep you are getting.

As the changelog for the alsa-utils upload above explains, this sound control will be muted by default for fresh installs, but will allow people to enable it should they choose to do so.

@Luke, I have a Dell Latitude D620 and I don't have a "PC Beep" control, and this bell is about to make me throw my computer out. What do we need to do?

I ran the alsa-info.sh script the output is here:

http://www.alsa-project.org/db/?f=e2ca388f4695b7da04ae27c5fdfbf5408daad02a

Daniel T Chen (crimsun) wrote :

Pete G, does unloading pcspkr help on your D620?

Luke Yelavich (themuso) wrote :

Pete, in alsamixer, do you have anything labeled beep anywhere? From your amixer output, you have a beep generator, but I am wondering whether it has a mixer control associated with it. If not, we will have to find out how to turn it off via other means.

I've also found out about a patch that fedora has to disable the beep by default at the kernel source level. I am building a custom kernel and will test with hardware I have access to that has one of these beeps, and see what affect the patch has.

@Luke, no beep exposed via alsamixer...

Pete, if the mixer has a "PC Speaker" control, try turning that off/down. If that makes no difference, then we'll have to change things the hard way. I was put onto a no beep hda patch from fedora the other day, I'll try it out, and submit it for inclusion in the kernel if its behavior is worth having.

@Luke,

It will have to be the hard way... no "PC Speaker" control. Sorry.

Pete Goodall (pgoodall) wrote :

I recently re-installed with Ubuntu 9.04 Alpha 5. I have applied all updates as of 3 March 2009. I now have a "PC Beep" volume in alsamixer and it is muted. The beep doesn't happen at all now, which is fine for me for now. However, if I turn that volume up I _still_ don't hear the beep. This indicates to me that PC beep is now completely disabled.

However, I still contend that turning the beep off completely is not a fix. It is a temporary work-around. This is essentially a regression as the pc beep was perfectly normal and non-annoying before Jaunty. That being said, thank you for at least making me hate my laptop less. :-)

/me starts wearing headphones again.

@Pete Graner, here is the patch I was telling you about. Let me know if it helps you at all.

> I am now able to turn it off in the GNOME Sound preferences (thanks Bug #325778!)

@Pete - I don't think that's the right bug number. Also confirming that this is the most annoying sound known to man.

Clownfishy (clownfishy) wrote :

I am running the beta as of 27/03 and have a DELL Precision M90. I get this beep when I shutdown and it is VERY LOUD! I too do not have any setting in the Volume control to turn this off

rdesfo (rdesfo) wrote :

I'm also running Jaunty Beta 1 on a Dell inspiron and it also beeps every time I turn my laptop off. IT also beeps when I'm using gvim. It really takes from the experience of using ubuntu and is something that definitely needs to be fixed before the official release

Robbie Williamson (robbiew) wrote :

@Luke,

Could people who update not be getting the fix? It appears that the issue is not resolved for them.

Changed in alsa-utils (Ubuntu Jaunty):
status: Fix Released → Triaged

On Fri, Apr 3, 2009 at 11:51 AM, Robbie Williamson <email address hidden> wrote:
> Could people who update not be getting the fix?  It appears that the
> issue is not resolved for them.

The setting is only effected on fresh installs. People who upgrade
have an existing /var/lib/alsa/asound.state and use that value (if
extant) instead.

Clownfishy (clownfishy) wrote :

I upgraded and I get this every time I shut down. It is VERY loud.

Robbie Williamson (robbiew) wrote :

@ Take Life Easy:

What happens if you do a:
 $ sudo modprobe -r pcspkr
Then shutdown...do you hear it then?

I think the best way to solve this issue for now is to disable the hda beep configuration options in the kernel, since some hda codecs have a volume control, and some don't. If the beep is really desired by people in the future, we can try and work out a solution.

I'll send a patch to the kernel team to disable these options, and will refer to this bug.

Luke Yelavich (themuso) on 2009-04-08
affects: alsa-utils (Ubuntu Jaunty) → linux (Ubuntu Jaunty)
Changed in linux (Ubuntu Jaunty):
status: Triaged → In Progress
Atanas Atanasov (thenasko) wrote :

I have the most recent Jaunty updates but still hear the beep on shutdown. I can also confirm in my case it is not a pc speaker beep but comes from the audio out (checked with headphones on Dell Inspiron 1721). Is the fix committed to public repositories yet?

On Sun, Apr 12, 2009 at 07:20:15AM -0000, Atanas Atanasov wrote:
> I have the most recent Jaunty updates but still hear the beep on
> shutdown. I can also confirm in my case it is not a pc speaker beep but
> comes from the audio out (checked with headphones on Dell Inspiron
> 1721). Is the fix committed to public repositories yet?

"Fix Committed" means that there is a fix for the bug in a version control
repository (in this case, git), not in the repositories. The bug will be
"Fix Released" when there is a fix in the repositories.

--
 - mdz

What is responsible for creating /var/lib/alsa/asound.state ? In that file, I have the following control:
control.16 {
 comment.access 'read write'
 comment.type INTEGER
 comment.count 1
 comment.range '0 - 3'
 comment.dbmin -1800
 comment.dbmax 0
 iface MIXER
 name 'PC Beep Playback Volume'
 value 0
}

As you can see, I only have 4 volume levels for pc beep, with the lowest giving it -18.00 dB gain. Apparently, this is still too loud and can hardly be considered as level 0. How do I change the dbmin and also give it more range?

On Tue, Apr 14, 2009 at 08:20:12AM -0000, Ahmad Syukri wrote:
> What is responsible for creating /var/lib/alsa/asound.state ?

/etc/init.d/alsa-utils

--
 - mdz

I have Ubuntu 9.04 installed on my Dell 1501 laptop... it has the same terribly loud beep on shutdown. I've tried everything, but to no avail. Please help correct this issue.

Stefan Bader (smb) on 2009-04-16
description: updated
Robbie Williamson (robbiew) wrote :

Moved this back to "Triaged" as the originally stated problem still exists.

Changed in linux (Ubuntu Jaunty):
status: Fix Committed → Triaged
Steve Langasek (vorlon) on 2009-04-16
Changed in linux (Ubuntu Jaunty):
milestone: ubuntu-9.04 → jaunty-updates
Robbie Williamson (robbiew) wrote :

Please wait on posting anymore "it's broken for me" type messages until the fix as been released for testing, as we cannot do anymore until then.

Changed in linux (Ubuntu Jaunty):
status: Triaged → Fix Committed
der_vegi (m-may) wrote :

According to the new description "Testcase: Working in a virtual terminal doing some action that causes a beep.", bug 290204 would not be duplicate any more. On some systems, the system beep does not only occur when working in a terminal, but also when you simply shut down your system in Gnome. Disabling the system beep does not work there, you can only blacklist pcspkr.

clombard (clombard44) wrote :

The answer to the question: "What happens if you do a:
 $ sudo modprobe -r pcspkr
Then shutdown...do you hear it then?"
is "NO" but when you restart then shut down...guess what...?
The most annoying sound known to man is heard...Loud & Clear.
Who thought,... System->Preferences->Sound...uncheck "system bell"
from Intrepid would be missed so much?

Matthäus Brandl (matthaeus) wrote :

@clombard:
You need to blacklist pcspkr by adding the line "blacklist pcspkr" to the file /etc/modprobe.d/blacklist.conf
You can check that the module has been blacklisted correctly by issuing "lsmod | grep pcspkr" in the console, it should return false and no output.

I am also getting this (absurdly loud) BEEP with a dell D620 with a fully patched fresh install of 9.04 (final release). This occurs only during system shut-down. The command
$ sudo modprobe -r pcspkr
This stops the problem for a single shut-down but it's not permanent. All I need is a way to stop this by un-checking a box somewhere.

Atanas Atanasov (thenasko) wrote :

I tried "sudo modprobe -r pcspkr" and can confirm the beep persists (even at the first shutdown) on a Dall Inspiron 1721 laptop. I checked it with headphones and the beep is definitely coming from line out not a pcspeaker (if the laptop has one in the first place).

This isn't a "me too" comment. I wanted to let you know that this problem exists for me in a fresh installation of Jaunty.

Oddly enough, I did not have this problem at all in the beta release of Jaunty when I upgraded from Intrepid.

Timo Vanwynsberghe (timovwb) wrote :

I fixed it. Don't know what did it, but these are the 3 things I've done:

 - $ sudo rmmod pcspkr

 - Added 'blacklist pcspkr' to /etc/modprobe.d/blacklist.conf

 - $ gconftool-2 --type bool --set /apps/metacity/general/audible_bell False

Roman Polach (rpolach) wrote :

As in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/331589/comments/14 have been already noticed,
disabling pc-speaker (even permanent) is not a fix.
I found pc-speaker useful when working in terminal,
but I only want to disable the monstrous beep on shutdown.
This was fine in Hardy (and Gutsy, Feisty, Edgy, ...) - beeps in terminal have worked and no beep on shutdown..
in Intrepid there was introduced a beep on shutdown - https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/290204
that in Jaunty it became this horrible sound.

Please, if you are searching for a proper fix, do not try to disable pc-speaker.
The problem is that shutdown process calls it and it shouldn't.

blakeyrat (blakeyrat-gmail) wrote :

I just wanted to log in to say that this is keeping me from using Ubuntu on my laptop. I wouldn't inflict that hideously-irritating sound on anybody within (the substantial) hearing range of my laptop when, for example, using it on a train or bus. I'm extremely disappointed that this wasn't fixed before release.

In addition to it occurring at shutdown, it seems to occur in places where the normal system beep should-- for example, when you search a Firefox webpage for text and the text isn't found.

The computer is a HP Pavilion tx1000 convertible tablet. Like posters above, I don't have a "PC Beep" entry in the mixer.

stinkinrich88 (stinkinrich88) wrote :

I've upgraded from Intrepid to Jaunty and I have the problem too.

With Intrepid, all beeps came from the internal pc speaker. In jaunty it comes from my sound-card speakers. I do not want to disable beep, I just want it back to my internal pc speaker. Any ideas how?

And I think a visual beep is much better for alerts. But I still want the "beep" command to make a noise so I can tell when I've received an email when away from my pc.

Thomas Costick (3dbloke) wrote :

I would like to add that, as well as at shutdown, the beep also occurs:
 -- in Gedit or Tomboy, when trying to move the text cursor beyond the start or end of a file.
 -- in Terminal when backspacing into the prompt.

I'm using Jaunty official release on a Dell Inspiron 6400 laptop.

It is VERY annoying, by the way. :-)

Chris Dickson (whiskychris) wrote :

As has previously been mentioned and detailed you can manually disable the pc speaker if you desire:

To get rid of most of the "alerts" (for instance in the terminal): System - Preferences - Sound - Sounds, then uncheck "Play alert sound"
==> This won't however stop the system beeping on shutdown

To get rid of the shutdown beep (and perhaps making that last step redundent) you should blacklist the pc speaker:

In a terminal type "gksu gedit /etc/modprobe.d/blacklist.conf"
=>This will open gedit, go to the last line in the file.

Type "blacklist pcspkr" without quotes onto a blank line at the end of this file and then save and close gedit.

This has all been said further up this report.

Download full text (3.6 KiB)

In addition, this Fix is committed BUT not released yet. I believe it should be released in an upcoming kernel update.

Sent via BlackBerry by AT&T

-----Original Message-----
From: Chris Dickson <email address hidden>

Date: Mon, 27 Apr 2009 13:03:39
To: <email address hidden>
Subject: [Bug 331589] Re: system beep in jaunty is the most annoying sound
 known to man

As has previously been mentioned and detailed you can manually disable
the pc speaker if you desire:

To get rid of most of the "alerts" (for instance in the terminal): System - Preferences - Sound - Sounds, then uncheck "Play alert sound"
==> This won't however stop the system beeping on shutdown

To get rid of the shutdown beep (and perhaps making that last step
redundent) you should blacklist the pc speaker:

In a terminal type "gksu gedit /etc/modprobe.d/blacklist.conf"
=>This will open gedit, go to the last line in the file.

Type "blacklist pcspkr" without quotes onto a blank line at the end of
this file and then save and close gedit.

This has all been said further up this report.

--
system beep in jaunty is the most annoying sound known to man
https://bugs.launchpad.net/bugs/331589
You received this bug notification because you are a direct subscriber
of the bug.

Status in “linux” source package in Ubuntu: Fix Committed
Status in linux in Ubuntu Jaunty: Fix Committed

Bug description:
SRU justification:

Impact: Having the speaker beep enabled for snd-hda-intel cards produces a very intrusive noise which is more annoying than helpful.

Fix: For now disable the system beep in that driver.

Testcase: Working in a virtual terminal doing some action that causes a beep.

---

I am seeing this problem on Jaunty and have been since I first installed. I am currently running Ubuntu 9.04 Alpha 4 with updates as of 18 Feb 2009. The current system beep is *EXTREMELY* annoying (even more annoying than people who feel the need to write in all caps). I'm surprised my ear drums have not burst yet (I'm not kidding). This sound is what I imagine I would hear if I were to stick my tongue into a 240V socket, except that might hurt less.

This same laptop worked fine with Intrepid and Hardy. Though sound doesn't work today it has certainly worked in the past. Regardless of whether any other system sound works the Annoying System Beep (tm) persists. I don't dare use headphones for fear the system might decide to beep.

I have tried disabling the system beep a number of ways:

 * blacklisted pcspkr in /etc/modprobe.d/blacklist
 * Add `xset b off` and `xset b 0 0 0` in various session files
 * Add `set bell-style none` in ~/.bashrc and ~/.profile

I am now able to turn it off in the GNOME Sound preferences (thanks Bug #325778!), but that doesn't stop the system from beeping when in a virtual terminal or if I'm not running X at all. Regardless, turning the sound off is merely a work-around. I have not yet tried shutting down, but the system used to beep then too (different bug afaik).

$ lspci -vv -s 00:1b.0
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
 Subsystem: Dell Devi...

Read more...

"To get rid of the shutdown beep (and perhaps making that last step redundent) you should blacklist the pc speaker:

In a terminal type "gksu gedit /etc/modprobe.d/blacklist.conf"
=>This will open gedit, go to the last line in the file.

Type "blacklist pcspkr" without quotes onto a blank line at the end of this file and then save and close gedit."
-------------------------
"blacklist pcspkr" did not work for me. I still had the beep at shutdown.

Instead, I did the following:
        sudo modprobe -r pcspkr

This fixed it. Seems to work across reboots, too.

Vytas (vytas) wrote :

sudo modprobe -r pcspkr -- unloads module temporarily, not across reboots I think.

However most probably you edited blacklist file as well and it came into effect after the next reboot ;)

In any case, this is just a workaround, not a fix!
And this bug should receive more attention in general, not because it is particularly severe, but it has been since intrepid release, and still unfixed, that is really sad... If anyone has a clear understanding what is emitting this beep (for instance if you shutdown from GDM => no beep), please help to fix!

enoksrd (enoksrd) wrote :

Vytas,

before disabling the beep (of apparently less doom) in intrepid by blacklisting pcspkr, I could log out without the beep by clicking on the Fast User Switch Applet and selecting "Shut down". But probably your "shutdown from GDM => no beep" is referring only to clicking System->Shut Down, so this is not quite the same thing.

Michael C (bigredpuppy) wrote :

If you are having problems trying to blacklist the sytem bell, here is the reason:
There is another open bug about this, but the modprob.d files are now appended with ".conf"
 so, instead of adding "blacklist pcspkr" to
/etc/modprobe.d/blacklist

add it to /etc/modprobe.d/blacklist.conf instead.

ah, the sound of silence:

Carlsberg don't do annoying sounds, but if they did...it still wouldn't come close the the sytem bell via 9.04 !

clombard (clombard44) wrote :

When is this "beep" getting fixed at the level where it started...?
This is why we got away from Microsoft in the first place...remember "Animal Farm"...?

Steve Langasek (vorlon) wrote :

Accepted linux into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

I can't be 100% positive that this is the case, but on my system at least I found that an error dialogue appeared along with the beep and after some investigation I found that it was related to Avant Window Navigator. Going through the settings in gconf-editor I found the following key: /apps/avant-window-navigator/show_dialogue_if_non_composited was checked. Unchecking that caused both the system beep and the error dialogue from appearing.
This may be a red herring, but may be worth investigating further.
In any case, this can be worked around without having to blacklist pcspkr for those who want to keep it for some reason.

Daniel Pop (danielpop) wrote :

I have installed all proposed updates and the beep is still there.
Also, the pcspkr isn't blacklisted, but muted in the volume control.

Matt Zimmerman (mdz) on 2009-05-03
summary: - system beep in jaunty is the most annoying sound known to man
+ Extremely loud and intrusive system beep with (some?) Intel HD Audio
+ devices

Matt,

Sorry, my laptop (which exhibited this problem) doesn't have Intel anything on it. It has a NVidia motherboard with RealTek HD sound card and displayed all of the symptoms reported on this thread:
* PC Speaker beep when shutting down
* PC Speaker beep playing instead of the OS-configured "alert" sound, i.e. when searching text in Firefox and the text is not found (exception: when actually setting the "alert" sound in the control panel it plays the correct sound)

Additionally, "PC Beep" and "PC Speaker" don't show up in the list of audio devices, so they can't be muted.

I also disagree with removing the "most annoying sound known to man" line; it might be a bit of hyperbole, but not a lot: nobody wants to be sitting on a train or bus and have their laptop pump out 120 Db of ear-grating square wave because they had the audacity to search for text that wasn't on the webpage. (I don't know about the majority of people, but I pretty much only use my laptop on public transit.)

I've actually uninstalled Ubuntu and put Vista back on my laptop until this bug can be fixed for good-- that's how annoying it is.

On Sun, May 03, 2009 at 04:18:08PM -0000, blakeyrat wrote:
> Sorry, my laptop (which exhibited this problem) doesn't have Intel anything on it. It has a NVidia motherboard with RealTek HD sound card and displayed all of the symptoms reported on this thread:

Exactly which sound device do you have and which driver does it use?

--
 - mdz

Sorry I don't know how to find that out. It says "Realtek High Definition Audio" and has an icon of a blue crab and a link to http://www.realtek.com.tw/

Roman Polach (rpolach) wrote :

This bug is NOT specific to Intel audio. I have this problem also with SB Live! audio card.
At least in the meaning of bug #290204 which is marked as dupe of this one.

So please do either: -- correct the bug title, or: -- undupe bug #290204

Matt Zimmerman (mdz) wrote :

The commit log message, for reference:

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-jaunty.git;a=commit;h=f0570b3cfc9799cd9ace683eeb5a4d07a4c4bd3f

UBUNTU: disable CONFIG_SND_HDA_INPUT_BEEP on amd64 and i386

Bug: #331589

It appears that different hda codecs have differing implementations of the
beep code, some offering volume controls to adjust/mute the beep, and others
offering no controls. Since many users find this beep annoying, and not all
codecs allow the beep volume to be controlled, lets get rid of it for now.

Signed-off-by: Luke Yelavich <email address hidden>
Signed-off-by: Tim Gardner <email address hidden>

summary: - Extremely loud and intrusive system beep with (some?) Intel HD Audio
- devices
+ Extremely loud and intrusive system beep with (some?) HD Audio devices

Blacklisting the pcspeaker works for me since I use the window flash feature instead.

However, in an attempt to support my fellow Ubuntu users who animately ask for a permanent solution, and not a work-around, I do feel that canonical should put this issue on the top of their list of bug fixes for Jaunty.

James (james-ellis-gmail) wrote :

found this bug while searching for fixes to the system beep in kubuntu after a jaunty upgrade.

suggestions:
firefox in about:config has a typeahead find setting with a value of beep - remove that and typeaheadfind no longer causes brown trousers.
KDE: open kmix, Settings menu ... Configure Channels and make sure PC Beep is checked, then ensure it is muted in the mixer. Fixes this for Kubuntu/KDE (and makes the firefox fix above redundant)

card info:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
        Subsystem: Dell Device 0209
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 21
        Region 0: Memory at febfc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

I didn't have a pcspkr module either to blacklist.

Nedenom (nedenom) wrote :

When shutting down my T60 I get no less than three loud beeps! The Windows users around me at work are laughing at my 'Buntu :(

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
 Subsystem: Lenovo Device 2010
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin B routed to IRQ 17
 Region 0: Memory at ee400000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

Robbie Williamson (robbiew) wrote :

For data gathering purposes, I am NOT having this issue on my Lenovo X301 (i.e. blacklisting pcspkr works for me), with the following Intel Audio chipset:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
 Subsystem: Lenovo Device 20f2
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin B routed to IRQ 17
 Region 0: Memory at f0620000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
  Address: 0000000000000000 Data: 0000
 Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
   ExtTag- RBE- FLReset+
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
   MaxPayload 128 bytes, MaxReadReq 128 bytes
  DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
  LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
   ClockPM- Suprise- LLActRep- BwNot-
  LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
 Capabilities: [100] Virtual Channel <?>
 Capabilities: [130] Root Complex Link <?>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

I suggest that future posters experiencing this problem, please post the Audio device information obtained from running 'sudo lspci -vvv' at a minimum.

Simon Fogliato (simonfogliato) wrote :

This really is the most annoying thing, to have your laptop beep out of control in class on shutdown. I have 2 desktops and 1 laptop running Jaunty and they all have the same issue. The following is my information from running: sudo lspci -vvv

Desktop PC
02:0d.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)
 Subsystem: Ensoniq ES1371 [AudioPCI-97]
 Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort+ <MAbort+ >SERR- <PERR- INTx-
 Latency: 32 (3000ns min, 32000ns max)
 Interrupt: pin A routed to IRQ 5
 Region 0: I/O ports at b000 [size=64]
 Capabilities: [dc] Power Management version 1
  Flags: PMEClk- DSI+ D1- D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Kernel driver in use: ENS1371
 Kernel modules: snd-ens1371

I will post information from my other computers later today.

Simon Fogliato (simonfogliato) wrote :

The following is my information from running: sudo lspci -vvv on my laptop that also has this annoying issue.

Laptop PC - HP TX1304ca
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
 Subsystem: Hewlett-Packard Company Device 30bf
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0 (500ns min, 1250ns max)
 Interrupt: pin B routed to IRQ 17
 Region 0: Memory at c3020000 (32-bit, non-prefetchable) [size=16K]
 Capabilities: [44] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [50] Message Signalled Interrupts: Mask+ 64bit+ Queue=0/0 Enable-
  Address: 0000000000000000 Data: 0000
  Masking: 00000000 Pending: 00000000
 Capabilities: [6c] HyperTransport: MSI Mapping Enable+ Fixed+
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

Damien (takahara) wrote :

FWIW the result of "sudo lspci -vvv" on my Thinkpad R40 is:

00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
 Subsystem: IBM Device 0523
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin B routed to IRQ 5
 Region 0: I/O ports at 1c00 [size=256]
 Region 1: I/O ports at 18c0 [size=64]
 Region 2: Memory at c0000c00 (32-bit, non-prefetchable) [size=512]
 Region 3: Memory at c0000800 (32-bit, non-prefetchable) [size=256]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Kernel driver in use: Intel ICH
 Kernel modules: snd-intel8x0

der_vegi (m-may) wrote :

Here my info from the duplicate bug, Dell Inspiron 1501:

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
 Subsystem: Dell Device 01f5
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64, Cache Line Size: 32 bytes
 Interrupt: pin ? routed to IRQ 16
 Region 0: Memory at c0000000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
  Address: 0000000000000000 Data: 0000
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

der_vegi (m-may) wrote :

Same problem on a Dell Inspiron 530n:
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
 Subsystem: Dell Device 020d
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 22
 Region 0: Memory at fdff4000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
  Address: 0000000000000000 Data: 0000
 Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
   ExtTag- RBE- FLReset+
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
   MaxPayload 128 bytes, MaxReadReq 128 bytes
  DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
  LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
   ClockPM- Suprise- LLActRep- BwNot-
  LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
 Capabilities: [100] Virtual Channel <?>
 Capabilities: [130] Root Complex Link <?>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

irrdev (irrdev) wrote :

I just did fresh installs of both Ubuntu and Kubuntu 9.04 on the same computer. Only Ubuntu plays the terrible system beep using my Intel sound card at shutdown. I have to admit that this is the most annoying *buntu bug that I have ever encountered, as I appreciate using the system beep in the terminal, but NOT whenever I shut down my system. Since only my Ubuntu installation seems to be affected, I wonder if this is a more Gnome-related issue rather than a linux kernal issue. BTW, I noticed that my Jaunty installation no longer has the "System Beep" tab like Intrepid did. I had to manually edit my configuration file to get a "visual beep" in some cases, although this hasn't disabled the system beep at shutdown, and as already mentioned above, I don't wish to blacklist pcspkr. This is an absolutely terrible bug which needs to be fixed by Cananical ASAP.

der_vegi (m-may) wrote :

Also present on an IBM ThinkPad T42:
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
 Subsystem: IBM Device 0537
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin B routed to IRQ 11
 Region 0: I/O ports at 1c00 [size=256]
 Region 1: I/O ports at 18c0 [size=64]
 Region 2: Memory at c0000c00 (32-bit, non-prefetchable) [size=512]
 Region 3: Memory at c0000800 (32-bit, non-prefetchable) [size=256]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Kernel driver in use: Intel ICH
 Kernel modules: snd-intel8x0

Ryan Egesdahl (deriamis) wrote :

I've done some snooping on this problem, and here is what I can tell you:

There is a setting in gconf under desktop->gnome->peripherals->keyboard called "bell_mode" that controls the system bell. When set to "on", a keyboard event (such as hitting backspace on an empty line) will cause the annoying beep. Setting it to "custom" allows for using a file to be played instead of just a beep, set by bell_custom_file. In any case, neither of these settings is changed in the sound preferences panel.

There is also a setting in the CompizConfig Settings Manager, under General->General, called "Audible Bell". Unsetting this also disables the system bell, but there is no means to configure a file to be played here.

It appears that the CompizConfig setting is prior to the gconf setting - when the CompizConfig setting is "off", the bell sound does not play regardless of the gconf setting. Both gconf and CompizConfig must be set to "on" for this to work.

When the pcspkr module is loaded, all system bell events get routed to the PC Speaker when they are to be played. If the module is unloaded, the sound instead gets routed through to the ALSA PC Speaker emulator. Setting a file to play did not seem to work, at least for the ogg files I had available.

I'm not sure that simply blacklisting the pcspkr module will solve the issue - though it needs to be done anyway if we are going to use the ALSA emulator for that. Perhaps blacklist the module if ALSA is installed? Also, simply disabling the system beep won't work because that prevents any audible alert notifications from happening. Shutdown and login do not seem to be affected by this - but let's assist the blind with knowing when they have hit the backspace key enough times, shall we? Visual notifications won't help them much.

Oh, and there is a separate issue floating around about a beep on logout. This is happening because there is apparently an error not-so-silently happening behind the scenes with power management when the computer is shutting down. It can be disabled in System->Preferences->Power Management->General->Extras->Use sound to notify in event of an error, but it really shouldn't be simply because it is a beep. It should be playing the proper sound selected, and if it is a false positive error, the problem should be found and corrected. Unfortunately, I haven't found the source of that problem yet.

And that's all I have. I hope it helps someone.

civility (lordjunkyard) wrote :

People,,

I have the same issue..

I've noticed compiz is not acting as expected either. My 3D cube and such are not working since the upgrade from Ibex to Jaunty.

If you can,, please check to see if your compiz settings are acting normal. If not, I fear this could be related and should be looked in to further.

Richard Ayotte (rich-ayotte) wrote :

Problem still there on HP G60.

00:07.0 Audio device: nVidia Corporation MCP78S [GeForce 8200] High Definition Audio (rev a1)
 Subsystem: Hewlett-Packard Company Device 360a
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0 (500ns min, 1250ns max)
 Interrupt: pin A routed to IRQ 19
 Region 0: Memory at c0000000 (32-bit, non-prefetchable) [size=16K]
 Capabilities: [44] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [50] Message Signalled Interrupts: Mask+ 64bit+ Queue=0/0 Enable-
  Address: 0000000000000000 Data: 0000
  Masking: 00000000 Pending: 00000000
 Capabilities: [6c] HyperTransport: MSI Mapping Enable+ Fixed+
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

Dominik (dominik.k) wrote :

I've made an overview of all the hints for the three problems, which are mixed up in all the comments for this bugs:

- the PC speaker bell is too loud > this initial problem
- beep at system shutdown (only GNOME/Ubuntu?) > https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/290204
- PC speaker beep instead alert sound in GNOME > https://bugs.edge.launchpad.net/ubuntu/+source/compiz/+bug/301174

I hope, I did not too much errors in the attached list. Hopefully, this could be another step to solve this problems.

Can somebody specify the bug descriptions so that the comments are placed at the right bug number?!

Which informations are useful, too?

bdoe (bdoe-att) wrote :

There are indeed three separate but possibly related problems intertwined in this ticket:

1. PCSpeaker audio too loud.
I haven't noticed this problem myself, specifically. My laptop's PCSpeaker output is routed through my sound card anyway, possibly a BIOS function. Something interesting to note here, though: PCSpeaker output is *always* through my laptop speakers, whether I have headphones plugged in or not (HDA Intel). However, I do have a volume control setting for "Beep" on my mixer. It is currently muted (which has no effect on its output through my speakers), but unmuting it and turning the volume up results in it being output through my headphones as well.

2. Beeps at system shutdown.
I can confirm this one. The beeps in question are the alert beeps that normally happen when one issues a shutdown command in console. I have always heard the series of beeps whenever I issue a shutdown command within a terminal window, from TTY, or over SSH if I remotely shut down another computer. These are also distinct from the "system beep in lieu of alert sound" bug, as these beeps are of a much higher pitch. It's important to note that these beeps have *never* been triggered by a shutdown from desktop; only from a shell shutdown. It is only with Jaunty that the beeps are now accompanying a shutdown from desktop.

3. System beep in lieu of alert sound setting in Gnome Sound Preferences.
This is a separate bug from #2, and may or may not be related. I have had this bug for as long as I can remember (I joined the Linux community with Feisty). Gnome Desktop seems to have never honored my alert sound settings. Now, what is TRULY interesting here is that, although Gnome does not honor it, some non-GTK programs do - namely Second Life. Backspacing too far within the SL client causes your chosen alert sound to play. So, this is clearly a Gnome bug.

As for the Compiz situation: I do not understand why it has a system beep setting. It seems to me that, if Compiz is going to be an official part of Ubuntu, then it should be integrated far better than it is now. This means forcing Compiz to honor all Gnome settings, rather than forcing users to set window decorators, mouse pointers, and system beeps in two different places.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-13.44

---------------
linux (2.6.28-13.44) jaunty-proposed; urgency=low

  [ Stefan Bader ]

  * Revert "SAUCE: [jaunty] ALSA: Add retry for Intel8x0 clock measurement"
  * Revert "SAUCE: [jaunty] ALSA: Fix clock and buffer calculations for
    Intel8x0"
  * Revert "SAUCE: [jaunty] ALSA: Fix buffer positions and checks"

linux (2.6.28-12.43) jaunty-proposed; urgency=low

  [ Amit Kucheria ]

  * Enable SYN_COOKIES for iop32x and versatile flavours
    - LP: #361687
  * SAUCE: Quirk for BT USB device on MacbookPro to be reset before use
    - LP: #332443

  [ Brad Figg ]

  * [jaunty] Add missing mvsas (Marvel SAS 6440) module configuration.
    - LP: #352336

  [ Chuck Short ]

  * SAUCE: [USB] Unusual Device support for Gold MP3 Player Energy
    - LP: #125250

  [ Daniel T Chen ]

  * SAUCE: [jaunty] ALSA: Fix buffer positions and checks
    - LP: #345627
  * SAUCE: [jaunty] ALSA: Fix clock and buffer calculations for Intel8x0
    - LP: #345627
  * SAUCE: [jaunty] ALSA: Add retry for Intel8x0 clock measurement
    - LP: #345627

  [ Luke Yelavich ]

  * disable CONFIG_SND_HDA_INPUT_BEEP on amd64 and i386
    - LP: #331589

  [ Makito SHIOKAWA ]

  * [ARM] 5404/1: Fix condition in arm_elf_read_implies_exec() to set
    READ_IMPLIES_EXEC
    - LP: #364358

  [ Manoj Iyer ]

  * SAUCE: Added quirk to fix key release for Samsung NC20
    - LP: #360247

  [ Oleg Nesterov ]

  * posix timers: fix RLIMIT_CPU && fork()
    - LP: #361508

  [ Scott James Remnant ]

  * [Config] Disable libusual and the ub driver
    - LP: #364538

  [ Stefan Bader ]

  * Disable unwanted staging builds
    - LP: #366144
  * Remove prism2_usb driver from ubuntu and use the one from staging
    - LP: #325366
  * SAUCE: Make rtl8187se depend on WIRELESS_EXT
    - LP: #366144
  * Disable CONFIG_RTL8187SE for armel.versatile
    - LP: #366144

  [ Tejun Heo ]

  * libata: handle SEMB signature better
    - LP: #257790

  [ Tim Gardner ]

  * Set USB_SERIAL=m for i386/amd64
    - LP: #345002
  * SAUCE: Jaunty - aic79xx - set reset delay to 5 seconds, down from 15.
    - LP: #79542
  * SAUCE: (drop after 2.6.28) Wifi suspend/resume scan timeout fixes
    - LP: #336055
  * Sony laptop: Sony Vaio laptops do not enable wwan power by default.
    - LP: #364678

  [ Tyler Hicks ]

  * SAUCE: (drop after 2.6.28) eCryptfs: Larger buffer for encrypted
    symlink targets
    - LP: #357345

  [ Upstream Kernel Changes ]

  * V4L/DVB (9999): gspca - zc3xx: Webcam 046d:089d added.
    - LP: #326674
  * V4L/DVB (10044): gspca - pac7311: Webcam 093a:2620 added.
    - LP: #363195
  * hwmon: (it87) Add support for the ITE IT8720F
    - LP: #357766
  * vgacon: Return the upper half of 512 character fonts
    - LP: #355057
  * drm/i915: add support for G41 chipset
    - LP: #365958

 -- Stefan Bader <email address hidden> Mon, 25 May 2009 17:30:40 +0200

Changed in linux (Ubuntu Jaunty):
status: Fix Committed → Fix Released

I still have this problem, has the patch been released yet? If not when should I expect an update to be released?

(If I turn off "play alert sound" the system beep goes away, but the alert sound isn't supposed to be a system beep)

On 06/18/2009 12:18 AM, Launchpad Bug Tracker wrote:
> This bug was fixed in the package linux - 2.6.28-13.44
>
> ---------------
> linux (2.6.28-13.44) jaunty-proposed; urgency=low
...
> ** Changed in: linux (Ubuntu Jaunty)
> Status: Fix Committed => Fix Released
>

Actually it wasn'tn as far as I can tell. No change in 2.6.28-14-generic
or 2.6.28-15-generic.

Problem persists for me on a Dell Vostro 1520.

---

2.6.28-15-generic

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
 Subsystem: Dell Device 02bc
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 22
 Region 0: Memory at f4800000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
  Address: 0000000000000000 Data: 0000
 Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
   ExtTag- RBE- FLReset+
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
   MaxPayload 128 bytes, MaxReadReq 128 bytes
  DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
  LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
   ClockPM- Suprise- LLActRep- BwNot-
  LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
 Capabilities: [100] Virtual Channel <?>
 Capabilities: [130] Root Complex Link <?>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

Jeremy Foshee (jeremyfoshee) wrote :

Has anyone tested this on the latest Development branch of Lucid? I'd be interested to see some testing in that regard. If someone does encounter the same error, please run 'apport-collect -p linux 331589' so that all relevant logging will be attached here.

Thanks!

-JFo

This problem no longer occurs for me under 9.10.

Andy Whitcroft (apw) on 2010-02-23
Changed in linux (Ubuntu):
status: Fix Committed → Triaged
milestone: jaunty-updates → ubuntu-10.04-beta-1
assignee: Luke Yelavich (themuso) → Andy Whitcroft (apw)
Clownfishy (clownfishy) wrote :

Just loaded Ubuntu 10.04 (Kernel 2.6.32-15-generic, fully patched as of 06/03/2010 7:24 GMT) and still have the same sound problems as before. No sound until you turn the volume my volume up and then it nearly blows my speakers. I have seen this problem through 9.10 to the latest release.

Clownfishy (clownfishy) wrote :

Forgot to add -

Dell Precision M90

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
 Subsystem: Dell Device 01cf
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-

Andy Whitcroft (apw) on 2010-03-09
Changed in linux (Ubuntu):
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
Victor (victorxpp) wrote :

same to me, when shutting down i hear a beep not from system speakers but from my laptop's speakers, it is very very annoying it is like when you want to plug the headphones to a socket and you touch the corners if someone understands what i mean...

ubuntu 9.10 x86_64.
  Audio device: ATI Technologies Inc R700 Audio Device [Radeon HD 4000 Series]
Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
 2.6.31-20-generic

Andy Whitcroft (apw) on 2010-04-01
tags: added: regression-potential
removed: verification-needed
Brad Figg (brad-figg) on 2010-04-06
Changed in linux (Ubuntu Lucid):
assignee: Andy Whitcroft (apw) → Brad Figg (brad-figg)
Andy Whitcroft (apw) on 2010-04-09
Changed in linux (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-2 → ubuntu-10.04
Steve Langasek (vorlon) on 2010-04-16
Changed in linux (Ubuntu Lucid):
milestone: ubuntu-10.04 → lucid-updates
omarly666 (omarly666) wrote :

 lspci -vv -s 00:1b.0
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
 Subsystem: Dell Device 022e
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 21
 Region 0: Memory at f6ffc000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

loud beep on logout for me too. sound-preferences theme set to None. 10.04 amd64 Dust Sand-theme on dell xps m1530

Tobias Krais (tux-spam) wrote :

Try to add in /etc/modprobe.d/alsa-base.conf the line
-----%<-----
options snd-hda-intel model=dell-bios
-----%<-----
This seems to fix it for me.

Ryan Egesdahl (deriamis) wrote :

I'm using Lucid now, and (on the same hardware) I no longer have this problem. I think it's fixed, now. Is anyone else using Lucid that can confirm the same thing?

Jacopo Moronato (jmoronat) wrote :

Yes, I can confirm.

Changed in linux (Ubuntu Lucid):
assignee: Brad Figg (brad-figg) → nobody
Changed in linux (Ubuntu):
assignee: Brad Figg (brad-figg) → nobody
Andy Whitcroft (apw) wrote :

According to the most recent feedback this was resolved in Lucid. Closing out the Lucid nomination and development tasks.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Changed in linux (Ubuntu Lucid):
assignee: nobody → Andy Whitcroft (apw)
status: Triaged → Fix Released
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
AutoStatic (autostatic) wrote :

I still have this issue on my HP DV7-1070ED notebook.

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

Codec: IDT 92HD71B7X

Ubuntu Lucid Lynx 10.04

Best,

Jeremy

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers