Web cam won't work in Intrepid, worked in previous Ubuntu versions

Bug #303755 reported by Craig Gilding on 2008-11-30
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.15 (Ubuntu)
Undecided
Unassigned

Bug Description

Well I actually posted here https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.15/+bug/41779 but someone asked me to file a new bug report so... I'm doing that now...

Information below;
My web cam worked fine on previous versions of Ubuntu. However, it won't work on 8.10 for some reason. Here is the camera in "lsusb"

Bus 003 Device 005: ID 05a9:a511 OmniVision Technologies, Inc. OV511+ WebCam

Attached is my output for dmesg and my /var/log/syslog

If anymore information is needed please feel free to let me know. I am on most nights so I will keep an eye out :D

Craig Gilding (slasherx2) wrote :
Craig Gilding (slasherx2) wrote :

Hello,
can you try :
ls /dev | grep video and
mplayer /dev/video?

What software do you use ? (cheese?)
Thanks.

Craig Gilding (slasherx2) wrote :

ls /dev | grep video gives;

video0

mplayer /dev/video gives;

MPlayer 1.0rc2-4.3.2 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 CPU T5600 @ 1.83GHz (Family: 6, Model: 15, Stepping: 6)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /dev/video.
File not found: '/dev/video'
Failed to open /dev/video.

Exiting... (End of file)

Yes, I use Cheese, although, I tried to setup my web cam with kopete and amsn but they wouldn't have it.

Ok, thanks
So the drivers are installed.

try : mplayer /dev/video0 (the number of the device)
try : gstreamer-properties

I don't know more.
Thanks

Craig Gilding (slasherx2) wrote :

craig@craig-laptop:~/fprint/libfprint-0.0.6$ mplayer /dev/video0
MPlayer 1.0rc2-4.3.2 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 CPU T5600 @ 1.83GHz (Family: 6, Model: 15, Stepping: 6)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /dev/video0.
File not found: '/dev/video0'
Failed to open /dev/video0.

Exiting... (End of file)

craig@craig-laptop:~/fprint/libfprint-0.0.6$ gstreamer-properties
gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'esdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'glimagesink'
gstreamer-properties-Message: Skipping unavailable plugin 'sdlvideosink'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
gstreamer-properties-Message: Error running pipeline 'Video for Linux (v4l)': Could not open device "/dev/video0" for reading and writing. [v4l_calls.c(179): gst_v4l_open (): /GstPipeline:pipeline0/GstV4lSrc:v4lsrc3:
system error: Permission denied]

I've tried that last command before and got the same thing

ok, thanks.
I don't known more about. :(

Craig Gilding (slasherx2) wrote :

Never mind, hopefully the information I provided will help someone else fix it. If anymore info is needed, let me know.

Marc Sanfaçon (ubuntu-jafs) wrote :

Just to let you know that I have the exact same problem as Craig. I have the same WebCam, at least the same USB name. Running the commands give me the exact same output.

I never tried it in previous Ubuntu version. I am running 8.10, kernel 2.6.27-9-generic.

Marc

description: updated
Changed in linux:
status: New → Confirmed
Changed in linux-source-2.6.15:
status: New → Confirmed
Craig Gilding (slasherx2) wrote :

Just a note, I tried this cam again with cheese on the Ubuntu 8.04 live CD and it worked no problem so it must be something that was changed in 8.10

Connor Imes (ckimes) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information.

Please include the information requested at https://wiki.ubuntu.com/DebuggingHardwareDetection as separate attachments (I see you've already attached some, please attach the full lsusb per those directions).

I'm going to close this task against the old kernel and leave it open against the development kernel.

Thanks in advance.

Changed in linux-source-2.6.15:
status: Confirmed → Won't Fix
Changed in linux:
importance: Undecided → Medium
status: Confirmed → Incomplete
Marc Sanfaçon (ubuntu-jafs) wrote :

Find the requested information attached.

Connor Imes (ckimes) wrote :

Thank you Marc. I'm marking this bug as Triaged, but it would also be good if Craig could also attach the requested information since he is the original reporter.
Thanks guys.

Changed in linux:
status: Incomplete → Triaged
Craig Gilding (slasherx2) wrote :

I will add the requested info on Monday when I get access to my laptop, sorry for the delay

pixolex (pixolex) wrote :

I have the exactly same problem and i'm leaving my logs here. I hope it helps.

pixolex (pixolex) wrote :
pixolex (pixolex) wrote :
pixolex (pixolex) wrote :
pixolex (pixolex) wrote :
Craig Gilding (slasherx2) wrote :

Sorry for the delay, attaching the log files now...

Craig Gilding (slasherx2) wrote :
Craig Gilding (slasherx2) wrote :
Craig Gilding (slasherx2) wrote :
Craig Gilding (slasherx2) wrote :
pixolex (pixolex) wrote :

Tested the webcam in Jaunty Beta 1 and still doesn't work.

palimmo (palimmo) wrote :

Same problem with Jaunty

Sergio Zanchetta (primes2h) wrote :

== Regression details ==
Discovered in version: Intrepid, Jaunty
Last known good version: Hardy

tags: added: regression-release
Jeremy Kerr (jk-ozlabs) wrote :

Looks like the video device is present, but you don't have permission to open it. Could you paste the output of:

id
ls -l /dev/video0

Cheers,

Jeremy

pixolex (pixolex) wrote :

Sorry for the late response Jeremy.

crw-rw---- 1 root video 81, 0 2009-09-22 22:07 /dev/video0

Jeremy Kerr (jk-ozlabs) wrote :

pixolex: how about the output of 'id'? are you in the 'video' group?

Cheers,

Jeremy

pixolex (pixolex) wrote :

uid=1000(pixolex) gid=1000(pixolex) grupos=4(adm),20(dialout),24(cdrom),44(video),46(plugdev),108(lpadmin),123(admin),124(sambashare),1000(pixolex)

The device is detected like this:
ov511:USB OV511+video device found
ov511:model:Creative Labs WebCam 3
ov511: Sensor is an OV7620

Jeremy Kerr (jk-ozlabs) wrote :

picolex: looks like you do have permissions to access the device. Are you seeing the exact same output as Craig Gilding (from comment #6) when you run gstreamer-properties?

Craig: could you post your output from 'id' and 'ls -l /dev/video0' too?

Craig Gilding (slasherx2) wrote :

Quick note to let you know I'm still alive..
I'm currently at work and my laptop is upgrading to the new alpha. I'll dig the cam out when I get home and post you the results. Apologies for the delay.

pixolex (pixolex) wrote :
Download full text (4.7 KiB)

MPlayer 1.0rc2-4.3.3 (C) 2000-2007 MPlayer Team
CPU: AMD Athlon(tm) XP 3000+ (Family: 6, Model: 10, Stepping: 0)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection.
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /dev/video0.
*** glibc detected *** mplayer: free(): invalid next size (fast): 0x096f2a98 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb64b4604]
/lib/tls/i686/cmov/libc.so.6[0xb64b7da4]
/lib/tls/i686/cmov/libc.so.6(__libc_memalign+0xe5)[0xb64b8be5]
/lib/tls/i686/cmov/libc.so.6(__libc_memalign+0x42)[0xb64b8b42]
mplayer(av_mallocz+0x2a)[0x868510a]
======= Memory map: ========
08048000-08926000 r-xp 00000000 08:01 4376276 /usr/bin/mplayer
08926000-08927000 r--p 008dd000 08:01 4376276 /usr/bin/mplayer
08927000-08999000 rw-p 008de000 08:01 4376276 /usr/bin/mplayer
08999000-08b0c000 rw-p 08999000 00:00 0
096ca000-0970c000 rw-p 096ca000 00:00 0 [heap]
b4d00000-b4d21000 rw-p b4d00000 00:00 0
b4d21000-b4e00000 ---p b4d21000 00:00 0
b4ee5000-b4ee6000 rw-p b4ee5000 00:00 0
b4ee6000-b4eed000 r--s 00000000 08:01 4382860 /usr/lib/gconv/gconv-modules.cache
b4eed000-b4f2c000 r--p 00000000 08:01 4407307 /usr/lib/locale/pt_PT.utf8/LC_CTYPE
b4f2c000-b4f96000 rw-p b4f2c000 00:00 0
b4f96000-b4f99000 r-xp 00000000 08:01 3047490 /lib/libgpg-error.so.0.3.0
b4f99000-b4f9a000 rw-p 00002000 08:01 3047490 /lib/libgpg-error.so.0.3.0
b4f9a000-b5000000 r-xp 00000000 08:01 3047475 /lib/libgcrypt.so.11.4.4
b5000000-b5001000 r--p 00065000 08:01 3047475 /lib/libgcrypt.so.11.4.4
b5001000-b5003000 rw-p 00066000 08:01 3047475 /lib/libgcrypt.so.11.4.4
b5003000-b5013000 r-xp 00000000 08:01 4375463 /usr/lib/libtasn1.so.3.0.16
b5013000-b5014000 r--p 0000f000 08:01 4375463 /usr/lib/libtasn1.so.3.0.16
b5014000-b5015000 rw-p 00010000 08:01 4375463 /usr/lib/libtasn1.so.3.0.16
b5015000-b50ac000 r-xp 00000000 08:01 4375713 /usr/lib/libgnutls.so.26.4.6
b50ac000-b50b1000 r--p 00097000 08:01 4375713 /usr/lib/libgnutls.so.26.4.6
b50b1000-b50b2000 rw-p 0009c000 08:01 4375713 /usr/lib/libgnutls.so.26.4.6
b50b2000-b50c8000 r-xp 00000000 08:01 4374719 /usr/lib/libsasl2.so.2.0.22
b50c8000-b50c9000 r--p 00015000 08:01 4374719 /usr/lib/libsasl2.so.2.0.22
b50c9000-b50ca000 rw-p 00016000 08:01 4374719 /usr/lib/libsasl2.so.2.0.22
b50ca000-b50cb000 rw-p b50ca000 00:00 0
b50cb000-b50cd000 r-xp 00000000 08:01 3047471 /lib/libkeyutils-1.2.so
b50cd000-b50ce000 r--p 00001000 08:01 3047471 /lib/libkeyutils-1.2.so
b50ce000-b50cf000 rw-p 00002000 08:01 3047471 /lib/libkeyutils-1.2.so
b50cf000-b50d6000 r-xp 00000000 08:01 4376228 /usr/lib/libkrb5support.so.0.1
b50d6000-b50d7000 r--p 00006000 08:01 4376228 /usr/lib/libkrb5support.so.0.1
b50d7000-b50d8000 rw-p 00007000 08:01 4376228 /usr/lib/libkrb5support.so.0.1
b50d8000-b50dc000 r-xp 00000000 08:01 3047814 /lib/libattr.so.1.1.0
b50dc000-b50dd000 r--p 00003000 08:01 3047814 /lib/libattr.so.1.1.0
b50dd000-b50de000 rw-p 00004000 08:01 3047814 /lib/libattr.so.1.1.0
b50de000-b50e1000 r-xp 0...

Read more...

pixolex (pixolex) wrote :

gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'esdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'glimagesink'
gstreamer-properties-Message: Skipping unavailable plugin 'sdlvideosink'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
libv4l2: error getting capabilities: Argumento inválido
libv4l2: error getting capabilities: Argumento inválido
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
libv4l2: error getting capabilities: Argumento inválido
gstreamer-properties-Message: Error running pipeline 'Video for Linux 2 (v4l2)': Erro ao obter as capacidades para o dispositivo '/dev/video0': Não é um driver v4l2. Verifique se é um driver v4l1. [v4l2_calls.c(95): gst_v4l2_get_capabilities (): /GstPipeline:pipeline3/GstV4l2Src:v4l2src3:
system error: Argumento inválido]

I've checked all the options, audio and video.

tags: added: intrepid
Alexanderich (alexanderich) wrote :

However, sudo gstreamer-properties work and sudo cheese too.

Jeremy Kerr (jk-ozlabs) wrote :

Craig - any updates?

Craig Gilding (slasherx2) wrote :

Indeed, I forgot this was still open - sorry, Have just tested it on the newest Ubuntu (10.04) and it seems to be working as expected :)

Thanks for your help and thanks to everyone who worked on the bugs and got them fixed :)

Sergio Zanchetta (primes2h) wrote :

I mark it as Fixed due to the last comment.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers