Creative Labs CA0106 Soundblaster SB Audigy LS [1102:0007] is not properly supported

Bug #303679 reported by Liam O'Reilly on 2008-11-30
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I have a K8N Neo 4 Platinum motherboard which has a built in Sound Blaster live 24 bit sound card. Product can be viewed at http://www.msicomputer.com/product/p_spec.asp?model=K8N_Neo4_Platinum/SLI.

I am running Ubuntu 8.10 (Intrepid Ibex). I have all the correct sound channels available with the exception of the "mater channel". The sound card is a 7.1 surround card that worked properly with surround sound when configured differently from the default settings in Ubuntu.

I believe there should be a master channel. There was a working master channel in a previous version of Ubuntu (Gutsy I think). I have not used Ubuntu on this computer for a while as hardware support was too bad to use it as a production environment. Now however, things have improved and hardware support is much better, only my sound card is not working perfectly with regards to the master channel.

When I open the volume control I can see the following:
-> 9 "playback" channels: ICE958 Center/LFE, ICE958 Front, ICE958 Rear, ICE958 Unknown, Analog Center/LFE Analog Front, Analog Rear, Analog Side and CAPTURE feedback.
-> 4 recording channels: Line in, Microphone, Phone, Aux
-> 1 Switch: IEC958
-> 4 options: IEC958, Analog Source, Digital Source, Shared Line in / Side out

The volume control state the device as CA0106 (Alsa Mixer)

I believe there should be a channel called Master (or similar").

Sitsofe Wheeler (sitsofe) wrote :

Liam:
What does
lspci -nn | grep audio
say your card is?

Sitsofe Wheeler (sitsofe) wrote :

Could you also add the output of
aplay -L
cat ~/.asoundrc (if it exists)

Sitsofe Wheeler (sitsofe) wrote :

Apparently the script http://alsa-project.org/alsa-info.sh provides lots of useful information...

Liam O'Reilly (aliam13-2) wrote :

Hi, Sorry for the late reply - I have been out of the country and did not have access to my PC.

The result of the command
lspci -nn | grep audio
is
*****
01:0d.0 Multimedia audio controller [0401]: Creative Labs SB Audigy LS [1102:0007]
*****

The result of
aplay -L
is
*****
front:CARD=CA0106,DEV=0
    CA0106, CA0106
    Front speakers
rear:CARD=CA0106,DEV=0
    CA0106, CA0106
    Rear speakers
center_lfe:CARD=CA0106,DEV=0
    CA0106, CA0106
    Center and Subwoofer speakers
side:CARD=CA0106,DEV=0
    CA0106, CA0106
    Side speakers
surround40:CARD=CA0106,DEV=0
    CA0106, CA0106
    4.0 Surround output to Front and Rear speakers
surround41:CARD=CA0106,DEV=0
    CA0106, CA0106
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=CA0106,DEV=0
    CA0106, CA0106
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=CA0106,DEV=0
    CA0106, CA0106
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=CA0106,DEV=0
    CA0106, CA0106
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=CA0106,DEV=0
    CA0106, CA0106
    IEC958 (S/PDIF) Digital Audio Output
null
    Discard all samples (playback) or generate zero samples (capture)
*****
The file ~/.asoundrc does not exist

Liam O'Reilly (aliam13-2) wrote :

The script http://alsa-project.org/alsa-info.sh has uploaded its results to the following page:

http://www.alsa-project.org/db/?f=12b5fa3639874925546785462caea22eb82968a0

I have also attached a copy of this report - just in case this online report disapears

komputes (komputes) wrote :

I can confirm that the following hardware does not work out of the box on Ubuntu 9.04. There is no sound output.
Creative Labs CA0106 Soundblaster [1102:0007]

http://www.alsa-project.org/main/index.php/Matrix:Vendor-Creative_Labs
Quote - "Digital/Analog input does not work yet. Needs more development work."
Does this driver need further work? How should we contact developers in an attempt to get the card to be properly supported?

I will try to get alsa-info.sh and run the command "apport-collect -p alsa-base 303679" to report more info to this bug.

Research:

== http://www.alsa-project.org/main/index.php/Matrix:Vendor-Creative_Labs ==
Sound Blaster Audigy SE
Sound Blaster Audigy Value
CA0106
Details [PCI] Digital/Analog input does not work yet. Needs more development work.
== ==

== http://wiki.debian.org/X-Fi ==
snd-ca0106

The following list is based on the alias fields of modinfo snd-ca0106 built from alsa-driver-snapshot 20090626:
PCI: 1102:0007 Creative Labs CA0106 Soundblaster
== ==

== https://bugs.launchpad.net/ubuntu/+source/linux/+bug/303679 ==
01:0d.0 Multimedia audio controller [0401]: Creative Labs SB Audigy LS [1102:0007]
My sound card is not working perfectly with regards to the master channel
== ==

komputes (komputes) on 2009-08-16
summary: - Sound - Master channel missing on sound blaster live 24bit
+ Creative Labs CA0106 Soundblaster SB Audigy LS [1102:0007] is not
+ properly supported
kernel-janitor (kernel-janitor) wrote :

Hi Liam,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/karmic . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p alsa-base 303679

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-sound
tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Liam O'Reilly (aliam13-2) wrote :

Hi,

I have filed a new bug under https://bugs.launchpad.net/ubuntu/+bug/426788 , where the new sound preference gui of karmic has many problems. Fixing all these problems will probably fix this bug as the GUI has changed so much from Ubuntu 8.10 to 9.04 that the channels seem to be abstracted away.

I will continue to help fill in this bug report though. I will not have Internet access at my home (where the pc is) for a few weeks. So I can not run the apport-collect command above - unless this can be done off line and manually uploaded on a different pc. I will do this as soon as possible once my Internet connection is up.

Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: cizzle 3295 F.... xfce4-mixer-plu
 /dev/snd/pcmC0D0p: cizzle 7664 F...m totem
 /dev/snd/controlC1: cizzle 3295 F.... xfce4-mixer-plu
 /dev/snd/timer: cizzle 7664 f.... totem
Card0.Amixer.info:
 Card hw:0 'ICH5'/'Intel ICH5 with ALC202 at irq 17'
   Mixer name : 'Realtek ALC202 rev 0'
   Components : 'AC97a:414c4740'
   Controls : 37
   Simple ctrls : 23
Card1.Amixer.info:
 Card hw:1 'CA0106'/'Audigy SE [SB0570] at 0xb400 irq 21'
   Mixer name : ''
   Components : ''
   Controls : 29
   Simple ctrls : 17
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.18.dfsg-1ubuntu8
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
Uname: Linux 2.6.28-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Cizzleator (bloodofthescribe) wrote :

Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: cizzle 3295 F.... xfce4-mixer-plu
 /dev/snd/controlC1: cizzle 3295 F.... xfce4-mixer-plu
Card0.Amixer.info:
 Card hw:0 'ICH5'/'Intel ICH5 with ALC202 at irq 17'
   Mixer name : 'Realtek ALC202 rev 0'
   Components : 'AC97a:414c4740'
   Controls : 37
   Simple ctrls : 23
Card1.Amixer.info:
 Card hw:1 'CA0106'/'Audigy SE [SB0570] at 0xb400 irq 21'
   Mixer name : ''
   Components : ''
   Controls : 29
   Simple ctrls : 17
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.18.dfsg-1ubuntu8
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
Uname: Linux 2.6.28-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Nanocom (alex-nanocom) wrote :

AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 2: ls: cannot access /dev/snd/: No such file or directory
AplayDevices: aplay: device_list:223: no soundcards found...
Architecture: i386
ArecordDevices: arecord: device_list:223: no soundcards found...
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 LANGUAGE=
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
Uname: Linux 2.6.31-15-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:8363): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:8363): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:8414): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:8391): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected
Liam O'Reilly (aliam13-2) wrote :

I can confirm that in 9.10 the master channel has returned to alsamixer, thus I think this direct problem has been fixed.

I have a (what I believe is a) related bug at https://bugs.launchpad.net/ubuntu/+source/gnome-media/+bug/426788 to do with how the new sound preferences GUI works. The GUI may be fine and the driver for the sound card _might_ be at fault.

Simillar problem on Kubuntu 9.10

It works out of the box but if you restart then it not works.

this is a fragment of my lshw:

*-multimedia
                description: Multimedia audio controller
                product: CA0106 Soundblaster
                vendor: Creative Labs
                physical id: 0
                bus info: pci@0000:04:00.0
                version: 00
                width: 32 bits
                clock: 33MHz
                capabilities: pm bus_master cap_list
                configuration: driver=CA0106 latency=64 maxlatency=20 mingnt=2
                resources: irq:16 ioport:cce0(size=32)

Architecture: i386
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: alsa-base (not installed)
ProcEnviron:
 SHELL=/bin/bash
 LANG=fr_FR.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
Uname: Linux 2.6.31-17-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Maxime Wojtczak (max-gyver) wrote :

Hello,

Got the same problem. It seems there is no problem detecting the sound blaster, but no output...
My sound card is a Creative Sound Blaster 24bits, 5.1
The strange thing is that the sound already worked with Ubuntu LInux, but since an unknown update (I'm not the regular user of this computer) , sound is no more working.
Tell me if you need any other info.

Max

OK, I have the exact same problem, prior to Jan 24th everything was working fine then an update came along and it stopped working, the full alsa details are all here:

http://www.alsa-project.org/db/?f=3ebe1b94a5729d0cd69d6a5efafd9a7927071b55

On the 24th Jan I got this:

/var/log/messages.2:Jan 24 09:33:34 earth kernel: [207973.271586] CA0106 0000:11:00.0: PCI INT A disabled
and now when I boot I always get this :

/var/log/messages:Feb 9 20:48:50 earth kernel: [ 456.951555] CA0106 0000:11:00.0: PCI INT A disabled
/var/log/messages:Feb 9 20:48:50 earth kernel: [ 457.411136] CA0106 0000:11:00.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
/var/log/messages:Feb 9 20:48:50 earth kernel: [ 457.411162] snd-ca0106: Model 100a Rev 00000000 Serial 100a1102

It worked fine (few times had to restart alsa but could play 5 sources simultaneously if I wanted and all worked) prior to updates.

The /var/log/messages:Feb 9 20:48:50 earth kernel: [ 456.951555] CA0106 0000:11:00.0: PCI INT A disabled
is a red herring. I removed snc-ca0106 from /etc/modules and it went away but modprobe --list still had it in the list

so it still doesn't work ??

It actually comes up every time I restart alsa, need to find out why ??

alsa unload
alsa reload

This in /var/log/messages
Feb 11 18:14:21 earth kernel: [35990.914082] CA0106 0000:11:00.0: PCI INT A disabled

OK fixed it now, after 3 weeks of graft.....yes FIXED

I have no /etc/modprobe.d/alsa-base.conf

I have the default /etc/asound.conf

pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}

What you need to do to get your:
card 0: CA0106 [CA0106], device 0: ca0106 [CA0106]
working is to mute IEC958 when in alsamixer, 2nd one in on the [Playback] tab

Yes MUTE IEC958...................................music to my ears.

Then save the config by running:
sudo alsactl store 0 (or card number.....)

Hope this helps you chaps

And using Pulseaudio configuration the surround sound works best for your speakers of course but I have "Analog Surround 5.1 Output" and it sounds great.

see also

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4906

Daniel T Chen (crimsun) wrote :

Which precise IEC958 mixer element did you need to mute?

(This isn't a driver problem.)

Changed in alsa-driver (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu):
status: New → Invalid

The first one labelled <IEC958>, not C/F/R or U I guess the master for IEC958, it appears as a slider in alsamixer but as a tick box only under gnome-alsamixer. It was gnome-alsamixer that led to me finding it, as it was a tick box, I unticked it (which mutes the channel) and hey presto started working. Some where along the way an alsa specific update must have unmuted it or changed its behaviour.

Item: IEC958 [Off] - needs to be shown in alsamixer.

Roberto Gustavo (rgp) wrote :

Same problem here, Ubuntu 10.10 - 64 running on AMD x 2 - Asus M2N4-SLI with integrated soundcard and CA0106 Soundblaster.

Both cards worked fine but after an upgrade the CA0106 was unable to play sound.

Solution: Install graphical ALSA mixer - gamix - and unmute the "IEC958 Playback" for "Audigy SE [SB0570]: CA0106"

Is located at the top left, second control, easy to find as is the only checkbox there, no slider at that field.

Changed in alsa-driver (Ubuntu):
status: Invalid → Fix Released

I have the Audigy SE [SB0570]: CA0106 and can't uncheck anything in gamix, and while gnome-alsamixer clearly shows a checked IEC958 there's no way o unchecking that box. : (

Creative Labs CA0106 Soundblaster works out of the box except the microphone on Raring (13.04).

lspci -v | grep -A7 -i "audio"
01:01.0 Multimedia audio controller: Creative Labs CA0106 Soundblaster
 Subsystem: Creative Labs Device 1007
 Flags: bus master, medium devsel, latency 64, IRQ 22
 I/O ports at dda0 [size=32]
 Capabilities: <access denied>
 Kernel driver in use: snd_ca0106

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.