Ubuntu

4 GB ram with 9500m GS video card will not load driver

Reported by Splinterpaw on 2008-10-24
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I have an Asus G1SN laptop with an NVIDIA 9500m GS video card and also 4 GB of ram on the laptop with 512 MB of ram on the video card. After upgrading to 8.10 (64 bit version), the NVIDIA driver will not load but Ubuntu will load in low graphics mode (i.e. 2D).

In 8.04 I had to recompile the kernal so that it would allow the NVIDIA driver to load correctly. With this version when I try to load the NVIDIA driver (version 173 or 177) and reboot the system comes back up and says that the configuration cannot be recognized.

Currently I cannot recompile the kernal to use the video driver as the packages are not yet available for the new version. Right now not having the 3D capability prevents me from using some of the programs which I have installed on they system.

I have the most recent updates for my system but this does not seem to help with this issue.

Can you post your dmesg output with 4 GB of RAM and also for 2 GB if possible? If you have your kernel patched to fix the issue, it would probably be best if you can revert to the non-patched kernel for the purposes of gathering this information. Also please post the info from /proc/iomem. If you did patch your kernel, can you post the patch you used?

It sounds like you are possibly running into the same addressing issue seen in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/206522, http://bugzilla.kernel.org/show_bug.cgi?id=10461, and https://bugzilla.redhat.com/show_bug.cgi?id=425794.

Changing package affected to 'linux' due to potential PCI memory addressing issue.

Rinias (rinias) wrote :

I haven't got the dmesg for my system with only 2GB of RAM, but here is my dmesg with 4GB of RAM.

I am running 8.10 (x86_64) on the 2.6.27-10-generic (proposed repo) with no patches/changes, ie default Ubuntu system.

I will post the info from cat /proc/iomem in another comment.

Rinias (rinias) wrote :

Here is the /proc/iomem for my system

Rinias (rinias) wrote :

This is the dmesg with 2G RAM but nVidia driver not enabled.

I will also include :

- /proc/iomem 2G w/o nVidia
- dmesg 2G w/ nVidia
- /proc/iomem 2G w/ nVidia

as I am not sure what you are looking for.

Again, this is the Asus G1Sn-B1 notebook. Exact hardware specifications can be found here : [Newegg.com] http://www.newegg.com/Product/Product.aspx?Item=N82E16834220280

Rinias (rinias) wrote :

nVidia display driver works correctly.

Rinias (rinias) wrote :

I thought that the lsmod output might be interesting as a lsmod | grep nv yields no results, so I assume that the nv driver isn't working (why would it not be used if it did indeed work?)

If any more information is needed, please let me know. And thank you in advance for any time spent trying to resolve this problem.

Ivan (hideaki02) wrote :

I would like to point out that this issue is not with 4GB of RAM, but with more than 2GB of RAM. I have an ASUS G1Sn with 3GB of RAM, and I get the same issue.

Rob Douglas (are-zee-dee) wrote :

i have the same issue with my pci-e video card geforce 9500GT also.
note thou that the onboard video is also nvidia. and it loads just fine when i take the card out.

Vincent Purcell (jadedoto) wrote :

This is still an issue with current iterations of the Jaunty 2.6.28 kernel.

TJ (tj) wrote :

Marking this as a duplicate of my master bug report for all PCI IOMEM allocation issues.

This is a mainline kernel issue that will be resolved upstream soon and be inherited by all distributions.

Splinterpaw, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.