Hardy - Samsung X11 won't boot with 3GB ram

Bug #206522 reported by Lemmy on 2008-03-25
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

With 2 GB of RAM in the notebook, Gutsy works fine. Once I put in another GB module, Gutsy crashes at startup causing an immediate reboot.

I think the problem is related to the Nvidia drivers. Neither the opensource nor the binary driver work. I can boot up with 3GB and the vesa driver however.

I attached dmesg outputs of a normal boot with 2GB and the binary driver as well as a boot with 3 gb in safe graphics (selected in grub).

I am currently using the newest nvidia driver (installed via Envy) but I have the same problem with the default Gutsy nv driver. Both 32 bit and 64 bit versions crash.

I really hope someone can help me with this, as I'd really prefer to use 3 GB.

Thank you in advance!

P.S.: Before Ubuntu I used Windows Vista which worked with 3 GB. I removed it, but I just wanted to say there must be some way to use the nvidia chip with 3GB :)

Lemmy (lehmannd) wrote :
Lemmy (lehmannd) wrote :

Using Hardy with the 2.6.24-16 kernel my notebook does not lockup anymore, but the graphics driver still won't run with more than 2 GB of RAM. Here is the error message taken from dmesg (with 3 GB of course):

[ 55.248869] NVRM: This PCI I/O region assigned to your NVIDIA device is invalid:
[ 55.248870] NVRM: BAR1 is 256M @ 0x00000000 (PCI:0001:00.0)
[ 55.248874] NVRM: This is a 64-bit BAR mapped above 4GB by the system BIOS or
[ 55.248875] NVRM: Linux kernel. The NVIDIA Linux graphics driver and other
[ 55.248876] NVRM: system software do not currently support this configuration
[ 55.248877] NVRM: reliably.
[ 55.248883] nvidia: probe of 0000:01:00.0 failed with error -1
[ 55.248898] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 55.248900] NVRM: None of the NVIDIA graphics adapters were initialized!

I attached the full dmesg output. Thanks again for your help.

I just tried with 2,5 (2048 plus 512) and that works. So it seems the BAR relocation just happens once you put in 3 GB (or more?)

Duane (duane-e164) wrote :

There is people commenting about this bug on the nvidia forum as well:

http://www.nvnews.net/vbulletin/showthread.php?t=113682

Duane (duane-e164) wrote :

Apparently the problem needs kernel changes where the system remaps memory to, the following link explains it and links to the fix:

http://www.nvnews.net/vbulletin/showthread.php?t=96613

The exact fix is attached also.

wvengen (wvengen) wrote :

I think http://tjworld.net/wiki/Linux/Bug/PciAllocationAlgorithm has a pretty good technical background on this. It also mentions kernel bug http://bugzilla.kernel.org/show_bug.cgi?id=10461 . Note that this problem doesn't just occur with the binary nvidia driver, but also with the open source nv driver; it really is a pci allocation issue.

Daniel T Chen (crimsun) on 2008-12-04
Changed in linux:
importance: Undecided → Low
status: New → Confirmed
Duane (duane-e164) wrote :

How can this be of low importance, anyone with > 2-2.5G of ram that runs a 64bit version gets at best the vesa driver in most cases.

Rob Douglas (are-zee-dee) wrote :

same issue. cept a little twist.

onboard video card (nvidia) works with nvidia drivers.... my pci-e (also nvidia) wont load.. i get this error..

system 64bit core 2 duo , 4 gb ram ,

TJ (tj) wrote :

Marking this as a duplicate of my master bug report for all PCI IOMEM allocation issues.

This is a mainline kernel issue that will be resolved upstream soon and be inherited by all distributions.

Lemmy, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.