iwl3945 doesn't come up due to rf kill switch

Bug #281728 reported by MarcoBazzani on 2008-10-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Tim Gardner
Nominated for Intrepid by MarcoBazzani

Bug Description

Binary package hint: linux-image

intrepid
iwl3945 driver loads correctly but the interface doesn't come up
here the error in the dmesg when I run
ifconfig wlan0 up
Oct 10 01:02:16 lappy kernel: [ 713.221338] iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
Oct 10 01:02:16 lappy kernel: [ 713.221793] iwl3945: Radio disabled by HW RF Kill switch

Dimitrios Symeonidis (azimout) wrote :

i can confirm this: on the 8086:4222, with 2.6.27-7 (but the problem exists since hardy), if the machine is turned on with the rf kill switch on, and then i turn off the rf kill switch later, i have to run "sudo ifconfig eth1 up" for the interface to come up

Changed in linux-meta:
status: New → Confirmed

on hardy this problem doesn't affect me
and the command: sudo ifconfig eth1up doesn't work

MarcoBazzani (visik7) wrote :

the problem begin if the NetworkManager start, before it wireless works setting it through iwconfig
so I link this bug on network manager

Alexander Sack (asac) wrote :

Tim, this sounds like a dejavu ;) ... can you please take a look?

Changed in network-manager:
assignee: nobody → timg-tpi
importance: Undecided → Medium
Alexander Sack (asac) wrote :

reassigning to linux for now.

Alexander Sack (asac) wrote :

bumping to high, as not getting network when booting with rf kill switch is quite annoying.

Changed in linux:
importance: Medium → High
Jean-Baptiste Lallement (jibel) wrote :

MarcoBazzani,

Please include the following additional information, as required by the Ubuntu Kernel Team:
1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" after a fresh boot and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "sudo lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

Can you please also check you BIOS settings ? Some BIOSes offers to enable/disable the card, and if it doesn't, restoring factory defaults can solve this kind of issue.

Thanks in advance.

MarcoBazzani (visik7) wrote :
MarcoBazzani (visik7) wrote :
MarcoBazzani (visik7) wrote :

and here the uname -a :

Linux lappy 2.6.27-7-generic #1 SMP Fri Oct 10 03:55:24 UTC 2008 i686 GNU/Linux

MarcoBazzani (visik7) wrote :

after some test the execution of NetworkManager doesn't affect this issue the wireless doesn't work also if NM isn't executed by default at boot time.

Martin Albisetti (beuno) wrote :

I get exactly this when when resuming.
Suspend/resume worked perfectly fine in Hardy, and now, to get network after resume, I have to:

- Kill the wireless with the switch and activate again
- sudo rmmod iwl3945 && sudo modprobe iwl3945

Then, I get wireless back, and everything is fine.
Attaching the extracts from different log files after resume.

Dimitrios Symeonidis (azimout) wrote :

martin, do you really have to remove the module and load it back?
can you try ifconfig up?

Martin Albisetti (beuno) wrote :

On Wed, Oct 15, 2008 at 8:30 AM, Dimitrios Symeonidis <email address hidden> wrote:
> martin, do you really have to remove the module and load it back?
> can you try ifconfig up?

I just tried this, but I don't see the wlan0 in ifconfig unless I
unload/reload the module.

Martin Albisetti (beuno) wrote :

I can also confirm I have to turn the wireless off/on as well, before unload/loading the module. The latter by itself doesn't cut it.

MarcoBazzani (visik7) wrote :

here the modprobe -r iwl3945 ; modprobe iwl3945 command doesn't work
but this bug is not on the hibernate / suspend issue is another problem that
on this laptop V6J this card doesn't load correctly make it unusable at all
so please open another bug if you want.
cheers

Martin Albisetti (beuno) wrote :

For what it's worth, after today's updates, it now works for me.

MarcoBazzani (visik7) wrote :

seems to be fixed after latest updates

Steve Langasek (vorlon) wrote :

this appears to be identical to bug #193970; marking as a duplicate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers