gparted no longer detects mmcblk

Bug #275345 reported by Rocko on 2008-09-28
78
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gparted (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

gparted in Intrepid and Jaunty no longer shows mmcblk as a device (ie in the dropdown list on the right-hand side), so it can't format SD/SDHC cards. This is a regression from Hardy.

Version information for Jaunty:

ubuntu 9.04
kernel 2.6.28-9-generic
gparted 0.4.3-0ubuntu1

Additionally, Intrepid's fdisk command (2.6.27 kernel) does not even recognise the /dev/mmcblk0 device. 'fdisk -l /dev/mmcblk0' shows correct details for it, but it doesn't show up with 'fdisk -l' or even 'sudo fdisk -l'. (fdisk was fixed in the 2.6.28-8-generic kernel in Jaunty.)

lspci for mmcblk0 device:

03:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
03:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
03:09.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
03:09.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
03:09.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)

Rocko (rockorequin) wrote :

It's also present in kernel 2.6.27-5-generic amd64.

Salze (stefan-sarzio) wrote :

I have a similar problem. Since updating from Hardy to Intrepid beta I can only use my SD card after ejecting it once.

Here is what /var/log/messages says during booting:

--- cut here ---
Oct 5 17:25:07 lllu0143 kernel: [ 14.130616] sdhci-pci 0000:02:00.1: SDHCI controller found [1180:0822] (rev 13)
Oct 5 17:25:07 lllu0143 kernel: [ 14.130634] sdhci-pci 0000:02:00.1: PCI INT B -> GSI 17 (level, low) -> IRQ 17
Oct 5 17:25:07 lllu0143 kernel: [ 14.133722] mmc0: SDHCI controller on PCI [0000:02:00.1] using PIO
Oct 5 17:25:07 lllu0143 kernel: [ 14.203597] wlan: 0.9.4
Oct 5 17:25:07 lllu0143 kernel: [ 14.284482] mmc0: new SDHC card at address d164
[...]
Oct 5 17:25:07 lllu0143 kernel: [ 17.160278] mmcblk0: mmc0:d164 SD32G 31850496KiB
Oct 5 17:25:07 lllu0143 kernel: [ 17.160337] mmcblk0: p1
--- cut here ---

I have no notification in the KDE plasmoid for removable devices. I do see the partition in dolphin - but I cannot access it.

After ejecting the card and re-inserting it /var/log/messages displays:

--- cut here ---
Oct 5 17:47:56 lllu0143 kernel: [ 1392.444143] mmc0: card d164 removed
Oct 5 17:47:58 lllu0143 kernel: [ 1394.784596] mmc0: new SDHC card at address d164
Oct 5 17:47:58 lllu0143 kernel: [ 1394.794916] mmcblk0: mmc0:d164 SD32G 31850496KiB
Oct 5 17:47:58 lllu0143 kernel: [ 1394.796070] mmcblk0: p1
--- cut here ---

No I do have a notification in the KDE plasmoid, dolphin shows it just like before - but now I can access it.

Hardware: Thinkpad X40

02:00.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 13)
        Subsystem: IBM Device [1014:0556]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 64
        Interrupt: pin B routed to IRQ 17
        Region 0: Memory at d0210000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [80] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=2 PME-
        Kernel driver in use: sdhci-pci
        Kernel modules: sdhci-pci

Rocko (rockorequin) wrote :

Does 'fdisk -l' show the partitions on the card after the first or second insertion?

I think your problem might be slightly different. I occasionally find I have to eject and re-insert the card to get hal to mount it, but normally it mounts OK and I can use it. I just can't format it using gparted any more.

Salze (stefan-sarzio) wrote :

No, neither after the first, nor after the second insertion. Neither before mounting it, nor after mounting it.

Salze (stefan-sarzio) wrote :

But I don't remember how it was with Hardy.

Rocko (rockorequin) wrote :

In Hardy you could see the mmcblk device in gparted, so you could format it. fdisk -l also showed the device. I'm pretty sure I was able to do the same in Intrepid until recently.

fdisk -l still doesn't work in kernel 2.6.27-6-generic.

Rocko (rockorequin) wrote :

Still present in 2.6.27-7-generic (amd64).

Mathieu Marquer (slasher-fun) wrote :

Confirming, same behavior for me with 2.6.27-7 i386 (see my duplicate bug for details), it was working with ubuntu hardy.

Changed in linux:
status: New → Confirmed
Mathieu Marquer (slasher-fun) wrote :

Just adding that the memory card can be mounted for example in /media/mmc with sudo mount /dev/mmcblk0p1 /media/mmc/ -t vfat, but then dmesg says :

[ 6878.349831] FAT: Invalid FSINFO signature: 0x01211212, 0x21013232 (sector = 1)
[ 6912.098294] FAT: Filesystem panic (dev mmcblk1p1)
[ 6912.098304] fat_get_cluster: invalid cluster chain (i_pos 0)
[ 6912.098308] File system has been set read-only
[ 6913.229767] FAT: Filesystem panic (dev mmcblk1p1)
[ 6913.229787] fat_get_cluster: invalid cluster chain (i_pos 0)

Not sure about the filesystem integrity of the card then...

Mathieu Marquer (slasher-fun) wrote :

Just adding that the memory card can be mounted for example in /media/mmc with sudo mount /dev/mmcblk1p1 /media/mmc/ -t vfat, but then dmesg says :

[ 6878.349831] FAT: Invalid FSINFO signature: 0x01211212, 0x21013232 (sector = 1)
[ 6912.098294] FAT: Filesystem panic (dev mmcblk1p1)
[ 6912.098304] fat_get_cluster: invalid cluster chain (i_pos 0)
[ 6912.098308] File system has been set read-only
[ 6913.229767] FAT: Filesystem panic (dev mmcblk1p1)
[ 6913.229787] fat_get_cluster: invalid cluster chain (i_pos 0)

Not sure about the filesystem integrity of the card then...

Rocko (rockorequin) wrote :

This bug is still present in the Intrepid release (2.6.27-7-generic). My SD card mounts fine (hal auto-mounts it), I just can't format it in gparted, probably because fdisk -l doesn't show it.

parted + select /dev/mmcblk0 + print shows the following, if this helps any:

Model: Unknown (unknown)
Disk /dev/mmcblk0: 2007MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 131kB 2007MB 2007MB primary fat16 boot

Mathieu, I'd say there is a separate problem with your partition - perhaps you could try using "sudo fsck -a /dev/mmcblk0" to fix the errors or reformatting it using parted?

BenHagan (smooth-texan) wrote :

I'm having the same issue as Rocko, I am also running 2.6.27-7. I never have any problems mounting the SDHC card, but gParted doesn't see it, neither does fdisk -l.

Rocko (rockorequin) wrote :

It's a problem in 2.6.27-8 as well.

BenHagan (smooth-texan) wrote :

What about in Hardy, can anyone confirm that it works with Hardy with the 27-5-8 kernels?

F. Medeiros (excalibas-gmail) wrote :

I have this problem also.

SD card mounts fine (hal auto-mounts it)

can't format it in gparted, probably because fdisk -l doesn't show it

Problem started when I upgraded to Intrepid, on Hardy it worked.

Emmet Hikory (persia) wrote :

I can certainly reproduce this in intrepid. I wonder if it's the architecture of SD storage, as the storage adaptor itself is hotplugged, rather than just the device. Does anyone have hotplug PCI/PCIe SATA or SCSI adaptors who might be able to check if this behaviour also happens for that hardware?

Rocko (rockorequin) wrote :

The bug is still present in both 2.6.27-11 and 2.6.28-4 also. How do we get these kinds of bugs reported upstream?

nozhx (nozhbass) wrote :

the error still present in the kernel 2.6.27.9 generic in ubuntu 8.10 in a Dell Inspiron 6000

nozhx (nozhbass) wrote :

the SD is a Kingston 1GB

Rocko (rockorequin) wrote :

The latest Jaunty kernel (2.6.28-8) can finally see the partition with fdisk, although only if you are root (previously it worked for normal users as well).

However, gparted can't see it, so you still can't format it via a GUI application.

Paul Natsuo Kishimoto (khaeru) wrote :

My observations about 2.6.28-8 match Rocko's.

I have also reported https://bugs.launchpad.net/ubuntu/+source/linux/+bug/313313, which may be related.

Rocko (rockorequin) wrote :

Changing from linux to gparted since fdisk in kernel 2.6.82-8+ now recognises the mmcblk device, but gparted still doesn't.

description: updated
Curtis Gedak (gedakc) wrote :

GParted 0.4.4 has just been released. It includes a bug fix to recognize /dev/mmcblk# devices.

See GParted Bug:
http://bugzilla.gnome.org/show_bug.cgi?id=572703

Rocko (rockorequin) wrote :

I confirm that the latest gparted (0.4.5) detects the mmcblk device on my pc.

Unfortunately the jaunty repositories still only have the old 0.4.3 version, which doesn't detect it.

Rocko (rockorequin) wrote :

I changed the status to fix released (by accident initially - who knew you could just do that by clicking on the status and not have to confirm it?!).

However, it is fixed for Karmic since Karmic includes gparted 0.4.5.

Changed in gparted (Ubuntu):
status: Confirmed → Fix Released

Also closing the linux (Ubuntu) kernel task.

Changed in linux (Ubuntu):
status: New → Fix Released
Tim Knight (tknight) wrote :

i am running a dual boot HP laptop about two years old. i am using windows vista and lucid lynx, having upgraded ubuntu from hardy heron.

i cannot get my SD card to be recognized or mounted on the OS. i have been trying a variety of ubuntu and linux help sites - which all state the bug is fixed - to no positive effect.

in fact, i have had to re-install linux twice due to my lack of knowledge with linux code.

i am very frustrated. Vista isn't looking so bad at this stage... if i could get access to it; grup has robbed me of that, too :( but that's a different issue that i can forgo once i get linux to see and mount my 1GB and 8GB SD cards... hopefully...

1. gparted 0.5.1 does not recognize my 1GB Lexar MicroSD card.
2. "sudo -lu" does not see the drive either.
3. "dmesg | tail" shows:
      [ 419.882063] end_request: I/O error, dev mmcblk0, sector 19
      [ 419.884992] mmcblk0: error -84 transferring data, sector 20, nr 4, card status 0x900
      .
      .
      .
      [ 420.277828] end_request: I/O error, dev mmcblk0, sector 6
      [ 420.280751] mmcblk0: error -84 transferring data, sector 7, nr 1, card status 0x900
      [ 420.280755] end_request: I/O error, dev mmcblk0, sector 7
4. i can see the drive and format in using Gnome Format, but that's it.

did i mention i was very frustrated with the "out of the box" capabilities of Ubuntu?

Tim Knight (tknight) wrote :

correction... i know "sudo -lu" is the wrong command line. i did use the right one to get the drive list, i forget the command at the moment of writing this.

Tim Knight (tknight) wrote :

"sudo fdisk -lu" gives me the following output:

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x632a632a

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 19318 155171803+ 7 HPFS/NTFS
/dev/sda2 * 19319 19701 3076447+ 82 Linux swap / Solaris
/dev/sda3 19702 30401 85947750 5 Extended
/dev/sda5 * 19702 30401 85947718+ 83 Linux

Tim Knight (tknight) wrote :

timknight@timknight-laptop:~$ sudo fdisk /dev/mmcblk0
[sudo] password for timknight:
You will not be able to write the partition table.

Unable to read /dev/mmcblk0
timknight@timknight-laptop:~$

Now what? I'm lost and frustrated after reading a zillion threads and causing enough code errors to have to reinstall lynx twice :(

Rocko (rockorequin) wrote :

@Tim: this particular bug was fixed a long time ago and so it isn't the best place to look for help. Your bug looks like a different one anyway, so I recommend you open a new bug. Perhaps the problem is related to the fact you're using a _micro_ SD card...? My 2GB and 8GB (non-micro) SD cards both work fine - fdisk, gparted, and System / Admin / Disk Utility all see them, as long as there is a card inserted in the reader. But I haven't got a micro SD card to try. Another thing you could try is the latest Ubuntu 10.10 Maverick beta (just run the live version from a USB key or CD) and see if its more recent kernel can read your card properly.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.