Ubuntu

[intrepid] RT61pci no wireless on resume from suspend with 2.6.27-4

Reported by Nick Russell on 2008-09-26
36
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Using my RT61pci powered linksys wmp54g card I find that on resume from suspend wireless networks are no longer detected.

iponeverything (cookema) wrote :

Dist upgrade to Intrepid today quite nice. rt61pci with levelone wpc-0301 won't comeback after suspend unless I reinsert the card. With regard to rt61pci and nm-applet playing together nicely -- well done -- it is an improvement and things worked pretty well before. Suspend issue is not a big deal for me - maybe it will be fixed in 2.6.27-5.8 -- thanks

Tim Wright (tim-binbash) wrote :

I have the same issue, although as I can't reinsert the card I've employed a rather hacky workaround (too lazy to investigate properly).

Drop the attachment in /usr/lib/pm-utils/sleep.d (assuming you're using pm-utils).

Changed in linux:
status: New → Confirmed
iponeverything (cookema) wrote :

Thanks Tim your 11rt61pci works like a charm.

Nick Russell (thatnick) wrote :

Still occurs in -7

Ian (ian-a-kramer) wrote :

Occurs in -7 with Gigabyte GN-WP01GS, and unfortunately Tim's workaround doesn't seem to work

Ian (ian-a-kramer) wrote :

Had a stupid moment, Tim's workaround does work, I just forgot to enable the file to be executed as a program. With the workaround everything works just fine.

gyrm (hbchai) wrote :

Sweet - it works for me too! Thanks Tim!

moose (snyderra) wrote :

from the release notes
"Wireless doesn't work after suspend with ath_pci driver

Wireless devices that use the ath_pci kernel driver, such as the Atheros AR5212 wireless card, will be unable to connect to the network after using suspend and resume. To work around this issue, users can create a file /etc/pm/config.d/madwifi containing the single line:

SUSPEND_MODULES=ath_pci

This will cause the module to be unloaded before suspend and reloaded on resume. "

Do the above but put rt61pci instead of ath_pci. Had to do this for my wired nvidia card also

sixstrings (laurenmerritt) wrote :

The madwifi fix using rt61pci worked great for me. Thanks, moose!

sixstrings (laurenmerritt) wrote :

. . . or at least it worked the first couple of times, and then stopped working for me. Ah, well. On with the quest.

Hi Guys,

Care to test the latest pre-release of Jaunty 9.04 (currently Alpha3) - http://cdimage.ubuntu.com/releases/jaunty/ . It contains a 2.6.28 based kernel. You should be able to test suspend via a LiveCD. Please let us know your results. Thanks.

Changed in linux:
status: Confirmed → Incomplete
moose (snyderra) wrote :

I tested it with the live cd(Alpha 5) and the video never came back so don't know if it worked there. I installed it to the hard drive and it failed causing lots of system problems.

did the following
created /etc/pm/config.d/madwifi containing the single line:

SUSPEND_MODULES=rt61pci

and suspend/resume works as expected.

what info would help fix this? and is the above not an acceptable fix?

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Doki (lkishalmi) wrote :

Tried suspend/resume with /etc/pm/config.d/madwifi and SUSPEND_MODULES=rt61pci and my system works marvellously for the first time with ATI and rt61 based pci wireless on jaunty beta. I would really appreciate if this fix would be introduced in the Jaunty RC.

Mark O'Neill (maroneill) wrote :

I can confirm that this happens with an Edimax rt61 PCI card on 9.04.

However, Tim Wright's quick fix works perfectly for suspend & hibernate (i.e. rmmod; modprobe is the only way I can get wifi to work again.)

Don't forget to chmod 755 the script! (I did :) )

Dirk F (fieldhouse) wrote :

I found the rmmod; modprobe solution for the rt61pci driver with an Edimax card using Intrepid but it no longer works in 2.6.27-14. After resuming dmesg shows a regular (~1s) attempt to access the card but a device register is busy, eg

[ 668.000712] phy1 -> rt61pci_bbp_read: Error - PHY_CSR3 register busy. Read failed.

Other notes:

- I didn't need the line to restart NetworkManager that Tim Wright included

- I used /etc/pm/sleep.d

- manually removing and reinserting the card after resume works fine

- the SUSPEND_MODULES solution is no better with -14; with -11 it does seem to disable the card on suspend but I didn't see the wifi connection being remade on resume

- I don't like to try Jaunty as a solution since it fails to boot on a similar (old) laptop with lots of SEGVs.

Dirk F (fieldhouse) wrote :

Similar or related issues are reported in bug 314088 (Edimax EW-7128G fails after using Sleep Mode) and bug 355117 (TOSHIBA PORTEGE M400 suspend/resume failure with edimax rtl wifi card inserted).

Aaron Clark (aaronwclark) wrote :

I had same issue with recent install of Jaunty 64bit

Original kernel was 2-6-28-11 - same with 2-6-28-13

ASUS P5Q-E - Intel Q9400 Quad Core

Rosewill RNX-G300EX PCI card using rt61pci module

Using WiCd for a network manager

In my case not only was I not able to connect to network after resume from suspend but USB sticks would not mount even though they showed up in results of lsusb

Also Shutdown/Restart would hang after showing the splash screen - responding to alt+sysreq keystrokes but never shutting down.

Other weird glitches & hangs too numerous to mention unless someone really wants to know

I tried the SUSPEND_MODULES solution and everything seems to be working as expected now.

Dirk F (fieldhouse) wrote :

I confirm that, after explicitly uninstalling 2.6.27-14, the SUSPEND_MODULES solution worked with -11. Xubuntu 8.10 32-bit with all other updates; 500MHz/192Mb.

AceLan Kao (acelankao) wrote :

According to bug 355117, it seems that karmic kernel 2.6.31 has fixed this issue, could you guys give it a try. Images for testing are available at http://cdimage.ubuntu.com/daily-live/current/ . Please let us know your results.

Setting this to Incomplete for now until we get feedback regarding comment #19. Thanks.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
siknasa9 (randy-curry666) wrote :

This still isn't fixed and none of the workarounds above work for me at least. I'm using Karmic X64 on an XFX 750a motherboard (NVIDIA 8200), phenom 9500, and corsair RAM.

siknasa9 (randy-curry666) wrote :

Oh... forgot that I have a wireless card as well and I set it to modprobe -r on suspend and modprobe it when I resumed. It's a broadcom driver.

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments