Ubuntu

intrepid - after upgrade to kernel 2.6.27 i cannot upgrade nor i can navigate internet

Reported by Aldo Maggi on 2008-09-21
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Unknown
Release Notes for Ubuntu
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned
Intrepid
High
Unassigned

Bug Description

ubuntu intrepid
kernel: linux-image-2.6.27-3-generic

after upgrade to kernel 2.6.27 i can ping but i can neither upgrade the system nor navigate internet.
if i restart using kernel 2.6.26 i can do the above actions.

i attach the tests i tried which show that the routing is alright, /etc/resolv.conf is correct, ping works, w3m url and traceroute6 url do not.

the problem affects the wan, not the lan, infact i can ssh the other pc's in my home lan and use nfs with my home server.

WORKAROUND:
Please execute the following command sequence in a Terminal session:

sudo su -
echo 0 > /proc/sys/net/ipv4/tcp_sack
exit

Aldo Maggi (sentiniate) wrote :

Hi Aldo,

After a fresh boot into 2.6.27, can you capture and attach the following:

* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log
* cat /proc/version_signature

It would also be good to capture the dmesg output after you've attempted to run the upgrade or navigate the internet just so any error messages would be logged get captured. Also, when you try to upgrade for example are there any error messages you see printed to the screen or say to /var/log/syslog ?

Thanks.

Changed in linux:
status: New → Incomplete
Aldo Maggi (sentiniate) wrote :

first of all, i thank you for your attention

please find herewith attached the files you have asked for.
just a comment on dmesg_after_update_attempt, gvfsd-trash segfaulted before the update attempt.

thanks again!
aldo

Aldo Maggi (sentiniate) wrote :
Aldo Maggi (sentiniate) wrote :
Aldo Maggi (sentiniate) wrote :
Aldo Maggi (sentiniate) wrote :

Hi Aldo,

Just for comparison can you attach your dmesg output from when you boot the 2.6.26 kernel. Also, I'm curious if you try booting a LiveCD that has a 2.6.27 kernel if you experience the same issues - http://www.ubuntu.com/testing/intrepid/beta . Thanks.

Il giorno Thu, 02 Oct 2008 22:37:23 -0000
Leann Ogasawara <email address hidden> ha scritto:

> Hi Aldo,
>
> Just for comparison can you attach your dmesg output from when you
> boot the 2.6.26 kernel. Also, I'm curious if you try booting a
> LiveCD that has a 2.6.27 kernel if you experience the same issues -
> http://www.ubuntu.com/testing/intrepid/beta . Thanks.
>

i attach herewith the dmesg i've got booting from the live Ubuntu 8.10
(Intrepid Ibex) Beta, desktop cd and the dmesg i get booting the kernel
2.6.26-5 from my hd.

should it be of interest, the live thinks to find a dhcp server, which
is not the case because the pc is connected to my home server under
"static", therefore i had to play with network-manager and eventually
i've got the same results i.e. correct route -n, ping working, firefox
does not work.

thanks
aldo

Aldo Maggi (sentiniate) wrote :

i think this bug can be closed
in fact i've downloaded from kernel.org the 2.6.26 source, patched it with the 2.6.27-rc8 prepatch, launched make oldconfig once accepting the default answers it proposed and a second time saying "no" to all of them.
i compiled and got two deb packages of the kernel, in both cases i've got the same results as with the linux-image in ubuntu repositories.
furthermore, since i have debian lenny in another partition in the same machine, i repeated the same procedures there as well, with the same negative results i get with intrepid.
moreover i've tried intrepid livecd on another machine in my home lan and even there i could not navigate nor update.
if i run iptraf in my home server i can see that udp requests to the dns servers from the machine where intrepid is installed receive answers (this is the reason why "host" and "ping" work, i think) while in the case of tcp connections the syn packet goes through but it does not receive ack.
i think i'll file a bug with kernel.org

thanks
aldo

Changed in linux:
status: Unknown → Confirmed

Hello Aldo,

I was wondering which kind of router you are using to connect to the Internet... I am also affected by this bug (2.6.26 works, 2.6.27 does not) and somehow have the suspicion that this is a strange incompatibility between the TCP/IP stacks of the Linux Kernel and my WAN router (a Netgear RP114 [running ZyNOS]).

Regards,
Thilo

Aldo Maggi (sentiniate) wrote :

the problem is being addressed upstream (see please http://bugzilla.kernel.org/show_bug.cgi?id=11721)
i use a Zyxel 642R, but maybe a few of outdated modem can cause this problem.
anyway, just today a workaround has been found (at least for me, please let us know if it works for you as well) try launching with sudo or as root the following command:
echo 0 > /proc/sys/net/ipv4/tcp_sack
and afterwards give a try to firefox to see if you can navigate internet.
should it work for you, this workaround will last until you shutdown or reboot.
in order to avoid to run that command anytime you start your system, you can write a file (give it whatever name you like) containing just this two lines:
#! /bin/bash
sysctl -w net.ipv4.tcp_sack="0"
and put it in /etc/network/if-pre-up.d (obviously you should cp or mv that file to that directory using either sudo or becoming root)

let me know
aldo

Hi Aldo,

thanks! Applying your proposed workaround solves the problem for me.

Regards,
Thilo

Aldo Maggi (sentiniate) wrote :

looking at bug 285430, it seems that launching the command sudo echo 0 > /proc/sys/net/ipv4/tcp_sack
doesn't work, the right way which has been proposed by thilo is:
sudo su -
echo 0 > /proc/sys/net/ipv4/tcp_sack
exit

aldo

description: updated
Kerin (cernunnos) wrote :

I have the same issue - however, the workaround does nothing for my system, near as I can tell. The only solution I've found is to regress to 2.6.24.7, which cleared the problems up entirely. I hope that we either get the kernel updated or switch back to the earlier (functional) version before the 30th, given the severity of the issue (total lack of internet capability) and the inaccessibility of the fix for anyone who isn't linux-literate.

Regards, K.

Aldo Maggi (sentiniate) wrote :

the problem is being addressed upstream (kernel.org, see please http://bugzilla.kernel.org/show_bug.cgi?id=11721) so i think that in few days it is solved there and ubuntu developpers will follow through.
yesterday i was given a patch to apply to the kernel source and after having compiled the 2.6.27.2 kernel the problem had disappeared, so either you wait a few days or you can compile yourself in order to test the patch in your environment (it would be useful, i think).
if you want to follow this second option, download the kernel source http://kernel.org/pub/linux/kernel/v2.6/linux-2.6.27.2.tar.bz2 , untar it, apply the patch i attach to this message and compile and install the new kernel.

let me know if the new kernel solves your issue.
i assume you know how to patch and compile a kernel, if not let me know.

aldo

Changed in linux:
status: Incomplete → New

I just wanted to add some additional information for the Ubuntu kernel team to reference. The following is a small excerpt from the upstream bug report

"We'll put the latest patch (from comment #58) and it soon makes to 2.6.28-rcsomething and hopefully with a semi-short delay to some 2.6.27.y, whichever y is appropriate at that time. I hope that the ubuntu kernel people will then include that as well but it's beoynd my control what they do."

The patch referenced can be seen here:

http://bugzilla.kernel.org/show_bug.cgi?id=11721#c58

Being that the Intrepid kernel is frozen because we are so close to Intrepid's final release we might not be able to squeeze this patch in before final. However, I've gone ahead and opened an Intrepid nomination so that if we miss getting this into Intrepid final we'll already have the SRU process going so that we can try to get this in for the first post Intrepid kernel upload. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
milestone: none → intrepid-updates
status: New → Triaged
Steve Langasek (vorlon) wrote :

Based on <http://bugzilla.kernel.org/show_bug.cgi?id=11721#c40>, this appears to be the same as bug #264019.

Interesting to see that there's an interop fix being worked on upstream that preserves use of tcp timestamps - I'll reopen bug #264019 and add more detail to the release notes.

Changed in linux:
status: Confirmed → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.