ALPS touchpad not recognized in Dell Latitude E6400

Bug #270643 reported by hasi on 2008-09-15
38
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Tim Gardner
Hardy
High
Tim Gardner
Intrepid
High
Tim Gardner
xorg (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Using freshly installed Ubuntu 8.10-alpha5, kernel 2.6.27-3 on a new DELL Latitude E6400.
ALPS touchpad is not recognized by X (see attached file /proc/bus/input/devices).
Only the PS/2 emulation mode works (very basic touchpad functionality).

It has been observed in earlier cases that the latest ALPS touchpads were not recognized. Fixes were relatively easy (see bug#129477, https://bugs.launchpad.net/ubuntu/+bug/129477).

Is this as simple as adding the name/number of the latest ALPS touchpad to the code?

hasi (whynot-nurfuerspam) wrote :
Mackenzie Morgan (maco.m) wrote :

Did this work on Hardy? What driver was in use then, Synaptics or something else?

hasi (whynot-nurfuerspam) wrote :

No, it also does not work in Hardy. The situation looks exactly the same: device not present in /proc/bus/input/devices.

Maybe this is interesting: if I run "sudo tpconfig", I get the following output:

Found Synaptics Touchpad.
Firmware: 8.96 (multiple-byte mode).

I cannot tell what this actually means. It sounds like the touchpad is recognized at some level.
However, I cannot change any of the touchpad settings. For instance if I run "sudo tpconfig -z4", to change the sensitivity, the command is syntactically recognized correctly. However, the value always remains at 6, as I get the following response: "Z threshold: 6 of 7.". If I enter a number larger than 7 (i.e. "sudo tpconfig -z8"), I get an error message: 'Invalid Z threshold "8" [use 0-7].'

Thanks to everyone who is willing to look into this.
Please let me know if I can provide any further information or if can run some additional tests.
--hasi

Mackenzie Morgan (maco.m) wrote :

Can you attach your /etc/X11/xorg.conf ?

hasi (whynot-nurfuerspam) wrote :

Mackenzie,

thanks very much for looking into this.

Which OS version do you want me to look at? I am currently running Hardy (2.6.24-21).
My xorg.conf is attached, and it is pretty basic at this point.
My guess is that the touchpad section is not doing anything anyway, as touchpad is not recognized and unloaded by X. To show you what I am talking about, I also attached a fragment of my /var/log/Xorg.0.log

Let me know if you are interested in anything else.
Cheers,
--hasi

hasi (whynot-nurfuerspam) wrote :
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It would be great if you could test this with the latest development release of Ubuntu, Intrepid Ibex Alpha 6, using the Live CD. You can find out more about it at http://www.ubuntu.com/testing . Thanks in advance.

hasi (whynot-nurfuerspam) wrote :

Hi Brian,
thank you for looking into this!
Actually, I had just completed all the upgrades today, and I am on the 2.6.27-4 kernel now. Is that sufficient, or do I still have to download the alpha6 CD and go from there?
--hasi

hasi (whynot-nurfuerspam) wrote :

Brian,

due to bug #263555 (see link below), my Intel Ethernet card may be destroyed when I use the 2.6.27 kernel.
Therefore, I am no longer in a position to boot Intrepid images until this is resolved.

--hasi

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/263555

I've found this link, it might help. There is a patch for the latitude E6500 which is a very similar laptop:
http://lkml.org/lkml/2008/9/7/133

Mackenzie Morgan (maco.m) wrote :

hasi:
Can you try the daily build? The driver in question has been removed from the daily builds.

Mackenzie Morgan (maco.m) wrote :

Setting importance to High since touchpads are pretty necessary on laptops.

Changed in xorg:
importance: Undecided → High
hasi (whynot-nurfuerspam) wrote :

Mackenzie and Matteo: thank you so much for helping here! I believe we are getting close!!!

Unfortunately, I am not very experienced, Mackenzie. Which daily build are you referring to? Please bare in mind that my system has an Intel NIC which is very likely affected by the e1000e problem, so that I am hesitant to try any of the 2.6.27 kernels at present.
However, there is very good news: I tried the patch that Matteo Collina suggested (thanks so much Matteo for finding this one!!!). I compiled a Hardy kernel, and it works! ALPS touchpad is correctly recognized. (it is listed in /proc/bus/input/devices). Also, after mapping the correct event in xorg.conf, and enabling SHMConfig, I am able to use synclient to change many touchpad settings. I successfully adjusted MinSpeed, MaxSpeed, AccelFactor. Vert and Horiz. scroll are working fine (after finding good numbers for RightEdge and BottomEdge).

However, since I am new at kernel compiling, I also had some problems. Currently my system is running 2.6.24-21. The kernel I had compiled turned out to be a customized version of 2.6.24-3. The wireless card and NIC were not recognized, as in earlier Hardy versions (before 8.04.1). What did go wrong? Did I not install the correct source packages? I would really like to get this working in Hardy. Can anyone help me? I believe I am very close. The only thing I need to do is apply the patch to the most recent version of Hardy.

hasi (whynot-nurfuerspam) wrote :

@Mackenzie:
Sorry, I just saw your other note about the removed driver. So you think it is safe to use the daily build? (I just found them, and the download is started). I may not be able to test it for tonight/tomorrow morning.
--hasi

Brian Murray (brian-murray) wrote :

If you look at the git tree for Intrepid at kernel.ubuntu.com, http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-intrepid.git;a=blob;f=drivers/input/mouse/alps.c;h=fb81e52603f7394c5ef535fc2e29cfedfa3c2e9a;hb=HEAD , you can see that this fix is not in the Intrepid kernel. However, I'll reassign this bug to the kernel and notify the team about the fix.

Changed in xorg:
assignee: nobody → ubuntu-kernel-team
status: Incomplete → Triaged
Rob Frohne (frohro) wrote :

Hi Everyone,

I have the same problem as hasi with my Latitude E6400. I hope this gets fixed soon. I may try and build a kernel with this patch, as I find it extremely annoying not be be able to scroll with the touchpad. Thanks to all for the good job triaging this bug!

Rob

@Hasi
I've found it just googling around.. I was searching for informations regarding the dell e6400 and linux. Then I found this bug and so I've just posted the link :).

Rob Frohne (frohro) wrote :

Hi All,

I can also confirm that the one line patch to alps.c solves the problem. gsynaptics still complains that it couldn't initialize, and that SHMConfig must be true, but scrolling works anyway. Also I do have SHMConfig on in /etc/X11/xorg.conf.

It is so nice having scrolling back. In fact it was worth the long wait to compile the kernel.

Rob

hasi (whynot-nurfuerspam) wrote :

Mackenzie:
Finally, I found time to try the daily build (09/30)--sorry for the delay. Still no ALPS devices listed under /proc/bus/input/devices. Therefore, it's probably not necessary to do further tests. The patch that Matteo supplied worked perfectly on a 2.6.24 kernel. Can it be included in the current/future kernel? Looking at the patch it really just seems a matter of adding one line with the "ID code" of the new device for it to be recognized.
--hasi

Rob Frohne (frohro) wrote :

The kernel I added the one line of identification to was:

frohro@Engr-FrohRo-6400:~$ uname -r
2.6.27-4-generic

I second a plea for this to be put in the kernel.

I think the reason my xorg.conf was ignored is explained because Intrepid ignores it. I'm not sure what gsyanptics needs to work, but even without being able to adjust the parameters, the touchkpad behaves much better with this one line modification to alps.c.

Rob

Rob Frohne (frohro) wrote :

Kernel 2.6.27-5-generic doesn't seem to include the patch. It did solve my problem with suspend and resume though! I guess I'll have to recompile the kernel again.

Rob

Tim Gardner (timg-tpi) wrote :

UBUNTU: SAUCE: ALPS touchpad for Dell Latitude E6500/E6400

Changed in linux:
assignee: ubuntu-kernel-team → timg-tpi
milestone: none → ubuntu-8.10
status: Triaged → Fix Committed
Tim Gardner (timg-tpi) wrote :
Changed in linux:
assignee: nobody → timg-tpi
importance: Undecided → Low
milestone: none → ubuntu-8.04.2
status: New → Fix Committed
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: ALPS touchpad not detected on Dell Latitude E6500/E6400

Patch Description: Add device ID

Patch: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy.git;a=commit;h=97e6f5b1d114cdb8cff85d45bbcf9de07d271fbf

test Case: See bug description

Changed in linux:
importance: Low → High
Changed in xorg:
status: New → Invalid
status: New → Invalid
Rob Frohne (frohro) wrote :

Thanks so much Tim! I have been getting tired of rebuilding the kernel every couple of days.

Rob

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.27-7.10

---------------
linux (2.6.27-7.10) intrepid; urgency=low

  [ Alexey Starikovskiy ]

  * SAUCE: ACPI: EC: do transaction from interrupt context
    - LP: #277802

  [ Ben Collins ]

  * build/d-i: Change virtio-modules udeb to prio standard

  [ Colin Ian King ]

  * SAUCE: Blacklist IBM 2656 in serio/i8042
    - LP: #21558

  [ Henrik Rydberg ]

  * Revert "SAUCE: applesmc: Add MacBookAir"
  * SAUCE: [PATCH 1/5] hwmon: applesmc: Specified number of bytes to read
    should match actual
  * SAUCE: [PATCH 2/5] hwmon: applesmc: Fix the 'wait status failed: c !=
    8' problem
  * SAUCE: [PATCH 3/5] hwmon: applesmc: Prolong status wait
  * SAUCE: [PATCH 4/5] hwmon: applesmc: Allow for variable ALV0 and ALV1
    package length
  * SAUCE: [PATCH 5/5] hwmon: applesmc: Add support for Macbook Air
  * SAUCE: hwmon: applesmc: Add support for Macbook Pro 4
  * SAUCE: hwmon: applesmc: Add support for Macbook Pro 3
  * SAUCE: hwmon: applesmc: Lighter wait mechanism, drastic improvement

  [ Leann Ogasawara ]

  * Add automatic model setting for Samsung Q45
    - LP: #200210

  [ Tim Gardner ]

  * SAUCE: Correctly blacklist Thinkpad r40e in ACPI
    - LP: #278794
  * SAUCE: Update Wacom tablet driver to 1.49
    - LP: #260675
  * SAUCE: ALPS touchpad for Dell Latitude E6500/E6400
    - LP: #270643
  * SAUCE: Fix Wacom tablet 1.49 porting errors
  * SAUCE: Enable an e1000e Intel Corporation 82567 Gigabit controller
  * SAUCE: Fix Oops in wlan_setup
    - LP: #263309

  [ Upstream Kernel Changes ]

  * ath9k: fix oops on trying to hold the wrong spinlock
  * [Bluetooth] Fix double frees on error paths of btusb and bpa10x drivers
  * [Bluetooth] Add reset quirk for new Targus and Belkin dongles
  * [Bluetooth] Add reset quirk for A-Link BlueUSB21 dongle
  * Revert "ax25: Fix std timer socket destroy handling."
  * ax25: Quick fix for making sure unaccepted sockets get destroyed.
  * netrom: Fix sock_orphan() use in nr_release
  * Revert "V4L/DVB (8904): cx88: add missing unlock_kernel"
  * SLOB: fix bogus ksize calculation
  * net: only invoke dev->change_rx_flags when device is UP
  * tcp: Fix possible double-ack w/ user dma
  * net: Fix netdev_run_todo dead-lock
  * tcp: Fix tcp_hybla zero congestion window growth with small rho and large cwnd.
  * [MIPS] Sibyte: Register PIO PATA device only for Swarm and Litte Sur
  * eeepc-laptop: Fix hwmon interface
  * hwmon: (it87) Prevent power-off on Shuttle SN68PT
  * hwmon: Define sysfs interface for energy consumption register
  * hwmon: (adt7473) Fix some bogosity in documentation file
  * hwmon: (abituguru3) Enable reading from AUX3 fan on Abit AT8 32X
  * hwmon: (abituguru3) Enable DMI probing feature on Abit AT8 32X
  * [CPUFREQ] correct broken links and email addresses
  * SLOB: fix bogus ksize calculation fix
  * Don't allow splice() to files opened with O_APPEND
  * Linux 2.6.27

 -- Tim Gardner <email address hidden> Wed, 08 Oct 2008 21:19:34 -0600

Changed in linux:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

linux 2.6.24-21 copied to hardy-updates.

Changed in linux:
status: Fix Committed → Fix Released
kszys (ksocha) wrote :

Hi there...

I am running currently kernel 2.6.27-7.14 on my Dell E6400 and I still do not see ALPS in the /proc/bus/input/devices. It looks pretty much like the one posted at the beginning of this bug report... with the PS/2 mouse emulation only...

Are you sure the bug is fixed? What can do to confirm it?

Kszys.

Martin Pitt (pitti) on 2008-11-14
Changed in linux:
status: Fix Released → In Progress
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux:
milestone: ubuntu-8.04.2 → none
status: In Progress → Fix Committed
Steve Langasek (vorlon) on 2008-11-14
Changed in linux:
milestone: none → ubuntu-8.04.2
Martin Pitt (pitti) wrote :

Accepted linux into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Paul Winkler (slinkp) wrote :

2.6.27-11.22 from intrepid proposed fixes the recognition problem for me, on a Dell e6400.

(Temporarily, anyway; there's a bug in the driver that causes the touchpad to occasionally glitch like crazy, sending the pointer wandering around the screen, after which it seems to get re-loaded as a generic mouse and scrolling is broken until you re-load the psmouse module. More about this bug here:
http://www.gossamer-threads.com/lists/linux/kernel/992364?search_string=dell%20e6400;#992364
)

Paul Winkler (slinkp) wrote :

Update: It actually seems pretty unreliable to me currently. On some boots, the touchpad works. About 50% of the time, nothing.

When things work, I will see the touchpad found in dmesg | grep -i alps, and also lshal | grep -i alps.
Other times, I will boot the same kernel and get no matches from either command.
What does this mean?

Launchpad Janitor (janitor) wrote :
Download full text (12.0 KiB)

This bug was fixed in the package linux - 2.6.24-23.46

---------------
linux (2.6.24-23.46) hardy-proposed; urgency=low

  [Alessio Igor Bogani]

  * rt: Updated PREEMPT_RT support to rt21
    - LP: #302138

  [Amit Kucheria]

  * SAUCE: Update lpia patches from moblin tree
    - LP: #291457

  [Andy Whitcroft]

  * SAUCE: replace gfs2_bitfit with upstream version to prevent oops
    - LP: #276641

  [Colin Ian King]

  * isdn: Do not validate ISDN net device address prior to interface-up
    - LP: #237306
  * hwmon: (coretemp) Add Penryn CPU to coretemp
    - LP: #235119
  * USB: add support for Motorola ROKR Z6 cellphone in mass storage mode
    - LP: #263217
  * md: fix an occasional deadlock in raid5
    - LP: #208551

  [Stefan Bader]

  * SAUCE: buildenv: Show CVE entries in printchanges
  * SAUCE: buildenv: Send git-ubuntu-log informational message to stderr
  * Xen: dma: avoid unnecessarily SWIOTLB bounce buffering
    - LP: #247148
  * Update openvz patchset to apply to latest stable tree.
    - LP: #301634
  * XEN: Fix FTBS with stable updates
    - LP: #301634

  [Steve Conklin]

  * Add HID quirk for dual USB gamepad
    - LP: #140608

  [Tim Gardner]

  * Enable CONFIG_AX25_DAMA_SLAVE=y
    - LP: #257684
  * SAUCE: Correctly blacklist Thinkpad r40e in ACPI
    - LP: #278794
  * SAUCE: ALPS touchpad for Dell Latitude E6500/E6400
    - LP: #270643

  [Upstream Kernel Changes]

  * Revert "[Bluetooth] Eliminate checks for impossible conditions in IRQ
    handler"
    - LP: #217659
  * KVM: VMX: Clear CR4.VMXE in hardware_disable
    - LP: #268981
  * iov_iter_advance() fix
    - LP: #231746
  * Fix off-by-one error in iov_iter_advance()
    - LP: #231746
  * USB: serial: ch341: New VID/PID for CH341 USB-serial
    - LP: #272485
  * x86: Fix 32-bit x86 MSI-X allocation leakage
    - LP: #273103
  * b43legacy: Fix failure in rate-adjustment mechanism
    - LP: #273143
  * x86: Reserve FIRST_DEVICE_VECTOR in used_vectors bitmap.
    - LP: #276334
  * openvz: merge missed fixes from vanilla 2.6.24 openvz branch
    - LP: #298059
  * openvz: some autofs related fixes
    - LP: #298059
  * openvz: fix ve stop deadlock after nfs connect
    - LP: #298059
  * openvz: fix netlink and rtnl inside container
    - LP: #298059
  * openvz: fix wrong size of ub0_percpu
    - LP: #298059
  * openvz: fix OOPS while stopping VE started before binfmt_misc.ko loaded
    - LP: #298059
  * x86-64: Fix "bytes left to copy" return value for copy_from_user()
  * NET: Fix race in dev_close(). (Bug 9750)
    - LP: #301608
  * IPV6: Fix IPsec datagram fragmentation
    - LP: #301608
  * IPV6: dst_entry leak in ip4ip6_err.
    - LP: #301608
  * IPV4: Remove IP_TOS setting privilege checks.
    - LP: #301608
  * IPCONFIG: The kernel gets no IP from some DHCP servers
    - LP: #301608
  * IPCOMP: Disable BH on output when using shared tfm
    - LP: #301608
  * IRQ_NOPROBE helper functions
    - LP: #301608
  * MIPS: Mark all but i8259 interrupts as no-probe.
    - LP: #301608
  * ub: fix up the conversion to sg_init_table()
    - LP: #301608
  * x86: adjust enable_NMI_through_LVT0()
    - LP: #301608
  * SCSI ips: handle scsi_add_host() failure, and other err cl...

Changed in linux:
status: Fix Committed → Fix Released
Mark Manashirov (arkainium) wrote :

I'm experiencing the same behavior as Paul:
If I accidentally touch the touchpad while using the pointing stick, the pointer will behave erratically for a moment until it is reloaded as a generic mouse.

I tried disabling the touchpad by setting "SendCoreEvents" to false in a HAL FDI policy file, but that doesn't help. While it does disable the touchpad and all its buttons, the touchpad remains "alive" if I accidentally touch it while using the pointing stick, resulting in the same erratic behavior.

Aside from that, the touchpad seems to work fine. Should a new bug report be created for this other problem?

P.S. This is on intrepid-proposed.

Raphael Kimmig (rkimmig) wrote :

@Mark,Paul
This seems to be due to the 9 byte packgage format used by dells dualpoint.
There is a patch[0] on the lkml that fixes that behaviour, though it's probably not perfect its a fine workaround for me.

regards

raf

[0] http://marc.info/?l=linux-kernel&m=122874571315439&w=2

I can confirm this bug on my Dell E6400. The patch from LKML doesn't really solve the problem, since the driver has still problems with using the stick and touchpad at the same time.

Maybe someone should open a new ticket for this bug, since the original problem of this ticket has been solved.

Mark Manashirov (arkainium) wrote :

Looks like there is one already: https://bugs.launchpad.net/ubuntu/+bug/296610
It's not getting much attention though.

I filed a new identical bug here https://bugs.launchpad.net/ubuntu/+bug/330885

donat (dondenoncourt) wrote :

I too have problems with the Alps touchpad. I'm on Ubuntu 8.10 with a Dell Vostro 1510. My specific problem is that the right mouse button does not function. What's odd is that the touchpad worked for several weeks. I'm guess an update caused it to stop.

dadrivr (dadrivr) wrote :

Any update on this? I am using Ubuntu 9.10 on a Dell Inspiron, and it doesn't detect my alps touchpad at all.

My touchpad strangely started working again a few months ago.
All I can say is I keep my updates current and one of them may have
resolved the Touchpad issue.

dadrivr wrote:
> Any update on this? I am using Ubuntu 9.10 on a Dell Inspiron, and it
> doesn't detect my alps touchpad at all.
>
>

Ketil Malde (ketil-ii) wrote :

A (presumably) ALPS touchpad on my HP dm-1 isn't detected either (also on Karmic). It shows up as an ImPS/2 wheel mouse. It really, really needs to have its sensitivity adjusted, so a solution to this would be great.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers